Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Call Transfer from SIP Dial Peer

Hi,

I have recently setup an inbound SIP connection between our site and Engin. This works OK, and i have setup an overlay buttin on the ephone 1 for the new ephone-dn 10. When the call is answered and we try to transfer the call when you hit the transfer key and enter the extension, the call is "blind" trasfered and you do not get an option to speak to the transfer"ee" before pushing the transfer key again.

I cannot work out how to change this. Any ideas would be greatly appreciated. I can run some debugs etc if needed.

Thanks

David

no ip dhcp use vrf connected

ip dhcp excluded-address 10.1.1.1 10.1.1.199

ip dhcp excluded-address 10.1.1.220 10.1.1.254

!

ip dhcp pool PHONES

network 10.1.1.0 255.255.255.0

default-router 10.1.1.254

option 150 ip 10.1.1.250

!

!

no ip domain lookup

ip host byo.engin.com.au 203.161.164.69

ip name-server 63.203.35.55
!
no ipv6 cef
!
multilink bundle-name authenticated
isdn switch-type basic-net3
!
!

voice service voip

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

no supplementary-service sip moved-temporarily

no supplementary-service sip refer

sip

bind control source-interface Vlan258

bind media source-interface Vlan258


!
!
voice class codec 10
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8

voice translation-rule 1
rule 1 /^\(.*\)/ /00\1/
!
voice translation-rule 2
rule 1 /^\(.*\)97466475/ /711/
rule 2 /^\(.*\)97469912/ /715/
!
voice translation-rule 3
rule 1 /715/ /97469912/
rule 14 /.*/ /97466475/
!
!
voice translation-profile Outside-BRI-Lines-Incomming
translate calling 1
translate called 2
!
voice translation-profile Outside-BRI-Lines-Outbound
translate calling 3
!
!

ip tftp source-interface Vlan100
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!

interface range FastEthernet0/1/0 - 8
switchport access vlan 258
spanning-tree portfast
!
!
interface BRI0/1/0
no ip address
isdn switch-type basic-net3
isdn point-to-point-setup
isdn incoming-voice voice
isdn sending-complete

!
interface Vlan1
no ip address
!
interface Vlan100
no ip address
!
interface Vlan258
description digerati DMZ02 VLAN
ip address 10.1.1.250 255.255.255.0
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.1.1.254
ip route 10.1.1.251 255.255.255.255 Integrated-Service-Engine0/0

!

!
voice-port 0/1/0
translation-profile incoming Outside-BRI-Lines-Incomming
translation-profile outgoing Outside-BRI-Lines-Outbound
echo-cancel coverage 24
compand-type a-law
cptone AU
!
voice-port 0/1/1
translation-profile incoming Outside-BRI-Lines-Incomming
translation-profile outgoing Outside-BRI-Lines-Outbound
echo-cancel coverage 24
compand-type a-law
cptone AU
!
voice-port 0/4/0
auto-cut-through
signal immediate
input gain auto-control
description Music On Hold Port
!
sccp local Vlan258
sccp ccm 10.1.1.250 identifier 1
sccp ip precedence 3
sccp
!
sccp ccm group 1
bind interface Vlan258
associate ccm 1 priority 1
associate profile 1 register TRANSCODE
!
dspfarm profile 1 transcode
description Transcoding Resources
codec g711ulaw
codec g711alaw
codec ilbc
codec g723r63
codec g723r53
codec gsmamr-nb
codec g729ar8
codec g729abr8
codec g729r8
codec g729br8
maximum sessions 4
associate application SCCP
!
!
dial-peer voice 7000 voip
description Voice Mail Dial Peer
destination-pattern 700.
session protocol sipv2
session target ipv4:10.1.1.251
incoming called-number .
dtmf-relay sip-notify
codec g711ulaw
no vad
!
dial-peer voice 5 pots
description ** MOH Port **
destination-pattern ABC
port 0/4/0
no sip-register
!
dial-peer voice 720 pots
description Fax
destination-pattern 720
direct-inward-dial
port 0/0/0
!
dial-peer voice 721 pots
description Modem
destination-pattern 721
direct-inward-dial
port 0/0/1
!
dial-peer voice 1000 pots
destination-pattern 0T
direct-inward-dial
port 0/1/0
!
dial-peer voice 1001 pots
destination-pattern 0T
direct-inward-dial
port 0/1/1
!
dial-peer voice 3000 voip
description VoIP to Engin
session protocol sipv2
session target ipv4:203.161.164.69
incoming called-number 0390177882
dtmf-relay h245-alphanumeric
codec g711ulaw
ip qos dscp ef signaling
no vad
!
!
sip-ua
authentication username 0390177882 password 7 052A1C5A7666182F4B
no remote-party-id
retry invite 2
retry register 10
timers connect 100
registrar dns:byo.engin.com.au expires 3600
sip-server dns:byo.engin.com.au
connection-reuse
host-registrar
!
!
!
telephony-service
sdspfarm units 1
sdspfarm transcode sessions 4
sdspfarm tag 1 TRANSCODE
load 7914 S00105000300
load 7915-12 B015-1-0-3
load 7915-24 B015-1-0-3
load 7916-12 B016-1-0-3
load 7916-24 B016-1-0-3
load 7906 SCCP11.8-4-2S
load 7911 SCCP11.8-4-2S
load 7921 CP7921G-1.2.1
load 7925 CP7925G-1.3.1
load 7931 SCCP31.8-4-2S
load 7937 apps37sccp.1-3-2-0
load 7941 SCCP41.8-4-2S
load 7941GE SCCP41.8-4-2S
load 7942 SCCP42.8-4-2S
load 7945 SCCP45.8-4-2S
load 7961 SCCP41.8-4-2S
load 7961GE SCCP41.8-4-2S
load 7962 SCCP42.8-4-2S
load 7965 SCCP45.8-4-2S
load 7971 SCCP70.8-4-2S
load 7975 SCCP75.8-4-2S
load 521G-524G cp524g-8-1-17
load 525G spa525g-7-1-9
load 501G spa5x5-7-1-3c
load 502G spa5x5-7-1-3c
load 504G spa5x5-7-1-3c
load 508G spa5x5-7-1-3c
load 509G spa5x5-7-1-3c
max-ephones 10
max-dn 15
ip source-address 10.1.1.250 port 2000
system message Digerati Solutions
url services http://10.1.1.251/voiceview/common/login.do
url authentication http://10.1.1.251/voiceview/authentication/authenticate.do
time-zone 48
date-format dd-mm-yy
voicemail 7001
max-conferences 8 gain -6
moh flash:media/Opus_Number_1.ulaw.wav
web admin system name admin secret 5 $1$IfFJ$ow0y5Be7WK..FE7K.uaz80
dn-webedit
time-webedit
transfer-system full-consult
directory entry 11 711 name Front Desk
directory entry 12 722 name Tim Faase
directory entry 13 713 name Josh Peters
directory entry 14 714 name Tim Kirkman
directory entry 20 720 name Fax
directory entry 21 721 name Modem
directory entry 15 715 name MaxComputing
create cnf-files version-stamp 7960 May 02 2011 18:37:03
!
!
ephone-dn 1 dual-line
number 711
pickup-group 1
label Reception
name Reception
call-forward busy 7001
call-forward noan 7001 timeout 20
hold-alert 30 originator
!
!
ephone-dn 2 dual-line
number 712
pickup-group 1
label Tim Faase
name Tim Faase
call-forward busy 7001
call-forward noan 7001 timeout 20
hold-alert 30 originator

!
ephone-dn 10
number 0390177882
label Melbourne_Number
name Melbourne_Number
hold-alert 30 originator
!

!
!
ephone 1
device-security-mode none
mac-address 0021.1BFC.7729
max-calls-per-button 2
username "Reception" password null
codec g729r8 dspfarm-assist
mtp
type 521G
1o2,10

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Call Transfer from SIP Dial Peer

Hi David,

Can you change the config to below:

ephone-dn 10 --- > ephone-dn 10 dual-line

I checked your telephony-service has the command "transfer-system full-consult" :

Perform H.450.2/SIP call transfers with consultation using second phone line if available, fallback to full-blind if second line unavailable.

You should be good to go, once you make the above change

Regards

Prashanthi

1 REPLY
Cisco Employee

Call Transfer from SIP Dial Peer

Hi David,

Can you change the config to below:

ephone-dn 10 --- > ephone-dn 10 dual-line

I checked your telephony-service has the command "transfer-system full-consult" :

Perform H.450.2/SIP call transfers with consultation using second phone line if available, fallback to full-blind if second line unavailable.

You should be good to go, once you make the above change

Regards

Prashanthi

576
Views
0
Helpful
1
Replies