Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Caller-id not working on IOS voice-gateway

Hi all,

I have a 2811 running IOS 12.4(24)T and set up as H.323 gateway for a UCM 7.1 cluster. This router has 2x VIC2-4FXO and 1x VWIC2-2MFT-T1/E1.

Both inbound and outbound calls are working fine on all FXO ports and also on the E1 line but I can't get caller-id working on any of them. I have tested the analog lines that are connected to router's FXO ports with an analog telephone and it does show the correct caller-id, but when this line is connected to the router's FXO, the IP Phones will show "Unknown Number". The same happens with the E1 line... with an old Analog PBX I do get the caller-ids but with the E1 line connected to the H.323 gateway, it won't work.

We have read many Cisco docs about this issue but didn't help at all. I guess we're missing something related to this gateway configs.

Current router config and ccapi debugs are attached.

Any Ideas?

Regards,

Guilherme

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Re: Caller-id not working on IOS voice-gateway

For analog, I understand that Brazil has a different standard (BINA) and it is not clear if Cisco support that or not (I think it does not)

For E1 R2, you need "ani" option in ds0-group, after that take "debug vpm signal", do not take any other debug.

9 REPLIES
Hall of Fame Super Gold

Re: Caller-id not working on IOS voice-gateway

For analog, I understand that Brazil has a different standard (BINA) and it is not clear if Cisco support that or not (I think it does not)

For E1 R2, you need "ani" option in ds0-group, after that take "debug vpm signal", do not take any other debug.

New Member

Re: Caller-id not working on IOS voice-gateway

Bevilacqua,

Do you mean "ani-digits" ?

I'm going to try that as soon as I can. The E1 line is currently in use by an Analog PBX so unfortunately I can't test that right now.

About the FXO, it's not a huge problem if clid doesn't work over those lines.

Thanks !

Regards,

Guilherme

New Member

Re: Caller-id not working on IOS voice-gateway

Guilherme,

Send me a "debug isdn q931"

Many Thanks,

Nico

Hall of Fame Super Gold

Re: Caller-id not working on IOS voice-gateway

debug isdn q931 does not apply, because there is no ISDN in this case.

New Member

Re: Caller-id not working on IOS voice-gateway

Add the "ani" in config:

change from:

controller E1 0/3/0

ds0-group 0 timeslots 1-15 type r2-digital r2-compelled

change to:

controller E1 0/3/0

ds0-group 0 timeslots 1-15 type r2-digital r2-compelled ani

Many Thanks,

Nico

New Member

Re: Caller-id not working on IOS voice-gateway

I just tested it with the E1 line and CLI is working fine, thank you guys!

I just need to check about the FXO issue now but it's not a huge deal yet.

Regards,

Guilherme

New Member

Re: Caller-id not working on IOS voice-gateway

Hi Guilherme,

Glad to be of assistance!!

Can you please give me marks so I can count up some NetPro points?

Many Thanks,

Nico

New Member

Re: Caller-id not working on IOS voice-gateway

Guilherme,

did you ever sort out your Caller-ID problem on the FXO ports?

I have exact same problem, PSTN line works with Caller-ID when connected to analog phone but when connected to router with FXO port I just get Unknown Number

Hall of Fame Super Gold

Re: Caller-id not working on IOS voice-gateway

Please open new thread for new problems, include port configuration, output of "debug vpm signal" when receiving a call.

671
Views
3
Helpful
9
Replies
CreatePlease to create content