Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

caller ID on FXO port

i'm facing a problem in the caller ID on an FXO port on the voice gateway connected to the telco CO switch, the problem is that the caller ID doesn't appear on the IP phone, although the caller ID feature is enabled from the Telco switch side and on the voice port with the command:

caller-id enable

i noted that the FXO port waits for three rings before answering the call and going offhook, i wonder if this might be the problem?

the type of the fxo card is VIC2-4FXO.

11 REPLIES
Hall of Fame Super Gold

Re: caller ID on FXO port

Hi,

which cptone have you configured unde voice port ?

Please take ¨debug voice vpm signal¨ with ¨term mon¨ to see what is going on.

New Member

Re: caller ID on FXO port

hi, and thanks for replying:

i tried many cptone under the voice port including FR, and JO, refering to France, and jordan cptones, with no use.

and i already used the debug the debug vpm signal command, and i noted that the router can't see any caller id information rescieved on the fxo port, but when i connect an analog phone to the line, the caller id information appears on the LED screen of the phone, so i'm pretty sure that the service is running.

besides that i tried many caller id protocols on the FXO port, including Bellcore, ETSI, and FSK, but the problem still exists.

but as i said in the previous mail, the fxo port waits for three rings before answering the call, and i don't know if the CO switch sends the caller id information at the third ring or not.

the voice port is configured as a connection plar to the auto attendant application.

so i wonder if any one has encountered this problem before.

thanks for yout interest.

Hall of Fame Super Gold

Re: caller ID on FXO port

Evidently there is a problem in recognizing the caller-id signals, as we don;t know at this time what is the exact standard to apply. It could even be an UK one, I'm not sure at this time.

With the normal phone, after how many rings do you see the caller-id appear ?

And, which exact IOS are you running ?

New Member

Re: caller ID on FXO port

i'm sending the configuration of the voice gateway, and the debug messages of the command debug vpm signal, the output appears after i tried to call the fxo port on the router, it seems from the output that the router waits for a timer to expire and after that it starts to read the caller id information from the CO switch.

the caller id information rescieved from the CO switch before the first ring on the analog phone.

by the way the type of the CO switch is seimens, so it's german.

i'm not sure, but i think that the router answers the call after the caller ID information is already sent, so it doesn't see any information related to the caller ID.

i tried many caller ID protocols whisch are related to different CPtones like Bellcore, ETSI, ETSI DTMF, FSK, but with no use.

i appreciate your help

Hall of Fame Super Gold

Re: caller ID on FXO port

Hi,

Which exact IOS are you using ?

New Member

Re: caller ID on FXO port

this is the image running on the 2851 router

c2800nm-advipservicesk9-mz.124-16.

it's of 12.4(16) series image

New Member

Re: caller ID on FXO port

We had the same problem on a 2811 using 7931 phones (c2800nm-advipservicesk9-mz.12.4-15T for my IOS). The delay was just over three rings before the phones started ringing. At that point, caller id became so secondary that we removed the caller id function completely. Now the phones ring slightly behind an analog phone (about 1/2 second delay).

Hopefully we can get this fixed so that it is usable in the future...

Hall of Fame Super Gold

Re: caller ID on FXO port

Hi, can you upgrade to 12.4(11)XJ4 and try again ?

In the meanwhile I'll try to find out which caller-id standard is used in Jordan.

New Member

Re: caller ID on FXO port

Khalil,

Looking at your debug the FXO is picking up after 1 ring cycle, not 3. Also that is the default for the FXO port, to pick up after 1 ring.

You can confirm this with 'show voice port 0/1/1' Look at 'Number of rings is set to x'. Also notice your caller id settings, probably set to receive after 1 ring.

Try increasing the number of rings under the FXO port to 3:

!

voice-port 0/1/1

ring number 3

!

Basically, your router is answering the call before it has a chance to receive the caller id info.

Mike

Hall of Fame Super Gold

Re: caller ID on FXO port

Correct observation by Mike, that should be tried indeed.

New Member

Re: caller ID on FXO port

Caller ID is not support on FXO card while using MGCP. Only when H323 is used does caller ID get passed.

414
Views
0
Helpful
11
Replies
CreatePlease login to create content