Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Caller Id problem

Hi,

I have two cisco 2800 routers, one of the fxo ports on the first router is connected to the PBX, on the other side I have similar router with fxs interface connected to analog telephone, when calling the fxs port the caller id is not displayed on the analog telephone, I run the command "show history voice on the router with the fxs interface and I can see the caller id is displayed correctly and identified, I changed the analog phone and still the same.

3 REPLIES
Hall of Fame Super Gold

Re: Caller Id problem

If you do not send relevant config for both routers, nothing can be suggested.

New Member

Re: Caller Id problem

Yes, also please explain what the exact topology is. What is the call control signaling used ? Is it H323 to MGCP ?

Something like this will be helpful :

Telco ---- FXO ---Router ---- h323 or mgcp ?? ---- CUCM or router ----- FXS --- analog phone

So what we will need :

1. configuration from the router

2. exact call flow

3. version on the routers

Thanks and Best Regards,

Pashmeen Mistry

New Member

Re: Caller Id problem

Hi,

sorry for being late my configuration as you said:

Telco ---- FXO ---router---- h323and sip?? ----  router ----- FXS --- analog phone

here is the configuration of the two gateways:

-----------------------------------------------------------------------------------------------------

router2#sh version
Cisco IOS Software, 2800 Software (C2800NM-SPSERVICESK9-M), Version 12.4(15)T7, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2008 by Cisco Systems, Inc.
Compiled Wed 13-Aug-08 17:09 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

router2 uptime is 23 hours, 48 minutes
System returned to ROM by reload at 13:51:53 UTC Mon Oct 18 2010
System image file is "flash:c2800nm-spservicesk9-mz.124-15.T7.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 2811 (revision 53.50) with 223232K/38912K bytes of memory.
Processor board ID FCZ1308707T
2 FastEthernet interfaces
1 Serial(sync/async) interface
4 Voice FXO interfaces
DRAM configuration is 64 bits wide with parity enabled.
239K bytes of non-volatile configuration memory.
62720K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102
------------------------------------------------------------------------------------------------

Router with fxo interfaces

router2#sh run
Building configuration...

Current configuration : 2268 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router2
!
boot-start-marker
boot-end-marker
!

!
no aaa new-model
memory-size iomem 15
dot11 syslog
!
!
ip cef
!
!
multilink bundle-name authenticated
!
!
voice-card 0
no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
  hidekeys
!
!
!
!
!
!
interface Loopback0
no ip address
!
interface FastEthernet0/0
ip address 192.168.6.107 255.255.255.0
duplex full
speed auto
no mop enabled
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/2/0
no ip address
shutdown
no fair-queue
clock rate 2000000
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.6.1
!
!
ip http server
no ip http secure-server
!

!
!
!
control-plane
!
!
!
voice-port 0/0/0
no battery-reversal
soft-offhook
signal groundStart
connection plar 10835
station-id number 10835
caller-id enable
!
voice-port 0/0/1
no battery-reversal
signal groundStart
compand-type a-law
cptone LB
timeouts call-disconnect 5
timeouts wait-release 1
connection plar 01256879
impedance complex1
caller-id enable
!
voice-port 0/1/0
no battery-reversal
cptone FR
connection plar 10833
!
voice-port 0/1/1
no battery-reversal
connection plar 10832
!
!
!
!
dial-peer cor custom
name 83pstn
name 01pstn
name 07pstn
name 09pstn
name 05pstn
!
!
dial-peer cor list allow
!
dial-peer cor list norestrict
member 83pstn
member 01pstn
member 07pstn
member 09pstn
member 05pstn
!
!
dial-peer voice 10 pots
destination-pattern 10...
port 0/0/0
!
dial-peer voice 100 pots
destination-pattern 10...
port 0/1/0
!
dial-peer voice 1000 pots
destination-pattern 10...
port 0/1/1
!
dial-peer voice 1 pots
destination-pattern ........
port 0/0/1
!
dial-peer voice 2 voip
destination-pattern 01256879
session target ipv4:10.3.3.101
dtmf-relay h245-alphanumeric
no vad
!
dial-peer voice 3 voip
destination-pattern 10...
session protocol sipv2
session target ipv4:10.3.3.101
!
!
!
line con 0
line aux 0
line vty 0 4

login
!
scheduler allocate 20000 1000
!
end

---------------------------------------------------------------------------------------------------------

FXS:

!
boot-start-marker
boot system flash:c2800nm-spservicesk9-mz.124-24.T1.bin
boot-end-marker
!
logging message-counter syslog
logging buffered 51200 warnings

no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
ip domain name yourdomain.com
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
!
voice service voip
fax protocol cisco
sip
!

voice-card 0
!
!
!
!

log config
  hidekeys
!
!
!
class-map match-all matchany
match protocol rtp audio
class-map match-all rtp
match protocol rtp audio
!
!
policy-map rtp
class matchany
   police cir 8000
     conform-action drop
class rtp
!
!
!
!
!
interface FastEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$
ip address 10.3.3.101 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
no cdp enable
no mop enabled
!
interface Serial0/0/0
no ip address
encapsulation ppp
shutdown
no fair-queue
clock rate 2000000
no cdp enable
ppp multilink group 44
!
no ip classless
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.3.3.1
ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
!
!
!

snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps vrrp
snmp-server enable traps ds1
snmp-server enable traps tty
snmp-server enable traps eigrp
snmp-server enable traps xgcp
snmp-server enable traps flash insertion removal
snmp-server enable traps adslline
snmp-server enable traps ds3
snmp-server enable traps envmon
snmp-server enable traps icsudsu
snmp-server enable traps isdn call-information
snmp-server enable traps isdn layer2
snmp-server enable traps isdn chan-not-avail
snmp-server enable traps isdn ietf
snmp-server enable traps ds0-busyout
snmp-server enable traps ds1-loopback
snmp-server enable traps ethernet cfm cc mep-up mep-down cross-connect loop config
snmp-server enable traps ethernet cfm crosscheck mep-missing mep-unknown service-up
snmp-server enable traps license
snmp-server enable traps disassociate
snmp-server enable traps deauthenticate
snmp-server enable traps authenticate-fail
snmp-server enable traps dot11-qos
snmp-server enable traps switch-over
snmp-server enable traps rogue-ap
snmp-server enable traps wlan-wep
snmp-server enable traps atm subif
snmp-server enable traps bgp
snmp-server enable traps bulkstat collection transfer
snmp-server enable traps memory bufferpeak
snmp-server enable traps cnpd
snmp-server enable traps config-copy
snmp-server enable traps config
snmp-server enable traps config-ctid
snmp-server enable traps dial
snmp-server enable traps dsp card-status
snmp-server enable traps dsp oper-state
snmp-server enable traps entity
snmp-server enable traps fru-ctrl
snmp-server enable traps resource-policy
snmp-server enable traps event-manager
snmp-server enable traps frame-relay multilink bundle-mismatch
snmp-server enable traps frame-relay
snmp-server enable traps frame-relay subif
snmp-server enable traps hsrp
snmp-server enable traps ipmulticast
snmp-server enable traps mpls ldp
snmp-server enable traps mpls traffic-eng
snmp-server enable traps mpls fast-reroute protected
snmp-server enable traps msdp
snmp-server enable traps mvpn
snmp-server enable traps ospf state-change
snmp-server enable traps ospf errors
snmp-server enable traps ospf retransmit
snmp-server enable traps ospf lsa
snmp-server enable traps ospf cisco-specific state-change nssa-trans-change
snmp-server enable traps ospf cisco-specific state-change shamlink interface-old
snmp-server enable traps ospf cisco-specific state-change shamlink neighbor
snmp-server enable traps ospf cisco-specific errors
snmp-server enable traps ospf cisco-specific retransmit
snmp-server enable traps ospf cisco-specific lsa
snmp-server enable traps pim neighbor-change rp-mapping-change invalid-pim-message
snmp-server enable traps pppoe
snmp-server enable traps cpu threshold
snmp-server enable traps rsvp
snmp-server enable traps ipsla
snmp-server enable traps syslog
snmp-server enable traps l2tun session
snmp-server enable traps l2tun pseudowire status
snmp-server enable traps vtp
snmp-server enable traps pw vc
snmp-server enable traps ccme
snmp-server enable traps srst
snmp-server enable traps mpls vpn
snmp-server enable traps voice
snmp-server enable traps dnis
!
control-plane
!
!
!
voice-port 0/2/0

description 10832

caller-id enable
!
voice-port 0/2/1
connection plar 10579
description 10835
caller-id enable
!
voice-port 0/3/0
ring cadence pattern02
cptone LB
description 01256879
station-id number 01256879
caller-id enable
caller-id format e911
!
voice-port 0/3/1
ring cadence pattern01
cptone FR
description 10833
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
dial-peer cor custom
name 01calls
name 83cellular
!
!
dial-peer cor list outpstn
member 01calls
!
dial-peer cor list 83out
member 83cellular
!
!
dial-peer voice 10832 pots
destination-pattern 10832
port 0/2/0
!
dial-peer voice 10835 pots
destination-pattern 10835
port 0/2/1
!
dial-peer voice 10833 pots
destination-pattern 10833
port 0/3/1
!
dial-peer voice 108 voip
destination-pattern 10...
session protocol sipv2
session target ipv4:192.168.6.107
!
dial-peer voice 103 voip
destination-pattern .T
session target ipv4:192.168.6.107
dtmf-relay h245-alphanumeric
!
dial-peer voice 1 pots
destination-pattern 01256879
port 0/3/1
forward-digits all
!
!
sip-ua

retry invite 2
retry response 2
retry bye 2
retry cancel 2
!
!
line con 0
login local
line aux 0
line vty 0
privilege level 15
login
transport input telnet
line vty 1 4
privilege level 15

no login
transport input telnet
line vty 5 988
no login
!
scheduler allocate 20000 1000
end

692
Views
0
Helpful
3
Replies