Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Calling between SIP softphones: no voice

We register 2 SIP softphones to CME and they work correctly if they call an SCCP phone or are called by an SCCP phone

or if they receive a call from an incoming SIP trunk or if they call with an outgoing SIP trunk

BUT

if they call each other no voice is heard.

We see that the RTP packets are sent to CME but CME doesn't forward the packets to the other phone.

The addresses, port numbers and so on are correct, the RTP connections are shown as working BUT the packets

are not forwarded.

Does anyone has a suggestion to try?

Thanks a lot

Paolo

4 REPLIES

Re: Calling between SIP softphones: no voice

Hi.

Can you post your config and a debug ccsip messages during a call?

Thx


Regards
Carlo

Sent from Cisco Technical Support iPhone App

Please rate all helpful posts "The more you help the more you learn"
Community Member

Re: Calling between SIP softphones: no voice

First of all, thanks for your help and patience!

I am enclosing:

a) conf.txt , the output from show running-config

b) ccsip.txt, debug output

c) call.cap, packet capture

If you have a look at call.cap, you can see the RTP exchange about at packet number 300

The packets are sent to the router 172.16.10.1 from the two endpoints, as requested by the

SIP handshake, but the router even if it knows about the RTP flows doesn't route the packets

back to their destinations.

If I capture a call between SCCP and SIP, the thing is quite similar BUT the router sends

the packets of the 2 RTP flows to their correct destinations.

Thanks a lot again for your help.

Paolo

Re: Calling between SIP softphones: no voice

Hi Paolo.

Can you send me the output of a show voip rtp connections during a call between sip phones...

Thanks

Carlo

Please rate all helpful posts

"The more you help the more you learn"

Please rate all helpful posts "The more you help the more you learn"
Community Member

Re: Calling between SIP softphones: no voice

Thanks Carlo for your time!

Meanwhile, we run some tests and found the solution.

I hate all those thread with people solving their problems BUT not giving back the solution to the community,

so I would like to explain that if you run in this problem, check if the SIP client is set for RFC2833 DTMF

I know, it seems crazy, no DTMF is involved in making a call, BUT if you set RFC2833 then everything

works correctly.

Otherwise, no voice!

146
Views
0
Helpful
4
Replies
CreatePlease to create content