Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Calling issue with Cisco 7937 conference station

Hi Friends,

I am facing issue wiht Cisco 7937 conference station, our customer have various branch offices accross the world. All branches are connected over MPLS through service provider( SIP service provider) . there is a centralized CUCM and remote office have SIP Voice gateways .

When making calls from once remote site to another using Cisco 6921 phones calls working fine

When making calls from once remote site to another using Cisco 7937 conference station to make call  any phone at remote office, calls are getting disconneted, remote phone rings when calls,  but its gets fast busy tone when other party picks up the phone and  not able to talk.

I suspect the issue with Codec but we have configured transcoders  in VG and registered with CUCM

Please help me if any one experience such issue earlier.

Regards

Siva

5 REPLIES
Cisco Employee

Calling issue with Cisco 7937 conference station

Hi Siva

You are suspecting it correct. Definetly a codec issue.

1. What is the codec mapping between 2 7937 IP Phones you are placing calls within?

2. Pls share the "Show run" of the GW running the Xcoders and also the output of "Show sccp".

A CM Detailed trace for this failed call would surely be helpful. Pls include Calling/ Called party numbers and Time of call as well.

- Basant

Calling issue with Cisco 7937 conference station

hi Basant,

1. Actually tow phones A and B are registerd with centralized CUCM, A and B are located in two different locations, RTP traffic between And B pass through service provider. 

Call Flow --> Phone A ---->CUCMRouterpattern--> SIP trunk ----> Voice gateway--->Service provider cloud---> Respective Voice Gateway---> CUCM -- Phone B

Show Run

----------------------------------------------------

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2014.02.27 15:14:52 =~=~=~=~=~=~=~=~=~=~=~=

sh run

Building configuration...

 

Current configuration : 12139 bytes

!

! Last configuration change at 06:35:59 UTC Tue Feb 25 2014

! NVRAM config last updated at 11:16:38 UTC Mon Feb 24 2014 by administrator

! NVRAM config last updated at 11:16:38 UTC Mon Feb 24 2014 by administrator

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname eucamvgw01

!

boot-start-marker

boot system flash:c2900-universalk9-mz.SPA.151-4.M5.bin

boot-end-marker

!

!

card type e1 0 0

logging buffered 51200 warnings

no logging console

!

no aaa new-model

!

no network-clock-participate wic 0

!

no ipv6 cef

ip source-route

!

ip traffic-export profile cuecapture mode capture

bidirectional

ip cef

!

!

!

ip multicast-routing

!

!

ip domain name drreddys.eu

ip name-server 10.197.20.1

ip name-server 10.197.20.2

!

multilink bundle-name authenticated

!

!

stcapp ccm-group 2

stcapp

!

stcapp feature access-code

!

stcapp feature speed-dial

!

!

!

stcapp supplementary-services

port 0/1/0

fallback-dn 5428025

port 0/1/1

fallback-dn 5428008

port 0/1/2

fallback-dn 5421462

port 0/1/3

fallback-dn 5421463

!

!

isdn switch-type primary-net5

!

crypto pki token default removal timeout 0

!

!

voice-card 0

dsp services dspfarm

!

!

voice call send-alert

voice call disc-pi-off

voice call convert-discpi-to-prog

voice rtp send-recv

!

voice service voip

ip address trusted list

ipv4 10.198.0.0 255.255.255.0

ipv4 152.63.1.0 255.255.255.0

address-hiding

allow-connections sip to sip

no supplementary-service h225-notify cid-update

no supplementary-service sip moved-temporarily

no supplementary-service sip refer

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

fax-relay ans-disable

sip

rel1xx supported "track"

privacy pstn

no update-callerid

early-offer forced

call-route p-called-party-id

!

!

voice class uri 100 sip

host 41.206.187.71

voice class codec 10

codec preference 1 g711alaw

codec preference 2 g711ulaw

codec preference 3 ilbc

codec preference 4 g729r8

codec preference 5 g729br8

!

voice class codec 20

codec preference 1 g729br8

codec preference 2 g729r8

!

!

voice moh-group 1

moh flash:moh/Panjo.alaw.wav

description MOH G711 alaw

multicast moh 239.1.1.2 port 16384 route 10.198.2.9

!

!

!

!

voice translation-rule 1

rule 1 /^012237280\(..\)/ /54280\1/

rule 2 /^012236514\(..\)/ /54214\1/

rule 3 /^01223651081/ /5428010/

rule 4 /^01223506701/ /5428010/

!

voice translation-rule 2

rule 1 /^00\(.+\)/ /+\1/

rule 2 /^0\(.+\)/ /+44\1/

rule 3 /^\([0-9].+\)/ /+\1/

!

voice translation-rule 3

rule 1 /^9\(.+\)/ /\1/

rule 2 /^\+44\(.+\)/ /0\1/

rule 3 /^\+\(.+\)/ /00\1/

!

voice translation-rule 4

rule 1 /^54280\(..\)/ /12237280\1/

rule 2 /^54214\(..\)/ /12236514\1/

rule 3 /^\+44\(.+\)/ /\1/

rule 4 /^.54280\(..\)/ /12237280\1/

rule 5 /^.54214\(..\)/ /12236514\1/

!

voice translation-rule 9

rule 1 /^\(....\)/ /542\1/

!

voice translation-rule 10

!

voice translation-rule 11

rule 1 /^\+44122372\(....\)/ /542\1/

rule 2 /^\+44122365\(....\)/ /542\1/

!

voice translation-rule 12

!

voice translation-rule 13

rule 1 /^\([18]...\)/ /542\1/

!

voice translation-rule 14

!

!

voice translation-profile MPLS-incoming

translate calling 10

translate called 9

!

voice translation-profile MPLS-outgoing

translate calling 11

translate called 12

!

voice translation-profile PSTN-incoming

translate calling 2

translate called 1

!

voice translation-profile PSTN-outgoing

translate calling 4

translate called 3

!

voice translation-profile SRST-incoming

translate calling 14

translate called 13

!

!

license udi pid CISCO2921/K9 sn FGL145110RE

hw-module ism 0

!

hw-module pvdm 0/0

!

!

!

username administrator privilege 15 secret 5 $1$syu5$DsxdOgfS7Wltx78o4PV.60

!

redundancy

!

!

!

!

controller E1 0/0/0

!

ip tcp path-mtu-discovery

ip scp server enable

!

!

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description internal LAN

ip address 10.198.2.9 255.255.255.0

duplex auto

speed auto

!

interface ISM0/0

ip unnumbered GigabitEthernet0/0

service-module ip address 10.198.2.8 255.255.255.0

!Application: CUE Running on ISM

service-module ip default-gateway 10.198.2.9

!

interface GigabitEthernet0/1

description to TATA NGN

ip address 115.114.225.122 255.255.255.252

duplex auto

speed auto

!

interface GigabitEthernet0/2

description SIP Trunks external

ip address 79.121.254.83 255.255.255.248

ip access-group SIP-InBound in

ip traffic-export apply cuecapture size 8000000

duplex auto

speed auto

!

interface ISM0/1

description Internal switch interface connected to Internal Service Module

no ip address

shutdown

!

interface Vlan1

no ip address

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 10.198.2.1

ip route 10.198.2.8 255.255.255.255 ISM0/0

ip route 41.206.187.0 255.255.255.0 115.114.225.121

ip route 77.37.25.46 255.255.255.255 79.121.254.81

ip route 83.245.6.81 255.255.255.255 79.121.254.81

ip route 83.245.6.82 255.255.255.255 79.121.254.81

ip route 95.223.1.107 255.255.255.255 79.121.254.81

ip route 192.54.47.0 255.255.255.0 79.121.254.81

!

ip access-list extended SIP-InBound

permit ip host 77.37.25.46 any

permit ip host 83.245.6.81 any

permit ip host 83.245.6.82 any

permit ip 192.54.47.0 0.0.0.255 any

permit icmp any any

permit ip host 95.223.1.107 any

deny ip any any log

!

!

!

!

!

!

!

control-plane

!

!

voice-port 0/1/0

compand-type a-law

timeouts initial 60

timeouts interdigit 60

timeouts ringing infinity

caller-id enable

!

voice-port 0/1/1

compand-type a-law

timeouts initial 60

timeouts interdigit 60

timeouts ringing infinity

caller-id enable

!

voice-port 0/1/2

compand-type a-law

timeouts initial 60

timeouts interdigit 60

timeouts ringing infinity

caller-id enable

!

voice-port 0/1/3

compand-type a-law

timeouts initial 60

timeouts interdigit 60

timeouts ringing infinity

caller-id enable

!

no ccm-manager fax protocol cisco

ccm-manager music-on-hold bind GigabitEthernet0/0

ccm-manager config server 152.63.1.19 152.63.1.100 172.27.210.5

ccm-manager sccp local GigabitEthernet0/0

ccm-manager sccp

!

!

mgcp profile default

!

sccp local GigabitEthernet0/0

sccp ccm 10.198.2.9 identifier 3 priority 3 version 7.0

sccp ccm 152.63.1.19 identifier 4 version 7.0

sccp ccm 152.63.1.100 identifier 5 version 7.0

sccp ccm 172.27.210.5 identifier 6 version 7.0

sccp

!

sccp ccm group 2

bind interface GigabitEthernet0/0

associate ccm 4 priority 1

associate ccm 5 priority 2

associate ccm 6 priority 3

associate ccm 3 priority 4

associate profile 1002 register CFB_UK_CAM_02

associate profile 1001 register XCODE_UK_CAM_02

associate profile 1000 register MTP_UK_CAM_02

!

dspfarm profile 1001 transcode

codec ilbc

codec g722-64

codec g729br8

codec g729r8

codec gsmamr-nb

codec pass-through

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

maximum sessions 18

associate application SCCP

!

dspfarm profile 1002 conference

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 2

associate application SCCP

!

dspfarm profile 1000 mtp

codec g711alaw

maximum sessions software 200

associate application SCCP

!

dial-peer cor custom

name SRSTMode

!

!

dial-peer cor list SRST

member SRSTMode

!

!

dial-peer voice 100 voip

description *** Inbound CUCM ***

translation-profile incoming PSTN-incoming

incoming called-number .

voice-class codec 10

voice-class sip call-route p-called-party-id

dtmf-relay rtp-nte

no vad

!

dial-peer voice 500 voip

description *** Inbound TATA MPLS ***

translation-profile incoming MPLS-incoming

session protocol sipv2

session target sip-server

incoming called-number ....

incoming uri from 100

voice-class codec 20

dtmf-relay rtp-nte

no vad

!

dial-peer voice 510 voip

description *** Outbound TATA MPLS ***

translation-profile outgoing MPLS-outgoing

destination-pattern 54[013-9]....

session protocol sipv2

session target ipv4:41.206.187.71

session transport udp

voice-class codec 20

dtmf-relay rtp-nte

no vad

!

dial-peer voice 520 voip

description *** Outbound TATA MPLS ***

translation-profile outgoing MPLS-outgoing

destination-pattern 5[0-35-9].....

session protocol sipv2

session target ipv4:41.206.187.71

session transport udp

voice-class codec 20

dtmf-relay rtp-nte

no vad

!

dial-peer voice 200 voip

description *** Inbound M12 *** 01223651081, 01223651440 - 01223651489

translation-profile incoming PSTN-incoming

session protocol sipv2

session target sip-server

session transport udp

incoming called-number 0122365....

dtmf-relay rtp-nte

codec g711ulaw

no vad

!

dial-peer voice 201 voip

description *** Inbound M12 *** 012237280XX

translation-profile incoming PSTN-incoming

session protocol sipv2

session target sip-server

session transport udp

incoming called-number 012237280..

dtmf-relay rtp-nte

codec g711ulaw

no vad

!

dial-peer voice 202 voip

description *** Inbound M12 *** 01223506701

translation-profile incoming PSTN-incoming

session protocol sipv2

session target sip-server

session transport udp

incoming called-number 01223506701

dtmf-relay rtp-nte

codec g711ulaw

no vad

!

dial-peer voice 210 voip

description *** Outbound M12 ***

translation-profile outgoing PSTN-outgoing

destination-pattern +...T

session protocol sipv2

session target ipv4:83.245.6.81

session transport udp

dtmf-relay rtp-nte

codec g711alaw

no vad

!

dial-peer voice 211 voip

description *** Outbound ISDN for SRST and emergency ***

translation-profile outgoing PSTN-outgoing

destination-pattern 9.T

session protocol sipv2

session target ipv4:83.245.6.81

session transport udp

dtmf-relay rtp-nte

codec g711alaw

no vad

!

dial-peer voice 212 voip

description *** Outbound ISDN for emergency ***

translation-profile outgoing PSTN-outgoing

destination-pattern 11[02]

session protocol sipv2

session target ipv4:83.245.6.81

session transport udp

dtmf-relay rtp-nte

codec g711alaw

no vad

!

dial-peer voice 2000 voip

description *** Outbound to CUCM Primary ***

preference 1

destination-pattern 542....

session protocol sipv2

session target ipv4:152.63.1.19

voice-class codec 10

voice-class sip call-route p-called-party-id

dtmf-relay rtp-nte

no vad

!

dial-peer voice 2001 voip

description *** Outbound to CUCM Secondary ***

preference 2

destination-pattern 542....

session protocol sipv2

session target ipv4:152.63.1.100

voice-class codec 10

voice-class sip call-route p-called-party-id

dtmf-relay rtp-nte

no vad

!

dial-peer voice 2002 voip

description *** Outbound to CUCM Teritiary ***

preference 3

destination-pattern 542....

session protocol sipv2

session target ipv4:172.27.210.5

voice-class codec 10

voice-class sip call-route p-called-party-id

dtmf-relay rtp-nte

no vad

!

dial-peer voice 999010 pots

service stcapp

port 0/1/0

!

dial-peer voice 999011 pots

service stcapp

port 0/1/1

!

dial-peer voice 999012 pots

service stcapp

port 0/1/2

!

dial-peer voice 999013 pots

service stcapp

port 0/1/3

!

!

sip-ua

no remote-party-id

!

!

!

gatekeeper

shutdown

!

!

call-manager-fallback

secondary-dialtone 9

max-conferences 4 gain -6

transfer-system full-consult

ip source-address 10.198.2.9 port 2000

max-ephones 110

max-dn 400 dual-line no-reg

translation-profile incoming SRST-incoming

moh flash:/moh/Panjo.ulaw.wav

multicast moh 239.1.1.1 port 16384 route 10.198.2.9

time-zone 22

time-format 24

date-format dd-mm-yy

!

!

!

line con 0

login local

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line 131

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

session-timeout 60

exec-timeout 60 0

privilege level 15

login local

transport input all

line vty 5 15

session-timeout 60

exec-timeout 60 0

privilege level 15

login local

transport input all

!

scheduler allocate 20000 1000

ntp server 10.1.30.1

end

eucamvgw01#

Sh SCCP

-----------------------------------------------------------------------------------------------

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2014.03.03 17:57:44 =~=~=~=~=~=~=~=~=~=~=~=

SCCP Admin State: UP

Gateway Local Interface: GigabitEthernet0/0

IPv4 Address: 10.198.2.9

Port Number: 2000

IP Precedence: 5

User Masked Codec list: None

Call Manager: 10.198.2.9, Port Number: 2000

Priority: 3, Version: 7.0, Identifier: 3

Call Manager: 152.63.1.19, Port Number: 2000

Priority: N/A, Version: 7.0, Identifier: 4

Trustpoint: N/A

Call Manager: 152.63.1.100, Port Number: 2000

Priority: N/A, Version: 7.0, Identifier: 5

Trustpoint: N/A

Call Manager: 172.27.210.5, Port Number: 2000

Priority: N/A, Version: 7.0, Identifier: 6

Trustpoint: N/A

MTP Oper State: ACTIVE - Cause Code: NONE

Active Call Manager: 152.63.1.19, Port Number: 2000

TCP Link Status: CONNECTED, Profile Identifier: 1000

Reported Max Streams: 400, Reported Max OOS Streams: 0

Supported Codec: g711alaw, Maximum Packetization Period: 30

Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30

Supported Codec: rfc2833 pass-thru, Maximum Packetization Period: 30

Supported Codec: inband-dtmf to rfc2833 conversion, Maximum Packetization Period: 30

TLS : ENABLED

Transcoding Oper State: ACTIVE - Cause Code: NONE

Active Call Manager: 152.63.1.19, Port Number: 2000

TCP Link Status: CONNECTED, Profile Identifier: 1001

Reported Max Streams: 36, Reported Max OOS Streams: 0

Supported Codec: ilbc, Maximum Packetization Period: 120

Supported Codec: g722r64, Maximum Packetization Period: 30

Supported Codec: g729br8, Maximum Packetization Period: 60

Supported Codec: g729r8, Maximum Packetization Period: 60

Supported Codec: gsmamr-nb, Maximum Packetization Period: 60

Supported Codec: pass-thru, Maximum Packetization Period: N/A

Supported Codec: g711ulaw, Maximum Packetization Period: 30

Supported Codec: g711alaw, Maximum Packetization Period: 30

Supported Codec: g729ar8, Maximum Packetization Period: 60

Supported Codec: g729abr8, Maximum Packetization Period: 60

Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30

Supported Codec: rfc2833 pass-thru, Maximum Packetization Period: 30

Supported Codec: inband-dtmf to rfc2833 conversion, Maximum Packetization Period: 30

Conferencing Oper State: ACTIVE - Cause Code: NONE

Active Call Manager: 152.63.1.19, Port Number: 2000

TCP Link Status: CONNECTED, Profile Identifier: 1002

Reported Max Streams: 16, Reported Max OOS Streams: 0

Supported Codec: g711ulaw, Maximum Packetization Period: 30

Supported Codec: g711alaw, Maximum Packetization Period: 30

Supported Codec: g729ar8, Maximum Packetization Period: 60

Supported Codec: g729abr8, Maximum Packetization Period: 60

Supported Codec: g729r8, Maximum Packetization Period: 60

Supported Codec: g729br8, Maximum Packetization Period: 60

Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30

Supported Codec: rfc2833 pass-thru, Maximum Packetization Period: 30

Supported Codec: inband-dtmf to rfc2833 conversion, Maximum Packetization Period: 30

TLS : ENABLED

Alg_Phone Oper State: ACTIVE - Cause Code: NONE

Active Call Manager: 152.63.1.19, Port Number: 2000

TCP Link Status: CONNECTED, Device Name: AN71FEF7F070080

Reported Max Streams: 1, Reported Max OOS Streams: 0

Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30

Supported Codec: g711ulaw, Maximum Packetization Period: 20

Supported Codec: g711alaw, Maximum Packetization Period: 20

Supported Codec: g729r8, Maximum Packetization Period: 220Supported Codec: g729ar8, Maximum Packetization Period: 220

Supported Codec: g729br8, Maximum Packetization Period: 220

Supported Codec: g729r8, Maximum Packetization Period: 220

Supported Codec: ilbc, Maximum Packetization Period: 120

Alg_Phone Oper State: ACTIVE - Cause Code: NONE

Active Call Manager: 152.63.1.19, Port Number: 2000

TCP Link Status: CONNECTED, Device Name: AN71FEF7F070081

Reported Max Streams: 1, Reported Max OOS Streams: 0

Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30

Supported Codec: g711ulaw, Maximum Packetization Period: 20

Supported Codec: g711alaw, Maximum Packetization Period: 20

Supported Codec: g729r8, Maximum Packetization Period: 220

Supported Codec: g729ar8, Maximum Packetization Period: 220

Supported Codec: g729br8, Maximum Packetization Period: 220

Supported Codec: g729r8, Maximum Packetization Period: 220

Supported Codec: ilbc, Maximum Packetization Period: 120

Alg_Phone Oper State: ACTIVE - Cause Code: NONE

Active Call Manager: 152.63.1.19, Port Number: 2000

TCP Link Status: CONNECTED, Device Name: AN71FEF7F070082

Reported Max Streams: 1, Reported Max OOS Streams: 0

Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30

Supported Codec: g711ulaw, Maximum Packetization Period: 20Supported Codec: g711alaw, Maximum Packetization Period: 20

Supported Codec: g729r8, Maximum Packetization Period: 220

Supported Codec: g729ar8, Maximum Packetization Period: 220

Supported Codec: g729br8, Maximum Packetization Period: 220

Supported Codec: g729r8, Maximum Packetization Period: 220

Supported Codec: ilbc, Maximum Packetization Period: 120

Alg_Phone Oper State: ACTIVE - Cause Code: NONE

Active Call Manager: 152.63.1.19, Port Number: 2000

TCP Link Status: CONNECTED, Device Name: AN71FEF7F070083

Reported Max Streams: 1, Reported Max OOS Streams: 0

Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30

Supported Codec: g711ulaw, Maximum Packetization Period: 20

Supported Codec: g711alaw, Maximum Packetization Period: 20

Supported Codec: g729r8, Maximum Packetization Period: 220

Supported Codec: g729ar8, Maximum Packetization Period: 220

Supported Codec: g729br8, Maximum Packetization Period: 220

Supported Codec: g729r8, Maximum Packetization Period: 220

Supported Codec: ilbc, Maximum Packetization Period: 120

eucamvgw01#

Cisco Employee

Calling issue with Cisco 7937 conference station

Hi Siva

Which VGW this config is of? Close to Phone A or Phone B. Do you have access to both the VGW? Please share the configuration of the second VGW as well alongwith:-

"Debug VOIP CCAPI inout" from both VGW for the failed call.

- Basant

Calling issue with Cisco 7937 conference station

HI Basant,

The provided logs are from Phone A Gateway, unfortunately i could not take Phone B gateway logs

Below are logs out put of debug voip ccapi inout

Source extension is 5431414  -- Conference station (7937)

Destination extension is 5591555

---------------------------------------------------------------------------------------------------------------------------------


*Mar  3 16:25:41.232: cc_api_get_xcode_stream : 4819
*Mar  3 16:25:41.232: //7392/2AF4E1358AC9/CCAPI/cc_api_bridge_drop_done:
   Conference Id=0xB61, Source Interface=0x32A78384, Source Call Id=7392,
   Destination Call Id=7391, Disposition=0x0, Tag=0x0
*Mar  3 16:25:41.232: //7391/2AF4E1358AC9/CCAPI/cc_generic_bridge_done:
   Conference Id=0xB61, Source Interface=0x32A78384, Source Call Id=7392,
   Destination Call Id=7391, Disposition=0x0, Tag=0x0
*Mar  3 16:25:41.232: //7391/2AF4E1358AC9/CCAPI/ccCallDisconnect:
   Cause Value=16, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=16)
*Mar  3 16:25:41.232: //7391/2AF4E1358AC9/CCAPI/ccCallDisconnect:
   Cause Value=16, Call Entry(Responsed=TRUE, Cause Value=16)
*Mar  3 16:25:41.232: //7392/2AF4E1358AC9/CCAPI/ccCallDisconnect:
   Cause Value=16, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)
*Mar  3 16:25:41.232: //7392/2AF4E1358AC9/CCAPI/ccCallDisconnect:
   Cause Value=16, Call Entry(Responsed=TRUE, Cause Value=16)
*Mar  3 16:25:41.232: //7391/2AF4E1358AC9/CCAPI/cc_api_call_disconnect_done:
   Disposition=0, Interface=0x32A78384, Tag=0x0, Call Id=7391,
   Call Entry(Disconnect Cause=16, Voice Class Cause Code=0, Retry Count=0)
*Mar  3 16:25:41.232: //7391/2AF4E1358AC9/CCAPI/cc_api_call_disconnect_done:
   Call Disconnect Event Sent
*Mar  3 16:25:41.232: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
  
*Mar  3 16:25:41.232: :cc_free_feature_vsa freeing 2C60ED90
*Mar  3 16:25:41.232: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
  
*Mar  3 16:25:41.232:  vsacount in free is 1
*Mar  3 16:25:41.396: //7392/2AF4E1358AC9/CCAPI/cc_api_call_disconnect_done:
   Disposition=0, Interface=0x32A78384, Tag=0x0, Call Id=7392,
   Call Entry(Disconnect Cause=16, Voice Class Cause Code=0, Retry Count=0)
*Mar  3 16:25:41.400: //7392/2AF4E1358AC9/CCAPI/cc_api_call_disconnect_done:
   Call Disconnect Event Sent
*Mar  3 16:25:41.400: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
  
*Mar  3 16:25:41.400: :cc_free_feature_vsa freeing 2C60F650
*Mar  3 16:25:41.400: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
  
*Mar  3 16:25:41.400:  vsacount in free is 0
*Mar  3 16:25:56.064: //-1/B93687000000/CCAPI/cc_api_display_ie_subfields:
   cc_api_call_setup_ind_common:
   cisco-username=5431414
   ----- ccCallInfo IE subfields -----
   cisco-ani=5431414
   cisco-anitype=0
   cisco-aniplan=0
   cisco-anipi=0
   cisco-anisi=1
   dest=5591555
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-rdntype=0
   cisco-rdnplan=0
   cisco-rdnpi=-1
   cisco-rdnsi=-1
   cisco-redirectreason=-1   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

*Mar  3 16:25:56.064: //-1/B93687000000/CCAPI/cc_api_call_setup_ind_common:
   Interface=0x32A78384, Call Info(
   Calling Number=5431414,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),
   Called Number=5591555(TON=Unknown, NPI=Unknown),
   Calling Translated=FALSE, Subscriber Type Str=Unknown, FinalDestinationFlag=TRUE,
   Incoming Dial-peer=100, Progress Indication=NULL(0), Calling IE Present=TRUE,
   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=7393
*Mar  3 16:25:56.064: //-1/B93687000000/CCAPI/ccCheckClipClir:
   In: Calling Number=5431414(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)
*Mar  3 16:25:56.064: //-1/B93687000000/CCAPI/ccCheckClipClir:
   Out: Calling Number=5431414(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)
*Mar  3 16:25:56.064: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
  
*Mar  3 16:25:56.064: :cc_get_feature_vsa malloc success
*Mar  3 16:25:56.064: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
  
*Mar  3 16:25:56.064:  cc_get_feature_vsa count is 1
*Mar  3 16:25:56.064: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
  
*Mar  3 16:25:56.064: :FEATURE_VSA attributes are: feature_name:0,feature_time:744552024,feature_id:7018
*Mar  3 16:25:56.064: //7393/B93687000000/CCAPI/cc_api_call_setup_ind_common:
   Set Up Event Sent;
   Call Info(Calling Number=5431414(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),
   Called Number=5591555(TON=Unknown, NPI=Unknown))
*Mar  3 16:25:56.064: //7393/B93687000000/CCAPI/cc_process_call_setup_ind:
   Event=0x344F9BD0
*Mar  3 16:25:56.064: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_search:
   Try with the demoted called number 5591555
*Mar  3 16:25:56.064: //7393/B93687000000/CCAPI/ccCallSetContext:
   Context=0x2ADEE544
*Mar  3 16:25:56.064: //7393/B93687000000/CCAPI/cc_process_call_setup_ind:
   >>>>CCAPI handed cid 7393 with tag 100 to app "_ManagedAppProcess_Default"
*Mar  3 16:25:56.064: //7393/B93687000000/CCAPI/ccCallProceeding:
   Progress Indication=NULL(0)
*Mar  3 16:25:56.068: //7393/B93687000000/CCAPI/ccCallSetupRequest:
   Destination=, Calling IE Present=TRUE, Mode=0,
   Outgoing Dial-peer=520, Params=0x2ADF0E74, Progress Indication=NULL(0)
*Mar  3 16:25:56.068: //7393/B93687000000/CCAPI/ccCheckClipClir:
   In: Calling Number=5431414(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)
*Mar  3 16:25:56.068: //7393/B93687000000/CCAPI/ccCheckClipClir:
   Out: Calling Number=5431414(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)
*Mar  3 16:25:56.068: //7393/B93687000000/CCAPI/ccCallSetupRequest:
   Destination Pattern=5[0-35-9]....., Called Number=5591555, Digit Strip=FALSE
*Mar  3 16:25:56.068: //7393/B93687000000/CCAPI/ccCallSetupRequest:
   Calling Number=5431414(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),
   Called Number=5591555(TON=Unknown, NPI=Unknown),
   Redirect Number=, Display Info=Board Room
   Account Number=5431414, Final Destination Flag=TRUE,
   Guid=B9368700-0001-0000-0000-78CF13013F98, Outgoing Dial-peer=520
*Mar  3 16:25:56.068: //7393/B93687000000/CCAPI/cc_api_display_ie_subfields:
   ccCallSetupRequest:
   cisco-username=5431414
   ----- ccCallInfo IE subfields -----
   cisco-ani=5431414
   cisco-anitype=0
   cisco-aniplan=0
   cisco-anipi=0
   cisco-anisi=1
   dest=5591555
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-rdntype=0
   cisco-rdnplan=0
   cisco-rdnpi=-1
   cisco-rdnsi=-1
   cisco-redirectreason=-1   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

*Mar  3 16:25:56.068: //7393/B93687000000/CCAPI/ccIFCallSetupRequestPrivate:
   Interface=0x32A78384, Interface Type=3, Destination=, Mode=0x0,
   Call Params(Calling Number=5431414,(Calling Name=Board Room)(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),
   Called Number=5591555(TON=Unknown, NPI=Unknown), Calling Translated=FALSE,
   Subscriber Type Str=Unknown, FinalDestinationFlag=TRUE, Outgoing Dial-peer=520, Call Count On=FALSE,
   Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Application Call Id=)
*Mar  3 16:25:56.068: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
  
*Mar  3 16:25:56.068: :cc_get_feature_vsa malloc success
*Mar  3 16:25:56.068: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
  
*Mar  3 16:25:56.068:  cc_get_feature_vsa count is 2
*Mar  3 16:25:56.068: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
  
*Mar  3 16:25:56.068: :FEATURE_VSA attributes are: feature_name:0,feature_time:744549784,feature_id:7019
*Mar  3 16:25:56.068: //7394/B93687000000/CCAPI/ccIFCallSetupRequestPrivate:
   SPI Call Setup Request Is Success; Interface Type=3, FlowMode=1
*Mar  3 16:25:56.068: //7394/B93687000000/CCAPI/ccCallSetContext:
   Context=0x2ADF0E24
*Mar  3 16:25:56.068: //7393/B93687000000/CCAPI/ccSaveDialpeerTag:
   Outgoing Dial-peer=520
*Mar  3 16:25:56.068: //7394/B93687000000/CCAPI/cc_api_call_proceeding:
   Interface=0x32A78384, Progress Indication=NULL(0)
*Mar  3 16:25:56.904: //7394/B93687000000/CCAPI/cc_api_call_alert:
   Interface=0x32A78384, Progress Indication=NULL(0), Signal Indication=SIGNAL RINGBACK(1)
*Mar  3 16:25:56.904: //7394/B93687000000/CCAPI/cc_api_call_alert:
   Call Entry(Retry Count=0, Responsed=TRUE)
*Mar  3 16:25:56.904: //7393/B93687000000/CCAPI/ccCallAlert:
   Progress Indication=NULL(0), Signal Indication=SIGNAL RINGBACK(1)
*Mar  3 16:25:56.904: //7393/B93687000000/CCAPI/ccCallAlert:
   Call Entry(Responsed=TRUE, Alert Sent=TRUE)
*Mar  3 16:26:05.788: //7394/B93687000000/CCAPI/cc_api_caps_ind:
   Destination Interface=0x0, Destination Call Id=-1, Source Call Id=7394,
   Caps(Codec=0x800, Fax Rate=0x2, Fax Version:=0, Vad=0x2,
   Modem=0x0, Codec Bytes=20, Signal Type=2)
*Mar  3 16:26:05.788: //7394/B93687000000/CCAPI/cc_api_caps_ind:
   Caps(Playout Mode=1, Playout Initial=60(ms), Playout Min=40(ms),
   Playout Max=1000(ms), Fax Nom=300(ms))
*Mar  3 16:26:05.788: //7393/B93687000000/CCAPI/cc_api_caps_ack:
   Destination Interface=0x0, Destination Call Id=7394, Source Call Id=7393,
   Caps(Codec=g711alaw(0x2), Fax Rate=FAX_RATE_VOICE(0x2), Fax Version:=0, Vad=OFF(0x1),
   Modem=OFF(0x0), Codec Bytes=160, Signal Type=2, Seq Num Start=9286)
*Mar  3 16:26:05.788: //7393/B93687000000/CCAPI/cc_api_caps_ack:
   Destination Interface=0x0, Destination Call Id=7394, Source Call Id=7393,
   Caps(Codec=g711alaw(0x2), Fax Rate=FAX_RATE_VOICE(0x2), Fax Version:=0, Vad=OFF(0x1),
   Modem=OFF(0x0), Codec Bytes=160, Signal Type=2, Seq Num Start=9286)
*Mar  3 16:26:05.788: //7394/B93687000000/CCAPI/cc_api_event_indication:
   Event=177, Call Id=7394
*Mar  3 16:26:05.788: //7394/B93687000000/CCAPI/cc_api_event_indication:
   Event Is Sent To Conferenced SPI(s) Directly
*Mar  3 16:26:05.788: //7394/B93687000000/CCAPI/cc_api_call_connected:
   Interface=0x32A78384, Data Bitmask=0x1, Progress Indication=NULL(0),
   Connection Handle=0
*Mar  3 16:26:05.788: //7394/B93687000000/CCAPI/cc_api_call_connected:
   Call Entry(Connected=TRUE, Responsed=TRUE, Retry Count=0)
*Mar  3 16:26:05.788: //7393/B93687000000/CCAPI/ccGetMediaClassTag:
   media class tag 0
*Mar  3 16:26:05.788: //7393/B93687000000/CCAPI/ccSetMediaclassIp2ipTags:
   media class tags set: NR 0, ASP 0
*Mar  3 16:26:05.788: //7394/B93687000000/CCAPI/ccGetMediaClassTag:
   media class tag 0
*Mar  3 16:26:05.788: //7394/B93687000000/CCAPI/ccSetMediaclassIp2ipTags:
   media class tags set: NR 0, ASP 0
*Mar  3 16:26:05.788: //7393/B93687000000/CCAPI/ccGet_xc_nr_asp_info:
   media class tags: NR 0, ASP 0
*Mar  3 16:26:05.788: //7394/B93687000000/CCAPI/ccGet_xc_nr_asp_info:
   media class tags: NR 0, ASP 0
*Mar  3 16:26:05.788: //7393/B93687000000/CCAPI/ccGetMediaClassTag:
   media class tag 0
*Mar  3 16:26:05.788: //7393/B93687000000/CCAPI/ccSetMediaclassIp2ipTags:
   media class tags set: NR 0, ASP 0
*Mar  3 16:26:05.788: //7394/B93687000000/CCAPI/ccGetMediaClassTag:
   media class tag 0
*Mar  3 16:26:05.788: //7394/B93687000000/CCAPI/ccSetMediaclassIp2ipTags:
   media class tags set: NR 0, ASP 0
*Mar  3 16:26:05.788: //7393/B93687000000/CCAPI/ccGet_xc_nr_asp_info:
   media class tags: NR 0, ASP 0
*Mar  3 16:26:05.788: //7394/B93687000000/CCAPI/ccGet_xc_nr_asp_info:
   media class tags: NR 0, ASP 0
*Mar  3 16:26:05.788: //7393/B93687000000/CCAPI/ccGetMediaClassTag:
   media class tag 0
*Mar  3 16:26:05.788: //7393/B93687000000/CCAPI/ccSetMediaclassIp2ipTags:
   media class tags set: NR 0, ASP 0
*Mar  3 16:26:05.788: //7394/B93687000000/CCAPI/ccGetMediaClassTag:
   media class tag 0
*Mar  3 16:26:05.788: //7394/B93687000000/CCAPI/ccSetMediaclassIp2ipTags:
   media class tags set: NR 0, ASP 0
*Mar  3 16:26:05.788: //7393/B93687000000/CCAPI/ccGet_xc_nr_asp_info:
   media class tags: NR 0, ASP 0
*Mar  3 16:26:05.788: //7394/B93687000000/CCAPI/ccGet_xc_nr_asp_info:
   media class tags: NR 0, ASP 0
*Mar  3 16:26:05.788: //7393/B93687000000/CCAPI/ccGetMediaClassTag:
   media class tag 0
*Mar  3 16:26:05.788: //7393/B93687000000/CCAPI/ccSetMediaclassIp2ipTags:
   media class tags set: NR 0, ASP 0
*Mar  3 16:26:05.788: //7394/B93687000000/CCAPI/ccGetMediaClassTag:
   media class tag 0
*Mar  3 16:26:05.788: //7394/B93687000000/CCAPI/ccSetMediaclassIp2ipTags:
   media class tags set: NR 0, ASP 0
*Mar  3 16:26:05.788: //7393/B93687000000/CCAPI/ccGet_xc_nr_asp_info:
   media class tags: NR 0, ASP 0
*Mar  3 16:26:05.788: //7394/B93687000000/CCAPI/ccGet_xc_nr_asp_info:
   media class tags: NR 0, ASP 0
*Mar  3 16:26:05.788: //7393/B93687000000/CCAPI/ccGetMediaClassTag:
   media class tag 0
*Mar  3 16:26:05.788: //7393/B93687000000/CCAPI/ccSetMediaclassIp2ipTags:
   media class tags set: NR 0, ASP 0
*Mar  3 16:26:05.788: //7394/B93687000000/CCAPI/ccGetMediaClassTag:
   media class tag 0
*Mar  3 16:26:05.788: //7394/B93687000000/CCAPI/ccSetMediaclassIp2ipTags:
   media class tags set: NR 0, ASP 0
*Mar  3 16:26:05.788: //7393/B93687000000/CCAPI/ccGet_xc_nr_asp_info:
   media class tags: NR 0, ASP 0
*Mar  3 16:26:05.788: //7394/B93687000000/CCAPI/ccGet_xc_nr_asp_info:
   media class tags: NR 0, ASP 0
*Mar  3 16:26:05.788: //7393/B93687000000/CCAPI/cc_api_event_indication:
   Event=188, Call Id=7393
*Mar  3 16:26:05.788: //7393/B93687000000/CCAPI/cc_api_event_indication:
   Event Is Sent To Conferenced SPI(s) Directly
*Mar  3 16:26:05.788: //7394/xxxxxxxxxxxx/CCAPI/cc_api_get_xcode_stream:
  
*Mar  3 16:26:05.788: cc_api_get_xcode_stream : 4819
*Mar  3 16:26:05.788: //7393/xxxxxxxxxxxx/CCAPI/cc_api_get_xcode_stream:
  
*Mar  3 16:26:05.788: cc_api_get_xcode_stream : 4819
*Mar  3 16:26:05.788: //7394/xxxxxxxxxxxx/CCAPI/cc_api_get_xcode_stream:
  
*Mar  3 16:26:05.788: cc_api_get_xcode_stream : 4819
*Mar  3 16:26:05.788: //7394/xxxxxxxxxxxx/CCAPI/cc_api_get_xcode_stream:
  
*Mar  3 16:26:05.788: cc_api_get_xcode_stream : 4819
*Mar  3 16:26:05.788: //7393/xxxxxxxxxxxx/CCAPI/cc_api_get_xcode_stream:
  
*Mar  3 16:26:05.788: cc_api_get_xcode_stream : 4819
*Mar  3 16:26:05.788: //7394/xxxxxxxxxxxx/CCAPI/cc_api_get_xcode_stream:
  
*Mar  3 16:26:05.788: cc_api_get_xcode_stream : 4819
*Mar  3 16:26:05.788: //7393/xxxxxxxxxxxx/CCAPI/cc_api_get_xcode_stream:
  
*Mar  3 16:26:05.788: cc_api_get_xcode_stream : 4819
*Mar  3 16:26:05.788: //7393/xxxxxxxxxxxx/CCAPI/cc_api_get_xcode_stream:
  
*Mar  3 16:26:05.788: cc_api_get_xcode_stream : 4819
*Mar  3 16:26:05.792: //7393/B93687000000/CCAPI/ccConferenceCreate:
   (confID=0xFFFFFFFF, callID1=0x1CE1, gcid=54C1877A-A22711E3-8AD2FFA6-C7150D9B, tag=0x0)
*Mar  3 16:26:05.792: //7394/B93687000000/CCAPI/ccConferenceCreate:
   (confID=0xFFFFFFFF, callID2=0x1CE2, gcid=54C1877A-A22711E3-8AD2FFA6-C7150D9B, tag=0x0)
*Mar  3 16:26:05.792: //7393/B93687000000/CCAPI/ccConferenceCreate:
   Conference Id=0xFFFFFFFF, Call Id1=7393, Call Id2=7394, Tag=0x0
*Mar  3 16:26:05.792: //7393/xxxxxxxxxxxx/CCAPI/cc_api_get_xcode_stream:
  
*Mar  3 16:26:05.792: cc_api_get_xcode_stream : 4819
*Mar  3 16:26:05.792: //7394/xxxxxxxxxxxx/CCAPI/cc_api_get_xcode_stream:
  
*Mar  3 16:26:05.792: cc_api_get_xcode_stream : 4819
*Mar  3 16:26:05.792: //7393/B93687000000/CCAPI/ccConferenceCreate:
  
*Mar  3 16:26:05.792: ccConferenceCreate: ret1=0, codecMask1=2048, bytes1=20, negot1=0, dtmf1=6
                    ret2=0, codecMask2=2048, bytes2=20, negot2=1, dtmf2=6,
                    tx_dynamic_pt1=0, rx_dynamic_pt1=0, codec_mode1=0, params_bitmap1 =0
                    tx_dynamic_pt2=18, rx_dynamic_pt2=18, codec_mode2=0, params_bitmap2 =0
*Mar  3 16:26:05.792: //7393/B93687000000/CCAPI/ccGetMediaClassTag:
   media class tag 0
*Mar  3 16:26:05.792: //7393/B93687000000/CCAPI/ccSetMediaclassIp2ipTags:
   media class tags set: NR 0, ASP 0
*Mar  3 16:26:05.792: //7394/B93687000000/CCAPI/ccGetMediaClassTag:
   media class tag 0
*Mar  3 16:26:05.792: //7394/B93687000000/CCAPI/ccSetMediaclassIp2ipTags:
   media class tags set: NR 0, ASP 0
*Mar  3 16:26:05.792: //7393/B93687000000/CCAPI/ccGet_xc_nr_asp_info:
   media class tags: NR 0, ASP 0
*Mar  3 16:26:05.792: //7394/B93687000000/CCAPI/ccGet_xc_nr_asp_info:
   media class tags: NR 0, ASP 0
*Mar  3 16:26:05.792: //7393/B93687000000/CCAPI/ccConferenceCreate:
   delay media to slow start case, codec negotation is not done
*Mar  3 16:26:05.792: //7393/xxxxxxxxxxxx/CCAPI/cc_api_get_xcode_stream:
  
*Mar  3 16:26:05.792: cc_api_get_xcode_stream : 4819
*Mar  3 16:26:05.792: //7393/xxxxxxxxxxxx/CCAPI/cc_api_get_xcode_stream:
  
*Mar  3 16:26:05.792: cc_api_get_xcode_stream : 4819
*Mar  3 16:26:05.792: //7393/B93687000000/CCAPI/cc_api_bridge_done:
   Conference Id=0xB62, Source Interface=0x32A78384, Source Call Id=7393,
   Destination Call Id=7394, Disposition=0x0, Tag=0x0
*Mar  3 16:26:05.792: //7394/xxxxxxxxxxxx/CCAPI/cc_api_get_xcode_stream:
  
*Mar  3 16:26:05.792: cc_api_get_xcode_stream : 4819
*Mar  3 16:26:05.792: //7394/xxxxxxxxxxxx/CCAPI/cc_api_get_xcode_stream:
  
*Mar  3 16:26:05.792: cc_api_get_xcode_stream : 4819
*Mar  3 16:26:05.792: //7394/B93687000000/CCAPI/cc_api_bridge_done:
   Conference Id=0xB62, Source Interface=0x32A78384, Source Call Id=7394,
   Destination Call Id=7393, Disposition=0x0, Tag=0x0
*Mar  3 16:26:05.792: //7393/B93687000000/CCAPI/cc_generic_bridge_done:
   Conference Id=0xB62, Source Interface=0x32A78384, Source Call Id=7394,
   Destination Call Id=7393, Disposition=0x0, Tag=0x0
*Mar  3 16:26:05.792: //7393/B93687000000/CCAPI/ccConferenceCreate:
   Call

Cisco Employee

Calling issue with Cisco 7937 conference station

Hi Siva

From the Debug, we could find:-

A. Incoming Dial-peer used for this call is 100 and Outbound is 520.

B. Codec=g711alaw(0x2) is selected as preferred codec for this GW.

Voice class codec applied on DP 100:-

voice class codec 10

codec preference 1 g711alaw

codec preference 2 g711ulaw

codec preference 3 ilbc

codec preference 4 g729r8

codec preference 5 g729br8

Voice class codec applied on DP 520:-

voice class codec 20

codec preference 1 g729br8

codec preference 2 g729r8

I see the transcoder configured on this GW (XCODE_UK_CAM_02) has support for G711alaw codec however we need to ensure this xcoder is accessible to MRGL/MRG of the 7937 calling phone and SIP Trunk to this VGW.

As a test, you can try adding "codec g711alaw" as preference 1 under "voice class codec 20" and see if it bypasses the Xcoder need however it would only help if the Phone B VGW is also negotiating the same codec.

Logs from Phone B VGW would help further.

- Basant

396
Views
0
Helpful
5
Replies
CreatePlease login to create content