Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

calling name not working on PRI

Hello All:

I need some help

I have a PRI from Allstream using NI2 as switchtype connected to a Cisco

WS-SVC-CMM with IOS 12.4.(7h).

In the CM gateway settings, I checked box enabled for

Display IE Delivery and Redirecting Number IE Deliver.

Any suggestions?

9 REPLIES
Cisco Employee

Re: calling name not working on PRI

have you confirmed you're receiving the calling name?? and on which IE??

HTH

java

if this helps, please rate

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
New Member

Re: calling name not working on PRI

my problem are with outbound call. I want to send the calling name to my PSTN. The calling name with inbound call are OK.

Cisco Employee

Re: calling name not working on PRI

OK, well still applies to make sure CUCM is sending the calling name. If you already have the name configured on every phone and the display checkboxes you should be sending the info.

a debug isdn q931 or a debug voip ccapi inout should show this.

HTH

java

if this helps, please rate

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
New Member

Re: calling name not working on PRI

I did !

So if I see "Display i = 'SIT'" I send the calling name to my PSTN and probably that the problem is from my PSTN ?

thanks.

Jan 9 19:14:50.465: ISDN Se1/5:23 Q931: TX -> SETUP pd = 8 callref = 0x0002

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98397

Exclusive, Channel 23

Facility i = 0x9F8B0100A10B0201010201008003534954

Protocol Profile = Networking Extensions

0xA10B0201010201008003534954

Component = Invoke component

Invoke Id = 1

Operation = CallingName

Name presentation allowed

Name = SIT

Progress Ind i = 0x8083 - Origination address is non-ISDN

Display i = 'SIT'

Calling Party Number i = 0x0081, '4186563508'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x80, '4186562550'

Plan:Unknown, Type:Unknown

Jan 9 19:14:50.509: ISDN Se1/5:23 Q931: RX <- STATUS pd = 8 callref = 0x8002

Cause i = 0x80E428 - Invalid information element contents

Call State i = 0x01

Jan 9 19:14:50.565: ISDN Se1/5:23 Q931: RX <- CALL_PROC pd = 8 callref = 0x8002

Channel ID i = 0xA98397

Exclusive, Channel 23

Jan 9 19:14:50.661: ISDN Se1/5:23 Q931: RX <- ALERTING pd = 8 callref = 0x8002

Progress Ind i = 0x8088 - In-band info or appropriate now available

Jan 9 19:14:55.309: ISDN Se1/5:23 Q931: RX <- CONNECT pd = 8 callref = 0x8002

Jan 9 19:14:55.317: ISDN Se1/5:23 Q931: TX -> CONNECT_ACK pd = 8 callref = 0x0002

Jan 9 19:14:58.809: ISDN Se1/5:23 Q931: RX <- DISCONNECT pd = 8 callref = 0x8002

Cause i = 0x8090 - Normal call clearing

Jan 9 19:14:58.829: ISDN Se1/5:23 Q931: TX -> RELEASE pd = 8 callref = 0x0002

Jan 9 19:14:58.861: ISDN Se1/5:23 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x8002

Re: calling name not working on PRI

This:

: RX <- STATUS pd = 8 callref = 0x8002

Cause i = 0x80E428 - Invalid information element contents

Shows that your provider doesn't support this IE (Information Element).

I would ask your provider how they would like the calling number, or if they support it.

hth,

nick

Cisco Employee

Re: calling name not working on PRI

you're definitely sending the calling name:

Operation = CallingName

Name presentation allowed

Name = SIT

Display i = 'SIT'

but telco is complaining of some IEs

Cause i = 0x80E428 - Invalid information element contents

Call State i = 0x01

probably it's the display IE with the name, i would call them and confirm they do support the calling name from your side. some telcos charge an extra fee for the service or some of them override the IEs or simply drop them. a call to the telco would clarify this.

try making calls to different numbers, i knew of some cases on which the issue was with the mobile company or the telco from the called party.

HTH

java

if this helps, please rate

HTH

java

if this helps, please rate

www.cisco.com/go/pdi

Re: calling name not working on PRI

More importantly - which protocol are you using? MGCP/H323?

New Member

Re: calling name not working on PRI

I use MGCP.

New Member

Re: calling name not working on PRI

Hi J,

Can you update the end of this issue? We are having the exactly issue with Allstream. They changed from NI2 to NI1 but still not working.

Thanks

523
Views
0
Helpful
9
Replies