Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CallManager 5.1 restore error

Hello,

I've a problem when I restore my CCM 5.1.

It said that Database is currently opened by another user. (more info in the attachments)

And I don't have any user connected ?!?!?

Thx very much ;-)

Hans

10 REPLIES

Re: CallManager 5.1 restore error

Hi Hans,

This is a known issue.

Open a TAC case and you get an ES release.

/Martin

New Member

Re: CallManager 5.1 restore error

Hi Hans,

taken from the Release Notes Document of Cisco the solution is:

Step 1 Stop the dbmon on all the subscriber servers.

admin:utils service stop Cisco Database Layer Monitor

Service Manager is running

Cisco Database Layer Monitor[STOPPING]

Cisco Database Layer Monitor[STOPPING]

Cisco Database Layer Monitor[STOPPING]

Cisco Database Layer Monitor[STOPPING]

Component is not running

Cisco Database Layer Monitor[NOTRUNNIG]

admin:

admin:

admin:quit

Copyright Cisco Systems 2006

[root@nw096a-86 root]#

[root@nw096a-86 root]#

[root@nw096a-86 root]# ps -ef | grep dbmon

root 28142 27797 0 15:59 pts/0 00:00:00 grep dbmon

Step 2 After DRF restore on the publisher server completes, restart the dbmon service.

admin:utils service start Cisco Database Layer Monitor

Service Manager is running

Cisco Database Layer Monitor[STARTED]

admin:quit

Copyright Cisco Systems 2006

[root@nw096a-86 sdi]# ps -ef | grep dbmon

database 28634 3362 4 16:11 ? 00:00:00 /usr/local/cm/bin/dbmon

root 28663 27797 0 16:12 pts/0 00:00:00 grep dbmon

[root@nw096a-86 sdi]#

Hope this helps.

Cheers.

New Member

Re: CallManager 5.1 restore error

Thx,

but I found this release note and apply this and there is no effects because I don't have a subscriber.

I explain :

I've a publisher and a subscriber in exploitation and I've just a publisher for tests in a floating network.

This is just for testing and I don't have a subscriber in my floating network...

I've backup my CCM in exploitation and I would to restore it on my CCM labo for testing.

I applied this release on my publisher, but there's no effect.

I've also upgrade my CCM from 5.1.1.1000-7 to 5.1.1.3000-5, but the problem persist...

I'm lost ....

New Member

Re: CallManager 5.1 restore error

OK, now I see what your problem is.

You cannot restore your exploited CCM onto a lab one because simply they have different MAC addresses. The license file you used to activate the exploited server cannot be used on the lab server. Sorry for that, but Cisco, after the initiation of the CCM v5 uses this type of lock-ups in order not to lose money from unlicesed CallManager installations.

I hope this helped.

Cheers.

New Member

Re: CallManager 5.1 restore error

Yes, but what I don't understand it's :

When I've restore a blank backup (whith no configuration), It's works.

After this restoration, I still restore the backup from my CCM in exploitation and there is no problem.

This is just when I restore the CCM in exploitation backup on a CCM in exploitation backup...

And the license files that have been added one time, stay even after any restore.

New Member

Re: CallManager 5.1 restore error

the license files might stay but they just don't work on a different server machine. This is it!

Cheers

New Member

Re: CallManager 5.1 restore error

Hi, I have the same problem than hanslepire , but on the original pub they are 200 DLU and in my lab I hay only 100 DLU for this new server. You think that this is my problem?

Thanks

Carlos

Re: CallManager 5.1 restore error

Do you have any (more) info on how to rebuild a publisher on a new machine?

If a publisher is gone for good the MAC address changes and everybody is having a coffee until a new license file is mailed from the TAC?

:-)

/Martin

New Member

Re: CallManager 5.1 restore error

hahahahahahaha

you are absolutely right about the coffee!!! Unfortunately this is the procedure (caffeine rulez).

Cheers Martin

New Member

Re: CallManager 5.1 restore error

Hi,

I have almost the exact same situation but this time without the subscriber.

I can't do the client's restore in my lab CCM. Untill here everything is the same as above. The only difference is that to beggin with, just to be abble to start the restore I had to edit the XML file produced during the backup and change the "server name" parameter to my lab's CCM name. Did you have to do this?

After this the restore operation beggins but i get a diferent error:

Log File: 2007-11-05-22-13-51_r_ccm01_ccm_locale.log =====================================================

Server : CCM01

Feature : CCM

Component : LOCALE

Time Completed: 2007-11-05-22-18-27

Result Code : 1

Result String : ERROR

=====================================================

----> BEGIN Standard Output

tarball does not exist or can not be read

----> END Standard Output

----> BEGIN Standard Error

----> END Standard Error

What i would like to know is if dispite your error are you abble to vizualize the backed up configuration after the restore even if it doesn't work?

BR,

Pedro

326
Views
0
Helpful
10
Replies
CreatePlease to create content