Cisco Support Community
Community Member

CallManager communication with VoiceGateway


I am trying to route calls from my internalk VOIP phones to PSTN, my route-pattern is working fine, as whenever i try dial 9 and 7 digit number, it automatically strips 9 but call doesnt go through to Gateway. there is no led initiated on FXO port on Voice Gateway ,

Second issue is When i try to dial in from my Cell Phone, led initiates on FXO port, but after one ring call gets disconnected , because VG is not forwarding call back to callmanager to proceed it to Voip extensions. Though i have configured Hunt list and list groups as well.


Re: CallManager communication with VoiceGateway

Which Protocol you are using MGCP or H323.

Could you please upload detailed CCM trace.?

Community Member

Re: CallManager communication with VoiceGateway


I am using MGCP. VG200 which contains both FXS and FXO ports. VG200 is acting as MGCP gateway . The commands which i configured on VG200 are :


mgcp call-agent service mgcp ver 0.1

mgcp dtmf-relay voip codec all out-of-band

ccm-manager mgcp

ccm-manager config

ccm-manager config server

dial-peer voice 1 pots

port 1/0/1 (FXO)

application MGCPAPP. Rest my router is full of most of MGCP commands which io downloaded from CallManager

VG#sh voice port 1/0/1

Foreign Exchange Office 1/0/1 Slot is 1, Sub-unit is 0, Port is 1

Type of VoicePort is FXO

Operation State is DORMANT

Administrative State is UP

The Last Interface Down Failure Cause is Administrative Shutdown

Description is not set

Noise Regeneration is enabled

Non Linear Processing is enabled

Non Linear Mute is disabled

Non Linear Threshold is -21 dB

Music On Hold Threshold is Set to -38 dBm

In Gain is Set to 0 dB

Out Attenuation is Set to 3 dB

Echo Cancellation is enabled

Echo Cancellation NLP mute is disabled

Echo Cancellation NLP threshold is -21 dB

Echo Cancel Coverage is set to 8 ms

Playout-delay Mode is set to default

Playout-delay Nominal is set to 60 ms

Playout-delay Maximum is set to 200 ms

Playout-delay Minimum mode is set to default, value 40 ms

Playout-delay Fax is set to 300 ms

Connection Mode is normal

Connection Number is not set

Initial Time Out is set to 10 s

Interdigit Time Out is set to 10 s

Call Disconnect Time Out is set to 60 s

Ringing Time Out is set to 180 s

Wait Release Time Out is set to 30 s

Companding Type is u-law

Region Tone is set for US

Analog Info Follows:

Currently processing none

Maintenance Mode Set to None (not in mtc mode)

Number of signaling protocol errors are 0

Impedance is set to 600r Ohm

Station name None, Station number None

Voice card specific Info Follows:

Signal Type is loopStart

Number Of Rings is set to 1

Supervisory Disconnect is inactive

Answer Supervision is inactive

Hook Status is On Hook

Ring Detect Status is inactive

Ring Ground Status is inactive

Tip Ground Status is inactive

Dial Type is dtmf

Digit Duration Timing is set to 100 ms

InterDigit Duration Timing is set to 100 ms

Pulse Rate Timing is set to 10 pulses/second

InterDigit Pulse Duration Timing is set to 750 ms

Percent Break of Pulse is 60 percent

GuardOut timer is 2000 ms


Re: CallManager communication with VoiceGateway

Also, is possible to have the show run? did you check the codecs for the GW region? is CCM stripping the digits or the GW (if it is H323)?

Also, put this command on the GW

> debug ISDN Q931

> term mon

And make a test call; that way we will see if CCM is sending the call to the GW, if it does, you just need to check the disconnect code.

If possible, please upload the debug outputs.

By the way, those commands are for H.323 GWs.

Community Member

Re: CallManager communication with VoiceGateway


Yes digit 9 is stripping which is before DOT. IP phone shows me remaining 7 characters. Once i dial the number it shows me RING OUT , but i dont hear anything . Second time when i dial, i continuously get busy tone afterwards. No initiation on Voice port(no led) on FXO port.

My point of view is something wrong with the gatyeway because route-pattern is working fine.

Community Member

Re: CallManager communication with VoiceGateway

I cannot run debug isdn q931, because there is no command like this in my VG200. And second thing, yes CCM is stripping predot digit . I am sure CCM is not sending the call to GW , because there is no led initiattion on VG200 when i try to place the call from IP phone. Though CCM also gives me second Dial Tone. when i press the numbers after 9.

Community Member

Re: CallManager communication with VoiceGateway

If your outbound dial-peer contains:

destination-pattern 9T

then you don't want to strip that 9 on your route-pattern. The call could be hitting the gateway, however, if destination-pattern is 9T it won't match and hit the voice port.

CreatePlease to create content