Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Callmanager Express not responding to SIP Request OPTIONS

Our Cisco Call Manager Express IP-PBX box stopped working with our provider today after a long period of service.  Packet capture shows that the CME is not responding to the provider's SIP Request OPTIONS ping packets with 200 OK and thus, the address of the CME box becomes "Out of Service" and no incoming and outgoing calls can be made.

Is there any specific commands that explicitly force the CME to reply with 200 OK from Request OPTIONS?

8 REPLIES

Callmanager Express not responding to SIP Request OPTIONS

Please post your config.

Regards,

Yosh

HTH Regards, Yosh
Hall of Fame Super Gold

Callmanager Express not responding to SIP Request OPTIONS

Try a reload if you haven't already.

New Member

Callmanager Express not responding to SIP Request OPTIONS

Try reloading...several times. Config posted below:

Current configuration : 22534 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname CiscoCME

!

boot-start-marker

boot system flash:c2800nm-spservicesk9-mz.124-24.T2.bin

boot-end-marker

!

logging message-counter syslog

logging buffered 2000000

no logging console

!

no aaa new-model

!

dot11 syslog

ip source-route

!

ip cef

!

ip domain lookup source-interface FastEthernet0/0

ip domain name mydomain.com

no ipv6 cef

multilink bundle-name authenticated

!

voice service voip

clid network-provided

allow-connections h323 to h323

allow-connections sip to sip

no supplementary-service sip moved-temporarily

no supplementary-service sip refer

fax protocol cisco

sip

   outbound-proxy ipv4:x.x.48.25:5070

!

voice class codec 1

codec preference 1 g729r8

codec preference 2 g711ulaw

!

voice translation-rule 1

rule 1 /^9/ //

!

voice translation-rule 2

rule 1 /^xxxxxxxxxx/ /xxxxxxxxxx/

!

voice translation-rule 4

rule 1 /^xxx948\(.*\)/ /\1/

rule 2 /^xxx884\(.*\)/ /\1/

rule 3 /^xxx957\(.*\)/ /\1/

!

voice translation-rule 6

!

voice translation-profile BLOCK

translate calling 6

!

voice translation-profile CUE

translate calling 4

translate called 4

translate redirect-called 4

!

voice translation-profile OUT

translate called 1

!

voice translation-profile voicemail

translate calling 2

!

voice-card 0

dspfarm

dsp services dspfarm

!

crypto pki trustpoint TP-self-signed-2647326429

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-2647326429

revocation-check none

rsakeypair TP-self-signed-2647326429

!

crypto pki certificate chain TP-self-signed-2647326429

certificate self-signed 01

!

username xxxxxx privilege 15 secret xxxxxx

archive

log config

  hidekeys

!

ip ftp username cisco

ip ftp password 7 045E5F025976666507

!

class-map match-all VoIP

match ip rtp 2000 16383

!

policy-map VoIP

class VoIP

  set dscp ef

!

interface FastEthernet0/0

ip address 192.168.100.253 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface Service-Engine1/0

ip unnumbered FastEthernet0/0

service-module ip address 192.168.100.252 255.255.255.0

service-module ip default-gateway 192.168.100.253

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 192.168.100.1

ip route 192.168.100.252 255.255.255.255 Service-Engine1/0

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

no logging trap

!

control-plane

!

!

voice-port 0/2/0

!

voice-port 0/2/1

!

voice-port 0/2/2

!

voice-port 0/2/3

!

voice-port 0/3/0

!

voice-port 0/3/1

!

voice-port 0/3/2

!

voice-port 0/3/3

!

sccp local FastEthernet0/0

sccp ccm 192.168.100.253 identifier 1 version 4.1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register CFB001CF6806720

associate profile 2 register MTP001CF6806720

keepalive retries 5

switchover method immediate

switchback method immediate

switchback interval 5

!

dspfarm profile 2 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 8

associate application SCCP

!

dspfarm profile 1 conference

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 4

associate application SCCP

!

dial-peer cor custom

name LONGDISTANCE

name INTERNATIONAL

!

dial-peer cor list LD-Calling

member LONGDISTANCE

!

dial-peer cor list INT-Calling

member INTERNATIONAL

!

dial-peer cor list Block-PSTN

!

dial-peer voice 7000 voip

mailbox-selection orig-called-num

description Cisco Unity Express voicemail pilot number

destination-pattern 7000

voice-class sip outbound-proxy ipv4:192.168.100.252

session protocol sipv2

session target ipv4:192.168.100.252

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 15 voip

description International

translation-profile outgoing OUT

preference 1

destination-pattern 9011T

voice-class codec 1

session protocol sipv2

session target ipv4:x.x.48.25:5070

dtmf-relay sip-notify

!

dial-peer voice 911 voip

destination-pattern 911

voice-class codec 1

session protocol sipv2

session target ipv4:x.x.48.25:5070

dtmf-relay sip-notify

!

dial-peer voice 7999 voip

description Administration via Telephone Prompt

destination-pattern 7999

voice-class sip outbound-proxy ipv4:192.168.100.252

session protocol sipv2

session target ipv4:192.168.100.252

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 7100 voip

destination-pattern 7100

voice-class sip outbound-proxy ipv4:192.168.100.252

session protocol sipv2

session target ipv4:192.168.100.252

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 5994 voip

mailbox-selection orig-called-num

description VM Pilot

translation-profile outgoing CUE

destination-pattern xxxxxx5994

voice-class sip outbound-proxy ipv4:192.168.100.252

session protocol sipv2

session target ipv4:192.168.100.252

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 5995 voip

description AA Pilot

destination-pattern xxxxxx5995

voice-class sip outbound-proxy ipv4:192.168.100.252

session protocol sipv2

session target ipv4:192.168.100.252

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 5996 voip

description GSM

destination-pattern xxxxxx5996

voice-class sip outbound-proxy ipv4:192.168.100.252

session protocol sipv2

session target ipv4:192.168.100.252

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 1011 voip

translation-profile outgoing OUT

call-block translation-profile incoming BLOCK

call-block disconnect-cause incoming user-busy

destination-pattern 9(1?)[2-9].........

voice-class codec 1

session protocol sipv2

session target ipv4:x.x.48.25:5070

incoming called-number .

dtmf-relay rtp-nte

!

gateway

timer receive-rtp 1200

!

sip-ua

authentication username xxxxxx password xxxxxx

retry invite 2

retry bye 2

retry cancel 2

retry register 10

sip-server ipv4:x.x.48.25

!

telephony-service

sdspfarm units 3

sdspfarm transcode sessions 16

sdspfarm tag 1 MTP001CF6806720

sdspfarm tag 2 CFB001CF6806720

max-ephones 42

max-dn 50

ip source-address 192.168.100.253 port 2000

auto assign 1 to 10

calling-number local

timeouts interdigit 5

system message xxxxxx

url services http://phone-xml.berbee.com/menu.xml?opts=134567

url authentication http://192.168.100.252/voiceview/authentication/authenticate.do

load 7914 S00105000300

load 7941 SCCP41.8-4-2S.loads

load 7961 SCCP41.8-4-2S.loads

time-zone 8

dialplan-pattern 1 xxxxxx59.. extension-length 4

dialplan-pattern 2 xxxxxx51.. extension-length 4

dialplan-pattern 3 xxxxxx86.. extension-length 4

voicemail 7000

max-conferences 8 gain -6

call-forward pattern .T

call-forward pattern 6000

moh music-on-hold.au

web admin system name cisco password cisco

dn-webedit

time-webedit

transfer-system full-consult

secondary-dialtone 9

night-service code *99

create cnf-files version-stamp 7960 Nov 28 2011 15:43:12

!

vm-integration

!

banner login ^C

^C

!

line con 0

login local

line aux 0

line 66

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

line vty 0 4

exec-timeout 30 0

privilege level 15

login local

transport input telnet ssh

line vty 5 15

exec-timeout 30 0

privilege level 15

login local

transport input telnet ssh

!

scheduler allocate 20000 1000

ntp server 208.66.175.36

end

Callmanager Express not responding to SIP Request OPTIONS

Do a show sip-us register status. Have you called your sip provider to troubleshoot? Below is a link that might help you with configuring you sip trunk incase you lost a configuration.

http://blog.alwaysthenetwork.com/tutorials/sip-trunk-with-cme/

Regards,

Yosh

HTH Regards, Yosh
New Member

Callmanager Express not responding to SIP Request OPTIONS

show sip-ua register status shows all the DID extensions that are registered.  Since our provider did not provide the equipment, all they could tell me is that their Acme Packet is not picking up any 200 OK replies aftering sending out SIP Request Options and consider the line to be"out of service".  Looks like I may have to resort this to a Cisco TAC.  THanks for the help.

New Member

Callmanager Express not responding to SIP Request OPTIONS

I'd like to add that no changes have been done to the CME configuration in over 2 months. The only recent change was in the ASA firewall, disabling the SIP inspect temporarily. The service provider does not uses standard ports and i found out my SIP header was advertising a private IP. I created a SIP inspect for non-standard SIP ports. I wonder if this would have anything to do with this problem?

Hall of Fame Super Gold

Callmanager Express not responding to SIP Request OPTIONS

Yes, firewalls are knows to not handle SIP properly, even if thye claim otherwise.

Callmanager Express not responding to SIP Request OPTIONS

I agree with Paolo and I would remove the inspect to see if that fixes your issue.

Regards,

Yosh

HTH Regards, Yosh
1050
Views
0
Helpful
8
Replies
CreatePlease login to create content