Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

calls don't establish

Hello:

I need help to troubleshooting this:

I have a ipipgw between a sip network and a h323 network. I make a call and the called endpoint (sip) rings and answer the call, but the h245 don't work. The called endpoint is conected but the caller (h323) continous with the alerting message.

What can be the problem? what can I see?

Thanks everbody

Antonio

15 REPLIES

Re: calls don't establish

on the IP2IPGW make sure to have the hairpaning enabled.

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

supplementary-service h450.12

h323

sip

min-se 1000

no call service stop

New Member

Re: calls don't establish

Hello.

I have the hairpaning enabled.

I have this lines from the degub.

*Nov 20 17:52:23.555: //50/CE6EA6B0801E/H323/cch323_h245_addr_notify: Sending event CC_EV_H245_ADDR, ev 4

*Nov 20 17:52:23.555: //50/CE6EA6B0801E/H323/cch323_h245_addr_notify: Unable to send event CC_EV_H245_ADDR

*Nov 20 17:52:23.555: //50/CE6EA6B0801E/H323/setup_cfm_notify: status = 8000009

*Nov 20 17:52:23.555: //50/CE6EA6B0801E/H323/cch323_h225_set_new_state: Changing from H225_REQ_FS_ALERT state to H225_WAIT_FOR_H245 state

*Nov 20 17:52:32.635: //-1/xxxxxxxxxxxx/H323/cch323_ct_main: SOCK 3 Event 0x1

*Nov 20 17:52:32.635: //-1/xxxxxxxxxxxx/H323/cch323_gw_process_read_socket: owner_data=0x641E8358, len=47, msgPtr=0x639D2050

I think that the proble is there but I don't undertand what means.

Thanks you

Antonio

Re: calls don't establish

Please enable the following debugs:

debug h225 asn1

debug h245 asn1

And upload the result. Seems to be that you can not reach the IP Address that h245 wants to announce (Media)

New Member

Re: calls don't establish

this is the result (in the attchments). In one moment the h245tunneling is true but later is false. Can be this?

What must I look for here?

Thanks you

VIP Super Bronze

Re: calls don't establish

Hi,

can you post the config on both your h323 gateway and ipipgw

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Re: calls don't establish

Hello again:

can you see my log? or Where can I see the IP Address that h245 wants to announce (Media)?

The problem is that the h245 channel don't establish it, but I don't know why not?

Thanks you

New Member

Re: calls don't establish

Hello:

jbarcena has the correct answer: I have this from the show call active voice:

VOIP:

ConnectionId[0x4C7F85C6 0xB70911DD 0x800AABB8 0x682ED17F]

IncomingConnectionId[0x4C7F85C6 0xB70911DD 0x800AABB8 0x682ED17F]

CallID=10

RemoteIPAddress=10.172.16.248

RemoteUDPPort=0

RemoteSignallingIPAddress=10.172.16.248

RemoteSignallingPort=1720

RemoteMediaIPAddress=0.0.0.0

RemoteMediaPort=0

RoundTripDelay=0 ms

SelectedQoS=best-effort

tx_DtmfRelay=inband-voice

FastConnect=FALSE

AnnexE=FALSE

Separate H245 Connection=FALSE

H245 Tunneling=FALSE

the RemoteMediaIPAddress=0.0.0.0, so the h245 don't works. But I don't know why? may be is a problem in my GK. Its from Polycom. It works in routed mode but the rtp traffic is between endpoints.

any idea?

VIP Super Bronze

Re: calls don't establish

Hi,

Make sure you have this command on the h.323 gateway interface that you are sending calls to from the ipipgw:

h323-gateway voip interface

h323-gateay voip bind srcaddr X.X.X.X

where x.x.x.x = ip adddress of the interface

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Re: calls don't establish

Hello:

I have configured this commands. The setup goes fine and the h323 endpoint answer the call but the gw don't know their ip address.

VIP Super Bronze

Re: calls don't establish

Hi,

Has your problem been solved? Do you still have the problem you have? I have had this problem in the past and this is how I resolved it

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Re: calls don't establish

Hello:

I have writed the wrongs words. The commands were configured from the begining. And I still have the problem. I think that the remote ip address must be the ip from the h323 endpoint. The gw doesn't know it.

New Member

Re: calls don't establish

Hello,

I think I have the same problem.

The architecture is :

IP_Phone - CUCM 6.1.2 last patch - H323 - Cube IP IP GW - SIP - CIRPACK - External Phone

When I do a call from Ip Phone to External Phone, I have got the Ip_Phone Busy. 3 seconds later, the External Phone rings and there is no communication.

I have seen that :

RemoteIPAddress=192.168.44.1

RemoteUDPPort=0

RemoteSignallingIPAddress=192.168.44.1

RemoteSignallingPort=33862

RemoteMediaIPAddress=0.0.0.0

What do you think about that?

Have you got a solution ?

Best regards.

New Member

Re: calls don't establish

Hello:

I don't have a solution.

I think that the problem is in the h245 tunneling and fast start. I think that my gk don't use h245 tunneling and I must to hold the H.245 connection procedures until after the H.225 connections are made

I don't know at 100%.

How can I turn off the h245 tunneling? I have tested with slow start but, I still have the problem so I want to try with the tunneling.

Thanks everyone

Antonio

New Member

Re: calls don't establish

Hi !

Whe have the same issue here...

Did you find a solution ?

Kind regards,

Thierry

New Member

Re: calls don't establish

Hello,

we have done an ip to ip with SIP to SIP connection. We haven't found a solution with H.323

Best regards.

596
Views
3
Helpful
15
Replies