Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

calls from UK PSTN to CUE fails

I am getting disconnected when i forward calls from the pstn to CUE. Works fine internally but from the PSTN the call fails. I think this may be a trasncoding issue as the CUE can only talk g711ulaw but i am not sure where or how to verify this My CUE is in the same device as the PSTN GW a E1 PRI. TIA

24 REPLIES

Re: calls from UK PSTN to CUE fails

What dial peers are you using on your router? Do any of them use G711alaw?

-nick

New Member

Re: calls from UK PSTN to CUE fails

my voip dial peers to the ccm have a codec class with 711alaw yes. thanks

Hall of Fame Super Gold

Re: calls from UK PSTN to CUE fails

Should be G.711u, even if you are in UK, that the "internal standard.

However the CUE isse is likely due to something else at DP level.

New Member

Re: calls from UK PSTN to CUE fails

sorry. what is the DP level. thanks

Hall of Fame Super Gold

Re: calls from UK PSTN to CUE fails

dial-peer, somehow the call comes in and is not sent to the CME correctly.

New Member

Hello everybody,any results

Hello everybody,

any results on this problem?

I am having the same issue, calls from PSTN do not make it to the CUE when busy/NoAnsw, the call just ends (they are redirected):

ephone-dn  8  dual-line
 number xxx
 label xxx-xxx
 name 3xxx
 call-forward busy 3199 (Voice mailbox pilot number)
 call-forward noan 3199 timeout 20

!

Instead, if I call from an IP phone registered to the CME to another colleague's phone (also registered) and he/she is busy/NoAnsw the call goes to CUE directly without problem and I can leave a message.

After doing several debugs I also think it is a transcode problem, but I do not know how to resolve it.

I thought of using something like this but I read it should only be used as last-resort method:

dspfarm profile 1 transcode universal
 codec g729abr8
 codec g729ar8
 codec g711alaw
 codec g711ulaw
 codec g729r8
 codec g729br8
 maximum sessions 5
 associate application SCCP

!

Here my dial-peer for voice mailbox:

dial-peer voice 91 voip
 description Unity Express Voice Mailbox pilot number
 destination-pattern 91
 session protocol sipv2
 session target ipv4:A.B.C.D !!--> IP@ ISM0/0 CUE
 dtmf-relay sip-notify
 codec g711ulaw
 no vad

 

When debugging ccapi I see how the call is redirected to 91.

To compare the calls making it to CUE from those ones that do not, I run a debug and, until the point I am showing to you, both debugs are more or less the same but in this point the debug (calling from PSTN) displays this ccSetMediaclass, ccGet... messages that I do not know what they mean whereas the debug from calls within the network do not show this kind of messages.

*Dec  5 14:04:25.064:  feature call forward featname is 3
*Dec  5 14:04:25.064: //557/86D8E9B78B8B/CCAPI/ccGetMediaClassTag:
   media class tag 0
*Dec  5 14:04:25.064: //557/86D8E9B78B8B/CCAPI/ccSetMediaclassIp2ipTags:
   media class tags set: NR 0, ASP 0
*Dec  5 14:04:25.064: //555/86D8E9B78B8B/CCAPI/ccGetMediaClassTag:
   media class tag 0
*Dec  5 14:04:25.064: //555/86D8E9B78B8B/CCAPI/ccSetMediaclassIp2ipTags:
   media class tags set: NR 0, ASP 0
*Dec  5 14:04:25.064: //557/86D8E9B78B8B/CCAPI/ccGet_xc_nr_asp_info:
   media class tags: NR 0, ASP 0
*Dec  5 14:04:25.064: //555/86D8E9B78B8B/CCAPI/ccGet_xc_nr_asp_info:
   media class tags: NR 0, ASP 0
*Dec  5 14:04:25.064: //557/86D8E9B78B8B/CCAPI/ccGetMediaClassTag:
   media class tag 0
*Dec  5 14:04:25.064: //557/86D8E9B78B8B/CCAPI/ccSetMediaclassIp2ipTags:
   media class tags set: NR 0, ASP 0
*Dec  5 14:04:25.064: //555/86D8E9B78B8B/CCAPI/ccGetMediaClassTag:
   media class tag 0
*Dec  5 14:04:25.064: //555/86D8E9B78B8B/CCAPI/ccSetMediaclassIp2ipTags:
   media class tags set: NR 0, ASP 0
*Dec  5 14:04:25.064: //557/86D8E9B78B8B/CCAPI/ccGet_xc_nr_asp_info:
   media class tags: NR 0, ASP 0
*Dec  5 14:04:25.064: //555/86D8E9B78B8B/CCAPI/ccGet_xc_nr_asp_info:
   media class tags: NR 0, ASP 0
*Dec  5 14:04:25.064: //557/86D8E9B78B8B/CCAPI/cc_api_call_disconnected:
   Cause Value=47, Interface=0x3D82B49C, Call Id=557
*Dec  5 14:04:25.068: //557/86D8E9B78B8B/CCAPI/cc_api_call_disconnected:
   Call Entry(Responsed=TRUE, Cause Value=47, Retry Count=0)

Any ideas?

Thanks,

Reg.

Can you post your full config

Can you post your full config and a debus ccsip messages?

Regards,

Yosh

HTH Regards, Yosh
New Member

Hello yahsiel2004, find

Hello yahsiel2004,

 

find attached the following files:

- CME config

- ccapi debug calling from pstn to my ip phone (97) --> doesn't work

- ccapi debug calling from ip phone (99) to ip phone (97) --> works

- ccsip debug pstn to my ip phone (97)

 

Thanks,

Reg.

RIght now also you are facing

RIght now also you are facing the same issue or not ?

New Member

Yes of course, that is why I

Yes of course, that is why I send this message to Cisco Community. 

In the CCSIP debug it is said clearly that "no codec" has been negotiated but I do not understand why the calls go perfectly well and when it turns to the CUE the calls coming from "outside network/PSTN" cannot make it to it.

Thanks,

Reg.

Normally when a  PSTN call

Normally when a  PSTN call hits to the gateway, what is the codec using. If it is g711ulaw ,then normally transcoder not needed for this .

But if it is different it should need a transcoder.

 

Apart from that you have mentioned that incoming calls dont have any problem.

That is the strange part. Anyway try registering a transcoder and check the result.

We can remove it later

New Member

In the CCSIP debug it says:

In the CCSIP debug it says:

 

*Dec  5 15:10:19.584: //583/A939D54C851C/SIP/Info/info/1/codec_found: Codec to be matched: g729r8(16)

 

When I call to my IP phone from PSTN and I issue the "sh voice call summary" and "sh voice call status" see what I get:

pabx#show voice call summary
PORT           CODEC     VAD VTSP STATE            VPM STATE
============== ========= === ==================== ======================
0/2/0         -          -  -                     FXSLS_ONHOOK
0/2/1         -          -  -                     FXSLS_ONHOOK
0/2/2         -          -  -                     FXSLS_ONHOOK
0/2/3         -          -  -                     FXSLS_ONHOOK
50/0/1  .1       -          -  -                     EFXS_ONHOOK
50/0/1  .2       -          -  -                     EFXS_ONHOOK
50/0/2  .1       -          -  -                     EFXS_ONHOOK
50/0/2  .2       -          -  -                     EFXS_ONHOOK
50/0/3  .1       g711ulaw   n  S_SETUP_REQ_PROC      EFXS_WAIT_OFFHOOK
50/0/3  .2       -          -  -                     EFXS_ONHOOK

 

----------------------------------------------------------------------------------------

pabx#sh voice call status
CallID     CID  ccVdb      Port        Slot/DSP:Ch  Called #   Codec    MLPP Dial-peers
0x2F1      175D 0x3EE2DDF0 50/0/3.0                *97         None     2/20003
1 active call found

On one hand it is g711ulaw, on the other hand it says "none".

 

New Member

Hello guys,in the end I got

Hello guys,

in the end I got it working following this site:

http://duzceli1979.blogspot.ch/2013/01/enable-cue-access-from-g729-enabled-wan.html

quite easy to understand and direct. I will update you if anything else goes wrong.

I did not need to enter any of the lines for sip in the voice group section.

 

Thanks for all your support.

Reg.

You don't have a PSTN, you

You don't have a PSTN, you have an ITSP. Since you have VoIP dial-peers which use G729r8 by default, you will need a transcoder and or you will need to change the codec on the incoming dial-peer to G711. Also you might need to put "no supplementary-service sip moved-temporarily" under the voice service voip because CUE doesn't like VoIP to VoIP calls forwards with sip moved-temporarily on.

voice service voip
no supplementary-service sip moved-temporarily

HTH

Yosh

HTH Regards, Yosh
New Member

Yosh, I set the codec to G711

Yosh,

 

I set the codec to G711 to the incoming dial-peer but even the calls were not working, so I removed it.

 

I will give it a try with all the changes you proposed and let you know.

 

Regards,

Reg.

New Member

The cause value = 47

The cause value = 47 indicates a "resource unavailable" event.

Can you please provide the CUE configuration?

What is the your voice mail box pilot number? In your dial peer you have mentioned,91 as VM pilot number but on your phone you are forwarding the call to a different VM number instead of 91.

 

Thanks 

New Member

Hello,The voice pilot number

Hello,

The voice pilot number is 91. Where do you find that the call is being forwarded to a different VM of 91?

 

Thanks,

Reg.

New Member

Hello,Can you please share

Hello,

Can you please share CUE configuration?

 call-forward busy 3199 (Voice mailbox pilot number)
 call-forward noa
n 3199 timeout 20

What is 3199?

Thanks

New Member

Hello inderpreetsingh23,find

Hello inderpreetsingh23,

find the CUE config attached.

I also thought of the "AllowTransferExternal" option in the GUI CUE. Is that a possible cause? (find also attached the screenshot).

 

Thanks,

Reg.

New Member

I don't think allow external

I don't think allow external transfers is causing any problem. Just change it to true and then try. Reload your CUE module and then test the call again.

 

Please configure the following:

voice service voip

sip

bind all source-interface <ip address of interface>

 

New Member

Sorry, what ip address of

Sorry, what ip address of interface? CUE? Voice LAN? ...?

 

Thanks,

Reg.

New Member

Voice vlan

Voice vlan.

Going through the debugs I think your call is failing due to codec mismatch.

Try this config:

voice class codec 2

codec preference 1 g711ulaw

codec preference 2 g729r8

 

dial-peer voice 91 voip
 description Unity Express Voice Mailbox pilot number
 destination-pattern 91
 session protocol sipv2
 session target ipv4:A.B.C.D !!--> IP@ ISM0/0 CUE
 dtmf-relay sip-notify
 voice class codec 2
 no vad

New Member

Oh sorry, I beg your pardon.

Oh sorry, I beg your pardon. That was an example, not the config I am using.

 

The config for the CME and debugs are above attached too.

 

Thanks,

Reg.

Re: calls from UK PSTN to CUE fails

I think it's still a codec issue. You can call internally fine because the codec hasn't been decided yet. Likely when you call from the PSTN the codec has been decided on, and CUE doesn't like that codec, and a transcoder isn't available to help.

-nick

375
Views
14
Helpful
24
Replies
CreatePlease to create content