Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Calls Not Playing Correct MOH File - UCCX

                   So, I have the user MOH file playing while the callers are in queue, then when an agent gets selected it should play the network MOH which is simply a ringback tone that I recorded.  There is nothing I can do to get this system to play anything but what is in audio stream 1.  Right now I have double checked that there are no common device configurations selected for anything.  The UCCX ports now have the ringback tone for both network and user moh, the CTI route points all have the same thing, nothing is on the lines.  The default MOH in the service parameters is set for the ringback file to be played for both network and user moh.  So, nothing is set to play audio stream 1..NOTHING!  but that is the only thing that gets played and the only way I can change it is to move the file to stream 1.

I have reset the ip media streaming app service multiple times, reset the moh servers, you name it, I have done it.

8 REPLIES
Hall of Fame Super Silver

Calls Not Playing Correct MOH File - UCCX

Did you upload the ringback moh source file to all CUCM servers?  This is common omission.

HTH,

Chris

New Member

Calls Not Playing Correct MOH File - UCCX

Indeed I did.

Hall of Fame Super Silver

Calls Not Playing Correct MOH File - UCCX

Quick test to see if the source file is OK, apply it to phone A and call phone A from phone B, place phone B on hold to see if you are hearing the ringback. If, so you know the file is OK.

Chris

New Member

Calls Not Playing Correct MOH File - UCCX

Chris,

I do not think that I am making myself clear.  I know that the ringback file works because if I configure audio stream 1 with that file, it plays.  Literally, the only MOH file this system will play is whatever is configured in audio stream 1.  Right now, I have nothing configured to play the file in audio stream 1 yet that is the only file that plays.

Hall of Fame Super Silver

Calls Not Playing Correct MOH File - UCCX

Understood. So, how do you go about assigning different i.e. 3 source file to the CTI Ports? Can you show a screen show of one of your cti ports?

Chris

New Member

Calls Not Playing Correct MOH File - UCCX

Actually you do it in UCCX Administration but it is the same for phones, you have a user moh and a network moh, device pool, MRGL etc.  The same thing happens with phones too, it isn't limited to the contact center.

Hall of Fame Super Silver

Calls Not Playing Correct MOH File - UCCX

Yes, I know where you do it, I have done quite a few of these and never had an issue :-)

My question is do you have MOH sources explicitly set on the device or via common device config?

MRGL on the cti ports does not play a role here, MRGL of the calling device (i.e. phone, GW, etc) drives where (which MOH server) you are being connected to.

Can you post a screen shot of the MOH source as well as the MOH server configuration?

Are you using multicast or unicast, if multicast is the source file and MRG set for multicast?

Chris

New Member

Calls Not Playing Correct MOH File - UCCX

Chris,

I resolved the problem.  After looking at a trace, I discovered that the jtapi port that was handling the call was actually on the secondary uccx server and those ports were not set up properly.  It never occurred to me that would be the case.  Once I made the proper adjustments, the correct moh file was played.

Thanks for your assistance

367
Views
0
Helpful
8
Replies