Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Can't get ip2ip to work...

We have some AS5350's which we currently use as a pseudo-ip2ip gateway... calls arrive at one 5350 by IP, are sent by crossover E1 to the other, and then can either go out through IP or through our E1 carriers. I am testing using a softphone and Elastix, this set-up works very well. However we would like to change to a proper ip2ip gateway for expansion.

We have a 3745 running c3745-ipvoice_ivs-mz.124-4.T.bin which I am using to test. The calls are sent from the 3745 to a 5350 which will terminate the calls through an E1 carrier. The destination phone rings briefly (half a ring) then stops. The call trace is showing InternalErrorCode=1.1.186.7.102.3

I have a very simple dial-peer on the 3745:

translation-rule 9001
Rule 0 ^00 9001
!

dial-peer voice 18 voip
destination-pattern 00.T
translate-outgoing called 9001
session target ipv4:192.168.1.225

!

Call trace is attached. Any help much appreciated!

11 REPLIES
New Member

Re: Can't get ip2ip to work...

Bump - any ideas please?

Silver

Re: Can't get ip2ip to work...

Mark,

First a word of warning - IP2IP can be simple or it can be difficult.  What you propose should not be bad, but I can't guarantee that it will work with 3rd party devices.

In order to run an IP2IP GW you need at least the following two lines - they enable a router to "switch" IP calls between VOIP dial-peers:

voice service voip
  allow-connections h323 to h323

Now I gather you are using the 5350 because you don't want to buy an E1 MFT for the 3745 (which would eliminate the need for the 5350).

So with you present setup your 3745 will be ONLY an IP2IP GW, with one set of DPs pointed at the 5350 and the other to the carrier.  I would suggest that you set up both incoming DPs and outgoing so that codec and VAD are properly set (IOS defaults to VAD on and G729 - which some non-Cisco devices don't like).

Look here for MUCH more information:

http://www.cisco.com/en/US/docs/ios/voice/cube/configuration/guide/vb_book/vb_book.html

Good luck, and have fun!

Art

New Member

Re: Can't get ip2ip to work...

Hi Art,

Thanks for the reply. I've already got the allow-connections line, as well as allow-connections sip to sip, sip to h323, h323 to sip (since my inbound call from Elastix is sip, and outgoing to the 5350 is h323).

The reason we are using the 5350 is because we have a few E1's which are shared between many gateways. It would not be practical to put E1's from every carrier, onto every gateway. So we have a 5350 with E1's from the carrier, and send calls to it from many gateways for termination.

The Elastix PBX does support G729, and the 5350 obviously does, so I don't think codec or VAD is an issue... the log file shows both using G729.

I've tried separating out the dial-peers:

dial-peer voice 18 voip
destination-pattern 00....T
translate-outgoing called 9001
session target ipv4:192.168.1.225
!
dial-peer voice 17 voip
session target ras
incoming called-number 00....T
!

... But I still get the same result.

InternalErrorCode=1.1.186.7.102.3

Silver

Re: Can't get ip2ip to work...

Hi Mark,

I see you have a gatekeeper in the mix as well - what does the "debug gatekeeper main 10" look like when a call is sent?

Art

Silver

Re: Can't get ip2ip to work...

Mark,

One other observation - in your logs you have "DisconnectText=network out of order (38)".  As often as not I have seen that caused by a codec.  Try setting everything at G711U - including your switch and softphone - just for kicks and giggles.

Art

New Member

Re: Can't get ip2ip to work...

We do not have a gatekeeper. That debug produces no output at all when a call is made.

Strange I don't seem to be able to change the outbound leg (to the 5350) to g711ulaw. I put it in the dial-peer:

dial-peer voice 18 voip
destination-pattern 00....T
translate-outgoing called 9001
session target ipv4:192.168.1.225
codec g711ulaw
!

...but still the outbound call is using g729r8 pre-ietf. Log file attached.

Silver

Re: Can't get ip2ip to work...

Mark,

I'm confused.  In one of your configurations you have this:

dial-peer voice 17 voip
session target ras
incoming called-number 00....T

seesion target ras indicates a gatekeeper

If your call is still g729 then a different dial-peer is catching that call than 18.

Please do a debug voice dialpeer and post the output.

Thanks,

Art

New Member

Re: Can't get ip2ip to work...

Art,

I've removed the session target ras line. No change in the results.

The log file above shows it is going through dial-peer 18...

PeerId=18

CoderTypeRate=g729r8 pre-ietf

Strange but true?

debug voice dialpeer:

Dec  2 17:07:02.111: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Calling Number=004420XXXXXXXX, Called Number=004420XXXXXXXX, Peer Info Type=DIALPEER_INFO_SPEECH
Dec  2 17:07:02.111: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=004420XXXXXXXX

Dec  2 17:07:02.111: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
Dec  2 17:07:02.111: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=18
Dec  2 17:07:02.111: //-1/F18690FC82BB/DPM/dpAssociateIncomingPeerCore:
   Calling Number=4420XXXXXXXXX, Called Number=004420XXXXXXXX, Voice-Interface=0x0,
   Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
   Peer Info Type=DIALPEER_INFO_SPEECH
Dec  2 17:07:02.111: //-1/F18690FC82BB/DPM/dpAssociateIncomingPeerCore:
   Result=Success(0) after DP_MATCH_INCOMING_DNIS; Incoming Dial-peer=17
Dec  2 17:07:02.115: //-1/F18690FC82BB/DPM/dpMatchPeersCore:
   Calling Number=, Called Number=004420XXXXXXXX, Peer Info Type=DIALPEER_INFO_SPEECH
Dec  2 17:07:02.115: //-1/F18690FC82BB/DPM/dpMatchPeersCore:
   Match Rule=DP_MATCH_DEST; Called Number=004420XXXXXXXX

Dec  2 17:07:02.115: //-1/F18690FC82BB/DPM/dpMatchPeersCore:
   Result=Success(0) after DP_MATCH_DEST
Dec  2 17:07:02.115: //-1/F18690FC82BB/DPM/dpMatchPeersMoreArg:
   Result=SUCCESS(0)
   List of Matched Outgoing Dial-peer(s):
     1: Dial-peer Tag=18

Silver

Re: Can't get ip2ip to work...

Mark,

It is matching DP 17 on the incoming leg, and I am not sure where DP 18 is sending the call - to the 5350 or the switch?  At any rate I would make sure ALL the DPs have G711 on them (including the 5350)  and see waht happens.  Again, I don't know if I can help you from here with the third party gear.

Good Luck,

Art

New Member

Re: Can't get ip2ip to work...

Art,

I've stripped down a lot of the config, it is now sending at g711. Not sure what was stopping it before, but hey ho, it's working now.

At g711 it's still getting the InternalErrorCode=1.1.186.7.102.3... log attached. Also log from 5350 attached, if that helps.

I don't see how it can be a problem with the Elastix. The below diagram shows 2 paths that I have tested, the top one has calls coming from the Elastix using SIP to a 5350, then over crossover E1's to the carrier 5350, and out to the carrier E1. The bottom path has calls coming from the Elastix to the 3745 by SIP, then to the carrier 5350 by h323, then out to the carrier E1. The top path works perfectly, I can make calls which connect with 2-way voice. But the bottom one doesn't. The Elastix box is doing exactly the same in both cases, just sending the call to a different IP address. The only difference in this setup is the 3745, and that seems to me to be where the problem lies.

Image1.gif

New Member

Re: Can't get ip2ip to work...

Art,

I've stripped down a lot of the config, it is now sending at g711. Not sure what was stopping it before, but hey ho, it's working now.

At g711 it's still getting the InternalErrorCode=1.1.186.7.102.3... log attached. Also log from 5350 attached, if that helps.

I don't see how it can be a problem with the Elastix. The below diagram shows 2 paths that I have tested, the top one has calls coming from the Elastix using SIP to a 5350, then over crossover E1's to the carrier 5350, and out to the carrier E1. The bottom path has calls coming from the Elastix to the 3745 by SIP, then to the carrier 5350 by h323, then out to the carrier E1. The top path works perfectly, I can make calls which connect with 2-way voice. But the bottom one doesn't. The Elastix box is doing exactly the same in both cases, just sending the call to a different IP address. The only difference in this setup is the 3745, and that seems to me to be where the problem lies.

Image1.gif

601
Views
0
Helpful
11
Replies
CreatePlease login to create content