Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

Can you auto assign extensions to CP99XX series

I have a few CP9971s and CP9951s that I am trying to register with CME. I can manually add and they come up just fine but, if I just plug them up without adding them I get a 401 Unauthorized.

Here is my show run.

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

logging buffered 51200 warnings

!

no aaa new-model

!

!

dot11 syslog

ip source-route

!

!

ip cef

!

ip dhcp excluded-address 192.168.1.1

!

ip dhcp pool Voice

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 192.168.1.1

option 150 ip 192.168.1.1

lease 9

!

!

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

!

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

no supplementary-service h450.2

no supplementary-service h450.3

no supplementary-service h450.7

no supplementary-service sip moved-temporarily

no supplementary-service sip refer

no supplementary-service sip handle-replaces

sip

  registrar server

!

!

voice register global

mode cme

source-address 192.168.1.1 port 5060

max-dn 100

max-pool 50

load 9971 sip9971.9-2-2SR1-9

authenticate register

tftp-path flash:

create profile sync 0001431294058847

!

voice register dn  1

number 1

shared-line

label 1

!

voice register dn  2

number 2

shared-line

label 2

!

voice register dn  3

number 3

shared-line

label 3

!

voice register dn  4

number 4

shared-line

label 4

!

voice register dn  5

number 5

shared-line

!

voice register dn  6

number 6

shared-line

!

voice register dn  7

number 7

shared-line

!

voice register dn  8

number 8

shared-line

!

voice register dn  9

number 9

shared-line

!

voice register pool  1

!

voice register pool  2

id mac 24B6.5745.EADC

type 9951

number 1 dn 2

!

voice register pool  3

id mac 58BF.EA20.9D31

type 9951

number 1 dn 3

!

voice register pool  4

id mac A418.7528.69D2

type 9951

number 1 dn 4

!

!

!

!

voice-card 0

!

crypto pki token default removal timeout 0

!

!

!

!

license udi pid CISCO2821 sn FTX1340AKNH

username system privilege 15 secret 4 iwLaMS24lhnMr4rFVYJA9wiXll1vHMtldUmHuj/rw5A

!

redundancy

!

!

no ip ftp passive

!

!

!

!

!

!

!

!

interface GigabitEthernet0/0

ip address 192.168.1.1 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

ip forward-protocol nd

ip http server

ip http authentication local

no ip http secure-server

!

!

!

!

!

!

!

!

tftp-server flash:dkern9971.100609R2-9-2-2SR1-9.sebn alias dkern9971.100609R2-9-2-2SR1-9.sebn

tftp-server flash:kern9971.9-2-2SR1-9.sebn alias kern9971.9-2-2SR1-9.sebn

tftp-server flash:rootfs9971.9-2-2SR1-9.sebn alias rootfs9971.9-2-2SR1-9.sebn

tftp-server flash:sboot9971.031610R1-9-2-2SR1-9.sebn alias sboot9971.031610R1-9-2-2SR1-9.sebn

tftp-server flash:sip9971.9-2-2SR1-9.loads alias sip9971.9-2-2SR1-9.loads

tftp-server flash:skern9971.022809R2-9-2-2SR1-9.sebn alias skern9971.022809R2-9-2-2SR1-9.sebn

tftp-server flash:sip9951.9-2-2SR1-9.loads alias sip9951.9-2-2SR1-9.loads

tftp-server flash:/United_States/g4-tones.xml

tftp-server flash:United_States/g4-tones.xml

!

control-plane

!

!

!

!

mgcp profile default

!

!

!

!

!

telephony-service

max-ephones 50

max-dn 100

ip source-address 192.168.1.1 port 2000

max-redirect 5

auto-register 5-40

cnf-file location flash:

max-conferences 8 gain -6

web admin system name system secret 5 $1$T2T5$BOfsYOYi9gX0PQ7OGB.b1/

transfer-system full-consult

create cnf-files version-stamp Jan 01 2002 00:00:00

!

!

ephone-template  1

softkeys hold  Join Newcall Resume Select

softkeys idle  Redial Newcall Cfwdall Pickup Gpickup Dnd Login

softkeys seized  Redial Endcall Cfwdall Pickup Gpickup Callback

softkeys alerting  Acct Callback Endcall

softkeys connected  Hold Endcall Trnsfer Confrn Acct Park

!

!

ephone  1

device-security-mode none

!

!

!

!

line con 0

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet

!

scheduler allocate 20000 1000

end

and here is the debug.

*Mar  7 19:41:51.739: //181/5D38EDC58041/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 401 Unauthorized

Via: SIP/2.0/UDP 192.168.1.5:5060;branch=z9hG4bK3ddc47e7

From: <sip:1@192.168.1.1>;tag=8cb64f5697f60003388ac6a4-4588b822

To: <sip:1@192.168.1.1>;tag=8C7BC0-1859

Date: Fri, 07 Mar 2014 19:41:51 GMT

Call-ID: 8cb64f56-97f60002-71d8abf2-52f0a9d7@192.168.1.5

Server: Cisco-SIPGateway/IOS-12.x

CSeq: 103 REGISTER

WWW-Authenticate: Digest realm="",nonce="CBC9B4FA000E0C60",algorithm=MD5,qop="au

th"

Content-Length: 0

*Mar  7 19:41:51.823: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

REGISTER sip:192.168.1.1 SIP/2.0

Via: SIP/2.0/UDP 192.168.1.5:5060;branch=z9hG4bK44db1c3e

From: <sip:1@192.168.1.1>;tag=8cb64f5697f60003388ac6a4-4588b822

To: <sip:1@192.168.1.1>

Call-ID: 8cb64f56-97f60002-71d8abf2-52f0a9d7@192.168.1.5

Max-Forwards: 70

Date: Fri, 01 Jan 1982 00:01:16 GMT

CSeq: 104 REGISTER

User-Agent: Cisco-CP9971/9.2.1

Contact: <sip:1@192.168.1.5:5060;transport=udp>;+sip.instance="<urn:uuid:0000000

0-0000-0000-0000-8cb64f5697f6>";+u.sip!devicename.ccm.cisco.com="SEP8CB64F5697F6

";+u.sip!model.ccm.cisco.com="493"

Authorization: Digest username="",realm="",uri="sip:192.168.1.1",response="e5c7e

cf2b98fecc4f85beedc34e51f45",nonce="CBC9B4FA000E0C60",cnonce="5e47f35a",qop=auth

,nc=00000003,algorithm=MD5

Supported: replaces,join,sdp-anat,norefersub,extended-refer,X-cisco-callinfo,X-c

isco-serviceuri,X-cisco-escapecodes,X-cisco-service-control,X-cisco-srtp-fallbac

k,X-cisco-monrec,X-cisco-config,X-cisco-sis-5.1.0,X-cisco-xsi-8.0.1

Content-Length: 0

Reason: SIP;cause=200;text="cisco-alarm:24 Name=SEP8CB64F5697F6 ActiveLoad=sip99

71.9-2-2SR1-9.loads InactiveLoad=sip9971.9-4-1-9.loads Last=phone-reg-rej"

Expires: 3600

*Mar  7 19:41:51.827: //181/5D38EDC58041/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 100 Trying

Via: SIP/2.0/UDP 192.168.1.5:5060;branch=z9hG4bK44db1c3e

From: <sip:1@192.168.1.1>;tag=8cb64f5697f60003388ac6a4-4588b822

To: <sip:1@192.168.1.1>;tag=8C7BC0-1859

Date: Fri, 07 Mar 2014 19:41:51 GMT

Call-ID: 8cb64f56-97f60002-71d8abf2-52f0a9d7@192.168.1.5

Server: Cisco-SIPGateway/IOS-12.x

CSeq: 104 REGISTER

Content-Length: 0

*Mar  7 19:41:51.827: //181/5D38EDC58041/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 401 Unauthorized

Via: SIP/2.0/UDP 192.168.1.5:5060;branch=z9hG4bK44db1c3e

From: <sip:1@192.168.1.1>;tag=8cb64f5697f60003388ac6a4-4588b822

To: <sip:1@192.168.1.1>;tag=8C7BC0-1859

Date: Fri, 07 Mar 2014 19:41:51 GMT

Call-ID: 8cb64f56-97f60002-71d8abf2-52f0a9d7@192.168.1.5

Server: Cisco-SIPGateway/IOS-12.x

CSeq: 104 REGISTER

WWW-Authenticate: Digest realm="",nonce="CBC9B4FA000E0C60",algorithm=MD5,qop="au

th"

Content-Length: 0

Everyone's tags (4)
4 REPLIES

Re:Can you auto assign extensions to CP99XX series

Are these phones in the subnet of the CME or remote. If they are remote you can't use auto registration.


Sent from Cisco Technical Support Android App

New Member

Can you auto assign extensions to CP99XX series

Same subnet all local. Just running in a lab environment to test these.

Can you auto assign extensions to CP99XX series

In this case, remove authenticate register command and they will use auto registration. Auto registration won't work with authenticate register since you need to define the digest authentication username/password manually for each pool

New Member

Can you auto assign extensions to CP99XX series

Ok, so after having done "no authenticate register" the phone are no longer getting the 401 Unauthorized. Now the phone is just continually downloading the XMLDefault.cnf.xml after not finding its SEPxxxxxxxxx.cnf.xml file.

*Mar  8 16:10:21.255: TFTP: Server request for port 49225, socket_id 0x49CBD70C for process 12

*Mar  8 16:10:21.255: TFTP: read request from host 192.168.1.4(49225) via GigabitEthernet0/0

*Mar  8 16:10:21.255: TFTP: Looking for CTLSEP8CB64F5697F6.tlv

*Mar  8 16:10:21.255: TFTP: Sending error 1 No such file

*Mar  8 16:10:21.347: TFTP: Server request for port 49225, socket_id 0x49CBD70C for process 12

*Mar  8 16:10:21.347: TFTP: read request from host 192.168.1.4(49225) via GigabitEthernet0/0

*Mar  8 16:10:21.347: TFTP: Looking for ITLSEP8CB64F5697F6.tlv

*Mar  8 16:10:21.347: TFTP: Sending error 1 No such file

*Mar  8 16:10:21.443: TFTP: Server request for port 49225, socket_id 0x49CBD70C for process 12

*Mar  8 16:10:21.443: TFTP: read request from host 192.168.1.4(49225) via GigabitEthernet0/0

*Mar  8 16:10:21.443: TFTP: Looking for ITLFile.tlv

*Mar  8 16:10:21.443: TFTP: Sending error 1 No such file

*Mar  8 16:10:21.695: TFTP: Server request for port 49225, socket_id 0x49CBD70C for process 12

*Mar  8 16:10:21.695: TFTP: read request from host 192.168.1.4(49225) via GigabitEthernet0/0

*Mar  8 16:10:21.695: TFTP: Looking for SEP8CB64F5697F6.cnf.xml

*Mar  8 16:10:21.695: TFTP: Sending error 1 No such file

*Mar  8 16:10:22.051: TFTP: Server request for port 49225, socket_id 0x49CBD70C for process 12

*Mar  8 16:10:22.051: TFTP: read request from host 192.168.1.4(49225) via GigabitEthernet0/0

*Mar  8 16:10:22.051: TFTP: Looking for XMLDefault.cnf.xml

*Mar  8 16:10:22.055: TFTP: Opened flash:/its/vrf1/XMLDefault.cnf.xml, fd 10, size 3238 for process 12

*Mar  8 16:10:22.055: TFTP: Sending block 1 (retry 0), socket_id 0x49CBD70C

*Mar  8 16:10:22.055: TFTP: Received ACK for block 1, socket_id 0x49CBD70C

*Mar  8 16:10:22.055: TFTP: Sending block 2 (retry 0), socket_id 0x49CBD70C

*Mar  8 16:10:22.055: TFTP: Received ACK for block 2, socket_id 0x49CBD70C

*Mar  8 16:10:22.055: TFTP: Sending block 3 (retry 0), socket_id 0x49CBD70C

*Mar  8 16:10:22.059: TFTP: Received ACK for block 3, socket_id 0x49CBD70C

*Mar  8 16:10:22.059: TFTP: Sending block 4 (retry 0), socket_id 0x49CBD70C

*Mar  8 16:10:22.063: TFTP: Received ACK for block 4, socket_id 0x49CBD70C

*Mar  8 16:10:22.063: TFTP: Sending block 5 (retry 0), socket_id 0x49CBD70C

*Mar  8 16:10:22.063: TFTP: Received ACK for block 5, socket_id 0x49CBD70C

*Mar  8 16:10:22.063: TFTP: Sending block 6 (retry 0), socket_id 0x49CBD70C

*Mar  8 16:10:22.063: TFTP: Received ACK for block 6, socket_id 0x49CBD70C

*Mar  8 16:10:22.063: TFTP: Sending block 7 (retry 0), socket_id 0x49CBD70C

*Mar  8 16:10:22.063: TFTP: Received ACK for block 7, socket_id 0x49CBD70C

*Mar  8 16:10:22.063: TFTP: Finished flash:/its/vrf1/XMLDefault.cnf.xml, time 00:00:00 for process 12

*Mar  8 16:10:52.835: TFTP: Server request for port 49225, socket_id 0x49CBD70C for process 12

*Mar  8 16:10:52.835: TFTP: read request from host 192.168.1.4(49225) via GigabitEthernet0/0

*Mar  8 16:10:52.835: TFTP: Looking for CTLSEP8CB64F5697F6.tlv

*Mar  8 16:10:52.835: TFTP: Sending error 1 No such file

*Mar  8 16:10:52.927: TFTP: Server request for port 49225, socket_id 0x49CBD70C for process 12

*Mar  8 16:10:52.927: TFTP: read request from host 192.168.1.4(49225) via GigabitEthernet0/0

*Mar  8 16:10:52.927: TFTP: Looking for ITLSEP8CB64F5697F6.tlv

*Mar  8 16:10:52.927: TFTP: Sending error 1 No such file

*Mar  8 16:10:53.019: TFTP: Server request for port 49225, socket_id 0x49CBD70C for process 12

*Mar  8 16:10:53.019: TFTP: read request from host 192.168.1.4(49225) via GigabitEthernet0/0

*Mar  8 16:10:53.019: TFTP: Looking for ITLFile.tlv

*Mar  8 16:10:53.019: TFTP: Sending error 1 No such file

*Mar  8 16:10:53.271: TFTP: Server request for port 49225, socket_id 0x49CBD70C for process 12

*Mar  8 16:10:53.271: TFTP: read request from host 192.168.1.4(49225) via GigabitEthernet0/0

*Mar  8 16:10:53.271: TFTP: Looking for SEP8CB64F5697F6.cnf.xml

*Mar  8 16:10:53.271: TFTP: Sending error 1 No such file

*Mar  8 16:10:53.619: TFTP: Server request for port 49225, socket_id 0x49CBD70C for process 12

*Mar  8 16:10:53.623: TFTP: read request from host 192.168.1.4(49225) via GigabitEthernet0/0

*Mar  8 16:10:53.623: TFTP: Looking for XMLDefault.cnf.xml

*Mar  8 16:10:53.623: TFTP: Opened flash:/its/vrf1/XMLDefault.cnf.xml, fd 10, size 3238 for process 12

*Mar  8 16:10:53.623: TFTP: Sending block 1 (retry 0), socket_id 0x49CBD70C

*Mar  8 16:10:53.623: TFTP: Received ACK for block 1, socket_id 0x49CBD70C

*Mar  8 16:10:53.623: TFTP: Sending block 2 (retry 0), socket_id 0x49CBD70C

*Mar  8 16:10:53.627: TFTP: Received ACK for block 2, socket_id 0x49CBD70C

*Mar  8 16:10:53.627: TFTP: Sending block 3 (retry 0), socket_id 0x49CBD70C

*Mar  8 16:10:53.627: TFTP: Received ACK for block 3, socket_id 0x49CBD70C

*Mar  8 16:10:53.627: TFTP: Sending block 4 (retry 0), socket_id 0x49CBD70C

*Mar  8 16:10:53.631: TFTP: Received ACK for block 4, socket_id 0x49CBD70C

*Mar  8 16:10:53.631: TFTP: Sending block 5 (retry 0), socket_id 0x49CBD70C

*Mar  8 16:10:53.631: TFTP: Received ACK for block 5, socket_id 0x49CBD70C

*Mar  8 16:10:53.631: TFTP: Sending block 6 (retry 0), socket_id 0x49CBD70C

*Mar  8 16:10:53.631: TFTP: Received ACK for block 6, socket_id 0x49CBD70C

*Mar  8 16:10:53.631: TFTP: Sending block 7 (retry 0), socket_id 0x49CBD70C

*Mar  8 16:10:53.631: TFTP: Received ACK for block 7, socket_id 0x49CBD70C

106
Views
0
Helpful
4
Replies
CreatePlease to create content