Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Cannot Access Backup Device in Unity Connection

CISCO VoIP System Info:

Cisco Unity Connection version: 8.6.2ES25.21900-25

CM Admin System version: 8.6.2.21900-5 on C200M2 Servers

 

We recently changed our backup process from a local SFTP server, to on going over our WAN.  Works fine in CM, however, it does not work in Unity Connection.

I was unable to get a good backup, and read on the Cisco Support Forum that I need to restart the MASTER and LOCAL DRF Service.  I did this and they started properly.

 

However, I am now unable to access the Backup Device to change the IP Address.  When I login and clikc Backup Device, it hangs and does not go to the Backup Device screen so I can change it.

 

I'm 99% sure I am missing something simple.  Any help would be greatly appreciated.  Thank you.

20 REPLIES
VIP Purple

Hi, Check whether the new

Hi,

 

Check whether the new sftp server across WAN is reachable from Unity connection or not.

 

regds,

aman

New Member

It is reachable via

It is reachable via Communication Manager and I am using the same computer.  I see no reason why it would not be reachable, but I cannot add it in as the backup device, as I cannot get to the Backup Device screen, due to my issue in the first post.  All I need to do is edit my backup device so that it points to the WAN SFTP server, but I cannot.

 

I am able to ping the SFTP server from that computer and get a full backup of CM using that server.  Thanks for the reply, and any help would be greatly appreciated.

I think the backup might be

I think the backup might be running when you try to access the Backup device or something is hung in the DRF. I would restart Unity Connection and try to reconfigure Unity Connection right after the reboot.

Please rate useful posts.
VIP Purple

Hi, you can also check the

Hi,

 

you can also check the port used for DRF/sftp

 

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/connection/8x/security/guide/8xcucsecx/8xcucsec010.pdf

 

regds,

aman

VIP Purple

hi, you can run utils service

hi,

 

you can run utils service list to check .

 

regds,

aman

New Member

Very silly question, but how

Very silly question, but how do I run the utils - from a cmd line?  If so, am I using telnet or some other command.  Sorry for the ignorance but if you don't do it.....  We have no documentation on how to do this and had never had to.  I have the IP addresses and credentials.  I will document this for the future.  Learning as we go.  Please let me know and thanks so much.

New Member

Sorry - jumped the gun - I

Sorry - jumped the gun - I remember we used Putty SSH client to console into the server.  Is there any specific command I need to run to check the backup status or a command I can use to shutdown the backup that could be running?  Thanks again, and sorry for the ignorance.

New Member

I did a utils service list

I did a utils service list and see a list of all the services running - I see both DRF agents running, however, I do not see anything related to "backup" - can you please assist with what service I am actually looking for - and if I see it, can I simply stop it by running a certain command?  Thanks again

Hello,Yes, thats what you

Hello,

Yes, thats what you need to look for. DRF Master agent and local agent. You can issue the command utils service restart <servicename>. Use the exact service name from when you issues utils service list.

 

Please rate useful posts.
New Member

Thank you George.  I did a

Thank you George.  I did a restart of both the Master and Local DRF Agents first thing this morning.  They both restarted properly and are currently running.  I still cannot access the Backup Device, Backup Status or Manual Backup page to change my SFTP server address.  Any other suggestions.  I am trying to not have to restart the entire server.  Thank you.

The utils service CLI

The utils service CLI commands are only going to allow you to do what you've already done, which is stop/start the DRF services. Here's a couple thoughts:

1.  You can use the "utils disaster_recovery ..." commands to get more access into the actual DRS controls.  You might first try canceling a backup to see if that's the problem.  You may also be able to add a new target via CLI.  I haven't had to do this personally and versions may have more/less access so mileage may vary.  Take a look at that here:

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/cli_ref/9_0_1/CUCM_BK_C3A58B83_00_cucm-cli-reference-guide-90/CUCM_BK_C3A58B83_00_cucm-cli-reference-guide-90_chapter_01001.html#d3908e2746a1635

2.  If you have a CUC cluster (2 servers), then you might try accessing the DRS on the secondary server.  With CUC, you can actually run separate, complete backups from both nodes (which I recommend).  So, if you are on the Pub and having issues - try from the Subscriber.  At minimum, you can get a DB backup while you figure out what's up with the Pub.

3. This may be of little value but you might also restart the Tomcat service.  This is just the web server service so you won't be able to access administratively for a few minutes but it's relatively low in service impact and doesn't require a reboot.  You can do that via CLI using the "utils service" commands.  Believe it or not, I have had an issue with DRS before where I needed to restart Tomcat.  It was a certificate issue so likely completely unrelated to what you have but an FYI for you nonetheless.

Hope this helps.

Hailey

New Member

Thank you.  Phone Admin only

Thank you.  Phone Admin only 1/5 of my duties, so I will try that tomorrow - I reply when I do or let you know if I found anything else.  Thanks again.

No worries ... that's what

No worries ... that's what the forums are for - sometimes you need a little help.

New Member

Thanks again for all of your

Thanks again for all of your assistance.

Just wanted to provide an update.  Nothing worked short of the reboot.  I rebooted both our Primary and Secondary Untiy Servers and I was able to get a backup.  Another mystery solved by a restart.  Thanks again.

New Member

mercercourts, did you ever

mercercourts, did you ever figure out why you can't access the backup device page? I'm having the exact same issue.

I can access backup device and backup to the SFTP server perfectly in CM. 

But when I try to do the same thing in Unity, it just hangs/freezes after clicking backup device. 

 

VIP Purple

Hi Kyle, try deleting the

Hi Kyle,

 

try deleting the existing backup device and create new one and check.

 

regds,

aman

New Member

Kyle,Yes, as stated above,

Kyle,

Yes, as stated above, the servers were not restarted for almost a year and the issue was resolved by restarting the CM and Unity Servers.  If you have a chance, try that.  I know it may be tough because I had to do very early in the morning, but it's worth a shot.  Restarts always help with clearing something.  :)

New Member

Thanks Joseph and Aman for

Thanks Joseph and Aman for replying so quickly. Great community.

Luckily I was able to get it working without restarting the servers.

When I went into network services under Backup and Restore, I see this:

Cisco DRF local - not running

Cisco DRF Master - running 

I tried starting DRF local, but it would only run for about 1 minute and then stop by itself. 

Finally, I decided to try restarting DRF Master, even though it was already running. Once I did that, DRF local stayed ON. It didn't stop anymore. 

Now I'm able to open Backup Devices like normal. 

Thanks guys!

New Member

Kyle,Also, you may want to

Kyle,

Also, you may want to confirm that the IP address/Name of the SFTP server (if that is how you are backing up) has not changed.  This caused an issue with us as well a while back, as the remote server IP changed and we were not informed.  This hung constantly, as it was trying to resolve the IP every time we logged on.

New Member

I could restart the server,

I could restart the server, and that is my last option, because that would have to be done after hours.  We do not have remote capability.  Do you know if there is a way to stop the backup or check to see if it is running, besides actually being in the Backup screen (whihc I cannot access).  I was told that Restarting the Master and Local DRF Agent would do that.  Thanks for the reply and any more assistance would be greatly appreciated.

630
Views
5
Helpful
20
Replies
CreatePlease to create content