Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cannot route calls to external sip proxy

Hi,

I am new to cisco voice ,I have cisco 2921 voice gateway , which is connected to both   PRI and WAN . We need to route all calls from PRI to external SIP proxy.

I configured router for achieving this one, it did not work. Please look at the following configuration and help me ,

.

Building configuration...

Current configuration : 5644 bytes

!

! Last configuration change at 16:35:11 gmt Sun May 27 2012

! NVRAM config last updated at 16:16:01 gmt Sun May 27 2012

! NVRAM config last updated at 16:16:01 gmt Sun May 27 2012

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Qatar_CIC

!

boot-start-marker

boot-end-marker

!

!

card type e1 0 1

no logging buffered

enable secret 5 $1$L4mH$WTv.bzkTh4EIjPt5LTXLe.

!

no aaa new-model

!

clock timezone gmt 3 0

network-clock-participate wic 1

network-clock-select 1 E1 0/1/0

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

!

no ip domain lookup

ip name-server 212.77.192.59

!

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-net5

!

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-3420541303

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3420541303

revocation-check none

rsakeypair TP-self-signed-3420541303

!

!

crypto pki certificate chain TP-self-signed-3420541303

certificate self-signed 01

3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030

31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

69666963 6174652D 33343230 35343133 3033301E 170D3132 30353237 30383539

33325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 34323035

34313330 3330819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

8100E28D 2A6699CF 9B3DDC45 E880A6EE F1FE085E FC1505A8 235742D0 D6136634

10A4C543 2EC259CC 10F9400B A39E35F1 F459C32C 10F37C23 778AFD42 4557BF5E

02F92D4D 0EC936D0 66F56A60 6ECB52BD 26D3B157 F72A8E56 AA566C8A 2D084D88

954D7A3E E8B93808 591603FD 7D742D18 5AD0ABC2 FF883BBA AF5D2E4D 5F89C60D

0C910203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603

551D2304 18301680 14FCE4E6 1645B7C7 C4108524 0AF0B739 CDF7DE94 78301D06

03551D0E 04160414 FCE4E616 45B7C7C4 1085240A F0B739CD F7DE9478 300D0609

2A864886 F70D0101 05050003 818100C9 47F060DC C336840C 2762F835 E073CBB2

1B1EF0D2 75E3A190 DDAAAB91 05B04A1D C0F41625 820606FE 557FE679 F2CB2D54

A85FB701 98F5BB2A 668CA514 1486DB67 637BEE47 F0B5FDA8 0F7A1652 C7E54A48

DDF0B67D C556DB7B A31E21E3 3675FC88 3B14A158 7B091816 1D16C0EB 9F67422E

73245F5C 1E2D3EF6 94F15355 8A4067

       quit

voice-card 0

!

!

!

voice service voip

allow-connections h323 to sip

allow-connections sip to sip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

sip

!

!

!

!

voice translation-rule 1

rule 1 /.*/ /300/

!

!

voice translation-profile LG

translate called 1

!

!

license udi pid CISCO2921/K9 sn FCZ1610700U

hw-module pvdm 0/0

!

!

!

username admin privilege 15 password 0 xxxx

!

redundancy

!

!

!

!

controller E1 0/1/0

framing NO-CRC4

pri-group timeslots 1-10,16

description 10ChannelPRI

!

!

!

crypto isakmp policy 1

encr 3des

authentication pre-share

crypto isakmp key lgsec address 83.111.224.82

crypto isakmp keepalive 10

!

!

crypto ipsec transform-set myset esp-3des esp-sha-hmac

!

crypto map vpn 10 ipsec-isakmp

set peer 83.111.224.82

set transform-set myset

match address 120

!

!

!

!

!

interface Tunnel0

ip address 192.168.16.2 255.255.255.252

ip tcp adjust-mss 1360

tunnel source 78.100.79.106

tunnel destination 83.111.224.82

crypto map vpn

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

ip address 78.100.79.111 255.255.255.248

duplex auto

speed auto

crypto map vpn

!

interface GigabitEthernet0/1

description $ES_LAN$

ip address 192.168.123.1 255.255.255.0

ip access-group 110 out

ip accounting output-packets

ip flow ingress

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

duplex auto

speed auto

!

interface Serial0/1/0:15

description 10ChannelPRI

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn integrate calltype all

!

ip forward-protocol nd

!

ip http server

ip http authentication local

ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 78.100.79.105

ip route 83.111.224.82 255.255.255.255 78.100.79.105

ip route 172.26.137.81 255.255.255.255 192.168.16.1

ip route 195.160.253.4 255.255.255.255 78.100.79.105

ip route 213.42.118.167 255.255.255.255 192.168.16.1 name To_Connect_SIP_PBX_in_

Dubai

ip route 213.42.118.169 255.255.255.255 192.168.16.1 name To_Connect_Magement_Se

rver_in_Dubai

ip route 213.42.118.170 255.255.255.255 192.168.16.1 name To_Connect_Magement_Se

rver_in_Dubai

!

access-list 110 permit tcp host 213.42.118.167 host 192.168.123.106 log

access-list 110 permit udp host 213.42.118.167 host 192.168.123.106 log

access-list 110 permit ip any any

access-list 120 permit gre host 78.100.79.106 host 83.111.224.82

!

!

!

!

!

!

control-plane

!

!

voice-port 0/1/0:15

description 10ChannelPRI

!

!

!

mgcp profile default

!

!

dial-peer voice 20 voip

destination-pattern 300

session protocol sipv2

session target ipv4:213.42.118.167

session transport udp

dtmf-relay rtp-nte

no vad

!

dial-peer voice 10 pots

destination-pattern .T

no digit-strip

port 0/1/0:15

!

dial-peer voice 12 pots

translation-profile incoming LG

incoming called-number .

no digit-strip

port 0/1/0:15

forward-digits all

!

!

sip-ua

!

!

!

gatekeeper

shutdown

!

!

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

password

login

transport input all

line vty 5 15

password

login

transport input all

!

scheduler allocate 20000 1000

end

400
Views
0
Helpful
0
Replies
CreatePlease login to create content