Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cannot Upgrade to CCM 5.x using DMA

I'm upgrading CCM 4.1(3) to 5.0(4) and I'm having an issue when I use the Windows Upgrade. Everytime it gets to the part that it wants the DMA file it fails. I get a message "File Retrieval failed for unknown reason" or it states that it cannot login with the user info that I have. I've must have tried 30 different options and the same thing. I've even did an basic install to verify that everything would work, and it does. But as soon as I try the Windows upgrade it fails.

Now I've tried the 3Com FTP Server, the Pumpkin FTP Server, msftpsrvr.exe SFTP server, and no luck. Is there a better one than these that someone has had better luck with.

I've printed out the DMABackupInfo.inf file to make sure that all the setting that I put in match what's on that file. I only have the 2 servers (Pub & SUB) and one other on this LAN, the other server I'm using it has a DNS and FTP-SFTP server.

Any input before going to TAC would be very helpful. I've not had very good luck lately with TAC getting back with me.

New Member

Re: Cannot Upgrade to CCM 5.x using DMA

Well I've made it past the FTP issue, but now when it goes through the install it gets the following error"

The installation has encounter a unrecoverable internal error. For further assistance report the following information to your support provider.


"usr.local/cm/script/ W1

PostInstall "4.1.3" /usr/local/cm


/common/log/install/install.log" exited with errors

The system will now halt.

It then asks me to put in my USB and have it dump to it, when I plug in my USB, it states that it doesn't see it.

Any assistance would help!


Re: Cannot Upgrade to CCM 5.x using DMA

This is the most common error message that you get with CM upgrade files. Actually, i've seen the same error on every upgrade failure and it does not give any info. You will have to connect a USB drive and collect the logs for anyone to analyse it. Though, couple of common reasons for this could be.

1. No Network Connectivity, as in Eth0 port is not disconnected.

2. Change of Hostname/IP Address.

Cisco Employee

Re: Cannot Upgrade to CCM 5.x using DMA

Hi Tony,

Did you try copying the DMA file on to a CD/DVD and then doing the windows upgrade . This will help you isolate the root cause of the issue.

If you think it is an issue with the SFTP server,you can try the following -

- Use freeFTPd software for SFTP. I always use this one for sftp.

- It would also be a great idea to check if personal firewall is disabled on your sftp server.

- Some of the other services to look out for and stop on the sftp server are Cisco Security agent and Cisco VPN service.



New Member

Re: Cannot Upgrade to CCM 5.x using DMA

Thanks for the reply, I do think I'm past the FTP issue and I have verified that it now does copy the file, but now it seems as if there is another issue. I did make a few backup DMA before I did the new install and tried all three of them. Now I can install the 5.x when selecting new install, it only happens when I use the DMA file. There is no firewall, it's just three PC's, the 2 CCM and a bare bones 2000 workstation with FTP on it.

Please look at my second posting and see the error it comes back with.

New Member

Re: Cannot Upgrade to CCM 5.x using DMA

Hi All

can you please tell me how can i fix the ftp problem.

tony can you please tell me how did you pass it and how did you fix it. i have the same errors that you had

thank you


Re: Cannot Upgrade to CCM 5.x using DMA

Can u attach the FTP Server logs for us to check which stage of the process does this hang. Else, you can copy the file on a CD/DVD and use that for the upgrade

New Member

Re: Cannot Upgrade to CCM 5.x using DMA


I had the same problem but i have finisch it with 3cdeamon to upload the file.

New Member

Re: Cannot Upgrade to CCM 5.x using DMA

sorry, forgot something do it with ftp and not sftp.(3cdeamon ftp)

Good luck ;-)

CreatePlease to create content