Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Cause code = 3 on H323 GATEWAY

I am working on a test lab where call coming from CME to H323 gateway, but the call is getting disconnected with cause code =3 on H323 GW.

I also get cause code = 3 when I make a call from CM to CME.

CUCM8.0.2 ----- H323 GW---------------------------------CME

Below is the H323 config deb h225 asn1 log

Router#show run

Building configuration...

Current configuration : 1721 bytes

!

! Last configuration change at 01:41:49 UTC Wed Jul 10 2013

! NVRAM config last updated at 01:41:52 UTC Wed Jul 10 2013

! NVRAM config last updated at 01:41:52 UTC Wed Jul 10 2013

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

!

!

dot11 syslog

ip source-route

!

!

ip cef

!

ip dhcp excluded-address 10.1.200.1 10.1.200.20

!

ip dhcp pool voice

network 10.1.200.0 255.255.255.0

default-router 10.1.200.1

option 150 ip 10.1.200.21

!

!

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

!

voice call disc-pi-off

voice rtp send-recv

!

voice class h323 1

  h225 timeout tcp establish 3

!

!

!

!

!

voice-card 0

!

crypto pki token default removal timeout 0

!

!

!

!

license udi pid CISCO2811 sn FTX1320A102

!

redundancy

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 10.1.200.22 255.255.255.0

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.1.200.22

!

interface FastEthernet0/1

ip address 10.1.100.10 255.255.255.0

duplex auto

speed auto

!

router rip

network 10.0.0.0

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

!

!

!

!

!

!

!

control-plane

!

!

!

!

mgcp profile default

!

!

dial-peer voice 10 voip

destination-pattern 1...

session target ipv4:10.1.100.11

voice-class h323 1

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 100 voip

destination-pattern 2...

session target ipv4:10.1.200.21

voice-class h323 1

dtmf-relay h245-alphanumeric

no vad

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

login

transport input all

!

scheduler allocate 20000 1000

ntp master 1

end

Router#

Router#

Router#

Jul 10 01:42:14.118: H225.0 INCOMING ENCODE BUFFER::= 2080060008914A00042800B500001240013C05010000837CD6F4E82E11E282EBAA1BCFE4B81000CD1D820007000A01

640BFC561100837D731CE82E11E282EDAA1BCFE4B8103402130000000D4001800B050001000A01640B42D7801E400000060401004D40018012150001000A01640B42D6000A01640B42D7

800100010001800180010010A80180530140B50000124CE0011200011C3B1C399E0100036774640000002E49414D2C0D0A4743492C383337636436663465383265313165323832656261

61316263666534623831300D0A0D0A18800006000400000003350204677464012E49414D2C0D0A4743492C38333763643666346538326531316532383265626161316263666534623831

300D0A0D0A

Jul 10 01:42:14.118:

Jul 10 01:42:14.118: H225.0 INCOMING PDU ::=

value H323_UserInformation ::=

    {

      h323-uu-pdu

      {

        h323-message-body setup :

        {

          protocolIdentifier { 0 0 8 2250 0 4 }

          sourceInfo

          {

            vendor

            {

              vendor

              {

                t35CountryCode 181

                t35Extension 0

                manufacturerCode 18

              }

            }

            gateway

            {

              protocol

              {

                voice :

                {

                  supportedPrefixes

                  {

                  }

                }

              }

            }

            mc FALSE

            undefinedNode FALSE

          }

          activeMC FALSE

          conferenceID '837CD6F4E82E11E282EBAA1BCFE4B810'H

          conferenceGoal create : NULL

          callType pointToPoint : NULL

          sourceCallSignalAddress ipAddress :

          {

            ip '0A01640B'H

            port 64598

          }

          callIdentifier

          {

            guid '837D731CE82E11E282EDAA1BCFE4B810'H

          }

          fastStart

          {

            '0000000D4001800B050001000A01640B42D780'H,

            '400000060401004D40018012150001000A01640B...'H

          }

          mediaWaitForConnect FALSE

          canOverlapSend FALSE

          multipleCalls TRUE

          maintainConnection TRUE

          symmetricOperationRequired NULL

        }

        h245Tunneling TRUE

        nonStandardControl

        {

          {

            nonStandardIdentifier h221NonStandard :

            {

              t35CountryCode 181

              t35Extension 0

              manufacturerCode 18

            }

            data 'E0011200011C3B1C399E0100036774640000002E...'H

          }

        }

        tunnelledSignallingMessage

        {

          tunnelledProtocolID

          {

            id tunnelledProtocolAlternateID :

            {

              protocolType "gtd"

            }

          }

          messageContent

          {

            '49414D2C0D0A4743492C38333763643666346538...'H

          }

        }

      }

    }

Jul 10 01:42:14.126: H225 NONSTD INCOMING ENCODE BUFFER::= E0011200011C3B1C399E0100036774640000002E49414D2C0D0A4743492C38333763643666346538326531316

532383265626161316263666534623831300D0A0D0A18800006000400000003

Jul 10 01:42:14.130:

Jul 10 01:42:14.130: H225 NONSTD INCOMING PDU ::=

value H323_UU_NonStdInfo ::=

    {

      version 18

      protoParam qsigNonStdInfo :

      {

        iei 28

        rawMesg '1C399E0100036774640000002E49414D2C0D0A47...'H

      }

      progIndParam progIndIEinfo :

      {

        progIndIE '00000003'H

      }

    }

Jul 10 01:42:14.142: H225.0 OUTGOING PDU ::=

value H323_UserInformation ::=

    {

      h323-uu-pdu

      {

        h323-message-body releaseComplete :

        {

          protocolIdentifier { 0 0 8 2250 0 4 }

          callIdentifier

          {

            guid '837D731CE82E11E282EDAA1BCFE4B810'H

          }

        }

        h245Tunneling TRUE

      }

    }

Jul 10 01:42:14.142: H225.0 OUTGOING ENCODE BUFFER::= 2580060008914A000411001100837D731CE82E11E282EDAA1BCFE4B81010800180

Jul 10 01:42:14.142:

1 REPLY
New Member

Cause code = 3 on H323 GATEWAY

Hi all,

The issue is fixed.. I didnt add the trusted list..

Thanks a lot!!

133
Views
0
Helpful
1
Replies
CreatePlease to create content