Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ccie voice lab "pstn phone not getting ip address" configure ip

Hi ,

I've managed to setup a ccie voice lab doing good.

4 sites one of the sites is configured as a pstn/frame relay router.

This pstn router is configured by trunk to a 3550 poe switch.

In my switch i configured the necessary configuration:

interface FastEthernet0/13

description TRUNK to PSTN-RTR

switchport trunk encapsulation dot1q

switchport mode trunk

duplex full

speed 100

interface FastEthernet0/14

description pstn phone

switchport access vlan 50

switchport mode access

switchport voice vlan 25

spanning-tree portfast

if i do a in pstn router

sh ip dhcp bind => no result

sh ephone reg=> no ephone registered

interface FastEthernet0/0.25

encapsulation dot1Q 25

ip address 192.168.25.254 255.255.255.0

!

interface FastEthernet0/0.50

encapsulation dot1Q 50

ip address 192.168.50.254 255.255.255.0

Am i forgetting something???

because my pstn phone cant get ip adress

data and voice vlan are created inmy 3550 switch


2 ACCEPTED SOLUTIONS

Accepted Solutions
New Member

ccie voice lab "pstn phone not getting ip address" configure ip

Hi,

     In the PoE switch can you see the IP Phone mac address learning the correct voice vlan? Have u assigned any static IP to the IP Phone, is DHCP enabled in the IP Phone? what if you assign static ip to a pc instead of the IP phone, can you reach the router?

Thankyou

     PC

ccie voice lab "pstn phone not getting ip address" configure ip

The reason why the phone wasn't getting an IP address, was because you were excluding the entire range of IPs...

"ip dhcp excluded-address 192.168.50.0 192.168.50.254"

HTH

Regards,

Yosh

HTH Regards, Yosh
7 REPLIES
Hall of Fame Super Silver

ccie voice lab "pstn phone not getting ip address" configure ip

Where is your DHCP scope created? Is it on one of the Cisco devices? If so, please provide the config. Or is it on a Windows server, etc?

Chris

New Member

ccie voice lab "pstn phone not getting ip address" configure ip

Hi Chris,

Its created on my pstn/frame relay router

This router is CME based.

ip dhcp excluded-address 192.168.50.0 192.168.50.254

!

ip dhcp pool PSTN_Phone

   network 192.168.50.0 255.255.255.0

   default-router 192.168.50.1

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.25 ( subinterfaces created in pstn router)

encapsulation dot1Q 25

ip address 192.168.25.254 255.255.255.0

!

interface FastEthernet0/1.50

encapsulation dot1Q 50

ip address 192.168.50.254 255.255.255.0

New Member

ccie voice lab "pstn phone not getting ip address" configure ip

Anyone?

No idea?

I'm totally lost

New Member

ccie voice lab "pstn phone not getting ip address" configure ip

Hi,

     In the PoE switch can you see the IP Phone mac address learning the correct voice vlan? Have u assigned any static IP to the IP Phone, is DHCP enabled in the IP Phone? what if you assign static ip to a pc instead of the IP phone, can you reach the router?

Thankyou

     PC

New Member

ccie voice lab "pstn phone not getting ip address" configure ip

Hi there,

Yes i can see the phone's mac adress in my switch ===>check

dhcp is enabled in phone===>check

voice vlan is enabled in phone yes => check

switchport configuration poe switch

interface FastEthernet0/14

description PSTN PHONE 7960 phone

switchport access vlan 50

switchport mode access

switchport voice vlan 25

spanning-tree portfast

interface FastEthernet0/13

description TRUNK to PSTN-RTR

switchport trunk encapsulation dot1q

switchport mode trunk

speed 100

SiteA-Switch#sh in fa0/13 trunk

Port        Mode         Encapsulation  Status        Native vlan

Fa0/13      on           802.1q         trunking      1

Port      Vlans allowed on trunk

Fa0/13      1-4094

Port        Vlans allowed and active in management domain

Fa0/13      1,25,50,101-103,130,200,240,340,400

Port        Vlans in spanning tree forwarding state and not pruned

Fa0/13      1,25,50,101-103,130,200,240,340,400

New Member

ccie voice lab "pstn phone not getting ip address" configure ip

I finally got it working

I created a new dhcp pool

created data and voice vlans

but i've noticed in switchport interface that only the data vlan was added.
So  added also the voice vlan (150)







PSTN config:
------------------
ip dhcp pool PSTN                          
this and configure static dhcp
   network 10.10.20.0 255.255.255.0
   option 150 ip 10.10.110.4       
   default-router 10.10.20.150    

interface FastEthernet0/1.100
 description "PSTN-DATA Vlan"
 encapsulation dot1Q 100 native
 ip address 10.10.10.100 255.255.255.0
!
interface FastEthernet0/1.150
description "PSTN-VOICE Vlan"
 encapsulation dot1Q 150
 ip address 10.10.20.150 255.255.255.0


ccie voice lab "pstn phone not getting ip address" configure ip

The reason why the phone wasn't getting an IP address, was because you were excluding the entire range of IPs...

"ip dhcp excluded-address 192.168.50.0 192.168.50.254"

HTH

Regards,

Yosh

HTH Regards, Yosh
712
Views
0
Helpful
7
Replies