Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

CCM 4.1.2 Publisher does not show any registered devices

I have a 4.1.2 pub which does not show any devices registered although the 2 subs do through CCM admin. Replication works fine as i have inserted a dummy and checked all databases for it. This does not affect the running of the cluster. Any ideas thanks

11 REPLIES
Hall of Fame Super Red

Re: CCM 4.1.2 Publisher does not show any registered devices

Hi David,

In many cases this is by design. One of the reccomended setups is that no devices register with the Pub and it is left free for other tasks. Have a look at your Callmanager Groups (through CCMADMIN) and see if any of them list the Pub first in the selection order. The relationship between Device Pools and Callmanager Groups dictates which CCM devices register with. It sounds like everything is OK so this may be the case in your environment.

Hope this helps!

Rob

Community Member

Re: CCM 4.1.2 Publisher does not show any registered devices

Thanks for the reply. maybe I wasn't clear enough. When looking at CCM admin physically on the publisher all devices show as not found. When viewing the same on a subs they show as registered to the relevant subscriber. We have no devices actually registering to the pub as you state.

Community Member

Re: CCM 4.1.2 Publisher does not show any registered devices

Hi David,

I met this situation several times and it's caused by the synchronization problem. Although you can create dummy devices and see the pub and sub database has it.

I resolved this by restart the pub and sub.

first reload pub, then the subs. You may have a try.

Good Luck.

Community Member

Re: CCM 4.1.2 Publisher does not show any registered devices

Many thanks. We are currently scheduling a cluster reboot to see if this clears it.

Gold

Re: CCM 4.1.2 Publisher does not show any registered devices

Can you check if "Cisco RIS Data Collector" is started on the Publisher. With phones being registered and CallManager status being shown as "Not Found" is the most typical symptom of this service being de-activated or stopped. Ensure that Cisco RIS Data Collector is Active and Started on the Publisher. That should resolve the issue.

To Activate a Service, please check:

http://www.cisco.com/en/US/customer/products/sw/voicesw/ps556/products_administration_guide_chapter09186a00803f52e4.html#wp68098

To restart a Service, please check:

http://www.cisco.com/en/US/customer/products/sw/voicesw/ps556/products_administration_guide_chapter09186a00803fe6bf.html

Hope this helps

Community Member

Re: CCM 4.1.2 Publisher does not show any registered devices

I had the same issue in CM 4.1(2), Cisco TAC told me to run the command regsvr32 dblx.dll under Publisher C:WINNT\system32 directory and the issue was solved.

I forget whethet we should reboot the publisher or not after running this command.

Community Member

Re: CCM 4.1.2 Publisher does not show any registered devices

Please ignore my previous post, the correct step is -restart "Cisco RIS Data Collector " services.

Community Member

Re: CCM 4.1.2 Publisher does not show any registered devices

I restarted the RIS data collector and all worked fine for a short period and then a search for phones works showing registered. After a few minutes this then fails and stops working even though the service seems to be running ??

Gold

Re: CCM 4.1.2 Publisher does not show any registered devices

Can u check the service status and confirm it is started. Also, check the Event Viewer to see if the service crashed

Community Member

Re: CCM 4.1.2 Publisher does not show any registered devices

he service seems ok and appears started even from services and there is no obvious messages in event log apart from this which seems to coincide with the restart.

Event Type: Error

Event Source: Service Control Manager

Event Category: None

Event ID: 7011

Date: 26/06/2007

Time: 14:41:36

User: N/A

Computer: CM-ALW-PUB

Description:

Timeout (30000 milliseconds) waiting for a transaction response from the service.

Gold

Re: CCM 4.1.2 Publisher does not show any registered devices

Could be an issue with RIS not being able to pull Data from SQL. I'd recommend opening a case with TAC to troubleshoot Database access/service crash issue

192
Views
0
Helpful
11
Replies
CreatePlease to create content