Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CCM 6.1 host not found

Hi,

I am trying to set-up IPMA on CUCM 6.1 and when the user presses the Services key they get the "HOST NOT FOUND" message

The Pub is using HOSTNAME - SASCCMP01

The services have been configured -

http://SASCCMP01:8080/ma/servlet/MAService?cmd=doPhoneService&Name=#DEVICENAME#

You can ping the hostname and this resolves back to the IP of the CUCM, but we cannot see the services created.

Has anyone came across something similar?

Thanks,

James

12 REPLIES
Cisco Employee

Re: CCM 6.1 host not found

Hi James,

Do the phones have DNS server information? Unless there's a really compelling reason to use the hostname, the recommendation is to use IP address in the service url. This eliminates an extra layer of complexity, where IP phones would first need to resolve the name. Is using IP address an option for you?

Regards,

Michael.

New Member

Re: CCM 6.1 host not found

Hi Michael,

Yes the phones have picked up the DNS server information.

I can use IP Addresses, but going by some of the doc's on CCO it mentions the following -

Configuration Tips

To provide redundancy for the Cisco IP Phone Service, create a Cisco IP Phone Service that uses the host name rather than the IP address. The host name in DNS should resolve to both IPMA primary and backup IP addresses. The phone functionality for softkeys and filtering, as well as the phone service, will fail over automatically in the case of a failover.

If this is not the case then l can use IP's.

Regards,

James

Cisco Employee

Re: CCM 6.1 host not found

Hi James,

Does the DNS server resolve the name to both IP addresses?

I suggest trying to use the ip address, even as a test. If it works, then you would know for sure that the issue is related to DNS resolution, then troubleshooting efforts can focus on that. If it still doesn't work, then we know we have other areas to investigate as well.

Regards,

Michael.

New Member

Re: CCM 6.1 host not found

Hi Michael,

The DNS does resolve the names to IP addresses.

I will change the hostname to IP and test it from there and let you know how l get on. If it does fail l will carry out a sniffer trace of the phone requesting the DNS information.

Regards,

James

Cisco Employee

Re: CCM 6.1 host not found

Good plan, James. Keep us posted.

Regards,

Michael.

New Member

Re: CCM 6.1 host not found

Hi Michael,

The DNS does resolve the names to IP addresses.

I will change the hostname to IP and test it from there and let you know how l get on. If it does fail l will carry out a sniffer trace of the phone requesting the DNS information.

Regards,

James

New Member

Re: CCM 6.1 host not found

I have the same problem but it is only effecting 1 out of 6 7941s at 1 specific location. All of the 46 - 7940s at this same location have no problem at all.

New Member

Re: CCM 6.1 host not found

Hi Adam,

After further discussions with the remote user DNS is working in the CUCM cluster, the problem is related to 3 new phones added to create a IPMA test enviroment.

I have carried out a erase of the 7960G phone and it does not pick up any of the services from CCM, all other phones on the system pick up DNS settings resolved from hostname to IP.

Further more it turns out that the IPMA phones only register to the Pub and the TFTP server.

James

Cisco Employee

Re: CCM 6.1 host not found

Nice update, James. To further specify the problem and possibly draw distinctions, the answers to these questions might help:

- What phone model are the existing working ones?

- Which phone load are the existing working phones using?

- Which phone load are the new 7960G phones using?

- When one of the new 7960G phones are placed in the same Device Pool as the working phones, do they still have the problem?

- Are the new 7960G phones in the same VLAN as the existing ones? Same network, default gateway, subnet mask?

- From the DNS server, can you ping the existing and new 7960G phones?

Regards,

Michael.

New Member

Re: CCM 6.1 host not found

Hi Michael,

Please find comments below -

- What phone model are the existing working ones? 7910, 7940G & 7960G

- Which phone load are the existing working phones using? P00308000800

- Which phone load are the new 7960G phones using? P00308000800

- When one of the new 7960G phones are placed in the same Device Pool as the working phones, do they still have the problem? Yes, the phones only register to the Pub

- Are the new 7960G phones in the same VLAN as the existing ones? Same network, default gateway, subnet mask? Yes, l am waiting to get the show run of each interface

- From the DNS server, can you ping the existing and new 7960G phones? I will confirm this on Monday the 18th of August

Regards,

James

Cisco Employee

Re: CCM 6.1 host not found

HI James,

When you get the opportunity, please also check the settings on the phones by hitting the Settings button, then selecting Network Settings. Then compare the values here with those of the working phones. Specifically, look at the values for:

- DHCP server

- Domain Name

- TFTP Server

- Default Router

- DNS Servers

- Operational VLAN

- CallManager 1

- CallManager 2

- CallManager 3

- Services URL

Are all these values the same on both the working and non-working phones?

Thanks

Michael.

New Member

Re: CCM 6.1 host not found

Hi Michael,

I have found out that the IPMA Phones are getting there DNS settings, what they are not seeing is the services URL. I have taken out the IP Addresses for the DNS settings etc, but they are the same on both the IPMA Phone and the non IPMA phone -

IPMA phones only have 1 CCM listed, SASCCMP01.

IPMA PHone -

Domain Name ***.ac.uk - Correct

Default Router A.B.C.D - Next hop into Network

Subnet Mask 255.255.0.0

TFTP Server 1 A.B.C.D - Pub

TFTP Server 2 A.B.C.D - Missing

DNS Server 1 A.B.C.D

DNS Server 2

Operational VLAN Id 24

Call Manager 1 A.B.C.D Active - Pub

Call Manager 2 A.B.C.D Standby - Missing

Services URL - http://A.B.C.D:8080/ma/servlet/MAService?cmd=doPhoneService&Name=#DEVICENAME# - Missing URL information

Users Phone -

Domain Name ***.ac.uk - Correct

Default Router A.B.C.D - Next hop into Network

Subnet Mask 255.255.0.0

TFTP Server 1 A.B.C.D - Sub

TFTP Server 2 A.B.C.D - Pub

DNS Server 1 A.B.C.D

DNS Server 2

Operational VLAN Id 24

Call Manager 1 A.B.C.D Active - Pub

Call Manager 2 A.B.C.D Standby - Sub

Services URL - http://A.B.C.D:8080/ma/servlet/MAService?cmd=doPhoneService&Name=#DEVICENAME# - IP Address of Sub

The IPMA phone only picks up the Pub to register against and the TFTP server.

Regards,

James

273
Views
0
Helpful
12
Replies