Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CCME - Transcoding g729r8 - g711

Hi all. I want to configure up my remote office 7941 to use the g729 codec. My remoe office has a vpn tunnel and works fine using the g711 codec, but its too bandwidth heavy really (connecting to a 2801 ccme).

I've manually set the ephone to use the 729 codec, but I don't get any voice traffic so I assume that i need to configure transcoding somehow.

Anyone got any pointers?

THanks

Huw

5 REPLIES

Re: CCME - Transcoding g729r8 - g711

Hi Huw,

You should not need a transcoder for phone-to-phone calls. If the remote phone only supports g729 then the local phones should use g729 locally when the call the remote phone.

You would need a transcoder for calls to CUE however, because it only supports G.711ulaw.

hth,

nick

New Member

Re: CCME - Transcoding g729r8 - g711

Thanks Nick. I always thought i'd need to transcode between the two codecs as ive never successfully made a 729r8 configured phone (7941 and the IP Communicator) talk to a 711 configured phone (7941). The phone will ring but no voice traffic happens.

When I revert both codecs back to 711 the conversations work.

So does this mean that i'll have to make all the phones in head office use the 728 codec (along with all remote IP Communicator's and 7941's ) then i'll be able to make the calls?

Hall of Fame Super Gold

Re: CCME - Transcoding g729r8 - g711

The thing is that is supposed to work configuring codec g729 on the remote only, without use of dspfarm, unless talking to something g711 only like CUE.

The phones on head office are supposed to be left at default and doing g729 only when the remote so requests.

Which FW you have on the 7941? Can you try other phones like ipcp ?

Re: CCME - Transcoding g729r8 - g711

Hi Davie,

Changing the codec shouldn't give you no-way voice. There would be something else going on there causing that problem. You can try configuring 'mtp' under the remote phones to see if this makes a difference, or upgrading IOS.

hth,

nick

New Member

Re: CCME - Transcoding g729r8 - g711

interestingly this only happens when I make a perfectly working remote phone use the g729 codec. As soon as I remove the relevant line i get voice traffic back.

I get the same on our UC520 too, so thats why i was thinking it was a transcoding issue.

475
Views
0
Helpful
5
Replies