Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CCME4.0 w/C2811 & VIC2-2BRI-NT/TE - Poor Voice Quality on PSTN calls

Hi,

I've just installed a C2811 with CCME4.0 using IOS 12.4(11)T

Off-net voice calls from the IP Phones via the VIC2-2BRI-NT/TE are terrible quality. Internal calls are fine. I also translated an inbound call on one ISDN-2 back out to a DDI on another (so in one ISDN B-Channel and out on another) and voice quality was fine. So this proves the ISDN is OK.

It seams the problem is from IP phones (inbound or outbound) via ISDN. I am using 7940, 7961 & 7906 phones - all display the same problem.

If all cases (isdn-to-isdn call, isdn-to-ip-phone) I use the same pots dial peer.

Can anyone help with this issue?

Thanks,

Chris

1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Re: CCME4.0 w/C2811 & VIC2-2BRI-NT/TE - Poor Voice Quality on PS

hi,

please check your compand type on the voice-port configuration.

voice-port x/y

compand-type a-law

regards

mehmet

6 REPLIES

Re: CCME4.0 w/C2811 & VIC2-2BRI-NT/TE - Poor Voice Quality on PS

Chris,

On a sample ephone that you are testing with, try setting the codec to g729r8. I have another issue currently with two brand new 38xx series routers that when using g711 I'm experiencing horrible quality on the PSTN PRI. Not saying this is the same issue, since mine is a CCM install, but it would be good to try. Possibly there could be new DSPs being shipped or something of the like since I've had DSP hardware bugs before. Let me know if that makes a difference.

ephone 1

codec g729r8

Thanks

Fred

Re: CCME4.0 w/C2811 & VIC2-2BRI-NT/TE - Poor Voice Quality on PS

Chris,

On a sample ephone that you are testing with, try setting the codec to g729r8. I have another issue currently with two brand new 38xx series routers that when using g711 I'm experiencing horrible quality on the PSTN PRI. Not saying this is the same issue, since mine is a CCM install, but it would be good to try. Possibly there could be new DSPs being shipped or something of the like since I've had DSP hardware bugs before. Let me know if that makes a difference.

ephone 1

codec g729r8

Thanks

Fred

New Member

Re: CCME4.0 w/C2811 & VIC2-2BRI-NT/TE - Poor Voice Quality on PS

Fred,

thanks for your suggestion. However I've already tried changing the codec to g729 and I've also changed the PVDM (DSP) and played with the codec complexity - still no joy.

I'm now trying out IOS images to see if its the IOS.

Any further suggestions would be appreciated.

Thanks,

Chris

Bronze

Re: CCME4.0 w/C2811 & VIC2-2BRI-NT/TE - Poor Voice Quality on PS

hi,

please check your compand type on the voice-port configuration.

voice-port x/y

compand-type a-law

regards

mehmet

New Member

Re: CCME4.0 w/C2811 & VIC2-2BRI-NT/TE - Poor Voice Quality on PS

Mehmet,

thank you for your response.

Changing the compand-type to a-law has resolved the problem.

Regards,

Chris

Hall of Fame Super Gold

Re: CCME4.0 w/C2811 & VIC2-2BRI-NT/TE - Poor Voice Quality on PS

The day that IOS will have a default compand-type depending on switch type configured... that would save some trouble!

143
Views
5
Helpful
6
Replies