Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.

CER JTAPI Failed to get the JTAPI Provider

 
Everyone's tags (3)
5 REPLIES
Cisco Employee

Re: CER JTAPI Failed to get the JTAPI Provider

Hi,

So, I am assuming that the following are CUCM servers

10.10.188.13

10.10.188.20

10.10.220.10

Confirm the following,

1. All these servers are reachable from CER and vice-versa.

2. CTI Manager service is started on the servers

3. The username and pass you use for the jtapi user that get assigned to CTI  route point is configured correctly on CER and CUCM. (try not to use any special characters in the username or pass)

4. If CTI Manager service is already started on CUCM, restart it.

If after this you still have the same issue, you will need to grab some traces from CER and open a TAC case.

Thanks,

Re: CER JTAPI Failed to get the JTAPI Provider

Bug ID is CSCtc65522 but workaround didn't exactly fix it for me
Using CER 7.1.1.10000-5 with CallManager 7.1.2.31900-1, I've tried using the AdminUtility to change CER to CallManager version 7.1 and 7.0 with no luck.

2010-02-08 15:52:18,236 | WARN  | CER_TELEPHONY | Failed to get the JTAPI Provider for : 10.20.188.13 trying infinitely

Changing via AdminUtility to 7.0 and rebooted but it didn't fix it, the trace kept showing a request for 7.1 JTAPI provider.  I changed it to 6.1 and my CTI Ports and CTI Route Point all registered. I then changed to 7.0.

The problem is CallManager 7.1.2 changed JTAP providers in 7.1.3, so CER AdminUtility drop down should show 7.1.2 and 7.1.3 as choices.

Re: CER JTAPI Failed to get the JTAPI Provider

I had the same issue and it turned out to be a version mismatch between the JTAPI provider on the UCM and CER servers.

To fix it I downgraded the CUCM version under the Admin Utility from 7.1 to 7.0 and it started working correctly again.

New Member

Re: CER JTAPI Failed to get the JTAPI Provider

I have the same versions of CUCM and CER with the same problem.  CER 7.0(3) worked just fine with CUCM 7.1.  After upgrading CER to 7.1(1) the JTAPI started failing.  I changed the CUCM version on the Admin Utility page to 7.0 and the JTAPI started working again.

Thanks for the tip.

Re: CER JTAPI Failed to get the JTAPI Provider

After upgrading UCM to 7.1.3 I was able to run the CER CUCM version at 7.1 without any issue.

1775
Views
10
Helpful
5
Replies
CreatePlease to create content