Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

CIPC 7.0.3.0 and MTP resource availability

We've upgraded around 160 seats from CIPC 7.0.2.0 to CIPC 7.0.3.0 Since doing so we have identified the following issues:

1. Transfer functionality intermittently does not work e.g. someone (Agent_1) will receive a call from a customer, they determine that the customer needs to be referred to another person (Agent_2). Agent_1 selects More and Confrn buttons and enters the number of the destination they need to call (e.g. Agent_2's xtn). Agent_2 answers the call and the two parties discuss the customers requirement before Agent_1 presses Confrn to initiate a 3 way conference. The fault occurs when Agent_1 presses the Confrn button because Agent_2 gets disconnected and Agent_1 is left with the customer.

This method of transferring is a company policy (called "warm transfer"), the customer cannot be "dumped" on another person ("cold transfer") without having first had their requirement discussed between the two agents, and the customer introduced to the second agent waiting to assist them.

This transfer process is used in our call centre solution Genesys, however I have replicated the fault outside of Genesys by using the transfer method described above using only CIPC.

2. We've noticed that since the time of the CIPC upgrade that we are now getting the following error messages appearing in RTMT:  %CCM_CALLMANAGER-CALLMANAGER-3-MtpNoMoreResourcesAvailable: No more MTP resources available.

These errors were not present before the CIPC upgrade.

Understanding that the number of MTP's in CUCM (Voice Streaming App Service Parameters) has a default of 48, which is what our setting was, we changed the number of MTP resources to 128 on both the publisher and subscriber CUCM's. In conjunction we restarted the Cisco IP Voice Media Streaming App service on both the publisher and subscriber CUCM's. This has not resolved the issue.

The version of CUCM is 6.1.2.1000-13.

Any assistance would be greatly appreciated. Please advise if more detail is required.

Everyone's tags (5)
6 REPLIES

Re: CIPC 7.0.3.0 and MTP resource availability

Hi, do you have Conference Bridge (either software or hardware based) configured and registered on CUCM?

Also, what type of codec you have configured to connect PSTN caller to you agent? And, what type of codec do you use when you are making the intersite calls (agent to agent)? If both of the types are not the same you will need transcoder to mix them in a single stream.

But before all of those, create a multiple party conference within some agents and see if those are successful or not, if not I can confirm it's the conference bridge issue.

Community Member

Re: CIPC 7.0.3.0 and MTP resource availability

Thanks for the reply.

We have software conference bridges configured and registered on CUCM.

The currently configured codec is G.711/G.722.

PSTN caller to agent and reverse uses G.722. Internal calls are using G.711u. I note though that all calls (internal and external) made on CIPC 2.1.4 use G.711u.

Although there appears to be a codec mismatch for CIPC 7.0.2.0 and 7.0.3.0 (G.711u and G.722 depending on internal or external call) I don't understand why we never saw the mtp issue when running 7.0.2.0 but all of a sudden we do with 7.0.3.0?

Going to try disabling G.722 in CUCM service.

Multiple party conferences are intermittently successful.

Community Member

Re: CIPC 7.0.3.0 and MTP resource availability

Disabled G.722 in CUCM service. Transfers now work however there is vocie degradation when the actual 3 way conference is in progress (voice quality is fine when customer is with Agent_1 at start of call or Agent_2 following the transfer. When all three parties are on the line together the voice quality sounds like they are speaking under water.

Replicating the conference process with 7941 hard phones the voice quality is OK throughout.

Re: CIPC 7.0.3.0 and MTP resource availability

Nice to hear that your problem is solved, as you are getting good voice quality with 7941, so there you might need some fine tuning on your desktop/laptop or with your sound card, that's not a problem of CUCM or Conference Bridge or network.

HTH.

Please rate helpful posts!

Community Member

Re: CIPC 7.0.3.0 and MTP resource availability

Problem isn't solved just yet... consider it solved when everything is working properly!

I don't think it is hardware/sound card. Not suggesting you aren't correct, we'll take your advice into consideration whilst troubleshooting. We're looking at higher level possibilities though, will post a reply when we work out what it is.

Full credit to you though for putting me on the right track re the codecs

Community Member

Re: CIPC 7.0.3.0 and MTP resource availability

Are you able to advise how you resolved your problem as we are having similar issues?. Thanks in advance.

1064
Views
5
Helpful
6
Replies
CreatePlease to create content