Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 7861 phone does nothing when you press the corporate directory button: just blank screen and no error message

Hello everyone, 

 

we recently deployed some Cisco 7861 (78xx.10-1-1SR1-4) phones running on cucm 9.1.2.10000-28 . What we have noticed is that after a while, the corporate directory stops working. But if we reboot the phone, it starts working again. 

 

Another thing we noticed is that when the phone stops access corporate directory, the phone's webpage stops working but if you reboot the phone, then you can access the phones web page again. 

 

Cisco actually tried to enable debugs while the phone was broken but the phone did not produce any logs, but if you reboot the phone, then it starts producing logs. 

 

I have a TAC case for but I just wanted to find out if there are other people here facing this same problem. with 78x phones?

 

Thanks 

 

Maxwell 

14 REPLIES
New Member

Hi Maxwell I have a very

Hi Maxwell

 

I have a very similar problem.  When pressing the phone book, nothing is shown on the display.  Neither the "Corporate directory" nor the "Personal address book" opptions apear.  Nothing is displayed.

 

We are running CUCM 8.6 and installed the latest Device Package.  The phones use sip78xx.10-1-1SR1-4.  I have seen the same problem on 7841 and 7861 phones.  I haven't reported to Cisco yet, but I am intending to.

 

Regards

 

New Member

you should, i have been

you should, i have been hearing that this problem is rampant. The problem exist on three sites that we have installed this phone. and yes, 7861and 41 uses the same firmware

New Member

Hi,i have similar issue with

Hi,

i have similar issue with 7841 firmware sip78xx.10-1-1SR1-4  cucm 9.1.2.10000-28.

i tried this configuration:

i configured under device-->phone :

External Data Locations Information (Leave blank to use default)-->

Secure Directory URL--> https://PublisherHostName:8443/ccmcip/xmldirectory.jsp  ; AND

Services ProvisioningRequired Field-->external URL

when i press directory button i see phone display as attached figure.

do i need to wait for a new firmware ?

thanks

New Member

Cisco never ended up fixing

Cisco never ended up fixing it - seems too ad-hoc/random to catch in the act properly, combined with the new SSH for debugging, made it frankly too difficult to troubleshoot and a PITA - we'll have to wait for a while and test with another firmware, in the mean time we stopped recommending them to our customers.

New Member

Hi Team,

Hi Team,

i have the same issue on 7841 with firmware sip78xx.11-5-1-18 and call manager version 9.1, from application menu i can access the directory but from button on the phone it is showing nothing,(just a lock symbol on the top right side), can anyone help me??

New Member

Hello all,

Hello all,

I have the same issue on 7821 and 7841. It works fine on 8831, 8851, ...

Did you resolve it?

Thanks for your feedback.

Hi Marco.Can you do this test

Hi Marco.

Can you do this test for me?

 

- Configure a non secure url pointing to corporate directory.

- Configure a span session on switch port where IP Phone is attached to.

- Put your pc an destination of monitor session and activate wireshark on your pc.

try to access corporate directory from that phone and capture the traffic.

 

Than post here  the result or if you want you can send me the file privately.

 

 

Thanks

 

Regards

 

Carlo

 

 

 

Please rate all helpful posts "The more you help the more you learn"
New Member

Hi Carlo,it's a pleasure

Hi Carlo,

it's a pleasure reading your replies ;).

Yes, changing from https to http corporate directory works. Your suggestion is the right workaround.

I noticed a strange behaviour on device phone web page configuration.

It seems URL Directory parameters are ignored by 7841 phones, and they always take into consideration those specified in enterprise parameters.

So i can get Corporate Directory working only if i delete Secure URL from enterprise parameters.

But our customer is not proud about this, and they want https.

bye

marco

 

New Member

Hi Marco What exactly did you

Hi Marco

 

What exactly did you do to make this work partially?

 

Regards

New Member

Hi,i deleted Secure URL

Hi,

i deleted Secure URL Directory in  enterprise parameters, so the phone take into consideration HTTP only for requesting corporate directory toward Publisher.

with http it works.

But i suggest first deleting certificates on the phone. Try deleting certificates on the phone first, without changing enterprise parameters, and let us know

bye

marco

New Member

Trust me,  The issue is not

Trust me, 

 

The issue is not fixed my friend. A reboot always fixes the problem, but it never fails to return within two weeks.  When it fails, the phone browser may also crash too 

 

This phone has been a massive pain to me. 

cheers

 

Yeah we have this issue too -

Yeah we have this issue too - have logged with TAC but they have not found anything yet.

 

Other issues we have include:

- When on a call the volume does not show on the screen

- Sometimes after a call is complete the call window remains on the screen and is blacked out.

New Member

Hello Ian,  I had the same

Hello Ian, 

 

I had the same problem with volume too, but since upgrading to the latest version, it has been stable for me for about ten days now. However, the directory is still not working.  My employer actually has two TAC cases for the directory issue. In fact, one of the cases is with the phone development team for over two weeks and still no joy.  

 

 

 

Yeah we're running the latest

Yeah we're running the latest version too - it has not resolved it for us. They are talking about an engineering release for us, but we are struggling with TAC they don't seem to understand times zones and keep putting engineers on it when we're not available

750
Views
5
Helpful
14
Replies
CreatePlease login to create content