Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 7940/60 DHCP problem (configuring IP)

Hi all,

i have some problem with my cisco 7940/60 cisco 7940/60 with 8.1(2) firmware would not register to CM 8.6(2)SU3. the problem was the phone is configuring IP and get DHCP server is 255.255.255.255. i tried to upgrade firmware to be 8.1(2)_SR2 and the problem solved. Cisco 7940/60 can register with CM.

Now the problem is reapper. when the 7940/60 phone resetted, the phone is configuring IP and get DHCP server 255.255.255.255 i have checked network and DHCP issue but no problem in there. and when i redowngrade the firmware to 8.1(2) ip phone get their ip address and registered well.

what should i to solve this problem when the problem reappear? is it BUG?

kindly thanks,

2 REPLIES
Hall of Fame Super Silver

Re: Cisco 7940/60 DHCP problem

I've never heard of similar bug, I would focus on looking at your network and try to sniff what is being received on the phone when dhcp is requested, perhaps thee us a rogue one on the network.

Chris

Sent from Cisco Technical Support iPhone App

New Member

Re: Cisco 7940/60 DHCP problem

Hi Chris,

Sorry for late reply,

Thanks,

it's happen (unfortunate configuring IP) only on 7940/60. all types except 7940/60 such as 7945 & 7975 working well.

i have gathered the log file from wireshark (as attached) and get error message :

source(TFTP) dest(IP Phone) === Data Packet , Block: 13 (last)

source(IP Phone) dest(TFTP) === Acknowledgment, Block: 13

source(IP Phone) dest(TFTP) === Read Request, File:CTLSEP(MAC).tlv, transfer type: octet

source(TFTP) dest(IP Phone) === Error code, code : file not found, message : file not found

would you like help me to read the logs?

my TFTP address : 146.44.4.182

my IP Phone address : 146.44.29.45

Thanks,

204
Views
0
Helpful
2
Replies