Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Cisco 7941 Not Registering in CME 8.6

Hi

I would appreciate if somebody could really help me with this. The status-> Firmware version list on my phone is as below:

Load File: *term41.default*

App Load ID:jar41sccp.9-3-1ES13.sbn

JVM Load ID:cvm41sccp.9-3-1ES13.sbn

OS Load ID:cnu41.9-3-1ES13.sbn

Boot Load ID:boot41.3-2-2-0.bin

DSP Load ID:dsp41.9-3-1ES13.sbn

I want to use my Router as my TFTP and it has CME 8.6. The problem is that my 7941 phone does not register at all. Is it something to do with my firmware incompatibility? Being not sure of myself I came here to seek your help. The image attached are from the 'Debug tftp events' in the router and 'status messages' from the phone. Please help me! Thank you.

*btw I do get IP addresses and TFTP address from the Router. When I do 'show ip dchp binding' I can see the IP address leased from the DCHP.

*under 'show flash' command there is nothing except the router image.

1 ACCEPTED SOLUTION

Accepted Solutions

Cisco 7941 Not Registering in CME 8.6

Hi Aditya,

You are missing the load command unde the telephony-service.

telephony-service

max-ephones 5

max-dn 5

ip source-address 10.1.1.1 port 2000

load 7941 term41.default<<<<<<<<<(Incorrect)

max-conferences 8 gain -6

transfer-system full-consult

create cnf-files version-stamp Jan 01 2002 00:00:00

••      When   configuring the

load command for   IP phones such as the Cisco Unified IP Phone 7906G, 7911G, 7941G, 7941GE,   7961G, 7961GE, 7970G, and 7971G, configure only the filenames that are marked   with an asterisk (*) in the table below.

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/requirements/guide/cme86spc.htm.html

Regards,

Kevin

23 REPLIES

Cisco 7941 Not Registering in CME 8.6

Hi,

can you please post the relevant config from your router? The section starting "telephony-service" would do.

Thanks.

G.

New Member

Cisco 7941 Not Registering in CME 8.6

Hi

Here's the config file off my CME router:

CME(config-telephony)#do sh run

Building configuration...

Current configuration : 1396 bytes

!

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname CME

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

!

!

dot11 syslog

ip source-route

!

!

ip cef

!

ip dhcp excluded-address 10.1.1.1 10.1.1.10

!

ip dhcp pool Voice_Pool

network 10.1.1.0 255.255.255.0

option 150 ip 10.1.1.1

default-router 10.1.1.1

!

!

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

!

!

!

voice-card 0

!

crypto pki token default removal timeout 0

!

!

!

!

license udi pid CISCO2811 sn FHK1213F09D

!

redundancy

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.10

encapsulation dot1Q 10

ip address 10.1.1.1 255.255.255.0

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

!

!

!

!

!

!

!

control-plane

!

!

!

!

mgcp profile default

!

!

!

!

!

telephony-service

max-ephones 5

max-dn 5

ip source-address 10.1.1.1 port 2000

max-conferences 8 gain -6

transfer-system full-consult

create cnf-files version-stamp Jan 01 2002 00:00:00

!

!

ephone-dn  1

number 1000

!

!

ephone  1

device-security-mode none

mac-address 0017.9406.FD55

button  1:1

!

!

!

!

line con 0

line aux 0

line vty 0 4

login

transport input all

!

scheduler allocate 20000 1000

end

CME(config-telephony)#

Cisco 7941 Not Registering in CME 8.6

Hi,

try specifying the type of the phone under the ephone section. Then under telephony-service, do no create cnf and again create cnf.

G.

New Member

Cisco 7941 Not Registering in CME 8.6

Hi Gergely

I tried it and now I am getting different messages plus the previous additional by issuing debug TFTP events.

TFTP: Looking for English_United_States/mk-sccp.jar

TFTP: Looking for United_States/g3-tones.xml

Under status messages in the phone I get 'Error Updating Locale' under phone status messages.

Thanks.

Cisco 7941 Not Registering in CME 8.6

Hi,

do you remember whether this phone has been connected to a CUCM, perhaps?

It may have an ITL (Initial Trust List) configured preventing connetion to CME.

Try

Settings > Security > Trust List > ITL File > **# (to unlock the settings) > Erase

G.

New Member

Cisco 7941 Not Registering in CME 8.6

Under ITL File it says 'Not Installed'. And the same Above it under CTL File it says 'Not Installed'. Thanks.

Cisco 7941 Not Registering in CME 8.6

Can you double check the type of your phone? Is it 7941G or 7941G-GE?

New Member

Cisco 7941 Not Registering in CME 8.6

Hi Gergely,

It is 7941G. Thanks.

New Member

Cisco 7941 Not Registering in CME 8.6

Not sure as to why am I not able to register the phone. Thanks.

New Member

Cisco 7941 Not Registering in CME 8.6

Sorry I mistakenly copied everything. Cheers for looking into it sir

Bronze

Cisco 7941 Not Registering in CME 8.6

Do you have any registred phones on your Router?

I thin you have just installed the IOS and nothing else.

If this assumption is correct, download the correct tar file at:

http://software.cisco.com/download/release.html?mdfid=277641082&catid=278875240&softwareid=282786567&release=10.0&relind=AVAILABLE&rellifecycle=&reltype=latest

you will then have to upload this file via the "archive tar /xtract" command

After this step all Firmwares are on your router.

But you will have to change your config a little bit more.

check the readme which is probably included in your router for full details.

In short you will have to add something like this: (of course you have to replace the firmwarefiles with your own and be sure to correct the path)

telephony-service

load 7941 TERM41.7-0-3-0S

tftp-server flash:/phone/apps41.8-2-2TR2.sbn alias apps41.8-2-2TR2.sbn

tftp-server flash:/phone/cnu41.8-2-2TR2.sbn alias cnu41.8-2-2TR2.sbn

tftp-server flash:/phone/cvm41sccp.8-2-2TR2.sbn alias cvm41sccp.8-2-2TR2.sbn

tftp-server flash:/phone/dsp41.8-2-2TR2.sbn alias dsp41.8-2-2TR2.sbn

tftp-server flash:/phone/jar41sccp.8-2-2TR2.sbn alias jar41sccp.8-2-2TR2.sbn

tftp-server flash:/phone/SCCP41.8-2-2SR2S.loads alias SCCP41.8-2-2SR2S.loads

tftp-server flash:/phone/term41.default.loads alias term41.default.loads

cheers

New Member

Cisco 7941 Not Registering in CME 8.6

Hi Slashdots,

Yes, when I do show flash only thing it shows is the ios image of the router. Thanks.

New Member

Cisco 7941 Not Registering in CME 8.6

Hi Slashdots,

I did exactly what you told me to. The phone upgrades with the firmware upon reset fine. But after when it returns to its normal screen again keeps saying registering. The debug tftp events, debug ephone register commands displays the following output (while the phone keeps saying registering at this stage) :

Router(config)#

*Feb 10 22:40:23.647: TFTP: Looking for CTLSEP00179406FD55.tlv

*Feb 10 22:40:23.803: TFTP: Looking for ITLSEP00179406FD55.tlv

*Feb 10 22:40:23.983: TFTP: Looking for ITLFile.tlv

*Feb 10 22:40:24.359: TFTP: Looking for SEP00179406FD55.cnf.xml

*Feb 10 22:40:24.363: TFTP: Opened system:/its/vrf1/XMLDefault7941.cnf.xml, fd 10, size 1254 for process 386

*Feb 10 22:40:24.367: TFTP: Finished system:/its/vrf1/XMLDefault7941.cnf.xml, time 00:00:00 for process 386

Thanks

Cisco 7941 Not Registering in CME 8.6

Hi Aditya,

I think you are missing these two files:

TFTP: Looking for English_United_States/mk-sccp.jar

TFTP: Looking for United_States/g3-tones.xml

Download the same from the this link below, CME locale 8.6:


http://software.cisco.com/download/release.html?mdfid=277641082&softwareid=282897001&release=10.0&relind=AVAILABLE&rellifecycle=&reltype=latest

Regards,

Kevin

New Member

Re:Cisco 7941 Not Registering in CME 8.6

Hi Kevin

Yes, I was missing it before but I managed to solve it by doing exactly what you've said above. However, even after the phone finishes downloading firmware successfully it is stuck in 'registering' with the above mentioned 'debug' messages, one that I have mentioned in my last reply. What I mean is that its not getting the config files like directory number etc. Is it something to do with CME 8.6 and phone firmware compatibility? Thanks.


Sent from Cisco Technical Support Android App

Re:Cisco 7941 Not Registering in CME 8.6

Hi Aditya,

Well just take the debug TFTP again, if you dont mind.

Regards,

Kevin

New Member

Re:Cisco 7941 Not Registering in CME 8.6

Hers is my updated config file:

Router#sh run
Building configuration...


Current configuration : 1936 bytes
!
! Last configuration change at 22:52:50 UTC Mon Feb 10 2014
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
dot11 syslog
ip source-route
!
!
ip cef
!
ip dhcp excluded-address 10.1.1.1 10.1.1.10
!
ip dhcp pool VOICE
network 10.1.1.0 255.255.255.0
default-router 10.1.1.1
option 150 ip 10.1.1.1
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2811 sn FHK1213F09D
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 10.1.1.1 255.255.255.0
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
tftp-server flash:SCCP41.9-3-1SR2-1S.loads
tftp-server flash:cnu41.9-3-1ES13.sbn
tftp-server flash:cvm41sccp.9-3-1ES13.sbn
tftp-server flash:dsp41.9-3-1ES13.sbn
tftp-server flash:jar41sccp.9-3-1ES13.sbn
tftp-server flash:term41.default.loads
tftp-server flash:apps41.9-3-1ES13.sbn
tftp-server flash:mk-sccp.jar alias English_United_States/mk-sccp.jar
tftp-server flash:g3-tones.xml alias United_States/g3-tones.xml
!
control-plane
!
!
!
!
mgcp profile default
!
!
!
!
!
telephony-service
max-ephones 5
max-dn 5
ip source-address 10.1.1.1 port 2000
load 7941 term41.default
max-conferences 8 gain -6
transfer-system full-consult
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn 1
number 1000
!
!
ephone 1
device-security-mode none
mac-address 0017.9406.FD55
type 7941
button 1:1
!
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
end

Router#


Sent from Cisco Technical Support Android App

Cisco 7941 Not Registering in CME 8.6

Hi Aditya,

Try resetting the phone and capture the debug tftp events again.

Regards,

Kevin

Cisco 7941 Not Registering in CME 8.6

Hi Aditya,

You are missing the load command unde the telephony-service.

telephony-service

max-ephones 5

max-dn 5

ip source-address 10.1.1.1 port 2000

load 7941 term41.default<<<<<<<<<(Incorrect)

max-conferences 8 gain -6

transfer-system full-consult

create cnf-files version-stamp Jan 01 2002 00:00:00

••      When   configuring the

load command for   IP phones such as the Cisco Unified IP Phone 7906G, 7911G, 7941G, 7941GE,   7961G, 7961GE, 7970G, and 7971G, configure only the filenames that are marked   with an asterisk (*) in the table below.

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/requirements/guide/cme86spc.htm.html

Regards,

Kevin

Cisco 7941 Not Registering in CME 8.6

Hi Aditya,

This is compatible firmware for the 7941 as per the CME 8.6:

Kindly rate the post accordingly.

Regards,

Kevin

New Member

Re:Cisco 7941 Not Registering in CME 8.6

Hi Kevin

Thank you so much for enlightening me towards the right path. I was still getting this error after I issued the command under telephony service 'load 7941 sccp41.9-3-1SR2-1S.loads': LOAD COMMAND ERROR:cnf-file location system is not supported for creating automatic tftp bindings. Please use file location flash | slot0 | tftp OR create tftp bindings manually


But I manages to solve it by entering the command 'cnf-file location flash:'. Thanks to this link.

http://pandaeatsbamboo.blogspot.co.uk/2010/03/create-tftp-bindings-for-phone-firmware.html

Thanks everyone.

Bronze

Re:Cisco 7941 Not Registering in CME 8.6

Have you entered the command "create cnf files" under "telephony-service" after you created your ephone?


Sent from Cisco Technical Support Android App

New Member

Re:Cisco 7941 Not Registering in CME 8.6

Hi Slashdots,

I managed to solve it. Check my previous post. Yes I did have the command 'create cnf-file' entered prior to your post. Thanks a tons though.

1191
Views
7
Helpful
23
Replies
CreatePlease to create content