Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 7960 SIP Phones are registered with CME but its not accepting proxy server IP address.

Hi, 

Cisco 7960 Sip phones are registered with CME on Cisco 2911 Router. But if I try to register ip phones with sip proxy server it is not accepting  proxy ip address. As it it using 'Usecallmanager' for registering phones. When I try to change ip setting in SIPDefault.cnf. It automatically revert back to Usecallmanager for registering phones. 

Can Anyone suggest solution please so that I could register phones with sip proxy server ip.  


CME#more SIPDefault.cnf
image_version: "P0S3-08-9-00";
call_manager1_addr: "10.15.1.1";
call_manager2_addr: "";
call_manager3_addr: "";
call_manager4_addr: "";
call_manager1_sip_port: "5060";
call_manager2_sip_port: "";
call_manager3_sip_port: "";
call_manager4_sip_port: "";
proxy1_address: "USECALLMANAGER";
proxy2_address: "";
proxy3_address: "";
proxy4_address: "";
proxy5_address: "";
proxy6_address: "";
proxy1_port: "5060";
proxy2_port: "";
proxy3_port: "";
proxy4_port: "";
proxy5_port: "";
proxy6_port: "";
proxy_register: "1";
time_zone: "PST";
dst_auto_adjust: "1";
 dst_start_month: "April";
dst_start_day: "";
dst_start_day_of_week: "Sun";
dst_start_week_of_month: "1";
dst_start_time: "02:00";
dst_stop_month: "October";
dst_stop_day: "";
dst_stop_day_of_week: "Sun";
dst_stop_week_of_month: "8";
dst_stop_time: "02:00";
date_format: "M/D/Y";
time_format_24hr: "0";
local_cfwd_enable: "1";
directory_url: "";
messages_uri: "";
services_url: "http://10.15.1.1:80/CMEserverForPhone/serviceurl";
logo_url: "";
stutter_msg_waiting: "0";
sync: "0004723960543944";
telnet_level: "0";
autocomplete: "1";
call_stats: "0";
Domain_Name: "";
dtmf_avt_payload: "101";
 --More--         dtmf_db_level: "3";
dtmf_inband: "1";
dtmf_outofband: "avt";
dyn_dns_addr_1: "";
dyn_dns_addr_2: "";
dyn_tftp_addr: "";
end_media_port: "32766";
http_proxy_addr: "";
http_proxy_port: "80";
nat_address: "";
nat_enable: "0";
nat_received_processing: "0";
network_port2_type: "Hub/Switch";
 

CME#sh voice register global
CONFIG [Version=8.6]
========================
  Version 8.6
  Mode is cme
  Max-pool is 10
  Max-dn is 20
  Outbound-proxy is enabled and will use global configured value
  Security Policy: DEVICE-DEFAULT
  Forced Authorization Code Refer is enabled
  Source-address is 10.15.1.1 port 5060
  Load 7960-40 is P0S3-08-9-00
  Authenticate register
  Authenticate realm all
  Time-format is 12
  Date-format is M/D/Y
  Time-zone is 5
  Hold-alert is disabled
  Mwi stutter is disabled
  Mwi registration for full E.164 is disabled
  Forwarding local is enabled
  Video is disabled
  Camera is disabled
  Privacy is enabled
  Privacy-on-hold is disabled
  Dst auto adjust is enabled
    start at Apr week 1 day Sun time 02:00
    stop  at Oct week 8 day Sun time 02:00
  Call List BLF is enabled

  Max redirect number is 5
  IP QoS DSCP:
    ef (the MS 6 bits, 46, in ToS, 0xB8) for media
    cs3 (the MS 6 bits, 24, in ToS, 0x60) for signal
    af41 (the MS 6 bits, 34, in ToS, 0x88) for video
    default (the MS 6 bits, 0, in ToS, 0x0) for service
  Telnet Level: 0
  Tftp path is flash:
  Generate text file is disabled
  Tftp files are created, current syncinfo 0004723960543944
   timeout interdigit 10
  network-locale[0] GB    (This is the default network locale for this box)
  network-locale[1] GB 
  network-locale[2] GB 
  network-locale[3] US 
  network-locale[4] US 
  user-locale[0] US    (This is the default user locale for this box)
  user-locale[1] US 
  user-locale[2] US 
  user-locale[3] US 
  user-locale[4] US   Active registrations  : 3

  Total SIP phones registered: 3
  Total Registration Statistics
    Registration requests  : 6
    Registration success   : 3
    Registration failed    : 3
    unRegister requests    : 0
    unRegister success     : 0
    unRegister failed      : 0
    Attempts to register 
           after last unregister : 0 
    Last register request time   : 21:32:05.035 UTC Tue Aug 19 2014 
    Last unregister request time : 
    Register success time        : 21:32:05.039 UTC Tue Aug 19 2014 
    Unregister success time      : 


CME#sh voice register pool all
 Pool Tag 1
Config:
  Mac address is 0003.6B54.BCD9
  Type is 7960
  Number list 1 : DN 1
  Proxy Ip address is 0.0.0.0
  Current Phone load version is Cisco-CP7960G/8.0
  DTMF Relay is enabled, sip-notify
  Call Waiting is disabled
  DnD is disabled
  Video is disabled
  Camera is disabled
  Busy trigger per button value is 0
  keep-conference is enabled
  registration expires timer max is 3600 and min is 3600
  username 5000 password 123abc!
  Lpcor Type is none

  Transport type is udp
  service-control mechanism is supported
  registration Call ID is 00036b54-bcd90002-7d9c5274-07362b91@10.15.1.11 
  Registration method: per line
  Privacy feature is not configured.
  Privacy button is disabled
  active primary line is: 5000

  contact IP address: 10.15.1.11 port 5060


Dialpeers created:

Dial-peers for Pool 1:

dial-peer voice 40002 voip
 destination-pattern 5000
 session target ipv4:10.15.1.11:5060
 session protocol sipv2
 dtmf-relay sip-notify
 codec  g711ulaw bytes 160
  call-fwd-busy        5002           
  after-hours-exempt   FALSE          

Statistics:
  Active registrations  : 1

  Total SIP phones registered: 3
  Total Registration Statistics
    Registration requests  : 1
    Registration success   : 1
    Registration failed    : 0
    unRegister requests    : 0
    unRegister success     : 0
    unRegister failed      : 0
    Attempts to register 
           after last unregister : 0 
    Last register request time   : 21:31:57.883 UTC Tue Aug 19 2014 
    Last unregister request time : 
    Register success time        : 21:31:57.887 UTC Tue Aug 19 2014 
    Unregister success time      : 


 Pool Tag 3
Config:
  Mac address is 0002.B9AF.C0F7
  Type is 7960
  Number list 1 : DN 3
  Proxy Ip address is 0.0.0.0
  Current Phone load version is Cisco-CP7960G/8.0
  DTMF Relay is enabled, sip-notify
  Call Waiting is disabled
  DnD is disabled
  Video is disabled
  Camera is disabled
  Busy trigger per button value is 0
  keep-conference is enabled
  registration expires timer max is 3600 and min is 3600
  username 5002 password 123abc!
  Lpcor Type is none

  Transport type is udp
  service-control mechanism is supported
  registration Call ID is 0002b9af-c0f70002-65fcb4a6-2907265f@10.15.1.12 
  Registration method: per line
  Privacy feature is not configured.
  Privacy button is disabled
  active primary line is: 5002

  contact IP address: 10.15.1.12 port 5060


Dialpeers created:

Dial-peers for Pool 3:

dial-peer voice 40001 voip
 destination-pattern 5002
 session target ipv4:10.15.1.12:5060
 session protocol sipv2
 dtmf-relay sip-notify
 codec  g711ulaw bytes 160
  call-fwd-busy        5003           
  after-hours-exempt   FALSE          

Statistics:
  Active registrations  : 1

  Total SIP phones registered: 3
  Total Registration Statistics
    Registration requests  : 1
    Registration success   : 1
    Registration failed    : 0
    unRegister requests    : 0
    unRegister success     : 0
    unRegister failed      : 0
    Attempts to register 
           after last unregister : 0 
    Last register request time   : 21:31:55.803 UTC Tue Aug 19 2014 
    Last unregister request time : 
    Register success time        : 21:31:55.803 UTC Tue Aug 19 2014 
    Unregister success time      : 


 Pool Tag 4
Config:
  Mac address is 0003.6B75.A91C
  Type is 7960
  Number list 1 : DN 4
  Proxy Ip address is 0.0.0.0
  Current Phone load version is Cisco-CP7960G/8.0
  DTMF Relay is enabled, sip-notify
  Call Waiting is disabled
  DnD is disabled
  Video is disabled
  Camera is disabled
  Busy trigger per button value is 0
  keep-conference is enabled
  registration expires timer max is 3600 and min is 3600
  username 5003 password 123abc!
  Lpcor Type is none

  Transport type is udp
  service-control mechanism is supported
  registration Call ID is 00036b75-a91c0002-7bab3ba2-4437ee75@10.15.1.13 
  Registration method: per line
  Privacy feature is not configured.
  Privacy button is disabled
  active primary line is: 5003

  contact IP address: 10.15.1.13 port 5060


Dialpeers created:

Dial-peers for Pool 4:

dial-peer voice 40003 voip
 destination-pattern 5003
 session target ipv4:10.15.1.13:5060
 session protocol sipv2
 dtmf-relay sip-notify
 codec  g711ulaw bytes 160
  call-fwd-busy        5000           
  after-hours-exempt   FALSE          

Statistics:
  Active registrations  : 1

  Total SIP phones registered: 3
  Total Registration Statistics
    Registration requests  : 1
    Registration success   : 1
    Registration failed    : 0
    unRegister requests    : 0
    unRegister success     : 0
    unRegister failed      : 0
    Attempts to register 
           after last unregister : 0 
    Last register request time   : 21:32:05.035 UTC Tue Aug 19 2014 
    Last unregister request time : 
    Register success time        : 21:32:05.039 UTC Tue Aug 19 2014 
    Unregister success time      : 


I do welcome any suggestion from anyone. 

 

Regards

  • IP Telephony
13 REPLIES
New Member

 Hi,      What is the

 

Hi,

      What is the firmware files has the IP Phone been loaded with? Make sure you use SIP based firmwares for the IP Phones.

 

 

Thankyou

      PC

New Member

This is running SIP firmware

This is running SIP firmware on all Cisco ip phones. All phones are registered as SIP using voice register global command. Regards

What do you mean by SIP proxy

What do you mean by SIP proxy server here ? Do you want SIP phone to register with other sip proxy server but not with CME SIP ?

If yes when you change IP adress on phone to point it to a new proxy server other that CME , what error do you get ? Have enable packet capture on Phone lan interface to see where register request are going and also on SIP proxy server do you receive any request from phone?

New Member

Hi Manish,Yes i would like to

Hi Manish,

Yes i would like to register with sip proxy server. following errors come when i try to change proxy server address on pools.

CME(config-register-pool)#voice register pool 1
CME(config-register-pool)#proxy 122.163.54.175
Failed: CME mode!
CME(config-register-pool)#voice register pool 2
CME(config-register-pool)#proxy 122.163.54.175
Failed: CME mode!

if I try to remove cme mode by enabling 'no mode cme' in 'voice register global' mode then it removes the option of configuring proxy address on phones under 'voice register pool' command. 

Regards

 

 

If you want 7960 to register

If you want 7960 to register with other proxy server , then change its tftp ip to 122.163.54.175 from the physical phone itself not from CME.

Here is the link.

New Member

Hi,its too difficult to

Hi,

its too difficult to change tftp server server on phone. Its not giving option to edit on phone even I follow the unlocking steps. I can edit all other configuration sip proxy server from phone, sip line setting etc but can not change network configuration. Its taking network configuration  frorm DHCP of router.

once I restart phone all configurations are revert back to same.

Regards

 

Change option 150 ip under

Change option 150 ip under dhcp pool to global ip.

New Member

Hi,Still not able to register

Hi,

Still not able to register with sip proxy server. please find show run output below.  

 

Building configuration...


Current configuration : 10145 bytes
!
! Last configuration change at 18:10:04 UTC Thu Aug 21 2014
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RedoQCME
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
network-clock-participate wic 0 
!
no ipv6 cef
ip source-route
ip cef
!
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.1.1 10.10.1.10
ip dhcp excluded-address 10.15.1.1 10.15.1.10
!
ip dhcp pool DATA
 network 10.10.1.0 255.255.255.0
 default-router 10.10.1.1 
!
ip dhcp pool VOICE
 network 10.15.1.0 255.255.255.0
 default-router 10.15.1.1 
 option 150 ip 122.163.33.51 
!
!
no ip domain lookup
ip name-server 78.143.192.10
ip name-server 78.143.192.20
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type basic-net3
!
!
trunk group ext
!
crypto pki token default removal timeout 0
!
!
voice-card 0
 codec complexity high
!
!
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 h323
  h225 timeout ntf 500
  call preserve 
  h245 caps mode restricted
 modem passthrough nse codec g711ulaw
 sip
  bind control source-interface GigabitEthernet0/1.15
  bind media source-interface GigabitEthernet0/1.15
  registrar server expires max 3600 min 3600
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g711alaw
 codec preference 3 g729r8
!
voice class h323 1
  h225 timeout tcp establish 3
!
!
voice register global
 mode cme
 source-address 10.15.1.1 port 5060
 max-dn 20
 max-pool 10
 load 7960-7940 P0S3-08-9-00
 authenticate register
 authenticate realm all
 call-forward system redirecting-expanded
 tftp-path flash:
 create profile sync 0004723960543943
 network-locale GB
 network-locale 1 GB
 network-locale 2 GB
!
voice register dn  1
 number 5000
 call-forward b2bua busy 5002  
 allow watch
 name SIP 1
!
voice register dn  3
 number 5002
 call-forward b2bua busy 5003  
 allow watch
 name SIP 3
!
voice register dn  4
 number 5003
 call-forward b2bua busy 5000  
 allow watch
 name SIP 4
!
voice register pool  1
 id mac 0003.6B54.BCD9
 type 7960
 number 1 dn 1
 dtmf-relay sip-notify
 username 5000 password 123abc!
 no call-waiting
 codec g711ulaw
!
voice register pool  3
 id mac 0002.B9AF.C0F7
 type 7960
 number 1 dn 3
 dtmf-relay sip-notify
 username 5002 password 123abc!
 no call-waiting
 codec g711ulaw
!
voice register pool  4
 id mac 0003.6B75.A91C
 type 7960
 number 1 dn 4
 dtmf-relay sip-notify
 username 5003 password 123abc!
 no call-waiting
 codec g711ulaw
!
voice hunt-group 1 sequential
 final 5003
 list 5000,5002
 timeout 20 
 pilot 5900 
!
!
!
!
!
license udi pid CISCO2911/K9 sn FCZ163379BR
license boot module c2900 technology-package securityk9
license boot module c2900 technology-package uck9
license boot module c2900 technology-package datak9
hw-module pvdm 0/0
!
!
!
username redoq privilege 15 secret 4 RItztkF0kItnl6GrGfyp9UBfMwc6PeNSfVkMYePCEkY
!
redundancy
!
!
!
!
controller VDSL 0/1/0
!

!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip address 1.1.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.1
 encapsulation dot1Q 1
 ip address 10.1.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface GigabitEthernet0/1.10
 encapsulation dot1Q 10 native
 ip address 10.10.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface GigabitEthernet0/1.15
 encapsulation dot1Q 15
 ip address 10.15.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface BRI0/0/0
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
 isdn incoming-voice voice
 isdn calling-number RedoQ
 isdn supp-service name calling
 isdn static-tei 0
!
interface BRI0/0/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
 isdn incoming-voice voice
 isdn supp-service name calling
 isdn static-tei 0
!
interface ATM0/1/0
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no atm ilmi-keepalive
 pvc 0/38 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface Ethernet0/1/0
 no ip address
 no fair-queue
!
interface Dialer0
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname xxxxxxxxxxxxxxxx
 ppp chap password 0 redoqinfinity1
 no cdp enable
!
!
!
router eigrp 100
 network 10.0.0.0
!
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 36000 requests 10000
ip http path flash:
!
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source list 2 interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
!
access-list 1 permit 1.0.0.0 0.255.255.255
access-list 2 permit 10.0.0.0 0.255.255.255
!
!
!
!
!
tftp-server flash:OS79XX.txt
tftp-server flash:P003-08-9-00.bin
tftp-server flash:P003-08-9-00.sbn
tftp-server flash:P0S3-08-9-00.loads
tftp-server flash:P0S3-08-9-00.sb2
!
control-plane
!
!
voice-port 0/0/0
 input gain 4
 compand-type a-law
 cptone GB
 timeouts call-disconnect 5
 timeouts wait-release 5
 connection plar 5900
 bearer-cap Speech
!
voice-port 0/0/1
 input gain 4
 compand-type a-law
 cptone GB
 timeouts call-disconnect 5
 timeouts wait-release 5
 connection plar 5900
 bearer-cap Speech
!
voice-port 0/2/0
 supervisory disconnect dualtone pre-connect
 supervisory answer dualtone sensitivity high
 no battery-reversal
 soft-offhook
 input gain 4
 cptone GB
 timeouts call-disconnect 5
 timeouts wait-release 5
 connection plar opx 5000
 impedance complex2
 bearer-cap Speech
 caller-id enable
!
voice-port 0/2/1
 supervisory disconnect dualtone pre-connect
 supervisory answer dualtone sensitivity high
 no battery-reversal
 soft-offhook
 input gain 4
 cptone GB
 timeouts call-disconnect 5
 timeouts wait-release 5
 connection plar opx 5000
 impedance complex2
 bearer-cap Speech
 caller-id enable
!
!
!
mgcp profile default
!
!
dial-peer voice 1 pots
 description *** emergency 999 ***
 destination-pattern 999
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 port 0/0/0
 forward-digits all
!
dial-peer voice 3 pots
 description ** E1 PRI pots dial-peer **
 destination-pattern 07412626634
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 incoming called-number .
 no digit-strip
 direct-inward-dial
 port 0/0/0
!
dial-peer voice 11 pots
 description *** emergency 999 ***
 destination-pattern 999
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 port 0/0/1
 forward-digits all
!
dial-peer voice 31 pots
 description ** E1 PRI pots dial-peer **
 destination-pattern 07412626634
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 incoming called-number .
 no digit-strip
 direct-inward-dial
 port 0/0/1
!
dial-peer voice 100 pots
 description *** Services ***
 destination-pattern 0[1-6]T
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 no digit-strip
 port 0/0/0
!
dial-peer voice 101 pots
 description *** Services ***
 destination-pattern 0[1-6]T
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 no digit-strip
 port 0/0/1
!
dial-peer voice 5999 voip
 description ** cue voicemail pilot number **
 destination-pattern 5999
 session protocol sipv2
 session target ipv4:10.15.1.2
 dtmf-relay sip-notify
 codec g711ulaw
!
dial-peer voice 9281 pots
 destination-pattern [2-8].....
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 no digit-strip
 port 0/0/1
!
dial-peer voice 9282 pots
 destination-pattern [2-8].....
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 no digit-strip
 port 0/0/0
!
dial-peer voice 800 pots
 description *** Customer Care Services ***
 destination-pattern 08.........
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 no digit-strip
 port 0/0/0
!
dial-peer voice 801 pots
 description *** Customer Care Services Services ***
 destination-pattern 08.........
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 no digit-strip
 port 0/0/1
!
dial-peer voice 1000 voip
 destination-pattern 5...
 session protocol sipv2
 session target ipv4:10.15.1.1
 dtmf-relay sip-notify
 codec g711ulaw
!
dial-peer voice 2001 voip
 destination-pattern 5...
 session protocol sipv2
 session target ipv4:10.15.1.11:5060
 dtmf-relay sip-notify
 codec g711ulaw
!
dial-peer voice 2002 voip
 destination-pattern 5...
 session protocol sipv2
 session target ipv4:10.15.1.1:5060
 dtmf-relay sip-notify
 codec g711ulaw
!
dial-peer voice 2003 voip
 destination-pattern 5...
 session protocol sipv2
 session target ipv4:10.15.1.12:5060
 dtmf-relay sip-notify
 codec g711ulaw
!
dial-peer voice 2004 voip
 destination-pattern 5...
 session protocol sipv2
 session target ipv4:10.15.1.13:5060
 dtmf-relay sip-notify
 codec g711ulaw
!
!
presence
 presence call-list
!
sip-ua 
 no remote-party-id
 retry invite 3
 retry register 3
 registrar ipv4:122.163.33.51 expires 3600
 sip-server ipv4:122.163.33.51
 host-registrar
!
!
!
gatekeeper
 shutdown
!
!
!
line con 0
 password

 login
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 password redoq123
 logging synchronous
 login local
 transport input all
 transport output all
!
scheduler allocate 20000 1000
ntp server 85.119.80.232
end

Regards

New Member

Manish,I have got success to

Manish,

I have got success to change tftp ip (network config)and proxy ip (sip line config) in ip phones only. I can receive calls on extensions from local trunk on router but not able to make calls on any extensions or outside network. it is showing CALLING ( OUT INV) on the phone. The status message on the phone are available in the image attached here. 

It will really be helpful if you find any clue with these.

 

Regards

 

709
Views
4
Helpful
13
Replies
This widget could not be displayed.