Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco 7960 SIP Phones are registered with CME but not able to make internal calls on LAN extensions.

I have 3 Cisco 7960 IP Phones registered  with Call Manager Express on Cisco 2911 Router. Router is using ISDN lines as trunk. All phones are registered with CME properly. the extensions are 5000, 5001, 5002. All incoming calls are working fine. Incoming calls are able to manage calls on extensions according hunt group defined. But I am not able to make call outside or inside on local extension from one phone to another. Its making engage tone.

All phones have sip firmware right now. All phones worked fine on SCCP firmware. No phones are registered with sip server provider right now

Do I need to register all sip phones with SIP provider (registrar server) for making  calls internally? Or dial-peer would be more than enough to make it work. 

 

Any type of suggestion and comments are most welcome. 

 

Regards

RUNNING COFIGURATION:- 

hostname RedoqCME
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
network-clock-participate wic 0 
!
no ipv6 cef
ip source-route
ip cef
!
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.1.1 10.10.1.10
ip dhcp excluded-address 10.15.1.1 10.15.1.10
!
ip dhcp pool DATA
 network 10.10.1.0 255.255.255.0
 default-router 10.10.1.1 
!
ip dhcp pool VOICE
 network 10.15.1.0 255.255.255.0
 default-router 10.15.1.1 
 option 150 ip 10.15.1.1 
!
!
no ip domain lookup
ip name-server 78.143.192.10
ip name-server 78.143.192.20
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type basic-net3
!
!
trunk group ext
!
crypto pki token default removal timeout 0
!
!
voice-card 0
 codec complexity high
!
!
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 h323
  h225 timeout ntf 500
  call preserve 
  h245 caps mode restricted
 modem passthrough nse codec g711ulaw
 sip
  bind control source-interface GigabitEthernet0/1.15
  bind media source-interface GigabitEthernet0/1.15
  registrar server
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g711alaw
 codec preference 3 g729r8
!
voice class h323 1
  h225 timeout tcp establish 3
!
!
voice register global
 mode cme
 source-address 10.15.1.1 port 5060
 max-dn 20
 max-pool 10
 load 7960-7940 P0S3-08-9-00
 authenticate register
 authenticate realm all
 call-forward system redirecting-expanded
 tftp-path flash:
 create profile sync 0001643292548154
 network-locale GB
 network-locale 1 GB
 network-locale 2 GB
!
voice register dn  1
 number 5000
 name SIP 1
 shared-line
!
voice register dn  2
 number 5001
 allow watch
 name SIP 2
!
voice register dn  3
 number 5002
 allow watch
 name SIP 3
!
voice register dn  4
 number 5003
 allow watch
 name SIP 4
!
voice register dialplan 1
 type 7940-7960-others
 pattern 1 5000
!
voice register dialplan 2
 type 7940-7960-others
 pattern 1 5001
!
voice register dialplan 3
 type 7940-7960-others
 pattern 1 5002
!
voice register dialplan 4
 type 7940-7960-others
 pattern 1 5003
!
voice register pool  1
 id mac 0003.6B54.BCD9
 type 7960
 number 1 dn 1
 dialplan 1
 presence call-list
 username redoq password redoq123
 codec g711ulaw
!
voice register pool  2
 id mac 0030.94C4.5009
 type 7960
 number 1 dn 2
 dialplan 2
 username redoq1 password redoq123
!
voice register pool  3
 id mac 0002.B9AF.C0F7
 type 7960
 number 1 dn 3
 dialplan 3
 username redoq2 password redoq123
!
voice register pool  4
 id mac 0003.6B75.A91C
 type 7960
 number 1 dn 4
 dialplan 4
 username redoq3 password redoq123
!
voice hunt-group 1 sequential
 final 5003
 list 5000,5001,5002
 timeout 20 
 pilot 5900 
!
!
!
!
!
license udi pid CISCO2911/K9 
license boot module c2900 technology-package securityk9
license boot module c2900 technology-package uck9
license boot module c2900 technology-package datak9
hw-module pvdm 0/0
!
!
!
username redoq privilege 15 secret 4 <removed>
!
redundancy
!
!
!
!
controller VDSL 0/1/0
!

!
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip address 1.1.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.1
 encapsulation dot1Q 1
 ip address 10.1.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface GigabitEthernet0/1.10
 encapsulation dot1Q 10 native
 ip address 10.10.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface GigabitEthernet0/1.15
 encapsulation dot1Q 15
 ip address 10.15.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface BRI0/0/0
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
 isdn incoming-voice voice
 isdn calling-number RedoQ
 isdn supp-service name calling
 isdn static-tei 0
!
interface BRI0/0/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
 isdn incoming-voice voice
 isdn supp-service name calling
 isdn static-tei 0
!
interface ATM0/1/0
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no atm ilmi-keepalive
 pvc 0/38 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface Ethernet0/1/0
 no ip address
 no fair-queue
!
interface Dialer0
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname D466314@hg70.btclick.com
 ppp chap password 0 redoqinfinity1
 no cdp enable
!
!
!
router eigrp 100
 network 10.0.0.0
!
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 36000 requests 10000
ip http path flash:gui
!
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source list 2 interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
!
access-list 1 permit 1.0.0.0 0.255.255.255
access-list 2 permit 10.0.0.0 0.255.255.255
!
!
!
!
!
tftp-server flash:OS79XX.txt
tftp-server flash:P003-08-9-00.bin
tftp-server flash:P003-08-9-00.sbn
tftp-server flash:P0S3-08-9-00.loads
tftp-server flash:P0S3-08-9-00.sb2
!
control-plane
!
!
voice-port 0/0/0
 input gain 4
 compand-type a-law
 cptone GB
 timeouts call-disconnect 5
 timeouts wait-release 5
 connection plar 5900
 bearer-cap Speech
!
voice-port 0/0/1
 input gain 4
 compand-type a-law
 cptone GB
 timeouts call-disconnect 5
 timeouts wait-release 5
 connection plar 5900
 bearer-cap Speech
!
voice-port 0/2/0
 supervisory disconnect dualtone pre-connect
 supervisory answer dualtone sensitivity high
 no battery-reversal
 soft-offhook
 input gain 4
 cptone GB
 timeouts call-disconnect 5
 timeouts wait-release 5
 connection plar opx 5000
 impedance complex2
 bearer-cap Speech
 caller-id enable
!
voice-port 0/2/1
 supervisory disconnect dualtone pre-connect
 supervisory answer dualtone sensitivity high
 no battery-reversal
 soft-offhook
 input gain 4
 cptone GB
 timeouts call-disconnect 5
 timeouts wait-release 5
 connection plar opx 5000
 impedance complex2
 bearer-cap Speech
 caller-id enable
!
!
!
mgcp profile default
!
!
dial-peer voice 1 pots
 description *** emergency 999 ***
 destination-pattern 999
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 port 0/0/0
 forward-digits all
!
dial-peer voice 3 pots
 description ** E1 PRI pots dial-peer **
 destination-pattern 074........
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 incoming called-number .
 no digit-strip
 direct-inward-dial
 port 0/0/0
!
dial-peer voice 11 pots
 description *** emergency 999 ***
 destination-pattern 999
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 port 0/0/1
 forward-digits all
!
dial-peer voice 31 pots
 description ** E1 PRI pots dial-peer **
 destination-pattern 074........
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 incoming called-number .
 no digit-strip
 direct-inward-dial
 port 0/0/1
!
dial-peer voice 100 pots
 description *** Services ***
 destination-pattern 0[1-6]T
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 no digit-strip
 port 0/0/0
!
dial-peer voice 101 pots
 description *** Services ***
 destination-pattern 0[1-6]T
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 no digit-strip
 port 0/0/1
!
dial-peer voice 5999 voip
 description ** cue voicemail pilot number **
 destination-pattern 5999
 session protocol sipv2
 session target ipv4:10.15.1.2
 dtmf-relay sip-notify
 codec g711ulaw
!
dial-peer voice 9281 pots
 destination-pattern [2-8].....
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 no digit-strip
 port 0/0/1
!
dial-peer voice 9282 pots
 destination-pattern [2-8].....
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 no digit-strip
 port 0/0/0
!
dial-peer voice 800 pots
 description *** Customer Care Services ***
 destination-pattern 08.........
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 no digit-strip
 port 0/0/0
!
dial-peer voice 801 pots
 description *** Customer Care Services Services ***
 destination-pattern 08.........
 progress_ind setup enable 3
 progress_ind alert enable 8
 translate-outgoing called 10
 no digit-strip
 port 0/0/1
!
dial-peer voice 1000 voip
 destination-pattern 5...
 session target ipv4:10.15.1.1
!
!
presence
 presence call-list
!
sip-ua 
!
!
!
gatekeeper
 shutdown
!
!
!
line con 0
 password <removed>
 login
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 password <removed>
 logging synchronous
 login local
 transport input all
 transport output all
!
scheduler allocate 20000 1000
end


 

Everyone's tags (3)
5 REPLIES
New Member

Hi Anupam, Apply the Codec

Hi Anupam,

 

Apply the Codec g711ulaw in all the voice register pool.

 

You only applied in pool 1 now.

 

Try and let me know the update.

 

Regards

Nithin Louis.

New Member

Hi Nithin, Applied codec to

Hi Nithin, 

Applied codec to all other pools but same stuation. Still Not able to make call on other extention and not even making calls outside network using trunk line. all dial peers for trunk port alread created.

Following outputs may help you a bit.

 

Regards

 

voice register dn  1
 number 5000
 call-forward b2bua busy 5002  
 allow watch
 name SIP 1
!
voice register dn  3
 number 5002
 call-forward b2bua busy 5003  
 allow watch
 name SIP 3
!
voice register dn  4
 number 5003
 call-forward b2bua busy 5000  
 allow watch
 name SIP 4
!
voice register dialplan 1
 type 7940-7960-others
 pattern 1 5000
!
voice register dialplan 3
 type 7940-7960-others
 pattern 1 5002
!
voice register dialplan 4
 type 7940-7960-others
 pattern 1 5003
!
voice register pool  1
 id mac 0003.6B54.BCD9
 type 7960
 number 1 dn 1
 presence call-list
 dtmf-relay sip-notify
 username 5000 password 123abc!
 codec g711ulaw
!
voice register pool  3
 id mac 0002.B9AF.C0F7
 type 7960
 number 1 dn 3
 dtmf-relay sip-notify
 username 5002 password 123abc!
 codec g711ulaw
!
voice register pool  4
 id mac 0003.6B75.A91C
 type 7960
 number 1 dn 4
 dtmf-relay sip-notify
 username 5003 password 123abc!
 codec g711ulaw
!
voice hunt-group 1 sequential
 final 5003
 list 5000,5002
 timeout 20 
 pilot 5900 

 

 

CME#sh voice register pool all


 Pool Tag 1
Config:
  Mac address is 0003.6B54.BCD9
  Type is 7960
  Number list 1 : DN 1
  Proxy Ip address is 0.0.0.0
  Current Phone load version is Cisco-CP7960G/8.0
  DTMF Relay is enabled, sip-notify
  Call Waiting is enabled
  DnD is disabled
  Video is disabled
  Camera is disabled
  Busy trigger per button value is 0
  keep-conference is enabled
  registration expires timer max is 3600 and min is 60
  username 5000 password 123abc!
  Lpcor Type is none

  blf call list is enabled

  Transport type is udp
  service-control mechanism is supported
  registration Call ID is 00036b54-bcd90002-7d9c5274-07362b91@10.15.1.11 
  Registration method: per line
 --More--           Privacy feature is not configured.
  Privacy button is disabled
  active primary line is: 5000

  contact IP address: 10.15.1.11 port 5060


Dialpeers created:

Dial-peers for Pool 1:

dial-peer voice 40001 voip
 destination-pattern 5000
 session target ipv4:10.15.1.11:5060
 session protocol sipv2
 dtmf-relay sip-notify
 codec  g711ulaw bytes 160
  call-fwd-busy        5002           
  after-hours-exempt   FALSE          

Statistics:
  Active registrations  : 1

  Total SIP phones registered: 3
 --More--           Total Registration Statistics
    Registration requests  : 25
    Registration success   : 25
    Registration failed    : 0
    unRegister requests    : 24
    unRegister success     : 24
    unRegister failed      : 0
    Attempts to register 
           after last unregister : 0 
    Last register request time   : 16:22:10.186 UTC Sat Aug 16 2014 
    Last unregister request time : 17:20:13.113 UTC Sat Aug 16 2014 
    Register success time        : 16:22:10.186 UTC Sat Aug 16 2014 
    Unregister success time      : 17:20:13.114 UTC Sat Aug 16 2014 


 Pool Tag 3
Config:
  Mac address is 0002.B9AF.C0F7
  Type is 7960
  Number list 1 : DN 3
  Proxy Ip address is 0.0.0.0
  Current Phone load version is Cisco-CP7960G/8.0
  DTMF Relay is enabled, sip-notify
  Call Waiting is enabled
 --More--           DnD is disabled
  Video is disabled
  Camera is disabled
  Busy trigger per button value is 0
  keep-conference is enabled
  registration expires timer max is 3600 and min is 60
  username 5002 password 123abc!
  Lpcor Type is none

  Transport type is udp
  service-control mechanism is supported
  registration Call ID is 0002b9af-c0f70003-7edb53d0-39cd5992@10.15.1.12 
  Registration method: per line
  Privacy feature is not configured.
  Privacy button is disabled
  active primary line is: 5002

  contact IP address: 10.15.1.12 port 5060


Dialpeers created:

Dial-peers for Pool 3:

 --More--         dial-peer voice 40002 voip
 destination-pattern 5002
 session target ipv4:10.15.1.12:5060
 session protocol sipv2
 dtmf-relay sip-notify
 codec  g711ulaw bytes 160
  call-fwd-busy        5003           
  after-hours-exempt   FALSE          

Statistics:
  Active registrations  : 1

  Total SIP phones registered: 3
  Total Registration Statistics
    Registration requests  : 21
    Registration success   : 21
    Registration failed    : 0
    unRegister requests    : 20
    unRegister success     : 20
    unRegister failed      : 0
    Attempts to register 
           after last unregister : 0 
    Last register request time   : 16:43:26.184 UTC Fri Aug 15 2014 
    Last unregister request time : 16:43:22.736 UTC Fri Aug 15 2014 
 --More--             Register success time        : 16:43:26.184 UTC Fri Aug 15 2014 
    Unregister success time      : 16:43:22.737 UTC Fri Aug 15 2014 


 Pool Tag 4
Config:
  Mac address is 0003.6B75.A91C
  Type is 7960
  Number list 1 : DN 4
  Proxy Ip address is 0.0.0.0
  Current Phone load version is Cisco-CP7960G/8.0
  DTMF Relay is enabled, sip-notify
  Call Waiting is enabled
  DnD is disabled
  Video is disabled
  Camera is disabled
  Busy trigger per button value is 0
  keep-conference is enabled
  registration expires timer max is 3600 and min is 60
  username 5003 password 123abc!
  Lpcor Type is none

  Transport type is udp
  service-control mechanism is supported
 --More--           registration Call ID is 00036b75-a91c0003-7d75a05c-6945de3c@10.15.1.13 
  Registration method: per line
  Privacy feature is not configured.
  Privacy button is disabled
  active primary line is: 5003

  contact IP address: 10.15.1.13 port 5060


Dialpeers created:

Dial-peers for Pool 4:

dial-peer voice 40003 voip
 destination-pattern 5003
 session target ipv4:10.15.1.13:5060
 session protocol sipv2
 dtmf-relay sip-notify
 codec  g711ulaw bytes 160
  call-fwd-busy        5000           
  after-hours-exempt   FALSE          

Statistics:
  Active registrations  : 1
 --More--         
  Total SIP phones registered: 3
  Total Registration Statistics
    Registration requests  : 18
    Registration success   : 18
    Registration failed    : 0
    unRegister requests    : 17
    unRegister success     : 17
    unRegister failed      : 0
    Attempts to register 
           after last unregister : 0 
    Last register request time   : 16:43:26.236 UTC Fri Aug 15 2014 
    Last unregister request time : 16:43:22.728 UTC Fri Aug 15 2014 
    Register success time        : 16:43:26.236 UTC Fri Aug 15 2014 
    Unregister success time      : 16:43:22.731 UTC Fri Aug 15 2014 

 

 

Cisco Employee

Hi Anupam,Please provide the

Hi Anupam,

Please provide the following information:

+ Collect packet capture on the binding interface. 

https://supportforums.cisco.com/document/11935676/ip-traffic-export-packet-capture

+ debug ccsip all, debug voip ccapi inout

Thanks,

Niran

New Member

Niranjan,I found that I was

Niranjan,

I found that I was supposed to create dial-peer for extensions to make voice packet to route in the network. Now I am able to make calls on extensions and even out of trunk line but it does not look reasonable. By this way I am supposed to create dial-peer for each phone everytime I add to the extension. And phones are assigned ip dynamically as well. I am sure there is best alternative possible. 

Following dial peers created:

dial-peer voice 2001 voip
 destination-pattern 5...
 session protocol sipv2
 session target ipv4:10.15.1.11:5060
 dtmf-relay sip-notify
 codec g711ulaw
!

dial-peer voice 2003 voip
 destination-pattern 5...
 session protocol sipv2
 session target ipv4:10.15.1.12:5060
 dtmf-relay sip-notify
 codec g711ulaw
!
dial-peer voice 2004 voip
 destination-pattern 5...
 session protocol sipv2
 session target ipv4:10.15.1.13:5060
 dtmf-relay sip-notify
 codec g711ulaw

Can anyone suggest other way to do this. 

 

Regards

Where is you CME config on

Where is you CME config on this router ?

Enable telephony service on this router and bind source adress first and then do the testing.

696
Views
0
Helpful
5
Replies
CreatePlease login to create content