Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 7962 Corporate Directory - not working says to Contact Administrator

I recently bought 350 Cisco 7962s for UCM 7.X of those 350 about 100 of them I cannot access our corporate directory. I get an error saying to contact the administrator.

I have tried to do the factory reset; there are no Config differences between the phones that work and the phones that do not work, Same Firmware, Same Subnet, and same UCM Config, I know this for sure as I used the same bulk template for them all.

Just wanted to see if anyone else has seen this, our next step is to update the firmware but I did not want to do firmware updates during our busy season in case that causing any other issuers.

Thanks,


Ed

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Green

Cisco 7962 Corporate Directory - not working says to Contact Adm

Hi,

Not sure if this bug has something to do with your issue

CSCte05181 Bug Details
Blank Page if corporate directories is pressed during requesting mode
Symptom:

On the CM 7, users press the directories button, the personal and corporate directories are available while "requesting" is displayed. If the users press either 4 or 5 to get one of these options while the "requesting" shows on the screen, they get a blank page that does not away.


Conditions:

none.

Workaround:

none.
StatusStatus
Fixed
(Verified)
Severity Severity
3 - moderate

Last Modified Last Modified
In Last Year

Product Product
Cisco Unified IP Phone 7900 Series

Technology Technology


1st Found-In 1st Found-in
8.4(2)

Fixed-In Fixed-in
9.0(3)MN1.10

Component(s) Component
sw-phone-jphone

Regression Regression
Y

Regards

Alex

Please rate useful posts

Regards, Alex. Please rate useful posts.
22 REPLIES
Silver

Cisco 7962 Corporate Directory - not working says to Contact Adm

Is that when you press the Directories button or when you try to select Corporate Directory

Graham

New Member

Cisco 7962 Corporate Directory - not working says to Contact Adm

Only after pressing the Corporate Directory. At first I was thinking LDAP issue, but I have nearly 1000 other phones that do not have an issue and a little under 200 7962s that are okay.

Silver

Cisco 7962 Corporate Directory - not working says to Contact Adm

Strange

The only thing I can suggest is make sure the "Span to PC port" is on for the phone. Load Wireshark onto the PC plugged into the back of the phone and capture the network traffic between the Phone and CUCM.

Whatever URL the phone is accessing you should be able to put into IE and see the XML results back from CUCM

Graham

Green

Cisco 7962 Corporate Directory - not working says to Contact Adm

Hi,

Can you look at the phone settings ---> Device config ---> HTTP Config

What does the Directies URL show ?

Regards

Alex

Regards, Alex. Please rate useful posts.
New Member

Cisco 7962 Corporate Directory - not working says to Contact Adm

it is the same on all phones, working and non working

Http://10.8.224.21:8080/ccmcip/xmldirectory.jsp

the IP is the IP of our PUB.

I can get to this address from the PC that the phone is connected to and from any other PC...

this is what I get... so that appears to be working.

 

-

  Select a directory

 

Green

Cisco 7962 Corporate Directory - not working says to Contact Adm

Hi,

Well at least that proves it does NOT look like a DNS problem.

Are all the phones that dont work in the same vlan/subnet, I know you said that you

can reach the URL from a PC in the back of

the phone but that will probably be on your DATA subnet/vlan not the VOIP vlan.

Regards

Alex

Regards, Alex. Please rate useful posts.
New Member

Cisco 7962 Corporate Directory - not working says to Contact Adm

On the subnet, there is a mix of phones that work and do not work, the strage thing here is I can pull the 7962 out and put in a 7960 or 7940 and it works. I am only seeing this on a handful of Cisco 7962s.

Green

Cisco 7962 Corporate Directory - not working says to Contact Adm

Hi,

Could you try to factory reset ONE 7962 phone

Step 1 Unplug the power cable from the phone and then plug it back in.

The phone begins its power up cycle.

Step 2 While the phone is powering up, and before the Speaker button flashes on and off,

press and hold #.

Continue to hold # until each line button flashes on and off in sequence in amber.

Step 3 Release # and press 123456789*0#.

You can press a key twice in a row, but if you press the keys out of sequence, the factory reset will not take place.

After you press these keys, the line buttons on the phone flash red and the phone goes through the factory reset process.

Do not power down the phone until it completes the factory reset process and the main screen appears.


Regards

Alex

Regards, Alex. Please rate useful posts.
New Member

Cisco 7962 Corporate Directory - not working says to Contact Adm

Good thought, but ... still the same.

its very strange, I am hoping a firmware update will do it but I have my doubts.

Green

Cisco 7962 Corporate Directory - not working says to Contact Adm

Hi,

Not sure if this bug has something to do with your issue

CSCte05181 Bug Details
Blank Page if corporate directories is pressed during requesting mode
Symptom:

On the CM 7, users press the directories button, the personal and corporate directories are available while "requesting" is displayed. If the users press either 4 or 5 to get one of these options while the "requesting" shows on the screen, they get a blank page that does not away.


Conditions:

none.

Workaround:

none.
StatusStatus
Fixed
(Verified)
Severity Severity
3 - moderate

Last Modified Last Modified
In Last Year

Product Product
Cisco Unified IP Phone 7900 Series

Technology Technology


1st Found-In 1st Found-in
8.4(2)

Fixed-In Fixed-in
9.0(3)MN1.10

Component(s) Component
sw-phone-jphone

Regression Regression
Y

Regards

Alex

Please rate useful posts

Regards, Alex. Please rate useful posts.
New Member

Cisco 7962 Corporate Directory - not working says to Contact Adm

This does look similar, I will investigate. Thank you so much for all your help so far!

New Member

Cisco 7962 Corporate Directory - not working says to Contact Adm

Alex thank you so much this looks like it is the issue. I have the firmware, I will get this updated.


Graham thanks for your help too!

New Member

Cisco 7962 Corporate Directory - not working says to Contact Adm

Upgraded to the latest Firware Version 9.2(3)

Still NO Corporate Directory... really strange

That bug really looked similar so I guess I just jumpped the gun or just wishful thinking.

I am going to open a TAC on this one and I will update this string when it is fixed.

Silver

Cisco 7962 Corporate Directory - not working says to Contact Adm

If you want to collect a Wireshark trace and post it I will have a look at it.

Graham

New Member

Cisco 7962 Corporate Directory - not working says to Contact Adm

some new info...

Before the Firmware upgrade, after pressing Corporate Directory, we got a message saying to conatct Administrator.

After the upgrade, its just a blank screen that says unknown host.

I did the wireshark and I am looking at that now... I do not see where I can upload them.

Silver

Re: Cisco 7962 Corporate Directory - not working says to Contact

Do a normal reply and just above the HTML tag in the top right is "Use advanced editor"

Click that and at the bottom is an Attach Files box

Graham

New Member

Re: Cisco 7962 Corporate Directory - not working says to Contact

just a thought, but under the phone config in cucm admin, set the directories services to external.

Sent from Cisco Technical Support iPad App

New Member

Re: Cisco 7962 Corporate Directory - not working says to Contact

I have attached the Wireshark..

I am going to test the extenal directory idea...good thought.

Silver

Re: Cisco 7962 Corporate Directory - not working says to Contact

The phone is not making any attempt to access CUCM for the directory XML.

Please try the following.

Login to Call Manager and select "Cisco Unified Serviceability"

Select Tools/Control Center - Feature Services, select the publisher IP address.

Under CM services restart the Cisco Tftp service. After it has restarted wait two minuets, reset one of your problem 7942 phones and see what happens.

If it still fails do a Fcatory Reset on the phone and try again.

If it still fails I want you to download the phone cnf file and post it to the forum.

On any PC open a cmd window, do a cd to a sutable directory, then enter

tftp 10.10.66.34 get SEPE80462127D04.cnf.xml.sgn

and post the resulting SEPE80462127D04.cnf.xml.sgn file

Graham

New Member

Cisco 7962 Corporate Directory - not working says to Contact Adm

Wanted to provide an update... This is still not working but I believe I found what may be the issue, just not sure why. Perhaps a new bug. ... But hopefully this may save someone a lot of frustration

  • After the firmware update, I now get Host not found when pressing the corporate directory, no longer says to contact administrator.
  • Running wireshark says the phone did not even try to go to the corporate directory, like Graham noted above.
  • I can get to the URL from the PC the phone is connected too and if I swap with a 7960 or 40 it works.
  • I have also tried everything from this post,,, just to rule out all things. 

To narrow things down a bit, I created a test Device Pool, test Region, and test MRGL, Etc.. and moved a few test phones into it. I edited one thing at a time editing; the MRGL, Region, Date and Time made no difference still no corporate directory on the 7962s, but the 7940s and 7960s still worked.

When I disabled the SRST Reference in the test device pool, the corporate directory started working on the 7962s and it still works on the 7940s and 7960s. however when I re-enable it only the 7940s and 7960s corporate directory works… the 7962s does not and says “Host Not Found”.  I am still digging through all the logs myself but this totally makes no since which is why I think it is a new bug.

I have summed this up for TAC with a TON of logs from the phone to back this up. Hopefully we will be able to move forward with this soon.

Any other thoughts let me know but I will post the resolution once I have it… hopefully this week.

Ed

New Member

Cisco 7962 Corporate Directory - not working says to Contact Adm

RESOLVED!!!!

Finally we have this fixed, Apparently the 7962s use DNS for some of the backend functions where the 7940s and 7960s do not. Per TAC, this may still be a bug, as there was no clear explanation to why, we have about 1000 phones and have not needed to do this before the 7962s.

The Fix was simply adding DNS to the DHCP router so the phones would get the DNS setting.  

Just glad it is fixed.

Thanks all.

New Member

Re: Cisco 7962 Corporate Directory - not working says to Contact

Hi Ed,

Thanks for confirming the issue.

I saw your case within TAC DB.

Since the 7960 Phones are working with the DNS enabled, could you send us those sniffers(working)?

It will help me to raise a bug with the development team and help other customer's too. Really intresting to know why these model phones need DNS!

Looking forward for a reply.

Thanks.

---

Regrads,

DJ

4157
Views
5
Helpful
22
Replies