Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 8961 SRST call transfer

Hi all,

I have a problem with call transfer when using Cisco 8961 sip phones.

When the phone is registered to the CUCM everything works fine, but when the wan link goes down and the phone is in SRST mode, incoming calls cannot be transfered to other sccp or sip extensions.

My config is as follow: The phone who is trying to transfer is the 2002 . the recepcionist . Connection plar to 2002

MAEC-GW-NY(config)#do sh run

Building configuration...

Current configuration : 4793 bytes

!

! Last configuration change at 14:40:43 UTC Tue Jul 3 2012 by admin

version 15.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname MAEC-GW-NY

!

boot-start-marker

boot system flash:c2900-universalk9-mz.SPA.152-3.T.bin

boot-end-marker

!

!

logging buffered 51200 warnings

enable secret 5 $1$z1v.$pwRQEuDfEnM3zyldlPVQH1

!

no aaa new-model

!

no ipv6 cef

!

!        

!

ip dhcp excluded-address 192.168.238.1

ip dhcp excluded-address 192.168.238.254

!

ip dhcp pool LAN NY

network 192.168.238.0 255.255.255.0

default-router 192.168.238.1

option 150 ip 172.17.60.12 172.17.60.32 172.17.60.13

dns-server 172.16.10.19 192.168.238.1

domain-name maec

!

!

no ip domain lookup

ip cef

multilink bundle-name authenticated

!

!

!

!

!

!

crypto pki trustpoint TP-self-signed-3109734756

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3109734756

revocation-check none

rsakeypair TP-self-signed-3109734756

!

!

crypto pki certificate chain TP-self-signed-3109734756

certificate self-signed 01

  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 33313039 37333437 3536301E 170D3132 30323037 30393439

  33325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 31303937

  33343735 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100C865 54F64179 5E44AF49 D43306CC E2747440 2DE9CB4B 85868279 757A189E

  D3F6933C 6B29DBC8 3A016E4D 6C28E1A9 CE343B4E A3C78C3A C89A3055 F0D74871

  0200D28B 227E41D5 CDF10BA3 517B04A7 F2DCD11A 8AFDA0EE 63F8CD37 C8A6F77B

  DA8C4B26 6A166561 D139BD70 664E7CBB D68AF8C5 EEF4E45B 23AB68A0 F2F679AE

  16950203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603

  551D1104 1B301982 17796F75 726E616D 652E796F 7572646F 6D61696E 2E636F6D

  301F0603 551D2304 18301680 14D83CE6 A679D324 40F40366 A7A1AF44 83B77C65

  80301D06 03551D0E 04160414 D83CE6A6 79D32440 F40366A7 A1AF4483 B77C6580

  300D0609 2A864886 F70D0101 04050003 81810010 B782D8BE A2D8D9DC AF4848AD

  6FA3598A A41268BF 67815455 25C4B1FE 1D58A272 A4C6025F D1093A66 582CA958

  4758E323 E3D15641 AD5898CF 78B33677 2D40DC10 D89AC0D3 B9B59869 BEB67089

  4BD1BDA1 D76681AE 800BCC36 149E8C49 09913777 A08EDDFE C91FC413 3001E8C9

  DF2B278B 82D78609 13154550 88C63E31 22C1FE

        quit

voice-card 0

!

!

!

voice service voip

allow-connections sip to sip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

h323

  call preserve

sip

  registrar server

!

!

voice register global

max-dn 10

max-pool 5

!

voice register dn  1

number 2000

preference 4

!

voice register dn  2

number 2001

preference 4

!

voice register pool  1

id network 192.168.238.0 mask 255.255.255.0

codec g711ulaw

!

!

!

!

!

license udi pid CISCO2911/K9 sn FCZ1606707U

license accept end user agreement

hw-module pvdm 0/0

!

!

!

username admin secret 5 $1$VfGh$5jIWjMzRW.PoK1NstQn91.

!

redundancy

!

!

!

!

!

!

interface Loopback10

description MoH Source Interface

ip address 10.255.255.254 255.255.255.255

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description --Vers le LAN Consulat NY--

ip address 192.168.238.254 255.255.255.0

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr 192.168.238.254

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

ip forward-protocol nd

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

!

!

snmp-server community publicmaec RO

snmp-server community privatemaec RW

snmp-server enable traps entity-sensor threshold

!

control-plane

!

!

!

!

!

ccm-manager music-on-hold

!

!

mgcp profile default

!

!

!

!

!

gatekeeper

shutdown

!

!

call-manager-fallback

max-conferences 8 gain -6

transfer-system full-blind

ip source-address 192.168.238.254 port 2000

max-ephones 58

max-dn 116 dual-line

system message primary Systeme de Secours Actif

no huntstop

moh "music-on-hold.au"

multicast moh 239.1.1.1 port 16384 route 10.255.255.254 192.168.238.254

date-format dd-mm-yy

!

!

!

line con 0

login local

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

privilege level 15

logging synchronous

login local

transport input telnet ssh

line vty 5 15

privilege level 15

logging synchronous

login local

transport input telnet ssh

!

scheduler allocate 20000 1000

!

end

  • IP Telephony
Everyone's tags (5)
5 REPLIES
New Member

Cisco 8961 SRST call transfer

Sorry it's an old config

i added this commands:

voice register dn  3

number 2002

preference 4

Regards

New Member

Cisco 8961 SRST call transfer

Anyone??

SCCP phones can transfer calls to SIP and SCCP;

But SIP phones can only transfer to another sip, when i try to complete transfer to sccp phone the message : cannot complete transfer appears on the screen.

Thank you

Silver

Cisco 8961 SRST call transfer

Have you tried adding a transfer-pattern under call-manager-fallback config?

New Member

Cisco 8961 SRST call transfer

Yes ,

I have transfer-pattern .... under call-manager-fallback.

This solves sccp call transfer .

actually sip to sip transfers : ok

sccp tp sccp : ok

sccp to sip : ok

sip to sccp ; fail with cannot complete transfer

Silver

Cisco 8961 SRST call transfer

What kind of SIP phone are using?  May be an issue with the SIP implementation the phone uses.  If it's a Cisco phone, try upgrading the firmware.

1471
Views
0
Helpful
5
Replies