Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

Cisco 9971 - Stuck Upgrading/Not Registering

Hi,

I'm trying to get a 9971 working with CUCM 8.6.2.21900-5 and it's stuck on the final file of a load pack, hoping someone can help/shed light.

Background:

The device looks like it rolled back it's .load file when it was originally plugged into our network. Originally, when the phone came online, it came up on our old pub/sub configuration. When I noticed this I did a factory reset on the phone, but it still came up on the wrong pub/sub.

At this point I manually pointed the phone to the new TFTP servers in the IPv4 Setup menu and restarted it, it was only then that I noticed that the scope on the VLAN it had initially landed on was pointing to an old TFTP/CUCM location.

I have since updated the scope, but the phone is now stuck in an upgrading state not registering with CUCM.

Things I can see:

  • Top banner has: Phone Not Registered and the spinning wheel
  • In the Phone Information menu I can see "Upgrade in Progress", it is on Active Load sip9971.9-0-3 and attempting to load 9971.9-2-4-19.
  • Drilling into the Details the phone loads all files, then gets stuck on the final one, which is called: rootfs9971.9-2-4-19.sebn
  • I cannot access any of the settings to change them/ do a factory reset via the Administrator Settings (everything greyed out)
  • In the Status Messages I see: "TFTP Error: ram/SEPE84040A3245B.cnf.xml" and File Not Found:SEPE84040A3245B.cnf.xml"

So I'm confused. Looking at the TFTP locations that I have pointed the phone to, I can see the

rootfs9971.9-2-4-19.sebn file present. I'm under the impression that I shouldn't need the <Mac>.cnf.xml file as it will just use the defaults for that model.

I've tried debugging the TFTP logs using the RTMT, but haven't had much luck figuring out how I'm meant to be checking these logs and what to look at. I've also tried pointing the phone to a standalone Linux TFTP server to debug it, which always worked fine in the past with 7960s, however the phone isn't hitting that server when I direct it there via DHCP.

Basically I think I've inadvertently hardcoded the TFTP settings on the phone (Alternate TFTP set to Yes) and it is no longer getting TFTP addresses from DHCP (from what I can tell). Can anyone tell me how to reset this phone when all of the settings are greyed out and non-responsive? I need a hard reset along the lines of 3491672850*# or 123456789*0# on the 7960s....I can't get into the Administrator Settings.

Any help would be greatly appreciated!

Everyone's tags (4)
6 REPLIES
Cisco Employee

Cisco 9971 - Stuck Upgrading/Not Registering

You can try the same factory reset procedure as the 79XX phones.

Step 1) While powering up the phone, press and hold #.

Step 2) When the light on the mute button and handset light strip turns off and all other lights (line button, headset button, speakerphone button and select button) stay green, press 123456789*0# in sequence.

When you press 1, the lights on the line buttons turn red. The light on the select button flash when a button is pressed.

If you press the buttons out of sequence, the lights on the line button, headset button, speakerphone button, and select button turn green. You will need to start over and press 123456789*0# in sequence again.

After you press these buttons, the phone goes through the factory reset process.

Do not power down the phone until it completes the factory reset process, and the main screen appears.

Cisco 9971 - Stuck Upgrading/Not Registering

Thanks Joe, I'm not sure that this is working though. I'm not seeing as described above:

Phone powers up and has red mute key and orange top two line buttons.

Hold down # key until the Mute key light goes out (top two line buttons are still orange, don;t actually see the other buttons turning Green?)

Input 1234567889*0#

Line Keys do a "count down" lighting up Green and the Cisco Java load screen comes on

Phone boots as normal

Any ideas?

Cisco 9971 - Stuck Upgrading/Not Registering

So I managed to perform a factory reset by powering the phone up on a PoE port whose VLAN was not configured with the TFTP scope, that stopped the phone attempting to update and allows access to the menu settings to do the reset. This would work using a power brick as well I imagine.

The problem remains though, the phone is still stuck on upgarding the final file in the load: rootfs9971.9-2-4-19.sebn

Is anyone aware of a problem going from load sip9971.9-0-3 to sip9971.9-2-4-19? Do I need to use an intermediate load to follow this upgrade path?


Cisco Employee

Cisco 9971 - Stuck Upgrading/Not Registering

That should be a direct upgrade between those versions.

Cisco Employee

Cisco 9971 - Stuck Upgrading/Not Registering

Is that 9971 provisioned in CUCM (File Not Found:SEPE84040A3245B.cnf.xml)?  Could you try and load the 9-3-1 firmware on CUCM and see if that helps the phone come up?

Re: Cisco 9971 - Stuck Upgrading/Not Registering

Hey,

It appears part of the problem with this phone was that the phone profile didn't have a number assigned on line 1 and was SIP protocol. Apparently if there is no number there, the phone can't register.

The thing that worked in the end was (as I had no phone profile present, possibly deleted during earlier fix attempts):

  • Manually created the phone in CME using it's MAC, copying out settings from a working 9971 (SIP protocol)
  • Assigned the phone a number on line 1
  • Factory reset the phone

When the phone came back up it discovered the .cnf file without issue and successfully upgraded and registered.

6469
Views
0
Helpful
6
Replies
CreatePlease login to create content