Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco Catalyst and Avaya IP Phones (One-way audio issue)

We are using a Cisco Catalyst C3560-48TS-S in combination with a IP Office 500 v2 (Avaya).
We are experiencing one-way audio issues. We are unable to hear the remote end, the remote end however is able to hear us. This happens to circa 10% of all the calls. We have segmented the voice and data network into two different vlan's (along with two other for wireless clients and guest). However we are unable to correctly configure QoS.

VLAN 10: VOICE
VLAN 20: DATA
VLAN 30: WIRELESS
VLAN 40: MISC.

We would like to configure all incoming voice traffic entering fast ethernet 0/11 (up-link from IPoffice) with a dscp value of 46. 

Config:

version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW01
!
boot-start-marker
boot-end-marker
!
!
enable secret ~~~~~~~~~~~~~~~~~~~~
!
no aaa new-model
clock timezone CET 1 0
system mtu routing 1500
!
!
!
!
mls qos srr-queue input bandwidth 70 30
mls qos srr-queue input threshold 1 80 90
mls qos srr-queue input priority-queue 2 bandwidth 30
mls qos srr-queue input cos-map queue 1 threshold 2 3
mls qos srr-queue input cos-map queue 1 threshold 3 6 7
mls qos srr-queue input cos-map queue 2 threshold 1 4
mls qos srr-queue input dscp-map queue 1 threshold 2 24
mls qos srr-queue input dscp-map queue 1 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue input dscp-map queue 1 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3 32 33 40 41 42 43 44 45
mls qos srr-queue input dscp-map queue 2 threshold 3 46 47
mls qos srr-queue output cos-map queue 1 threshold 3 4 5
mls qos srr-queue output cos-map queue 2 threshold 1 2
mls qos srr-queue output cos-map queue 2 threshold 2 3
mls qos srr-queue output cos-map queue 2 threshold 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 0
mls qos srr-queue output cos-map queue 4 threshold 3 1
mls qos srr-queue output dscp-map queue 1 threshold 3 32 33 40 41 42 43 44 45
mls qos srr-queue output dscp-map queue 1 threshold 3 46 47
mls qos srr-queue output dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 2 threshold 1 26 27 28 29 30 31 34 35
mls qos srr-queue output dscp-map queue 2 threshold 1 36 37 38 39
mls qos srr-queue output dscp-map queue 2 threshold 2 24
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue output dscp-map queue 4 threshold 1 8 9 11 13 15
mls qos srr-queue output dscp-map queue 4 threshold 2 10 12 14
mls qos queue-set output 1 threshold 1 100 100 50 200
mls qos queue-set output 1 threshold 2 125 125 100 400
mls qos queue-set output 1 threshold 3 100 100 100 400
mls qos queue-set output 1 threshold 4 60 150 50 200
mls qos queue-set output 1 buffers 15 25 40 20
!

!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
lldp run
!
!
!
!
!
!
!
interface FastEthernet0/1
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
 switchport access vlan 20
!
interface FastEthernet0/10
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/11
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/12
 switchport access vlan 20
 switchport mode access
 switchport voice vlan 10
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/13
 switchport access vlan 20
 switchport mode access
 switchport voice vlan 10
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/14
 switchport access vlan 20
 switchport mode access
 switchport voice vlan 10
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/15
 switchport access vlan 20
 switchport mode access
 switchport voice vlan 10
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/16
 switchport access vlan 20
 switchport mode access
 switchport voice vlan 10
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/17
 switchport access vlan 20
 switchport mode access
 switchport voice vlan 10
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/18
 switchport access vlan 20
 switchport mode access
 switchport voice vlan 10
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/19
 switchport access vlan 20
 switchport mode access
 switchport voice vlan 10
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/20
 switchport access vlan 20
 switchport mode access
 switchport voice vlan 10
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/21
 switchport access vlan 20
 switchport mode access
 switchport voice vlan 10
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/22
 switchport access vlan 20
 switchport mode access
 switchport voice vlan 10
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/23
 switchport access vlan 20
 switchport mode access
 switchport voice vlan 10
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/24
 switchport access vlan 20
 switchport mode access
 switchport voice vlan 10
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/25
 switchport access vlan 20
 switchport mode access
 switchport voice vlan 10
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/26
 switchport access vlan 20
 switchport mode access
 switchport voice vlan 10
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/27
 switchport access vlan 20
 switchport mode access
 switchport voice vlan 10
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/28
 switchport access vlan 20
 switchport mode access
 switchport voice vlan 10
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/29
 switchport access vlan 20
 switchport mode access
 switchport voice vlan 10
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/30
 switchport access vlan 20
 switchport mode access
 switchport voice vlan 10
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/31
 switchport access vlan 20
 switchport mode access
 switchport voice vlan 10
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/32
 switchport access vlan 20
 switchport mode access
 switchport voice vlan 10
 no cdp enable
 spanning-tree portfast
!
interface FastEthernet0/33
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/34
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/35
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/36
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/37
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/38
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/39
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/40
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/41
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/42
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/43
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/44
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/45
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/46
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/48
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 no ip address
!
interface Vlan20
 ip address 10.0.17.5 255.255.255.0
!
interface Vlan30
 ip address 10.0.30.253 255.255.255.0
!
interface Vlan40
 ip address 10.0.40.253 255.255.255.0
!
interface Vlan50
 ip address 10.0.50.253 255.255.255.0
!
interface Vlan80
 no ip address
!
ip http server
ip http secure-server
!
!
!
logging esm config
access-list 100 permit udp any any range 49152 53246
access-list 100 permit udp any any eq 5060
!
snmp-server community public RO
snmp-server community constantit RO
!
!
line con 0
line vty 0 4
 password ~~~~~~
 login
line vty 5 15
 password ~~~~~~
 login
!
end
1 ACCEPTED SOLUTION

Accepted Solutions

Please compare the QOS and

Please compare the QOS and add to yours:

 

mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2  1
mls qos srr-queue input cos-map queue 1 threshold 3  0
mls qos srr-queue input cos-map queue 2 threshold 1  2
mls qos srr-queue input cos-map queue 2 threshold 2  4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3  3 5
mls qos srr-queue input dscp-map queue 1 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3  0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3  32
mls qos srr-queue input dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2  33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2  49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2  57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3  5
mls qos srr-queue output cos-map queue 2 threshold 3  3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3  2 4
mls qos srr-queue output cos-map queue 4 threshold 2  1
mls qos srr-queue output cos-map queue 4 threshold 3  0
mls qos srr-queue output dscp-map queue 1 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3  16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3  32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1  8
mls qos srr-queue output dscp-map queue 4 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3  0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos   
!
!
!

For the normal access ports on the switch:

 

!
interface GigabitEthernet1/0/1
 switchport access vlan xx
 switchport mode access
 switchport voice vlan xx
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust cos
 auto qos voip trust
 spanning-tree portfast
 spanning-tree bpduguard enable

On your trunk ports:

 

interface TenGigabitEthernet2/0/2
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan xx,xx,xx,xx,xx
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust cos
 auto qos voip trust

On your router port for example for all LAN traffic comming in before leaving over the WAN or PSTN:

!
class-map match-any VoIP-RTP-Trust
 match ip dscp ef
class-map match-any VoIP-Control-Trust
 match ip dscp cs3
 match ip dscp af31
!
!
policy-map Policy-Trust
 class VoIP-RTP-Trust
  priority percent 70
 class VoIP-Control-Trust
  bandwidth percent 5
 class class-default
  fair-queue

!
interface GigabitEthernet0/0
 ip address xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx
 duplex auto
 speed auto
 media-type rj45
 service-policy output Policy-Trust

see if this helps you.

Voice CCIE #37771
2 REPLIES

Please compare the QOS and

Please compare the QOS and add to yours:

 

mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue input bandwidth 90 10
mls qos srr-queue input threshold 1 8 16
mls qos srr-queue input threshold 2 34 66
mls qos srr-queue input buffers 67 33
mls qos srr-queue input cos-map queue 1 threshold 2  1
mls qos srr-queue input cos-map queue 1 threshold 3  0
mls qos srr-queue input cos-map queue 2 threshold 1  2
mls qos srr-queue input cos-map queue 2 threshold 2  4 6 7
mls qos srr-queue input cos-map queue 2 threshold 3  3 5
mls qos srr-queue input dscp-map queue 1 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue input dscp-map queue 1 threshold 3  0 1 2 3 4 5 6 7
mls qos srr-queue input dscp-map queue 1 threshold 3  32
mls qos srr-queue input dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23
mls qos srr-queue input dscp-map queue 2 threshold 2  33 34 35 36 37 38 39 48
mls qos srr-queue input dscp-map queue 2 threshold 2  49 50 51 52 53 54 55 56
mls qos srr-queue input dscp-map queue 2 threshold 2  57 58 59 60 61 62 63
mls qos srr-queue input dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue input dscp-map queue 2 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output cos-map queue 1 threshold 3  5
mls qos srr-queue output cos-map queue 2 threshold 3  3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3  2 4
mls qos srr-queue output cos-map queue 4 threshold 2  1
mls qos srr-queue output cos-map queue 4 threshold 3  0
mls qos srr-queue output dscp-map queue 1 threshold 3  40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3  16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3  32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1  8
mls qos srr-queue output dscp-map queue 4 threshold 2  9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3  0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos   
!
!
!

For the normal access ports on the switch:

 

!
interface GigabitEthernet1/0/1
 switchport access vlan xx
 switchport mode access
 switchport voice vlan xx
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust cos
 auto qos voip trust
 spanning-tree portfast
 spanning-tree bpduguard enable

On your trunk ports:

 

interface TenGigabitEthernet2/0/2
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan xx,xx,xx,xx,xx
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust cos
 auto qos voip trust

On your router port for example for all LAN traffic comming in before leaving over the WAN or PSTN:

!
class-map match-any VoIP-RTP-Trust
 match ip dscp ef
class-map match-any VoIP-Control-Trust
 match ip dscp cs3
 match ip dscp af31
!
!
policy-map Policy-Trust
 class VoIP-RTP-Trust
  priority percent 70
 class VoIP-Control-Trust
  bandwidth percent 5
 class class-default
  fair-queue

!
interface GigabitEthernet0/0
 ip address xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx
 duplex auto
 speed auto
 media-type rj45
 service-policy output Policy-Trust

see if this helps you.

Voice CCIE #37771

One-way audio is usually not

One-way audio is usually not a QoS issue unless the audio is cutting in and out on the call rather than true one-way audio.

 

I would take a look into a possible routing issue.

737
Views
0
Helpful
2
Replies
CreatePlease login to create content