Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco CME Call Forward Problem - SIP and CUE

Hi there,

I have a frustrating problem with a CME/CUE 7.1 system.  The CME is on a 2811

and the CUE is an AIM Module.  There is NO firewall of any kind set up.

I have the luxury of a lab setup for this issue with matching provider, equipment,

etc. so I can try just about anything without interupting service.

The service provider provides SIP trunks and also supports supplementary service

SIP refer and moved-temporarily.  I have no need to SIP hairpin the calls in order

to account for anything. 

The problem is this: when I configure CFA on an ephone WITH the SIP supplementary

service commands enabled in voice service voip, the calls forward to a cell

phone perfectly.  It takes a couple of extra seconds, but works well.  But if I

set the CFA up in this manner, I cannot set CFB or CFNA to forward to CUE.  I have

CUE set up with a destination-pattern 2000.  When I check the traces, it shows

that the CFB and CFNA calls directed at the CUE are sent back to the

service provider. Of course, the service provider doesn't know what 2000

is, so the call fails.  When I checked the Cisco documentation and several

other posts, it clearly says that when the two supplementary service SIP

commands are enabled, all dial-peers need to be E.164 numbers.  I am not

sure how to resolve this.  How do I give my CUE an E.164 number? I have

set the E.164 number inside CUE to match the incoming call.

There is more info on this....

I decided to turn OFF the supplementary services SIP commands, and

just use hairpin SIP.  I have lots of bandwidth.

Now, calls set for CFNA and CFB are properly forwarded to the CUE,

so I know it's set up correctly.  However, when I do this, my hairpinned

SIP calls that are forwarded to a cell phone do transfer, but I have no

audio.  I checked the SIP traces and each call leg is correctly using G711u.

I tried putting the codec command on every leg, and also tried using

voice-class codec, suspecting that the no audio was a codec issue.

No combination of what I have tried seems to work.

I installed a previous version of the IOS, which would change

the system to a version 4.1, but I get the same problem.

Has anyone seen this before?  This is a pretty common setup and

I am stumped as to why I can't get something a simple as CFA

working with a SIP provider that supports the SIP supplementary

services.

The customer just switched to SIP, and had never used the CFA

function until recently when we discovered the problem.

I can certainly post configs etc on this, but after reading all the forums

and posts, there has to be somebody else who has seen this before.

Many thanks

Randy

----------

  • IP Telephony
Everyone's tags (5)
2 REPLIES

Cisco CME Call Forward Problem - SIP and CUE

Please refer to this document:

http://www.cisco.com/en/US/products/sw/voicesw/ps4625/prducts_configuration_example09186a00808f9666.shtml#call-fwd

Please post your CME and CUE config so everyone can assist you.

Please rate replies and mark question as "answered" if applicable.

Please rate replies and mark question as "answered" if applicable.
New Member

Re: Cisco CME Call Forward Problem - SIP and CUE

Thanks for responding.

I have attached the CME/CUE config below.  Also, the ccsip debug is there.

Any hackers out there, don't get too excited, these are all lab numbers....

1st Scenario:

- system set up for SIP trunking - hairpin

- sip supplementary services disabled

- voice mail works properly when the CFA is not enabled.

- main number 7783713050 set up for CFA to a cell phone 6048371076

- call goes through, but NO AUDIO

Thanks for looking at this.

Note that the link posted below by rr cuares does not work. I have found the

call-fwd config on the Cisco site and reviewed it - obviously I am just missing

something...!

1534
Views
0
Helpful
2
Replies