Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Cisco Gateway generates 488 "Media Type(s) Unavailable"

Hi all,

 

I have a trouble with incoming calls from a ISR3945 to a ISR 2951.. When I send the call I receive a 488 Not acceptable here, I added the dial-peer config:

 

voice class codec 100
 codec preference 1 transparent
 codec preference 1 g711alaw
 codec preference 2 g711ulaw
 codec preference 3 g729r8

!

!

dial-peer voice 300 voip
 destination-pattern 61[0-9][0-9]
 session protocol sipv2
 session target ipv4:10.2.201.2

voice-class codec 100

 voice-class sip bind control source-interface GigabitEthernet0/0
 voice-class sip bind media source-interface GigabitEthernet0/0
 dtmf-relay rtp-nte sip-kpml sip-notify

no vad
 !

!

Here you have a trace matching this dial-peer, the call is refused inmediately after receiving the invite:

INVITE sip:6100@172.26.1.2:5060 SIP/2.0
Via: SIP/2.0/UDP 10.227.19.233:5060;branch=z9hG4bK1642BD
Remote-Party-ID: <sip:5524420252@10.227.19.233>;party=calling;screen=no;privacy=off
From: <sip:5524420252@10.227.19.233>;tag=242C8A8C-14D
To: <sip:6100@172.26.1.2>
Date: Mon, 23 Jun 2014 17:16:42 GMT
Call-ID: FB0F3DFB-FA3011E3-83F8D79A-24C3E955@10.227.19.233
Supported: 100rel,timer,resource-priority,replaces,sdp-anat
Min-SE:  1800
Cisco-Guid: 4006857602-4193063395-2465580347-3968770196
User-Agent: Cisco-SIPGateway/IOS-15.4.1.T
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
CSeq: 101 INVITE
Timestamp: 1403543802
Contact: <sip:5524420252@10.227.19.233:5060>
Expires: 180
Allow-Events: telephone-event
Max-Forwards: 65
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 250

v=0
o=CiscoSystemsSIP-GW-UserAgent 2397 6528 IN IP4 10.227.19.233
s=SIP Call
c=IN IP4 10.227.19.233
t=0 0
m=audio 17028 RTP/AVP 8 101
c=IN IP4 10.227.19.233
a=rtpmap:8 PCMA/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=ptime:20

--------------------------------------------------

SIP/2.0 488 Not Acceptable Media
Via: SIP/2.0/UDP 10.227.19.233:5060;branch=z9hG4bK1642BD
From: <sip:5524420252@10.227.19.233>;tag=242C8A8C-14D
To: <sip:6100@172.26.1.2>;tag=80CBF7B0-128A
Date: Mon, 23 Jun 2014 17:19:21 GMT
Call-ID: FB0F3DFB-FA3011E3-83F8D79A-24C3E955@10.227.19.233
Timestamp: 1403543802
CSeq: 101 INVITE
Allow-Events: telephone-event
Warning: 304 172.26.1.2 "Media Type(s) Unavailable"
Reason: Q.850;cause=65
Server: Cisco-SIPGateway/IOS-15.2.4.M4
Content-Length: 0

In the other hand, when I send outbound calls, they are succesfully completed as follows:

 

dial-peer voice 200 voip

 description CELULAR Local - Telecomm Atlas
 translation-profile outgoing remove7
 destination-pattern 044..........
 session protocol sipv2
 session target ipv4:10.227.19.233

 voice-class sip bind control source-interface GigabitEthernet0/1
 voice-class sip bind media source-interface GigabitEthernet0/1
 voice-class codec 100  
 dtmf-relay rtp-nte sip-kpml sip-notify
 no vad

!

!

Here you have a tracecall of a succesfull outbound call:

INVITE sip:0449932018628@10.227.19.233:5060 SIP/2.0
Via: SIP/2.0/UDP 172.26.1.2:5060;branch=z9hG4bK8425C3
Remote-Party-ID: "SA-Remigio Salvador Sanchez" <sip:9931516100@172.26.1.2>;party=calling;screen=yes;privacy=off
From: "SA-Remigio Salvador Sanchez" <sip:9931516100@172.26.1.2>;tag=808F9518-25F0
To: <sip:0449932018628@10.227.19.233>
Date: Mon, 23 Jun 2014 16:13:23 GMT
Call-ID: 227707E4-FA2811E3-A4A1A740-A248493A@172.26.1.2
Supported: 100rel,timer,resource-priority,replaces,sdp-anat
Min-SE:  1800
Cisco-Guid: 1264244992-0000065536-0000000791-0046727690
User-Agent: Cisco-SIPGateway/IOS-15.2.4.M4
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
CSeq: 101 INVITE
Timestamp: 1403540003
Contact: <sip:9931516100@172.26.1.2:5060>
Call-Info: <sip:172.26.1.2:5060>;method="NOTIFY;Event=telephone-event;Duration=2000"
Expires: 180
Allow-Events: kpml, telephone-event
Max-Forwards: 69
Session-Expires:  1800
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 241

v=0
o=CiscoSystemsSIP-GW-UserAgent 8112 1672 IN IP4 172.26.1.2
s=SIP Call
c=IN IP4 172.26.1.2
t=0 0
m=audio 20720 RTP/AVP 8 101
c=IN IP4 172.26.1.2
a=rtpmap:8 PCMA/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-15
a=ptime:20

 

SIP/2.0 183 Session Progress
Via: SIP/2.0/UDP 172.26.1.2:5060;branch=z9hG4bK8425C3
From: "SA-Remigio Salvador Sanchez" <sip:9931516100@172.26.1.2>;tag=808F9518-25F0
To: <sip:0449932018628@10.227.19.233>;tag=23F03944-21E6
Date: Mon, 23 Jun 2014 16:10:45 GMT
Call-ID: 227707E4-FA2811E3-A4A1A740-A248493A@172.26.1.2
Timestamp: 1403540003
CSeq: 101 INVITE
Require: 100rel
RSeq: 7688
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
Allow-Events: telephone-event
Remote-Party-ID: <sip:0449932018628@10.227.19.233>;party=called;screen=yes;privacy=off
Contact: <sip:0449932018628@10.227.19.233:5060>
Call-Info: <sip:10.227.19.233:5060>;method="NOTIFY;Event=telephone-event;Duration=2000"
Supported: sdp-anat
Server: Cisco-SIPGateway/IOS-15.4.1.T
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 194

v=0
o=CiscoSystemsSIP-GW-UserAgent 6163 8882 IN IP4 10.227.19.233
s=SIP Call
c=IN IP4 10.227.19.233
t=0 0
m=audio 17010 RTP/AVP 8
c=IN IP4 10.227.19.233
a=rtpmap:8 PCMA/8000
a=ptime:20

 

 

PRACK sip:0449932018628@10.227.19.233:5060 SIP/2.0
Via: SIP/2.0/UDP 172.26.1.2:5060;branch=z9hG4bK85183B
From: "SA-Remigio Salvador Sanchez" <sip:9931516100@172.26.1.2>;tag=808F9518-25F0
To: <sip:0449932018628@10.227.19.233>;tag=23F03944-21E6
Date: Mon, 23 Jun 2014 16:13:23 GMT
Call-ID: 227707E4-FA2811E3-A4A1A740-A248493A@172.26.1.2
CSeq: 102 PRACK
RAck: 7688 101 INVITE
Allow-Events: kpml, telephone-event
Max-Forwards: 70
Content-Length: 0

 

SIP/2.0 200 OK
Via: SIP/2.0/UDP 172.26.1.2:5060;branch=z9hG4bK85183B
From: "SA-Remigio Salvador Sanchez" <sip:9931516100@172.26.1.2>;tag=808F9518-25F0
To: <sip:0449932018628@10.227.19.233>;tag=23F03944-21E6
Date: Mon, 23 Jun 2014 16:10:49 GMT
Call-ID: 227707E4-FA2811E3-A4A1A740-A248493A@172.26.1.2
Server: Cisco-SIPGateway/IOS-15.4.1.T
CSeq: 102 PRACK
Content-Length: 0

 

SIP/2.0 200 OK
Via: SIP/2.0/UDP 172.26.1.2:5060;branch=z9hG4bK8425C3
From: "SA-Remigio Salvador Sanchez" <sip:9931516100@172.26.1.2>;tag=808F9518-25F0
To: <sip:0449932018628@10.227.19.233>;tag=23F03944-21E6
Date: Mon, 23 Jun 2014 16:10:49 GMT
Call-ID: 227707E4-FA2811E3-A4A1A740-A248493A@172.26.1.2
Timestamp: 1403540003
CSeq: 101 INVITE
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
Allow-Events: telephone-event
Remote-Party-ID: <sip:0449932018628@10.227.19.233>;party=called;screen=no;privacy=off
Contact: <sip:sgc_c@10.227.19.233:5060>
Supported: replaces
Call-Info: <sip:10.227.19.233:5060>;method="NOTIFY;Event=telephone-event;Duration=2000"
Supported: sdp-anat
Server: Cisco-SIPGateway/IOS-15.4.1.T
Session-Expires:  1800;refresher=uac
Require: timer
Supported: timer
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 194

 

I checked both SDP info in both calls, but I dont have any idea to try to figure out this issue. I alrerady tried to forced the codec without succesfull.

 

Thanks

11 REPLIES

It would be great if you

It would be great if you could send full configs from either router however, make sure that the incoming dial-peer on the gateway that is sending 488 has G711ulaw. 

Please rate useful posts.

You always have an option to

You always have an option to passthru unsupported media , but to dig in further as George suggested we need router config with "debug voice ccapi inout" logs.

Community Member

Hi Manish, I send you the

Hi Manish, I send you the confis of both Gateways: the sending  gateway is the one that sends the invite and the customer Gatweway is the one that generates the 488. When I put the debug voice ccapi inout, I dont see my call in the debug from the customer gateway but I do in my Sending Gateway.

 

Please advise me if you could download the attached file.

 

The following is the sh run of the sending:

RO_AC_DGTIC#sh run
Building configuration...


Current configuration : 11736 bytes
!
! Last configuration change at 10:47:58 CDT Tue Jun 24 2014 by cliente
! NVRAM config last updated at 10:37:51 CDT Tue Jun 24 2014 by cliente
!
version 15.4
service timestamps debug datetime
service timestamps log datetime localtime
service password-encryption
!
hostname RO_AC_DGTIC
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
! card type command needed for slot/vwic-slot 0/1
logging buffered 51200 warnings
logging console errors
enable secret 5 $1$aj7F$Kei4iMFn0SUrH7lecNNFY1
!
no aaa new-model
clock timezone CST -6 0
clock summer-time CDT recurring 1 Sun Apr 2:00 4 Sun Oct 2:00
clock calendar-valid
!
!
!
!
!
!         
!


!
ip vrf hospital_graham
 rd 6500:34
 route-target export 6500:34
 route-target import 6500:34
!
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool ccp-pool
 import all
 network 10.10.10.0 255.255.255.248
 default-router 10.10.10.1 
 lease 0 2
!
!
!
ip flow-cache timeout inactive 10
ip flow-cache timeout active 5
no ip domain lookup
ip domain name yourdomain.com
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!         
!
crypto pki trustpoint TP-self-signed-3489277466
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3489277466
 revocation-check none
 rsakeypair TP-self-signed-3489277466
!
!
crypto pki certificate chain TP-self-signed-3489277466
 certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030 
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 33343839 32373734 3636301E 170D3134 30313232 31393533 
  33355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649 
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 34383932 
  37373436 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 
  8100AB35 0A87E4DA 1ACD8540 AFEEE620 602514EA 22299F8C DB2F0E3E AA712C7F 
  589BC60E 122549FC 037A8E1F D4AACB14 645A6E16 89C74B8B B2E24FF8 C49C7B48 
  919C0A5F AF860FCB 6D26D152 D4A617A8 130AC676 46D31A75 3F30099F 0C7BDB5F 
  596C829C 55D155CF B93D48C8 B07ECEBD 09E2026F 25797D37 D591FF7C 63B9921D 
  9C110203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603 
  551D2304 18301680 14A57689 07B81A48 067070F1 7F9CDEE5 BD112158 D7301D06 
  03551D0E 04160414 A5768907 B81A4806 7070F17F 9CDEE5BD 112158D7 300D0609 
  2A864886 F70D0101 05050003 8181001E 9AF73B5B 8EEF5F00 E2591477 6A0B1B88 
  6DF1BAB0 45B19C62 D6186D02 811CA548 ABE26524 AFFEB1B3 B735074C 86415CCC 
  34E6BE23 2280C575 FB0389A9 E44070B5 7BC9CC96 C4A0BEB6 1BE89979 EAC3BEA7 
  D4CD8FEE B43C9A14 7FC89583 E95A0D19 2AF78C71 DE0A91C2 9F1278B3 E9FC13A5 
  476F44CF 6757DED4 416A07A3 06478C
        quit
voice-card 0
!
!         
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 sip
!
voice class codec 10
 codec preference 1 transparent
 codec preference 2 g711alaw
 codec preference 3 g711ulaw
 codec preference 4 g729r8
!
!
!
!
!
!
license udi pid C3900-SPE150/K9 sn FOC174684S6
license boot module c3900 technology-package uck9
hw-module pvdm 0/0
!
!
!
username cliente password 7 022154595A551D2F1C
username bytenet password 7 0306421F550172581C594851
!
redundancy
!
!         
ip tftp source-interface Loopback5
!
class-map match-any VLAN
 match vlan  100
 match vlan  200
 match vlan  10
class-map match-all VOICE-ALL
 match any 
class-map match-all CONTROL
 match precedence 6  7 
class-map match-all VOICE
 match dscp ef 
!
policy-map QOS-OUTPUT-CHILD
 class CONTROL
  bandwidth percent 3 
 class VOICE
  priority percent 30
 class class-default
  bandwidth percent 67 
  random-detect
policy-map PARENT-OUTPUT-TELECOMM
 class VLAN
  shape average 103000000
   service-policy QOS-OUTPUT-CHILD
policy-map INPUT-MARK-VOICE
 class VOICE-ALL
  set dscp ef
!
!
!
!         
!
interface Loopback0
 description TRAFICO_GESTION
 ip address 172.19.1.128 255.255.255.255
!
interface Loopback1
 description TRAFICO_VOZ
 ip address 10.227.19.233 255.255.255.255
!
interface Loopback5
 no ip address
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description TRAFICO_DGTIC_A_VGW_DGTIC_VOZ
 ip address 172.26.1.1 255.255.255.252
 duplex auto
 speed auto
 service-policy input INPUT-MARK-VOICE
!
interface GigabitEthernet0/1
 description B2B_TO_FORTINET_PUBLIC
 ip address 187.189.129.1 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 ip address 192.168.1.1 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/0/0
 description Link to ME_DI_VHS_PT_01
 no ip address
 ip flow ingress
 service-policy output PARENT-OUTPUT-TELECOMM
!
interface GigabitEthernet0/0/0.10
 description TRAFICO_GESTION_A_TELECOMM_ATLAS
 encapsulation dot1Q 10
 ip address 172.19.1.1 255.255.255.252
 ip flow ingress
!
interface GigabitEthernet0/0/0.100
 description TRAFICO_DATOS
 encapsulation dot1Q 100
 ip address 10.127.19.1 255.255.255.252
 ip flow ingress
!
interface GigabitEthernet0/0/0.200
 description TRAFICO_VOZ
 encapsulation dot1Q 200
 ip address 10.227.19.1 255.255.255.252
 ip flow ingress
!
interface GigabitEthernet0/2/0
 description Link to ME_DI_VHS_PT_01
 no ip address
!
interface GigabitEthernet0/2/0.100
 encapsulation dot1Q 100
 ip vrf forwarding hospital_graham
 ip address 10.127.19.93 255.255.255.252
!
interface GigabitEthernet0/3/0
 description TO RO_AC_HGRA
 no ip address
 duplex full
 speed 1000
!
interface GigabitEthernet0/3/0.100
 encapsulation dot1Q 100
 ip vrf forwarding hospital_graham
 ip address 187.189.129.93 255.255.255.252
!
!
ip forward-protocol nd
!
no ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip flow-export version 5
ip flow-export destination 192.168.2.2 9991
!
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/0.100 10.127.19.2
ip route 10.2.201.2 255.255.255.255 172.26.1.2
ip route 10.11.202.0 255.255.255.0 GigabitEthernet0/0 172.26.1.2
ip route 172.19.2.0 255.255.255.0 GigabitEthernet0/0/0.10 172.19.1.2
ip route 187.189.129.243 255.255.255.255 GigabitEthernet0/0/0.200 

10.227.19.2
ip route 192.168.2.0 255.255.255.0 GigabitEthernet0/0/0.10 172.19.1.2
ip route 192.168.5.0 255.255.255.0 GigabitEthernet0/0/0.10 172.19.1.2
ip route vrf hospital_graham 0.0.0.0 0.0.0.0 10.127.19.94
!
!
nls resp-timeout 1
cpd cr-id 1
!
!
control-plane
!
call treatment on
call threshold global total-calls low 30 high 30
 !
 !
 !
 !
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
dial-peer voice 10 voip
 description DGTIC A PSTN - Llamadas Local
 destination-pattern [1-9]......
 session protocol sipv2
 session target ipv4:187.189.129.243
 voice-class codec 10  
 voice-class sip bind control source-interface Loopback1
 voice-class sip bind media source-interface Loopback1
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 11 voip
 description DGTIC A PSTN - Llamadas LDN
 destination-pattern 01..........
 session protocol sipv2
 session target ipv4:187.189.129.243
 voice-class codec 10  
 voice-class sip bind control source-interface Loopback1
 voice-class sip bind media source-interface Loopback1
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 12 voip
 description DGTIC A PSTN - Llamadas Cel_Local
 destination-pattern 044..........
 session protocol sipv2
 session target ipv4:187.189.129.243
 voice-class codec 10  
 voice-class sip bind control source-interface Loopback1
 voice-class sip bind media source-interface Loopback1
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 13 voip
 description DGTIC A PSTN- Llamadas Cel_LD
 destination-pattern 045..........
 session protocol sipv2
 session target ipv4:187.189.129.243
 voice-class codec 10  
 voice-class sip bind control source-interface Loopback1
 voice-class sip bind media source-interface Loopback1
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 14 voip
 description DGTIC A PSTN- Llamadas EUyCAN
 destination-pattern 001..........
 session protocol sipv2
 session target ipv4:187.189.129.243
 voice-class codec 10  
 voice-class sip bind control source-interface Loopback1
 voice-class sip bind media source-interface Loopback1
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 15 voip
 description DGTIC A PSTN - Llamadas LDM
 destination-pattern 00[2-9]T
 session protocol sipv2
 session target ipv4:187.189.129.243
 voice-class codec 10  
 voice-class sip bind control source-interface Loopback1
 voice-class sip bind media source-interface Loopback1
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 16 voip
 description DGTIC A PSTN - Llamadas 01800
 destination-pattern 01800.......
 session protocol sipv2
 session target ipv4:187.189.129.243
 voice-class codec 10  
 voice-class sip bind control source-interface Loopback1
 voice-class sip bind media source-interface Loopback1
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 17 voip
 description DGTIC A PSTN- Llamadas Numeros Gratuitos
 destination-pattern 0[3467].
 session protocol sipv2
 session target ipv4:187.189.129.243
 voice-class codec 10  
 voice-class sip bind control source-interface Loopback1
 voice-class sip bind media source-interface Loopback1
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 100 voip
 description Llamadas  DE ENTRADA A DGTIC
 destination-pattern 61[0-9][0-9]
 session protocol sipv2
 session target ipv4:172.26.1.2
 voice-class codec 10  
 voice-class sip bind control source-interface GigabitEthernet0/0
 voice-class sip bind media source-interface GigabitEthernet0/0
 dtmf-relay rtp-nte sip-kpml sip-notify
 no vad
!
!
!
!
gatekeeper
 shutdown
!
!
telephony-service
 max-conferences 8 gain -6
 transfer-system full-consult
!
!         
banner motd ^C
=========================================================================

================
=========================================================================

================

|||||||||||            ||
     ||        |||||   ||    |||||      |||||   ||||||    |||     |||    

|||     |||     
     ||       ||  |||  ||   ||  |||   ||       ||    ||   ||  |||  ||    

||  |||  ||
     ||       ||       ||   ||        ||       ||    ||   ||       ||    

||       ||
     ||         ||||   ||     ||||      |||||    |||||    ||       ||    

||       ||

                      ||||||      ||    ||                  
                     ||     ||    ||    ||      ||||||||     |||||||
                     || ||| ||  |||||   ||    ||     ||    |||||
                     ||     ||    ||    ||    ||     ||         |||||
                     ||     ||    |||   ||      ||||||||     |||||||

=========================================================================

================
=========================================================================

================
**Unauthorized access to this network device is prohibited.**
You must have explicit permission to access or configure this
device.  All activities performed on this device are logged and
violations of this policy may result in disciplinary action.
=========================================================================

===============
=========================================================================

===============
^C
!
line con 0
 login local
 stopbits 1
line aux 0
 stopbits 1
line 2
 no activation-character
 no exec
 transport preferred none
 transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
!
end

 

The debug voip ccapi in the sending:

RO_AC_DGTIC#debug ccsip messages 
SIP Call messages tracing is enabled
RO_AC_DGTIC#
Jun 24 16:45:24: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received: 
INVITE sip:6100@10.227.19.233:5060 SIP/2.0
Via: SIP/2.0/UDP 187.189.129.243:5060;branch=z9hG4bK750C53
Remote-Party-ID: <sip:5524420252@187.189.129.243>;party=calling;screen=no;privacy=off
From: <sip:5524420252@187.189.129.243>;tag=4687B624-1EAD
To: <sip:6100@10.227.19.233>
Date: Tue, 24 Jun 2014 08:45:26 GMT
Call-ID: FFFFFFFFB8E400CC-FFFFFFFFFAB211E3-FFFFFFFF93E8C53B-FFFFFFFFEC8EA094@187.189.129.243
Supported: 100rel,timer,resource-priority,replaces,sdp-anat
Min-SE:  1800
Cisco-Guid: 3101910180-4205973987-2481112379-3968770196
User-Agent: Cisco-SIPGateway/IOS-15.3.3.S1
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
CSeq: 101 INVITE
Timestamp: 1403599526
Contact: <sip:5524420252@187.189.129.243:5060>
Call-Info: <sip:187.189.129.243:5060>;method="NOTIFY;Event=telephone-event;Duration=2000"
Expires: 180
Allow-Events: kpml, telephone-event
Max-Forwards: 66
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 315

v=0
o=CiscoSystemsSIP-GW-UserAgent 4860 1254 IN IP4 187.189.129.243
s=SIP Call
c=IN IP4 187.189.129.243
t=0 0
m=audio 19422 RTP/AVP 18 8 101 19
c=IN IP4 187.189.129.243
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:8 PCMA/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-15
a=rtpmap:19 CN/8000

Jun 24 16:45:24: //29/B8E364A493E2/SIP/Msg/ccsipDisplayMsg:
Sent: 
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 187.189.129.243:5060;branch=z9hG4bK750C53
From: <sip:5524420252@187.189.129.243>;tag=4687B624-1EAD
To: <sip:6100@10.227.19.233>
Date: Tue, 24 Jun 2014 16:45:24 GMT
Call-ID: FFFFFFFFB8E400CC-FFFFFFFFFAB211E3-FFFFFFFF93E8C53B-FFFFFFFFEC8EA094@187.189.129.243
Timestamp: 1403599526
CSeq: 101 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-15.4.1.T
Content-Length: 0


Jun 24 16:45:24: //30/B8E364A493E2/SIP/Msg/ccsipDisplayMsg:
Sent: 
INVITE sip:6100@172.26.1.2:5060 SIP/2.0
Via: SIP/2.0/UDP 172.26.1.1:5060;branch=z9hG4bKE2471
Remote-Party-ID: <sip:5524420252@172.26.1.1>;party=calling;screen=no;privacy=off
From: <sip:5524420252@172.26.1.1>;tag=4C4A440-1D3
To: <sip:6100@172.26.1.2>
Date: Tue, 24 Jun 2014 16:45:24 GMT
Call-ID: C59B4176-FAF511E3-805BDC73-8BA84171@172.26.1.1
Supported: 100rel,timer,resource-priority,replaces,sdp-anat
Min-SE:  1800
Cisco-Guid: 3101910180-4205973987-2481112379-3968770196
User-Agent: Cisco-SIPGateway/IOS-15.4.1.T
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
CSeq: 101 INVITE
Timestamp: 1403628324
Contact: <sip:5524420252@172.26.1.1:5060>
Call-Info: <sip:172.26.1.1:5060>;method="NOTIFY;Event=telephone-event;Duration=2000"
Expires: 180
Allow-Events: kpml, telephone-event
Max-Forwards: 65
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 288

v=0
o=CiscoSystemsSIP-GW-UserAgent 5553 9892 IN IP4 172.26.1.1
s=SIP Call
c=IN IP4 172.26.1.1
t=0 0
m=audio 16442 RTP/AVP 18 8 101
c=IN IP4 172.26.1.1
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:8 PCMA/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=ptime:20

Jun 24 16:45:24: //30/B8E364A493E2/SIP/Msg/ccsipDisplayMsg:
Received: 
SIP/2.0 488 Not Acceptable Media
Via: SIP/2.0/UDP 172.26.1.1:5060;branch=z9hG4bKE2471
From: <sip:5524420252@172.26.1.1>;tag=4C4A440-1D3
To: <sip:6100@172.26.1.2>;tag=85D59C2C-1D5C
Date: Tue, 24 Jun 2014 16:48:06 GMT
Call-ID: C59B4176-FAF511E3-805BDC73-8BA84171@172.26.1.1
Timestamp: 1403628324
CSeq: 101 INVITE
Allow-Events: telephone-event
Warning: 304 172.26.1.2 "Media Type(s) Unavailable"
Reason: Q.850;cause=65
Server: Cisco-SIPGateway/IOS-15.2.4.M4
Content-Length: 0


Jun 24 16:45:24: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent: 
ACK sip:6100@172.26.1.2:5060 SIP/2.0
Via: SIP/2.0/UDP 172.26.1.1:5060;branch=z9hG4bKE2471
From: <sip:5524420252@172.26.1.1>;tag=4C4A440-1D3
To: <sip:6100@172.26.1.2>;tag=85D59C2C-1D5C
Date: Tue, 24 Jun 2014 16:45:24 GMT
Call-ID: C59B4176-FAF511E3-805BDC73-8BA84171@172.26.1.1
Max-Forwards: 70
CSeq: 101 ACK
Allow-Events: kpml, telephone-event
Content-Length: 0


Jun 24 16:45:24: //29/B8E364A493E2/SIP/Msg/ccsipDisplayMsg:
Sent: 
SIP/2.0 500 Internal Server Error
Via: SIP/2.0/UDP 187.189.129.243:5060;branch=z9hG4bK750C53
From: <sip:5524420252@187.189.129.243>;tag=4687B624-1EAD
To: <sip:6100@10.227.19.233>;tag=4C4A444-1A42
Date: Tue, 24 Jun 2014 16:45:24 GMT
Call-ID: FFFFFFFFB8E400CC-FFFFFFFFFAB211E3-FFFFFFFF93E8C53B-FFFFFFFFEC8EA094@187.189.129.243
Timestamp: 1403599526
CSeq: 101 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-15.4.1.T
Reason: Q.850;cause=127
Content-Length: 0


Jun 24 16:45:24: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received: 
ACK sip:6100@10.227.19.233:5060 SIP/2.0
Via: SIP/2.0/UDP 187.189.129.243:5060;branch=z9hG4bK750C53
From: <sip:5524420252@187.189.129.243>;tag=4687B624-1EAD
To: <sip:6100@10.227.19.233>;tag=4C4A444-1A42
Date: Tue, 24 Jun 2014 08:45:26 GMT
Call-ID: FFFFFFFFB8E400CC-FFFFFFFFFAB211E3-FFFFFFFF93E8C53B-FFFFFFFFEC8EA094@187.189.129.243
Max-Forwards: 70
CSeq: 101 ACK
Allow-Events: kpml, telephone-event
Content-Length: 0

 

 

Community Member

Hi George, please receive the

Hi George, please receive the attached file: sh run of the customer Gateway, the one that sends the 488, and I copy the sh run of my sengind gateway:

 

RO_AC_DGTIC#sh run
Building configuration...


Current configuration : 11736 bytes
!
! Last configuration change at 10:47:58 CDT Tue Jun 24 2014 by cliente
! NVRAM config last updated at 10:37:51 CDT Tue Jun 24 2014 by cliente
!
version 15.4
service timestamps debug datetime
service timestamps log datetime localtime
service password-encryption
!
hostname RO_AC_DGTIC
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
! card type command needed for slot/vwic-slot 0/1
logging buffered 51200 warnings
logging console errors
enable secret 5 $1$aj7F$Kei4iMFn0SUrH7lecNNFY1
!
no aaa new-model
clock timezone CST -6 0
clock summer-time CDT recurring 1 Sun Apr 2:00 4 Sun Oct 2:00
clock calendar-valid
!
!
!
!
!
!         
!


!
ip vrf hospital_graham
 rd 6500:34
 route-target export 6500:34
 route-target import 6500:34
!
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool ccp-pool
 import all
 network 10.10.10.0 255.255.255.248
 default-router 10.10.10.1 
 lease 0 2
!
!
!
ip flow-cache timeout inactive 10
ip flow-cache timeout active 5
no ip domain lookup
ip domain name yourdomain.com
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!         
!
crypto pki trustpoint TP-self-signed-3489277466
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3489277466
 revocation-check none
 rsakeypair TP-self-signed-3489277466
!
!
crypto pki certificate chain TP-self-signed-3489277466
 certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030 
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 33343839 32373734 3636301E 170D3134 30313232 31393533 
  33355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649 
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 34383932 
  37373436 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 
  8100AB35 0A87E4DA 1ACD8540 AFEEE620 602514EA 22299F8C DB2F0E3E AA712C7F 
  589BC60E 122549FC 037A8E1F D4AACB14 645A6E16 89C74B8B B2E24FF8 C49C7B48 
  919C0A5F AF860FCB 6D26D152 D4A617A8 130AC676 46D31A75 3F30099F 0C7BDB5F 
  596C829C 55D155CF B93D48C8 B07ECEBD 09E2026F 25797D37 D591FF7C 63B9921D 
  9C110203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603 
  551D2304 18301680 14A57689 07B81A48 067070F1 7F9CDEE5 BD112158 D7301D06 
  03551D0E 04160414 A5768907 B81A4806 7070F17F 9CDEE5BD 112158D7 300D0609 
  2A864886 F70D0101 05050003 8181001E 9AF73B5B 8EEF5F00 E2591477 6A0B1B88 
  6DF1BAB0 45B19C62 D6186D02 811CA548 ABE26524 AFFEB1B3 B735074C 86415CCC 
  34E6BE23 2280C575 FB0389A9 E44070B5 7BC9CC96 C4A0BEB6 1BE89979 EAC3BEA7 
  D4CD8FEE B43C9A14 7FC89583 E95A0D19 2AF78C71 DE0A91C2 9F1278B3 E9FC13A5 
  476F44CF 6757DED4 416A07A3 06478C
        quit
voice-card 0
!
!         
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 sip
!
voice class codec 10
 codec preference 1 transparent
 codec preference 2 g711alaw
 codec preference 3 g711ulaw
 codec preference 4 g729r8
!
!
!
!
!
!
license udi pid C3900-SPE150/K9 sn FOC174684S6
license boot module c3900 technology-package uck9
hw-module pvdm 0/0
!
!
!
username cliente password 7 022154595A551D2F1C
username bytenet password 7 0306421F550172581C594851
!
redundancy
!
!         
ip tftp source-interface Loopback5
!
class-map match-any VLAN
 match vlan  100
 match vlan  200
 match vlan  10
class-map match-all VOICE-ALL
 match any 
class-map match-all CONTROL
 match precedence 6  7 
class-map match-all VOICE
 match dscp ef 
!
policy-map QOS-OUTPUT-CHILD
 class CONTROL
  bandwidth percent 3 
 class VOICE
  priority percent 30
 class class-default
  bandwidth percent 67 
  random-detect
policy-map PARENT-OUTPUT-TELECOMM
 class VLAN
  shape average 103000000
   service-policy QOS-OUTPUT-CHILD
policy-map INPUT-MARK-VOICE
 class VOICE-ALL
  set dscp ef
!
!
!
!         
!
interface Loopback0
 description TRAFICO_GESTION
 ip address 172.19.1.128 255.255.255.255
!
interface Loopback1
 description TRAFICO_VOZ
 ip address 10.227.19.233 255.255.255.255
!
interface Loopback5
 no ip address
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description TRAFICO_DGTIC_A_VGW_DGTIC_VOZ
 ip address 172.26.1.1 255.255.255.252
 duplex auto
 speed auto
 service-policy input INPUT-MARK-VOICE
!
interface GigabitEthernet0/1
 description B2B_TO_FORTINET_PUBLIC
 ip address 187.189.129.1 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 ip address 192.168.1.1 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/0/0
 description Link to ME_DI_VHS_PT_01
 no ip address
 ip flow ingress
 service-policy output PARENT-OUTPUT-TELECOMM
!
interface GigabitEthernet0/0/0.10
 description TRAFICO_GESTION_A_TELECOMM_ATLAS
 encapsulation dot1Q 10
 ip address 172.19.1.1 255.255.255.252
 ip flow ingress
!
interface GigabitEthernet0/0/0.100
 description TRAFICO_DATOS
 encapsulation dot1Q 100
 ip address 10.127.19.1 255.255.255.252
 ip flow ingress
!
interface GigabitEthernet0/0/0.200
 description TRAFICO_VOZ
 encapsulation dot1Q 200
 ip address 10.227.19.1 255.255.255.252
 ip flow ingress
!
interface GigabitEthernet0/2/0
 description Link to ME_DI_VHS_PT_01
 no ip address
!
interface GigabitEthernet0/2/0.100
 encapsulation dot1Q 100
 ip vrf forwarding hospital_graham
 ip address 10.127.19.93 255.255.255.252
!
interface GigabitEthernet0/3/0
 description TO RO_AC_HGRA
 no ip address
 duplex full
 speed 1000
!
interface GigabitEthernet0/3/0.100
 encapsulation dot1Q 100
 ip vrf forwarding hospital_graham
 ip address 187.189.129.93 255.255.255.252
!
!
ip forward-protocol nd
!
no ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip flow-export version 5
ip flow-export destination 192.168.2.2 9991
!
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/0.100 10.127.19.2
ip route 10.2.201.2 255.255.255.255 172.26.1.2
ip route 10.11.202.0 255.255.255.0 GigabitEthernet0/0 172.26.1.2
ip route 172.19.2.0 255.255.255.0 GigabitEthernet0/0/0.10 172.19.1.2
ip route 187.189.129.243 255.255.255.255 GigabitEthernet0/0/0.200 10.227.19.2
ip route 192.168.2.0 255.255.255.0 GigabitEthernet0/0/0.10 172.19.1.2
ip route 192.168.5.0 255.255.255.0 GigabitEthernet0/0/0.10 172.19.1.2
ip route vrf hospital_graham 0.0.0.0 0.0.0.0 10.127.19.94
!
!
nls resp-timeout 1
cpd cr-id 1
!
!
control-plane
!
call treatment on
call threshold global total-calls low 30 high 30
 !
 !
 !
 !
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
dial-peer voice 10 voip
 description DGTIC A PSTN - Llamadas Local
 destination-pattern [1-9]......
 session protocol sipv2
 session target ipv4:187.189.129.243
 voice-class codec 10  
 voice-class sip bind control source-interface Loopback1
 voice-class sip bind media source-interface Loopback1
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 11 voip
 description DGTIC A PSTN - Llamadas LDN
 destination-pattern 01..........
 session protocol sipv2
 session target ipv4:187.189.129.243
 voice-class codec 10  
 voice-class sip bind control source-interface Loopback1
 voice-class sip bind media source-interface Loopback1
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 12 voip
 description DGTIC A PSTN - Llamadas Cel_Local
 destination-pattern 044..........
 session protocol sipv2
 session target ipv4:187.189.129.243
 voice-class codec 10  
 voice-class sip bind control source-interface Loopback1
 voice-class sip bind media source-interface Loopback1
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 13 voip
 description DGTIC A PSTN- Llamadas Cel_LD
 destination-pattern 045..........
 session protocol sipv2
 session target ipv4:187.189.129.243
 voice-class codec 10  
 voice-class sip bind control source-interface Loopback1
 voice-class sip bind media source-interface Loopback1
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 14 voip
 description DGTIC A PSTN- Llamadas EUyCAN
 destination-pattern 001..........
 session protocol sipv2
 session target ipv4:187.189.129.243
 voice-class codec 10  
 voice-class sip bind control source-interface Loopback1
 voice-class sip bind media source-interface Loopback1
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 15 voip
 description DGTIC A PSTN - Llamadas LDM
 destination-pattern 00[2-9]T
 session protocol sipv2
 session target ipv4:187.189.129.243
 voice-class codec 10  
 voice-class sip bind control source-interface Loopback1
 voice-class sip bind media source-interface Loopback1
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 16 voip
 description DGTIC A PSTN - Llamadas 01800
 destination-pattern 01800.......
 session protocol sipv2
 session target ipv4:187.189.129.243
 voice-class codec 10  
 voice-class sip bind control source-interface Loopback1
 voice-class sip bind media source-interface Loopback1
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 17 voip
 description DGTIC A PSTN- Llamadas Numeros Gratuitos
 destination-pattern 0[3467].
 session protocol sipv2
 session target ipv4:187.189.129.243
 voice-class codec 10  
 voice-class sip bind control source-interface Loopback1
 voice-class sip bind media source-interface Loopback1
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 100 voip
 description Llamadas  DE ENTRADA A DGTIC
 destination-pattern 61[0-9][0-9]
 session protocol sipv2
 session target ipv4:172.26.1.2
 voice-class codec 10  
 voice-class sip bind control source-interface GigabitEthernet0/0
 voice-class sip bind media source-interface GigabitEthernet0/0
 dtmf-relay rtp-nte sip-kpml sip-notify
 no vad
!
!
!
!
gatekeeper
 shutdown
!
!
telephony-service
 max-conferences 8 gain -6
 transfer-system full-consult
!
!         
banner motd ^C
=========================================================================================
=========================================================================================

|||||||||||            ||
     ||        |||||   ||    |||||      |||||   ||||||    |||     |||    |||     |||     
     ||       ||  |||  ||   ||  |||   ||       ||    ||   ||  |||  ||    ||  |||  ||
     ||       ||       ||   ||        ||       ||    ||   ||       ||    ||       ||
     ||         ||||   ||     ||||      |||||    |||||    ||       ||    ||       ||

                      ||||||      ||    ||                  
                     ||     ||    ||    ||      ||||||||     |||||||
                     || ||| ||  |||||   ||    ||     ||    |||||
                     ||     ||    ||    ||    ||     ||         |||||
                     ||     ||    |||   ||      ||||||||     |||||||

=========================================================================================
=========================================================================================
**Unauthorized access to this network device is prohibited.**
You must have explicit permission to access or configure this
device.  All activities performed on this device are logged and
violations of this policy may result in disciplinary action.
========================================================================================
========================================================================================
^C
!
line con 0
 login local
 stopbits 1
line aux 0
 stopbits 1
line 2
 no activation-character
 no exec
 transport preferred none
 transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
!
end

On your customer's gateway

On your customer's gateway there are a tonne of H323 dial-peers and 2 SIp dial-peers. My guess is that the customer doesnt have an incoming dial-peer for SIP and the incoming call leg matches the H323 dial-peer and the call fails. I would add a incoming dial-peer at either  location (I dont see one at your site as well) 

Something like this:

dial-peer voice XX voip

incoming called-number .

codec g711ulaw

dtmf-relay rtp-nte.

Make sure you test it after you apply the configuration and make sure nothing else is affected on the customer's network. You might have to reorder the dial-peer in such a way that the incoming dial-peer is the first DP in the list.

Please rate useful posts.
Community Member

Hi George,Indeed there is a

Hi George,

Indeed there is a dial-peer for the incoming call that is failing:

 

dial-peer voice 300 voip
 description Llamadas DE ENTRADA A DID DP_S_ADMINISTRACION
 destination-pattern 61[0-9][0-9]
 session protocol sipv2
 session target ipv4:10.2.201.2
 voice-class codec 100  
 no voice-class sip early-offer forced
 voice-class sip bind control source-interface GigabitEthernet0/0
 voice-class sip bind media source-interface GigabitEthernet0/0
 dtmf-relay rtp-nte sip-kpml sip-notify
 no vad

Hi, Dial-peer 300 in not an

Hi,

 

Dial-peer 300 is not an inbound dial-peer , its an outbound dial-peer pointing to 10.2.201.2 ( i guess customer CUCM) , what you need to do is to create a new dial-peer as suggested above by George on customer gateway.

When I put the debug voice ccapi inout, I dont see my call in the debug from the customer gateway- Have you enabled terminal monitor on customer gateway ?

VIP Super Bronze

George, though he doesnt have

George, though he doesnt have an inbound dial-peer (and I agree for best practice he should configure a specific dial-peer) but the call matches an inbound dial-peer 10 (based on destination-pattern of the calling number)..So its not a dial-peer issue, because the voice ccapi logs shows that an inbound dial-peer is matched.

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
VIP Super Bronze

 Please send your full config

 

Please send your full config as suggested by friends here...However I see something a little funny. The format parameter used for DTMF has the range 0-16 (16 been for hook flash)..This is the only thing I see here that could be the cause of your issue. If you look at the working call..it only supports 0-15. By RFC the gateway should just ignore this and allow the call to go through..If this is indeed the issue then you may be looking at doing an IOS upgrade on the affected gateway

 

m=audio 17028 RTP/AVP 8 101
c=IN IP4 10.227.19.233
a=rtpmap:8 PCMA/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=ptime:20

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
Community Member

Hi Ayodeji, I attached the

Hi Ayodeji, I attached the config of the customer (The gateway that sends the 488). and I copy the config of the sending gateway, i also ccopy the debug of the: debug voip ccapi and debug ccsip messages (Both applied on the sending gateway); from the debug ccsip messa, I can see that this sending gateway changes the values of SDP that you talked about; it changes from 0 -15 to 0 -16.

 

Sh run of the sending Gateway:

 

RO_AC_DGTIC#sh run
Building configuration...


Current configuration : 11736 bytes
!
! Last configuration change at 10:47:58 CDT Tue Jun 24 2014 by cliente
! NVRAM config last updated at 10:37:51 CDT Tue Jun 24 2014 by cliente
!
version 15.4
service timestamps debug datetime
service timestamps log datetime localtime
service password-encryption
!
hostname RO_AC_DGTIC
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
! card type command needed for slot/vwic-slot 0/1
logging buffered 51200 warnings
logging console errors
enable secret 5 $1$aj7F$Kei4iMFn0SUrH7lecNNFY1
!
no aaa new-model
clock timezone CST -6 0
clock summer-time CDT recurring 1 Sun Apr 2:00 4 Sun Oct 2:00
clock calendar-valid
!
!
!
!
!
!         
!


!
ip vrf hospital_graham
 rd 6500:34
 route-target export 6500:34
 route-target import 6500:34
!
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool ccp-pool
 import all
 network 10.10.10.0 255.255.255.248
 default-router 10.10.10.1 
 lease 0 2
!
!
!
ip flow-cache timeout inactive 10
ip flow-cache timeout active 5
no ip domain lookup
ip domain name yourdomain.com
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!         
!
crypto pki trustpoint TP-self-signed-3489277466
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3489277466
 revocation-check none
 rsakeypair TP-self-signed-3489277466
!
!
crypto pki certificate chain TP-self-signed-3489277466
 certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030 
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 33343839 32373734 3636301E 170D3134 30313232 31393533 
  33355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649 
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 34383932 
  37373436 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 
  8100AB35 0A87E4DA 1ACD8540 AFEEE620 602514EA 22299F8C DB2F0E3E AA712C7F 
  589BC60E 122549FC 037A8E1F D4AACB14 645A6E16 89C74B8B B2E24FF8 C49C7B48 
  919C0A5F AF860FCB 6D26D152 D4A617A8 130AC676 46D31A75 3F30099F 0C7BDB5F 
  596C829C 55D155CF B93D48C8 B07ECEBD 09E2026F 25797D37 D591FF7C 63B9921D 
  9C110203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603 
  551D2304 18301680 14A57689 07B81A48 067070F1 7F9CDEE5 BD112158 D7301D06 
  03551D0E 04160414 A5768907 B81A4806 7070F17F 9CDEE5BD 112158D7 300D0609 
  2A864886 F70D0101 05050003 8181001E 9AF73B5B 8EEF5F00 E2591477 6A0B1B88 
  6DF1BAB0 45B19C62 D6186D02 811CA548 ABE26524 AFFEB1B3 B735074C 86415CCC 
  34E6BE23 2280C575 FB0389A9 E44070B5 7BC9CC96 C4A0BEB6 1BE89979 EAC3BEA7 
  D4CD8FEE B43C9A14 7FC89583 E95A0D19 2AF78C71 DE0A91C2 9F1278B3 E9FC13A5 
  476F44CF 6757DED4 416A07A3 06478C
        quit
voice-card 0
!
!         
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 sip
!
voice class codec 10
 codec preference 1 transparent
 codec preference 2 g711alaw
 codec preference 3 g711ulaw
 codec preference 4 g729r8
!
!
!
!
!
!
license udi pid C3900-SPE150/K9 sn FOC174684S6
license boot module c3900 technology-package uck9
hw-module pvdm 0/0
!
!
!
username cliente password 7 022154595A551D2F1C
username bytenet password 7 0306421F550172581C594851
!
redundancy
!
!         
ip tftp source-interface Loopback5
!
class-map match-any VLAN
 match vlan  100
 match vlan  200
 match vlan  10
class-map match-all VOICE-ALL
 match any 
class-map match-all CONTROL
 match precedence 6  7 
class-map match-all VOICE
 match dscp ef 
!
policy-map QOS-OUTPUT-CHILD
 class CONTROL
  bandwidth percent 3 
 class VOICE
  priority percent 30
 class class-default
  bandwidth percent 67 
  random-detect
policy-map PARENT-OUTPUT-TELECOMM
 class VLAN
  shape average 103000000
   service-policy QOS-OUTPUT-CHILD
policy-map INPUT-MARK-VOICE
 class VOICE-ALL
  set dscp ef
!
!
!
!         
!
interface Loopback0
 description TRAFICO_GESTION
 ip address 172.19.1.128 255.255.255.255
!
interface Loopback1
 description TRAFICO_VOZ
 ip address 10.227.19.233 255.255.255.255
!
interface Loopback5
 no ip address
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description TRAFICO_DGTIC_A_VGW_DGTIC_VOZ
 ip address 172.26.1.1 255.255.255.252
 duplex auto
 speed auto
 service-policy input INPUT-MARK-VOICE
!
interface GigabitEthernet0/1
 description B2B_TO_FORTINET_PUBLIC
 ip address 187.189.129.1 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 ip address 192.168.1.1 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/0/0
 description Link to ME_DI_VHS_PT_01
 no ip address
 ip flow ingress
 service-policy output PARENT-OUTPUT-TELECOMM
!
interface GigabitEthernet0/0/0.10
 description TRAFICO_GESTION_A_TELECOMM_ATLAS
 encapsulation dot1Q 10
 ip address 172.19.1.1 255.255.255.252
 ip flow ingress
!
interface GigabitEthernet0/0/0.100
 description TRAFICO_DATOS
 encapsulation dot1Q 100
 ip address 10.127.19.1 255.255.255.252
 ip flow ingress
!
interface GigabitEthernet0/0/0.200
 description TRAFICO_VOZ
 encapsulation dot1Q 200
 ip address 10.227.19.1 255.255.255.252
 ip flow ingress
!
interface GigabitEthernet0/2/0
 description Link to ME_DI_VHS_PT_01
 no ip address
!
interface GigabitEthernet0/2/0.100
 encapsulation dot1Q 100
 ip vrf forwarding hospital_graham
 ip address 10.127.19.93 255.255.255.252
!
interface GigabitEthernet0/3/0
 description TO RO_AC_HGRA
 no ip address
 duplex full
 speed 1000
!
interface GigabitEthernet0/3/0.100
 encapsulation dot1Q 100
 ip vrf forwarding hospital_graham
 ip address 187.189.129.93 255.255.255.252
!
!
ip forward-protocol nd
!
no ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip flow-export version 5
ip flow-export destination 192.168.2.2 9991
!
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/0.100 10.127.19.2
ip route 10.2.201.2 255.255.255.255 172.26.1.2
ip route 10.11.202.0 255.255.255.0 GigabitEthernet0/0 172.26.1.2
ip route 172.19.2.0 255.255.255.0 GigabitEthernet0/0/0.10 172.19.1.2
ip route 187.189.129.243 255.255.255.255 GigabitEthernet0/0/0.200 

10.227.19.2
ip route 192.168.2.0 255.255.255.0 GigabitEthernet0/0/0.10 172.19.1.2
ip route 192.168.5.0 255.255.255.0 GigabitEthernet0/0/0.10 172.19.1.2
ip route vrf hospital_graham 0.0.0.0 0.0.0.0 10.127.19.94
!
!
nls resp-timeout 1
cpd cr-id 1
!
!
control-plane
!
call treatment on
call threshold global total-calls low 30 high 30
 !
 !
 !
 !
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
dial-peer voice 10 voip
 description DGTIC A PSTN - Llamadas Local
 destination-pattern [1-9]......
 session protocol sipv2
 session target ipv4:187.189.129.243
 voice-class codec 10  
 voice-class sip bind control source-interface Loopback1
 voice-class sip bind media source-interface Loopback1
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 11 voip
 description DGTIC A PSTN - Llamadas LDN
 destination-pattern 01..........
 session protocol sipv2
 session target ipv4:187.189.129.243
 voice-class codec 10  
 voice-class sip bind control source-interface Loopback1
 voice-class sip bind media source-interface Loopback1
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 12 voip
 description DGTIC A PSTN - Llamadas Cel_Local
 destination-pattern 044..........
 session protocol sipv2
 session target ipv4:187.189.129.243
 voice-class codec 10  
 voice-class sip bind control source-interface Loopback1
 voice-class sip bind media source-interface Loopback1
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 13 voip
 description DGTIC A PSTN- Llamadas Cel_LD
 destination-pattern 045..........
 session protocol sipv2
 session target ipv4:187.189.129.243
 voice-class codec 10  
 voice-class sip bind control source-interface Loopback1
 voice-class sip bind media source-interface Loopback1
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 14 voip
 description DGTIC A PSTN- Llamadas EUyCAN
 destination-pattern 001..........
 session protocol sipv2
 session target ipv4:187.189.129.243
 voice-class codec 10  
 voice-class sip bind control source-interface Loopback1
 voice-class sip bind media source-interface Loopback1
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 15 voip
 description DGTIC A PSTN - Llamadas LDM
 destination-pattern 00[2-9]T
 session protocol sipv2
 session target ipv4:187.189.129.243
 voice-class codec 10  
 voice-class sip bind control source-interface Loopback1
 voice-class sip bind media source-interface Loopback1
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 16 voip
 description DGTIC A PSTN - Llamadas 01800
 destination-pattern 01800.......
 session protocol sipv2
 session target ipv4:187.189.129.243
 voice-class codec 10  
 voice-class sip bind control source-interface Loopback1
 voice-class sip bind media source-interface Loopback1
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 17 voip
 description DGTIC A PSTN- Llamadas Numeros Gratuitos
 destination-pattern 0[3467].
 session protocol sipv2
 session target ipv4:187.189.129.243
 voice-class codec 10  
 voice-class sip bind control source-interface Loopback1
 voice-class sip bind media source-interface Loopback1
 dtmf-relay sip-notify rtp-nte
!
dial-peer voice 100 voip
 description Llamadas  DE ENTRADA A DGTIC
 destination-pattern 61[0-9][0-9]
 session protocol sipv2
 session target ipv4:172.26.1.2
 voice-class codec 10  
 voice-class sip bind control source-interface GigabitEthernet0/0
 voice-class sip bind media source-interface GigabitEthernet0/0
 dtmf-relay rtp-nte sip-kpml sip-notify
 no vad
!
!
!
!
gatekeeper
 shutdown
!
!
telephony-service
 max-conferences 8 gain -6
 transfer-system full-consult
!
!         
banner motd ^C
=========================================================================

================
=========================================================================

================

|||||||||||            ||
     ||        |||||   ||    |||||      |||||   ||||||    |||     |||    

|||     |||     
     ||       ||  |||  ||   ||  |||   ||       ||    ||   ||  |||  ||    

||  |||  ||
     ||       ||       ||   ||        ||       ||    ||   ||       ||    

||       ||
     ||         ||||   ||     ||||      |||||    |||||    ||       ||    

||       ||

                      ||||||      ||    ||                  
                     ||     ||    ||    ||      ||||||||     |||||||
                     || ||| ||  |||||   ||    ||     ||    |||||
                     ||     ||    ||    ||    ||     ||         |||||
                     ||     ||    |||   ||      ||||||||     |||||||

=========================================================================

================
=========================================================================

================
**Unauthorized access to this network device is prohibited.**
You must have explicit permission to access or configure this
device.  All activities performed on this device are logged and
violations of this policy may result in disciplinary action.
=========================================================================

===============
=========================================================================

===============
^C
!
line con 0
 login local
 stopbits 1
line aux 0
 stopbits 1
line 2
 no activation-character
 no exec
 transport preferred none
 transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
!
end

 

 

debug ccsip messages:

RO_AC_DGTIC#debug ccsip messages 
SIP Call messages tracing is enabled
RO_AC_DGTIC#
Jun 24 16:45:24: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received: 
INVITE sip:6100@10.227.19.233:5060 SIP/2.0
Via: SIP/2.0/UDP 187.189.129.243:5060;branch=z9hG4bK750C53
Remote-Party-ID: <sip:5524420252@187.189.129.243>;party=calling;screen=no;privacy=off
From: <sip:5524420252@187.189.129.243>;tag=4687B624-1EAD
To: <sip:6100@10.227.19.233>
Date: Tue, 24 Jun 2014 08:45:26 GMT
Call-ID: FFFFFFFFB8E400CC-FFFFFFFFFAB211E3-FFFFFFFF93E8C53B-FFFFFFFFEC8EA094@187.189.129.243
Supported: 100rel,timer,resource-priority,replaces,sdp-anat
Min-SE:  1800
Cisco-Guid: 3101910180-4205973987-2481112379-3968770196
User-Agent: Cisco-SIPGateway/IOS-15.3.3.S1
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
CSeq: 101 INVITE
Timestamp: 1403599526
Contact: <sip:5524420252@187.189.129.243:5060>
Call-Info: <sip:187.189.129.243:5060>;method="NOTIFY;Event=telephone-event;Duration=2000"
Expires: 180
Allow-Events: kpml, telephone-event
Max-Forwards: 66
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 315

v=0
o=CiscoSystemsSIP-GW-UserAgent 4860 1254 IN IP4 187.189.129.243
s=SIP Call
c=IN IP4 187.189.129.243
t=0 0
m=audio 19422 RTP/AVP 18 8 101 19
c=IN IP4 187.189.129.243
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:8 PCMA/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-15
a=rtpmap:19 CN/8000

Jun 24 16:45:24: //29/B8E364A493E2/SIP/Msg/ccsipDisplayMsg:
Sent: 
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 187.189.129.243:5060;branch=z9hG4bK750C53
From: <sip:5524420252@187.189.129.243>;tag=4687B624-1EAD
To: <sip:6100@10.227.19.233>
Date: Tue, 24 Jun 2014 16:45:24 GMT
Call-ID: FFFFFFFFB8E400CC-FFFFFFFFFAB211E3-FFFFFFFF93E8C53B-FFFFFFFFEC8EA094@187.189.129.243
Timestamp: 1403599526
CSeq: 101 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-15.4.1.T
Content-Length: 0


Jun 24 16:45:24: //30/B8E364A493E2/SIP/Msg/ccsipDisplayMsg:
Sent: 
INVITE sip:6100@172.26.1.2:5060 SIP/2.0
Via: SIP/2.0/UDP 172.26.1.1:5060;branch=z9hG4bKE2471
Remote-Party-ID: <sip:5524420252@172.26.1.1>;party=calling;screen=no;privacy=off
From: <sip:5524420252@172.26.1.1>;tag=4C4A440-1D3
To: <sip:6100@172.26.1.2>
Date: Tue, 24 Jun 2014 16:45:24 GMT
Call-ID: C59B4176-FAF511E3-805BDC73-8BA84171@172.26.1.1
Supported: 100rel,timer,resource-priority,replaces,sdp-anat
Min-SE:  1800
Cisco-Guid: 3101910180-4205973987-2481112379-3968770196
User-Agent: Cisco-SIPGateway/IOS-15.4.1.T
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
CSeq: 101 INVITE
Timestamp: 1403628324
Contact: <sip:5524420252@172.26.1.1:5060>
Call-Info: <sip:172.26.1.1:5060>;method="NOTIFY;Event=telephone-event;Duration=2000"
Expires: 180
Allow-Events: kpml, telephone-event
Max-Forwards: 65
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 288

v=0
o=CiscoSystemsSIP-GW-UserAgent 5553 9892 IN IP4 172.26.1.1
s=SIP Call
c=IN IP4 172.26.1.1
t=0 0
m=audio 16442 RTP/AVP 18 8 101
c=IN IP4 172.26.1.1
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:8 PCMA/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=ptime:20

Jun 24 16:45:24: //30/B8E364A493E2/SIP/Msg/ccsipDisplayMsg:
Received: 
SIP/2.0 488 Not Acceptable Media
Via: SIP/2.0/UDP 172.26.1.1:5060;branch=z9hG4bKE2471
From: <sip:5524420252@172.26.1.1>;tag=4C4A440-1D3
To: <sip:6100@172.26.1.2>;tag=85D59C2C-1D5C
Date: Tue, 24 Jun 2014 16:48:06 GMT
Call-ID: C59B4176-FAF511E3-805BDC73-8BA84171@172.26.1.1
Timestamp: 1403628324
CSeq: 101 INVITE
Allow-Events: telephone-event
Warning: 304 172.26.1.2 "Media Type(s) Unavailable"
Reason: Q.850;cause=65
Server: Cisco-SIPGateway/IOS-15.2.4.M4
Content-Length: 0


Jun 24 16:45:24: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent: 
ACK sip:6100@172.26.1.2:5060 SIP/2.0
Via: SIP/2.0/UDP 172.26.1.1:5060;branch=z9hG4bKE2471
From: <sip:5524420252@172.26.1.1>;tag=4C4A440-1D3
To: <sip:6100@172.26.1.2>;tag=85D59C2C-1D5C
Date: Tue, 24 Jun 2014 16:45:24 GMT
Call-ID: C59B4176-FAF511E3-805BDC73-8BA84171@172.26.1.1
Max-Forwards: 70
CSeq: 101 ACK
Allow-Events: kpml, telephone-event
Content-Length: 0


Jun 24 16:45:24: //29/B8E364A493E2/SIP/Msg/ccsipDisplayMsg:
Sent: 
SIP/2.0 500 Internal Server Error
Via: SIP/2.0/UDP 187.189.129.243:5060;branch=z9hG4bK750C53
From: <sip:5524420252@187.189.129.243>;tag=4687B624-1EAD
To: <sip:6100@10.227.19.233>;tag=4C4A444-1A42
Date: Tue, 24 Jun 2014 16:45:24 GMT
Call-ID: FFFFFFFFB8E400CC-FFFFFFFFFAB211E3-FFFFFFFF93E8C53B-FFFFFFFFEC8EA094@187.189.129.243
Timestamp: 1403599526
CSeq: 101 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-15.4.1.T
Reason: Q.850;cause=127
Content-Length: 0


Jun 24 16:45:24: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received: 
ACK sip:6100@10.227.19.233:5060 SIP/2.0
Via: SIP/2.0/UDP 187.189.129.243:5060;branch=z9hG4bK750C53
From: <sip:5524420252@187.189.129.243>;tag=4687B624-1EAD
To: <sip:6100@10.227.19.233>;tag=4C4A444-1A42
Date: Tue, 24 Jun 2014 08:45:26 GMT
Call-ID: FFFFFFFFB8E400CC-FFFFFFFFFAB211E3-FFFFFFFF93E8C53B-FFFFFFFFEC8EA094@187.189.129.243
Max-Forwards: 70
CSeq: 101 ACK
Allow-Events: kpml, telephone-event
Content-Length: 0

 

debug voip ccapi messages:

RO_AC_DGTIC#debug voip ccapi inout
voip ccapi inout debugging is on
RO_AC_DGTIC#debug voip ccapi inout
voip ccapi inout debugging is on
RO_AC_DGTIC#
Jun 24 16:30:19: //-1/9DCA5B4A93D5/CCAPI/cc_api_display_ie_subfields:
   cc_api_call_setup_ind_common:
   cisco-username=9932018628
   ----- ccCallInfo IE subfields -----
   cisco-ani=9932018628
   cisco-anitype=0
   cisco-aniplan=0
   cisco-anipi=0
   cisco-anisi=0
   dest=6100
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-rdntype=0
   cisco-rdnplan=0
   cisco-rdnpi=-1
   cisco-rdnsi=-1
   cisco-redirectreason=-1   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

Jun 24 16:30:19: //-1/9DCA5B4A93D5/CCAPI/cc_api_call_setup_ind_common:
   Interface=0x31491C8, Call Info(
   Calling Number=9932018628,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=6100(TON=Unknown, NPI=Unknown),
   Calling Translated=FALSE, Subscriber Type Str=Unknown, FinalDestinationFlag=TRUE,
   Incoming Dial-peer=10, Progress Indication=NULL(0), Calling IE Present=TRUE,
   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=27
Jun 24 16:30:19: //-1/9DCA5B4A93D5/CCAPI/ccCheckClipClir:
   In: Calling Number=9932018628(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
Jun 24 16:30:19: //-1/9DCA5B4A93D5/CCAPI/ccCheckClipClir:
   Out: Calling Number=9932018628(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
Jun 24 16:30:19: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
Jun 24 16:30:19: :cc_get_feature_vsa malloc success
Jun 24 16:30:19: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
Jun 24 16:30:19:  cc_get_feature_vsa count is 1
Jun 24 16:30:19: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
Jun 24 16:30:19: :FEATURE_VSA attributes are: feature_name:0,feature_time:17103120,feature_id:27
Jun 24 16:30:19: //27/9DCA5B4A93D5/CCAPI/cc_api_call_setup_ind_common:
   Set Up Event Sent;
   Call Info(Calling Number=9932018628(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=6100(TON=Unknown, NPI=Unknown))
Jun 24 16:30:19: //27/9DCA5B4A93D5/CCAPI/cc_process_call_setup_ind:
   Event=0x14D0D248
Jun 24 16:30:19: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_search:
   Try with the demoted called number 6100
Jun 24 16:30:19: //27/9DCA5B4A93D5/CCAPI/ccCallSetContext:
   Context=0x2D1801C
Jun 24 16:30:19: //27/9DCA5B4A93D5/CCAPI/cc_process_call_setup_ind:
   >>>>CCAPI handed cid 27 with tag 10 to app "_ManagedAppProcess_Default"
Jun 24 16:30:19: //27/9DCA5B4A93D5/CCAPI/ccCallProceeding:
   Progress Indication=NULL(0)
Jun 24 16:30:19: //27/9DCA5B4A93D5/CCAPI/ccCallSetupRequest:
   Destination=, Calling IE Present=TRUE, Mode=0,
   Outgoing Dial-peer=100, Params=0x2D16ACC, Progress Indication=NULL(0)
Jun 24 16:30:19: //27/9DCA5B4A93D5/CCAPI/ccCheckClipClir:
   In: Calling Number=9932018628(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
Jun 24 16:30:19: //27/9DCA5B4A93D5/CCAPI/ccCheckClipClir:
   Out: Calling Number=9932018628(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
Jun 24 16:30:19: //27/9DCA5B4A93D5/CCAPI/ccCallSetupRequest:
   Destination Pattern=61[0-9][0-9], Called Number=6100, Digit Strip=FALSE
Jun 24 16:30:19: //27/9DCA5B4A93D5/CCAPI/ccCallSetupRequest:
   Calling Number=9932018628(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=6100(TON=Unknown, NPI=Unknown),
   Redirect Number=, Display Info=
   Account Number=9932018628, Final Destination Flag=TRUE,
   Guid=9DCA5B4A-FAB0-11E3-93D5-C53BEC8EA094, Outgoing Dial-peer=100
Jun 24 16:30:19: //27/9DCA5B4A93D5/CCAPI/cc_api_display_ie_subfields:
   ccCallSetupRequest:
   cisco-username=9932018628
   ----- ccCallInfo IE subfields -----
   cisco-ani=9932018628
   cisco-anitype=0
   cisco-aniplan=0
   cisco-anipi=0
   cisco-anisi=0
   dest=6100
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-rdntype=0
   cisco-rdnplan=0
   cisco-rdnpi=-1
   cisco-rdnsi=-1
   cisco-redirectreason=-1   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

Jun 24 16:30:19: //27/9DCA5B4A93D5/CCAPI/ccIFCallSetupRequestPrivate:
   Interface=0x31491C8, Interface Type=3, Destination=, Mode=0x0,
   Call Params(Calling Number=9932018628,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
   Called Number=6100(TON=Unknown, NPI=Unknown), Calling Translated=FALSE,
   Subscriber Type Str=Unknown, FinalDestinationFlag=TRUE, Outgoing Dial-peer=100, Call Count On=FALSE,
   Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Application Call Id=)
Jun 24 16:30:19: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
Jun 24 16:30:19: :cc_get_feature_vsa malloc success
Jun 24 16:30:19: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
Jun 24 16:30:19:  cc_get_feature_vsa count is 2
Jun 24 16:30:19: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:
   
Jun 24 16:30:19: :FEATURE_VSA attributes are: feature_name:0,feature_time:17102896,feature_id:28
Jun 24 16:30:19: //27/9DCA5B4A93D5/CCAPI/cc_api_event_indication:
   Event=101, Call Id=27
Jun 24 16:30:19: //27/9DCA5B4A93D5/CCAPI/cc_api_event_indication:
   Event Is Sent To Conferenced SPI(s) Directly
Jun 24 16:30:19: //28/9DCA5B4A93D5/CCAPI/ccIFCallSetupRequestPrivate:
   SPI Call Setup Request Is Success; Interface Type=3, FlowMode=1
Jun 24 16:30:19: //28/9DCA5B4A93D5/CCAPI/ccCallSetContext:
   Context=0x2D16A7C
Jun 24 16:30:19: //27/9DCA5B4A93D5/CCAPI/ccSaveDialpeerTag:
   Outgoing Dial-peer=100
Jun 24 16:30:19: //28/9DCA5B4A93D5/CCAPI/ccGetMediaClassTag:
   media class tag 0
Jun 24 16:30:19: //28/9DCA5B4A93D5/CCAPI/ccSetMediaclassIp2ipTags:
   media class tags set: NR 0, ASP 0
Jun 24 16:30:19: //27/9DCA5B4A93D5/CCAPI/ccGetMediaClassTag:
   media class tag 0
Jun 24 16:30:19: //27/9DCA5B4A93D5/CCAPI/ccSetMediaclassIp2ipTags:
   media class tags set: NR 0, ASP 0
Jun 24 16:30:19: //28/9DCA5B4A93D5/CCAPI/ccGet_xc_nr_asp_info:
   media class tags: NR 0, ASP 0
Jun 24 16:30:19: //27/9DCA5B4A93D5/CCAPI/ccGet_xc_nr_asp_info:
   media class tags: NR 0, ASP 0
Jun 24 16:30:19: //28/9DCA5B4A93D5/CCAPI/cc_api_event_indication:
   Event=193, Call Id=28
Jun 24 16:30:19: //28/9DCA5B4A93D5/CCAPI/cc_api_event_indication:
   Event Is Sent To Conferenced SPI(s) Directly
Jun 24 16:30:19: //27/xxxxxxxxxxxx/CCAPI/cc_api_get_xcode_stream:
   
Jun 24 16:30:19: cc_api_get_xcode_stream : 4982
Jun 24 16:30:19: //28/xxxxxxxxxxxx/CCAPI/cc_api_get_xcode_stream:
   
Jun 24 16:30:19: cc_api_get_xcode_stream : 4982
Jun 24 16:30:19: //27/xxxxxxxxxxxx/CCAPI/cc_api_get_xcode_stream:
   
Jun 24 16:30:19: cc_api_get_xcode_stream : 4982
Jun 24 16:30:19: //27/xxxxxxxxxxxx/CCAPI/cc_api_get_xcode_stream:
   
Jun 24 16:30:19: cc_api_get_xcode_stream : 4982
Jun 24 16:30:19: //28/xxxxxxxxxxxx/CCAPI/cc_api_get_xcode_stream:
   
Jun 24 16:30:19: cc_api_get_xcode_stream : 4982
Jun 24 16:30:19: //27/xxxxxxxxxxxx/CCAPI/cc_api_get_xcode_stream:
   
Jun 24 16:30:19: cc_api_get_xcode_stream : 4982
Jun 24 16:30:19: //28/xxxxxxxxxxxx/CCAPI/cc_api_get_xcode_stream:
   
Jun 24 16:30:19: cc_api_get_xcode_stream : 4982
Jun 24 16:30:19: //28/xxxxxxxxxxxx/CCAPI/cc_api_get_xcode_stream:
   
Jun 24 16:30:19: cc_api_get_xcode_stream : 4982
Jun 24 16:30:19: //28/9DCA5B4A93D5/CCAPI/cc_api_call_proceeding:
   Interface=0x31491C8, Progress Indication=NULL(0)
Jun 24 16:30:19: //28/9DCA5B4A93D5/CCAPI/cc_api_call_disconnected:
   Cause Value=57, Interface=0x31491C8, Call Id=28
Jun 24 16:30:19: //28/9DCA5B4A93D5/CCAPI/cc_api_call_disconnected:
   Call Entry(Responsed=TRUE, Cause Value=57, Retry Count=0)
Jun 24 16:30:19: //27/9DCA5B4A93D5/CCAPI/ccCallReleaseResources:
   release reserved xcoding resource.
Jun 24 16:30:19: //28/9DCA5B4A93D5/CCAPI/ccCallSetAAA_Accounting:
   Accounting=0, Call Id=28
Jun 24 16:30:19: //28/9DCA5B4A93D5/CCAPI/ccCallDisconnect:
   Cause Value=57, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=57)
Jun 24 16:30:19: //28/9DCA5B4A93D5/CCAPI/ccCallDisconnect:
   Cause Value=57, Call Entry(Responsed=TRUE, Cause Value=57)
Jun 24 16:30:19: //28/9DCA5B4A93D5/CCAPI/cc_api_call_disconnect_done:
   Disposition=0, Interface=0x31491C8, Tag=0x0, Call Id=28,
   Call Entry(Disconnect Cause=57, Voice Class Cause Code=0, Retry Count=0)
Jun 24 16:30:19: //28/9DCA5B4A93D5/CCAPI/cc_api_call_disconnect_done:
   Call Disconnect Event Sent
Jun 24 16:30:19: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
Jun 24 16:30:19: :cc_free_feature_vsa freeing 104F828
Jun 24 16:30:19: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
Jun 24 16:30:19:  vsacount in free is 1
Jun 24 16:30:19: //27/9DCA5B4A93D5/CCAPI/ccCallDisconnect:
   Cause Value=57, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)
Jun 24 16:30:19: //27/9DCA5B4A93D5/CCAPI/ccCallDisconnect:
   Cause Value=57, Call Entry(Responsed=TRUE, Cause Value=57)
Jun 24 16:30:19: //27/9DCA5B4A93D5/CCAPI/cc_api_call_disconnect_done:
   Disposition=0, Interface=0x31491C8, Tag=0x0, Call Id=27,
   Call Entry(Disconnect Cause=57, Voice Class Cause Code=0, Retry Count=0)
Jun 24 16:30:19: //27/9DCA5B4A93D5/CCAPI/cc_api_call_disconnect_done:
   Call Disconnect Event Sent
Jun 24 16:30:19: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
Jun 24 16:30:19: :cc_free_feature_vsa freeing 104F908
Jun 24 16:30:19: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:
   
Jun 24 16:30:19:  vsacount in free is 0

 

 

 

 

VIP Super Bronze

Ok..looking at your config..

Ok..looking at your config...You cant use transparen codec on both inbound and outbound dial-peers.If you plan to configure both incoming and outgoing dial peers, you must specify the transparent codec on the incoming dial peer.

Can you do the ff:

1. Remove codec preference 1 transparent from the voice class codec and test again

2. configure your voice class codec with codec transparency and then on the outbound dial-peer 100, ensure that you set a valid codec (either use a voice class codec with no transparency or manually configure a codec on the dial-peer)

 

 

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
1609
Views
0
Helpful
11
Replies
CreatePlease to create content