Cisco Support Community
Community Member

Cisco JTAPI problem

6.1 (2.1000) - 13 is the call manager

6.1 (2.1000) - 12 is the JTAPI Client

The problem that we are having is with the JTAPI client connecting to the Cisco Communications Manager. Initially we tried to connect with the Audiolog server and were unable to get connected. I sent logs to Verint to be analyzed by both technical support and development. In both cases I was told that the problem was caused by the JTAPI client. This made me wonder if there was a tool that I could test connectivity without having the Audiolog application in play, and sure enough after reading the Read Me documentation on the JTAPI tool I found a tool called JTrace. This tool allows me to try and make a connection with the CCM based upon a user name and password. I attempted to do this several times but kept receiving the following: Unable to create provider -- Connection refused: connect. I checked against the wrapper log that the JTAPI client produces and this is the same error that I was getting when the Audiolog was trying to connect. Being unsure if this JTrace tool really worked or not I tested the application on a machine that is at another customer's site that is functioning properly and the tool worked; I was able to connect with my credentials. I believe that if we can successfully get this JTrace tool to connect then we will be fine when the Audiolog server tries to connect.

One major obstacle is that the client does not have anyone who is an expert on the CCM or JTAPI applications. We were able to create an account, assign devices to the account, and set groups and permissions, but when we tried to uses those credentials on the CCMUsers page it did not allow us to log in. Again at the other client's site I am able to do this. I am not sure if these two issues go hand-in-hand, but I just wanted to throw that out there. I have attached a copy of the wrapper.log which is the connection log for the JTAPI client. Let me know if there is anything else that I can do to help with this issue. The client is very helpful, but this is a very confidential network so access is very limited.


Community Member

Re: Cisco JTAPI problem

We found out that the issue was that the system did not have service observe enabled and that fixed the issue.

CreatePlease to create content