Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Cisco Phones never switch to voice VLAN after switch reboot

Hello,

I have just come across an issue during a new VoIP deployment.

We are using 3750G switches for access switches running IOS c3750-ipbasek9-mz.122-37.SE1.

The phones are a mix of Cisco 7965 and 7841s.

When I reload a switch all of the phones never switch over to the voice VLAN as I assume they should. The mac address table for a port with a phone and computer has 2 entries. 1 for the phone and 1 for the computer. Both in the data VLAN.

Here is a standard port config.

switchport access vlan 33

switchport mode access

switchport voice vlan 613

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape  10  0  0  0

queue-set 2

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

To fix the issue I just bounce all of the ports on the switch and the phones come back up in the correct VLAN. I know that during the bootup process the phones negotiate the voice VLAN and I know the phones come up before the switch fully boots. However I would assume the phone should switch VLANs based on information it receives via CDP.

Any help would be appreciated.

Elton

5 REPLIES
Community Member

Re:Cisco Phones never switch to voice VLAN after switch reboot

Can you post full show config? And show vlan ?


Sent from Cisco Technical Support Android App

Cisco Phones never switch to voice VLAN after switch reboot

Here ya go. I removed most of the access port configs as they were all the same and take up a lot of space.

version 12.2

no service pad

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

service sequence-numbers

!

hostname 310RM-3750-ST1

!

logging buffered 8092 informational

enable secret 5 XXXXXXXXXXXXXXXXXX

enable password 7 XXXXXXXXXXXXXX

!

username tacacsdown privilege 15 secret 5 XXXXXXXXXXXXX

aaa new-model

aaa group server radius RADIUSGROUP

server 10.69.16.100 auth-port 1812 acct-port 1813

server 10.69.17.20 auth-port 1812 acct-port 1813

!

aaa group server tacacs+ XXXXXXXXXX

server 10.38.96.28

server 10.38.96.29

server 10.39.96.29

!

aaa authentication login default group XXXXXXXX local

aaa authorization exec default group XXXXXXXXX local

aaa accounting exec default start-stop group XXXXXXXXX

!

aaa session-id common

clock timezone est -5

clock summer-time EDT recurring

switch 1 provision ws-c3750g-48ps

switch 2 provision ws-c3750g-48ps

system mtu routing 1500

ip subnet-zero

no ip domain-lookup

ip domain-name XXXXXXXXXXXX

!

ip tftp source-interface Vlan1

ip ssh version 2

login block-for 3 attempts 3 within 3

login on-failure log every 3

!

mls qos map cos-dscp 0 8 16 26 32 46 48 56

mls qos srr-queue input bandwidth 90 10

mls qos srr-queue input threshold 1 8 16

mls qos srr-queue input threshold 2 34 66

mls qos srr-queue input buffers 67 33

mls qos srr-queue input cos-map queue 1 threshold 2  1

mls qos srr-queue input cos-map queue 1 threshold 3  0

mls qos srr-queue input cos-map queue 2 threshold 1  2

mls qos srr-queue input cos-map queue 2 threshold 2  4 6 7

mls qos srr-queue input cos-map queue 2 threshold 3  3 5

mls qos srr-queue input dscp-map queue 1 threshold 2  9 10 11 12 13 14 15

mls qos srr-queue input dscp-map queue 1 threshold 3  0 1 2 3 4 5 6 7

mls qos srr-queue input dscp-map queue 1 threshold 3  32

mls qos srr-queue input dscp-map queue 2 threshold 1  16 17 18 19 20 21 22 23

mls qos srr-queue input dscp-map queue 2 threshold 2  33 34 35 36 37 38 39 48

mls qos srr-queue input dscp-map queue 2 threshold 2  49 50 51 52 53 54 55 56

mls qos srr-queue input dscp-map queue 2 threshold 2  57 58 59 60 61 62 63

mls qos srr-queue input dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31

mls qos srr-queue input dscp-map queue 2 threshold 3  40 41 42 43 44 45 46 47

mls qos srr-queue output cos-map queue 1 threshold 3  5

mls qos srr-queue output cos-map queue 2 threshold 3  3 6 7

mls qos srr-queue output cos-map queue 3 threshold 3  2 4

mls qos srr-queue output cos-map queue 4 threshold 2  1

mls qos srr-queue output cos-map queue 4 threshold 3  0

mls qos srr-queue output dscp-map queue 1 threshold 3  40 41 42 43 44 45 46 47

mls qos srr-queue output dscp-map queue 2 threshold 3  24 25 26 27 28 29 30 31

mls qos srr-queue output dscp-map queue 2 threshold 3  48 49 50 51 52 53 54 55

mls qos srr-queue output dscp-map queue 2 threshold 3  56 57 58 59 60 61 62 63

mls qos srr-queue output dscp-map queue 3 threshold 3  16 17 18 19 20 21 22 23

mls qos srr-queue output dscp-map queue 3 threshold 3  32 33 34 35 36 37 38 39

mls qos srr-queue output dscp-map queue 4 threshold 1  8

mls qos srr-queue output dscp-map queue 4 threshold 2  9 10 11 12 13 14 15

mls qos srr-queue output dscp-map queue 4 threshold 3  0 1 2 3 4 5 6 7

mls qos queue-set output 1 threshold 1 138 138 92 138

mls qos queue-set output 1 threshold 2 138 138 92 400

mls qos queue-set output 1 threshold 3 36 77 100 318

mls qos queue-set output 1 threshold 4 20 50 67 400

mls qos queue-set output 2 threshold 1 149 149 100 149

mls qos queue-set output 2 threshold 2 118 118 100 235

mls qos queue-set output 2 threshold 3 41 68 100 272

mls qos queue-set output 2 threshold 4 42 72 100 242

mls qos queue-set output 1 buffers 10 10 26 54

mls qos queue-set output 2 buffers 16 6 17 61

mls qos

!

crypto pki trustpoint TP-self-signed-2963009664

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-2963009664

revocation-check none

rsakeypair TP-self-signed-2963009664

!

!

crypto pki certificate chain TP-self-signed-2963009664

certificate self-signed 01

  308202B4 3082021D A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  60312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 32393633 30303936 3634312D 302B0609 2A864886 F70D0109

  02161E33 3130524D 2D333735 302D5354 312E646D 762E7374 6174652E 6E792E75

  73301E17 0D393330 33303130 30303332 355A170D 32303031 30313030 30303030

  5A306031 2F302D06 03550403 1326494F 532D5365 6C662D53 69676E65 642D4365

  72746966 69636174 652D3239 36333030 39363634 312D302B 06092A86 4886F70D

  01090216 1E333130 524D2D33 3735302D 5354312E 646D762E 73746174 652E6E79

  2E757330 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100

  BF4F08C6 05B48324 AC98D509 09F45EA2 3FB3EC15 D8D54E9E 0DA24B45 6AC7071A

  80B98F27 548A651C D6BC6745 139BDF36 88A00EAD F6168137 E22412DE DA36A6F9

  1F1E4616 8E6FEB98 B927F594 F9E93BE6 1DFC74F8 AF7C30EA FA6428FE B8211A82

  107EB5B7 0D8406E8 3C932B2B 10EE45DB CD4D219C AEF58265 252EF054 F6A4F747

  02030100 01A37E30 7C300F06 03551D13 0101FF04 05300301 01FF3029 0603551D

  11042230 20821E33 3130524D 2D333735 302D5354 312E646D 762E7374 6174652E

  6E792E75 73301F06 03551D23 04183016 8014C098 657145B6 655D93E6 7BDC2BE1

  46FA96DF F085301D 0603551D 0E041604 14C09865 7145B665 5D93E67B DC2BE146

  FA96DFF0 85300D06 092A8648 86F70D01 01040500 03818100 59FBD91A DA1A39B6

  A8122D40 AA6DC3E1 B66AFD5F 98B55A32 59AE5153 508ED513 AA602875 2EE89D2E

  47CB6BC4 3AAF79B7 34462AD9 AEBFA282 EA341698 B25AE228 D409922B 44687836

  BD5DAD2F 74692EA9 9F19CC0C 2D6A2427 FEEF87A8 299355E1 AEDF138D B6074B96

  9F55E176 D116FD9C 67EB5921 9F676381 44ADF357 D4CF05AF

  quit

!

!

errdisable recovery cause psecure-violation

errdisable recovery interval 30

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface Port-channel1

description C1-41C

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,16,33,98,599,613,901

switchport mode trunk

spanning-tree portfast disable

!

interface GigabitEthernet1/0/1

description UPS

switchport mode access

switchport voice vlan 613

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape  10  0  0  0

queue-set 2

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

!

interface GigabitEthernet1/0/2

switchport access vlan 33

switchport mode access

switchport voice vlan 613

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape  10  0  0  0

queue-set 2

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

interface GigabitEthernet1/0/49

description C1-41C

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,16,33,98,599,613,901

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape  10  0  0  0

queue-set 2

mls qos trust cos

auto qos voip trust

channel-group 1 mode passive

spanning-tree portfast disable

!

interface GigabitEthernet1/0/50

description C1-41C

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,16,33,98,599,613,901

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape  10  0  0  0

queue-set 2

mls qos trust cos

auto qos voip trust

channel-group 1 mode passive

spanning-tree portfast disable

!

interface GigabitEthernet1/0/51

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1

switchport mode trunk

shutdown

no cdp enable

spanning-tree portfast disable

!

interface GigabitEthernet1/0/52

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1

switchport mode trunk

shutdown

no cdp enable

spanning-tree portfast disable

interface GigabitEthernet2/0/1

switchport access vlan 33

switchport mode access

switchport voice vlan 613

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape  10  0  0  0

queue-set 2

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

!

interface GigabitEthernet2/0/2

switchport access vlan 33

switchport mode access

switchport voice vlan 613

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape  10  0  0  0

queue-set 2

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

interface GigabitEthernet2/0/49

description C1-41C

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,16,33,98,599,613,901

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape  10  0  0  0

queue-set 2

mls qos trust cos

auto qos voip trust

channel-group 1 mode passive

spanning-tree portfast disable

!

interface GigabitEthernet2/0/50

description C1-41C

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,16,33,98,599,613,901

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape  10  0  0  0

queue-set 2

mls qos trust cos

auto qos voip trust

channel-group 1 mode passive

spanning-tree portfast disable

!

interface GigabitEthernet2/0/51

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1

switchport mode trunk

shutdown

no cdp enable

spanning-tree portfast disable

!

interface GigabitEthernet2/0/52

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1

switchport mode trunk

shutdown

no cdp enable

spanning-tree portfast disable

!

interface Vlan1

ip address 172.16.33.1 255.255.0.0

!

interface Vlan599

ip address 10.56.68.133 255.255.255.128

!

ip default-gateway 10.56.68.129

ip classless

no ip http server

ip http secure-server

ip tacacs source-interface Vlan599

!

ip access-list standard RO1

!

ip access-list extended VTY

permit tcp 10.69.66.0 0.0.0.255 any eq telnet log

permit tcp 10.69.66.0 0.0.0.255 any eq 22 log

permit tcp 172.16.0.0 0.0.255.255 any eq 22 log

permit tcp 172.16.0.0 0.0.255.255 any eq telnet log

permit tcp 10.69.31.0 0.0.0.255 any eq 22 log

permit tcp 10.69.31.0 0.0.0.255 any eq telnet log

permit tcp 1.11.1.0 0.0.0.255 any eq telnet log

permit tcp 1.11.1.0 0.0.0.255 any eq 22 log

permit tcp 10.48.32.96 0.0.0.7 any eq 22 log

permit tcp 10.48.32.88 0.0.0.7 any eq 22 log

permit tcp 10.48.24.16 0.0.0.15 any eq 22 log

permit tcp 10.38.97.0 0.0.0.255 any eq 22 log

permit tcp 10.38.96.0 0.0.0.255 any eq 22 log

permit tcp 10.39.97.0 0.0.0.255 any eq 22 log

permit tcp 10.77.16.0 0.0.1.255 any eq 22 log

permit tcp 10.48.56.32 0.0.0.7 any eq 22 log

permit tcp 10.36.0.0 0.3.255.255 any eq 22 log

permit tcp 10.48.40.0 0.0.0.127 any eq 22 log

permit tcp 10.53.65.128 0.0.0.15 any eq 22 log

permit tcp 10.53.65.144 0.0.0.15 any eq 22 log

permit tcp 10.63.128.0 0.0.0.255 any eq 22 log

permit tcp 10.63.129.0 0.0.0.255 any eq 22 log

permit tcp 10.56.68.128 0.0.0.127 any eq 22 log

deny   ip any any log

logging 10.69.27.129

logging 10.72.52.30

access-list 1 remark SNMP Managers

access-list 1 permit 10.69.31.97

access-list 1 permit 10.69.31.100

access-list 1 permit 10.69.31.101

access-list 1 permit 10.69.17.40

access-list 1 permit 10.69.30.242

access-list 1 permit 10.69.19.229

access-list 1 permit 10.69.27.129

access-list 4 permit 10.69.31.148

access-list 4 permit 10.69.31.149

access-list 4 permit 10.69.31.150

access-list 4 permit 10.69.31.151

access-list 101 deny   ospf any any

access-list 101 permit ip any any

snmp-server community XXXXXXXXXXXX RO 1

snmp-server community XXXXXXXXXX RW 1

snmp-server community XXXXXXXXXXX RO 4

snmp-server community XXXXXXXXX RO

snmp-server enable traps snmp coldstart warmstart

snmp-server enable traps flash insertion removal

snmp-server enable traps envmon fan shutdown supply temperature status

snmp-server enable traps license

snmp-server enable traps config

snmp-server enable traps syslog

snmp-server host 10.69.17.40 XXXXXXXXXXXX

snmp-server host 10.69.19.229 XXXXXXXXXXXX

snmp-server host 10.69.27.110 XXXXXXXXXXXX

snmp-server host 10.69.27.129 XXXXXXXXXXXX

snmp-server host 10.69.30.242 XXXXXXXXXXXX

snmp-server host 10.69.31.100 XXXXXXXXXXXX

snmp-server host 10.69.31.101 XXXXXXXXXXXX

snmp-server host 10.69.31.97 XXXXXXXXXXXXX

snmp-server host 10.38.96.70 XXXXXXXXXXXX

tacacs-server host 10.69.31.18 timeout 10

tacacs-server host 10.69.31.17

tacacs-server host 10.38.96.28

tacacs-server host 10.38.96.29

tacacs-server host 10.39.96.29

tacacs-server directed-request

tacacs-server key 7 XXXXXXXXXXXXXXXXXXXX

!

control-plane

!

banner motd ^C************************************

Unauthorized Entry To This Device Is

        STRICTLY PROHIBITED

************************************^C

!

line con 0

exec-timeout 120 0

password 7

logging synchronous

line vty 0 4

access-class VTY in

exec-timeout 120 0

password 7

logging synchronous

length 0

transport input telnet ssh

line vty 5 15

password 7

!

ntp clock-period 36029392

ntp server 10.38.96.37 prefer

ntp server 10.69.16.1

_________________________________________

1    default                          active    Gi1/0/1, Gi1/0/51, Gi1/0/52

                                                Gi2/0/50, Gi2/0/51, Gi2/0/52

33   RM310                            active    Gi1/0/2, Gi1/0/3, Gi1/0/4

                                                Gi1/0/5, Gi1/0/6, Gi1/0/7

                                                Gi1/0/8, Gi1/0/9, Gi1/0/10

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

                                                Gi1/0/11, Gi1/0/12, Gi1/0/13

                                                Gi1/0/14, Gi1/0/15, Gi1/0/16

                                                Gi1/0/17, Gi1/0/18, Gi1/0/19

                                                Gi1/0/20, Gi1/0/21, Gi1/0/22

                                                Gi1/0/23, Gi1/0/24, Gi1/0/25

                                                Gi1/0/26, Gi1/0/27, Gi1/0/28

                                                Gi1/0/29, Gi1/0/30, Gi1/0/31

                                                Gi1/0/32, Gi1/0/33, Gi1/0/34

                                                Gi1/0/35, Gi1/0/36, Gi1/0/37

                                                Gi1/0/38, Gi1/0/39, Gi1/0/40

                                                Gi1/0/41, Gi1/0/42, Gi1/0/43

                                                Gi1/0/44, Gi1/0/45, Gi1/0/46

                                                Gi1/0/47, Gi1/0/48, Gi2/0/1

                                                Gi2/0/2, Gi2/0/3, Gi2/0/4

                                                Gi2/0/5, Gi2/0/6, Gi2/0/7

                                                Gi2/0/8, Gi2/0/9, Gi2/0/10

                                                Gi2/0/11, Gi2/0/12, Gi2/0/13

                                                Gi2/0/14, Gi2/0/15, Gi2/0/16

                                                Gi2/0/17, Gi2/0/18, Gi2/0/19

                                                Gi2/0/20, Gi2/0/21, Gi2/0/22

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

                                                Gi2/0/23, Gi2/0/24, Gi2/0/25

                                                Gi2/0/26, Gi2/0/27, Gi2/0/28

                                                Gi2/0/29, Gi2/0/30, Gi2/0/31

                                                Gi2/0/32, Gi2/0/33, Gi2/0/34

                                                Gi2/0/35, Gi2/0/36, Gi2/0/37

                                                Gi2/0/38, Gi2/0/39, Gi2/0/40

                                                Gi2/0/41, Gi2/0/42, Gi2/0/43

                                                Gi2/0/44, Gi2/0/45, Gi2/0/46

                                                Gi2/0/47, Gi2/0/48

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

613  VOICE-8P1-Core1-Floor3       active    Gi1/0/1, Gi1/0/2, Gi1/0/3

                                                Gi1/0/4, Gi1/0/5, Gi1/0/6

                                                Gi1/0/7, Gi1/0/8, Gi1/0/9

                                                Gi1/0/10, Gi1/0/11, Gi1/0/12

                                                Gi1/0/13, Gi1/0/14, Gi1/0/15

                                                Gi1/0/16, Gi1/0/17, Gi1/0/18

                                                Gi1/0/19, Gi1/0/20, Gi1/0/21

                                                Gi1/0/22, Gi1/0/23, Gi1/0/24

                                                Gi1/0/25, Gi1/0/26, Gi1/0/27

                                                Gi1/0/28, Gi1/0/29, Gi1/0/30

                                                Gi1/0/31, Gi1/0/32, Gi1/0/33

                                                Gi1/0/34, Gi1/0/35, Gi1/0/36

                                                Gi1/0/37, Gi1/0/38, Gi1/0/39

                                                Gi1/0/40, Gi1/0/41, Gi1/0/42

                                                Gi1/0/43, Gi1/0/44, Gi1/0/45

                                                Gi1/0/46, Gi1/0/47, Gi1/0/48

                                                Gi2/0/1, Gi2/0/2, Gi2/0/3

                                                Gi2/0/4, Gi2/0/5, Gi2/0/6

                                                Gi2/0/7, Gi2/0/8, Gi2/0/9

                                                Gi2/0/10, Gi2/0/11, Gi2/0/12

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

                                                Gi2/0/13, Gi2/0/14, Gi2/0/15

                                                Gi2/0/16, Gi2/0/17, Gi2/0/18

                                                Gi2/0/19, Gi2/0/20, Gi2/0/21

                                                Gi2/0/22, Gi2/0/23, Gi2/0/24

                                                Gi2/0/25, Gi2/0/26, Gi2/0/27

                                                Gi2/0/28, Gi2/0/29, Gi2/0/30

                                                Gi2/0/31, Gi2/0/32, Gi2/0/33

                                                Gi2/0/34, Gi2/0/35, Gi2/0/36

                                                Gi2/0/37, Gi2/0/38, Gi2/0/39

                                                Gi2/0/40, Gi2/0/41, Gi2/0/42

                                                Gi2/0/43, Gi2/0/44, Gi2/0/45

                                                Gi2/0/46, Gi2/0/47, Gi2/0/48

Re: Cisco Phones never switch to voice VLAN after switch reboot

Just to clarify a little more it seems to only be the 7841 phones that don't move over to the voice VLAN after a switch reboot. The 7965 phones work just fine.

I also discovered this is only happening on our 3750 stacks of 2 or more switches. The single switch stacks don't have this issue.

Sent from Cisco Technical Support iPhone App

Community Member

Re: Cisco Phones never switch to voice VLAN after switch reboot

I didn't see any erorrs in the code.....you can try

interface vlan 613

no shut

exit

vlan 613

but since 613 is already up I dont think it would help.

At this point I would suggest attempting to upgrade firmware on the IOS and/or the phone and see if you are experiencing different results....might be a bug.

Re: Cisco Phones never switch to voice VLAN after switch reboot

Hi Elton,

Can you please try below task and share with us:-

  • Reset the phone (7841) and see if phone gets the voice vlan normally.
  • Try to erase the phone configuration of any one phone (7841) and see if phone gets the voice vlan by normal process.

And as you said you are using Stack, then just confirm once that all the switches in stack are using the same "vlan.dat" file.

Regards,
Nishant Savalia

Regards, Nishant Savalia
262
Views
0
Helpful
5
Replies
CreatePlease to create content