Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

CISCO phones releasing IP addresses

Hi there,

I have got a situation when some of my phones constantly realising IP settings and trying to get a new ones.

I am using CCME 7.1, 2 Windows DHCP servers with a few scopes.

I have got 2 DHCP server server1(win2k3 sp2) and server2(win2k3 sp2) in the single domain which are on the different subnets.

It created a Spitted scope

server1 address pool: for distribution - 10.110.64.2-10.110.64.254, excluded - 10.110.64.2-10.110.64.139

reservation for hp switch 10.110.64.2 000d9db48500

server2 address pool: for distribution - 10.110.64.2-10.110.64.254, excluded - 10.110.64.140-10.110.64.254

reservation for hp switch 10.110.64.2 000d9db48500

Router Cisco 2821. HP switch connected to the Cisco router also I am using POWERDsine 6024 switch, also I have got 3 VLANS.

It looks like HP switch or Cisco router is trying to change a vlan once per minute.

Cisco phone connects to hp switch which is connected to cisco router, on cisco router there is a dhcp relay set up.

This phone is constantly releasing ip settings.

I checked logs on server1 and server2.

Server1:

10,06/10/09,11:09:44,Assign,10.110.64.147,SEP001E4AF359FC.domain.com,001E4AF359FC,

12,06/10/09,11:10:37,Release,10.110.64.147,SEP001E4AF359FC.domain.com,001E4AF359FC,

15,06/10/09,11:10:37,NACK,10.110.64.147,,001E4AF359FC,

10,06/10/09,11:10:44,Assign,10.110.64.147,SEP001E4AF359FC.domain.com,001E4AF359FC,

12,06/10/09,11:11:37,Release,10.110.64.147,SEP001E4AF359FC.domain.com,001E4AF359FC,

15,06/10/09,11:11:37,NACK,10.110.64.147,,001E4AF359FC,

10,06/10/09,11:17:44,Assign,10.110.64.147,SEP001E4AF359FC.domain.com,001E4AF359FC,

12,06/10/09,11:18:37,Release,10.110.64.147,SEP001E4AF359FC.domain.com,001E4AF359FC,

15,06/10/09,11:18:37,NACK,10.110.64.147,,001E4AF359FC,

Server2:

10,06/10/09,11:07:43,Assign,10.110.64.9,SEP001E4AF359FC.domain.com,001E4AF359FC,

12,06/10/09,11:08:37,Release,10.110.64.9,SEP001E4AF359FC.domain.com,001E4AF359FC,

24,06/10/09,11:15:24,Database Cleanup Begin,,,,

25,06/10/09,11:15:24,0 leases expired and 0 leases deleted,,,,

25,06/10/09,11:15:24,0 leases expired and 0 leases deleted,,,,

10,06/10/09,11:15:39,Assign,10.110.64.9,SEP001E4AF359FC.domain.com,001E4AF359FC,

12,06/10/09,11:16:37,Release,10.110.64.9,SEP001E4AF359FC.domain.com,001E4AF359FC,

10,06/10/09,11:19:39,Assign,10.110.64.9,SEP001E4AF359FC.domain.com,001E4AF359FC,

11,06/10/09,11:19:39,Renew,10.110.64.9,SEP001E4AF359FC.domain.com,001E4AF359FC,

12,06/10/09,11:20:37,Release,10.110.64.9,SEP001E4AF359FC.domain.com,001E4AF359FC,

10,06/10/09,11:20:40,Assign,10.110.64.9,SEP001E4AF359FC.domain.com,001E4AF359FC,

12,06/10/09,11:21:37,Release,10.110.64.9,SEP001E4AF359FC.domain.com,001E4AF359FC

Any advices how to resolve this problem?

19 REPLIES
Hall of Fame Super Gold

Re: CISCO phones releasing IP addresses

Do not use any server for dhcp to the phones.

Put the phones in voice vlan and let cme router be dhcp server, with default settings and option 150.

You will never have any problems doing so "by the book".

Community Member

Re: CISCO phones releasing IP addresses

I have got a separate voice vlan, using 10.110.64.x/24(for data), 10.110.0.x/23(for data),10.111.0.x/23(for voice).

It is required to use windows dhcp servers.

Hall of Fame Super Gold

Re: CISCO phones releasing IP addresses

Required by who?

Cisco phones work well with cisco router dhcp server (or CUCM), that is what cisco tells you to do and everybody does, once you deviate from that you're on your own.

Community Member

Re: CISCO phones releasing IP addresses

required by our company policy.

I need to get it working with current equipment.

Hall of Fame Super Gold

Re: CISCO phones releasing IP addresses

You should work on improving policies instead.

"company" should have no word on technical matters and the best way to make things work.

Community Member

Re: CISCO phones releasing IP addresses

I don't want to be rude,

but you don't need to comment if you are not able to offer particular solution for particular task.

I don't want to participate in the dispute like what is better windows or linux.

Community Member

Re: CISCO phones releasing IP addresses

I don't want to be rude,

but you don't need to comment if you are not able to offer particular solution for particular task.

I don't want to participate in the dispute like what is better windows or linux.

Re: CISCO phones releasing IP addresses

Hi Vasily,

There are some things to look into:

Check the lease time on the phones. Most DHCP servers have the renew time to half the lease, and the phones will follow this.

You may also want to do some search for HP compatibility with IP phones. The phones normally get their VLAN ID via CDP, which the switches may be 'faking' or be related to the problem.

-nick

Community Member

Re: CISCO phones releasing IP addresses

Hi,

to add to Nicks post, here is an interoperability guide for Cisco IP Phones with HP Switches. I had this set up in a lab and it seemed to work reliably.

http://h40060.www4.hp.com/procurve/uk/en/pdfs/application-notes/AN-C3_ProCurve-Cisco-IP-phone-7900-final-101308.pdf

7900 Phones with newer firmware (as of 8.3(3))use LLDP to negotiate Voice VLAN with HP Switches.

Also you could check to see if there is a new firmware version for your phones.

Ingo

Hall of Fame Super Gold

Re: CISCO phones releasing IP addresses

No dispute here.

Cisco makes a product and tells you how to configure it (best practices).

In the DHCP case, that is because no matter what, the phone system never depends by an external server, even if redundant. As you gain experience, you will find that this a very good thing.

When you deviate from best practices, you're on your own, good luck.

Community Member

Re: CISCO phones releasing IP addresses

..

Re: CISCO phones releasing IP addresses

Hi Vasily,

I think the phones are getting confused which server to ask for addresses.

Can you show us your ip helper config?

Can you try using just one server for the config as a beginning so we can separate the possible causes - dhcp problem or phone fw problem.

DHCP is a standard protocol so it should work no matter if on server or on any other device.

Re: CISCO phones releasing IP addresses

I agree with Vasily, Use 1 DHCP server per vlan, DHCP requests will be sent to any server it hits first...

That and increase your DHCP lease time on your voice vlan.

Do you have a ip helper-address assigned on the HP Switch for the voice vlan?

HTH, Please rate if so

Regards,

Justin

Hall of Fame Super Gold

Re: CISCO phones releasing IP addresses

Then what happens if you have a power glitch and the windows servers says "no active partition found" when rebooting ?

Community Member

Re: CISCO phones releasing IP addresses

Now I have done an experiment.

I have got a spare power adapter for my test phone.

Plugging my test socket directly into the cisco 2823.

Now I have got a permanent IP address on my phone from windows server. It is 10.111.1.89 IP address.

10,06/18/09,11:33:10,Assign,10.111.1.89,SEP001E4AF359FC,001E4AF359FC,

cisco config

vlan 1

description Clients1

ip address 10.110.0.1 255.255.254.0

ip helper-address 10.130.32.31

ip helper-address 10.120.32.38

no mop enabled

vlan 2

description Voice-Clients1

ip address 10.111.0.1 255.255.254.0

ip helper-address 10.130.32.31

ip helper-address 10.120.32.38

vlan 3

description Clients2

ip address 10.110.64.1 255.255.255.0

ip helper-address 10.130.32.31

ip helper-address 10.120.32.38

interface FA 1/3

description test-phone

switchport trunk allowed vlan 1,2,3,…

switchport mode trunk

switchport voice vlan 2

Phone is getting Operational VLAN id 2(when It is plugging in into hp switch where we have the problem this field is empty, if I plug it into different hp switch it is getting vlan).

We have got many hp switches and have this problem only with one of them.

So it looks like problem connected with wrong hp switch configuration.

Community Member

Re: CISCO phones releasing IP addresses

Hi Vasily,

If you have this problem with only one HP switch, compare the firmware versions and switch configuration. If necessary, upgrade the firmware of the HP switch.

You should also check speed/duplex settings ony your switch. E.g. the powerdsine you mentioned only supports 10/100, no gigabit. Only the powerdsine 6024G supports gigabit. so if your HP switch is gigabit, set it to 100Mbit/Full manually just to be one the safe side.

hth

Ingo

Community Member

Re: CISCO phones releasing IP addresses

Now I am using a power adapter instead of power switch just for test phone.

2 hp switches 2650, the same firmware, they are behaving differently. I am trying to find out difference in configs.

Community Member

Re: CISCO phones releasing IP addresses

Not working hp switch had next setting for the phone's port

Vlan1, Vlan2, Vlan3

Tagged Tagged Untagged

On working switch it is

Vlan1, Vlan2, Vlan3

Untagged Tagged No

After I change particular port on switch 1 to

On working switch it is

Vlan1, Vlan2, Vlan3

Untagged Tagged No

and restarted port

phone started work properly and showing operational vlan 2

now I need to spend some time in order to investigate how to set up vlans configuration for ports properly.

Community Member

Re: CISCO phones releasing IP addresses

Hi,

the link I postet earlier had some guidelines on configuring voice vlans on HP switches:

http://h40060.www4.hp.com/procurve/uk/en/pdfs/application-notes/AN-C3_ProCurve-Cisco-IP-phone-7900-final-101308.pdf

at least its working now ;-)

Ingo

487
Views
0
Helpful
19
Replies
CreatePlease to create content