Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco SIP Phone 9971 won't register on CME 8.6

Hello,

I'm facing a very strange problem:

a Cisco SIP Phone 9971 won't register on CME 8.6 running on a 2811

I have read all the related-postings to this and other Forum, but I have not been able to solve it.

One of the "potential solutions" was to make sure that the Phone had a Line configured.

But I think that the commands voice register dn  and  voice register pool are properly configured (see config below)

So frankly, I have no idea what I could be missing.

I'm pasting the Router's config.

I hope somebody is able to point me in the right direction.

Here is the config.  Thank you!

----------

C2811#sh run

Building configuration...

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname C2811

!

no aaa new-model

!

dot11 syslog

ip source-route

!

ip cef

!

ip dhcp excluded-address 172.25.140.1 172.25.140.10

ip dhcp excluded-address 172.35.140.1 172.35.140.10

!

ip dhcp pool Data

network 172.25.140.0 255.255.255.0

default-router 172.25.140.1

option 150 ip 172.25.140.1

dns-server 172.25.140.1

!

ip dhcp pool Voice

network 172.35.140.0 255.255.255.0

default-router 172.35.140.1

option 150 ip 172.35.140.1

dns-server 172.35.140.1

!

!

no ip domain lookup

no ipv6 cef

!

multilink bundle-name authenticated

!

!

voice service voip

allow-connections sip to sip

sip

  registrar server expires max 3600 min 120

!

!

voice register global

mode cme

source-address 172.25.140.1 port 5060

max-dn 40

max-pool 42

load 9971 sip9971.9-4-1-9.loads

authenticate register

authenticate realm cisco

tftp-path flash:

create profile sync 0004820400584603

!

voice register dn  1

number 1010

allow watch

name Phone10

label Phone10

mwi

!

voice register pool  1

id mac 189C.5DB6.BD09

type 9971

number 1 dn 1

presence call-list

dtmf-relay rtp-nte

username adm password adm

call-forward b2bua busy 68600

codec g711ulaw

no vad

camera

video

!

!

voice-card 0

!

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-1879153754

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1879153754

revocation-check none

rsakeypair TP-self-signed-1879153754

!

!

crypto pki certificate chain TP-self-signed-1879153754

certificate self-signed 01

(details ommited)

!

!

license udi pid CISCO2811 sn FTX1146A44H

username admin privilege 15 password 0 admin

!

redundancy

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.25

description Data VLAN

encapsulation dot1Q 25

ip address 172.25.140.1 255.255.255.0

!

interface FastEthernet0/0.35

description Voice VLAN

encapsulation dot1Q 35

ip address 172.35.140.1 255.255.255.0

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

ip forward-protocol nd

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 600 life 86400 requests 10000

!

!

tftp-server flash:P00308010200.bin

tftp-server flash:P00308010200.sbn

tftp-server flash:P00308010200.sb2

tftp-server flash:P00308010200.loads

tftp-server flash:SCCP42.9-3-1SR3-1S.loads

tftp-server flash:apps42.9-3-1ES19.sbn

tftp-server flash:cnu42.9-3-1ES19.sbn

tftp-server flash:cvm42sccp.9-3-1ES19.sbn

tftp-server flash:dsp42.9-3-1ES19.sbn

tftp-server flash:jar42sccp.9-3-1ES19.sbn

tftp-server flash:term42.default.loads

tftp-server flash:term62.default.loads

tftp-server flash:SCCP45.9-3-1SR3-1S.loads

tftp-server flash:apps45.9-3-1ES19.sbn

tftp-server flash:cnu45.9-3-1ES19.sbn

tftp-server flash:cvm45sccp.9-3-1ES19.sbn

tftp-server flash:dsp45.9-3-1ES19.sbn

tftp-server flash:jar45sccp.9-3-1ES19.sbn

tftp-server flash:term45.default.loads

tftp-server flash:term65.default.loads

tftp-server flash:/Ringtones/Ringlist.xml alias Ringlist.xml

tftp-server flash:/Ringtones/DistinctiveRingList.xml alias DistinctiveRingList.x

ml

tftp-server flash:sip9971.9-4-1-9.loads

tftp-server flash:kern9971.9-4-1-9.sebn

tftp-server flash:rootfs9971.9-4-1-9.sebn

tftp-server flash:dkern9971.100609R2-9-4-1-9.sebn

tftp-server flash:sboot9971.031610R1-9-4-1-9.sebn

tftp-server flash:skern9971.022809R2-9-4-1-9.sebn

tftp-server flash:/g4-tones.xml alias United_States/g4-tones.xml

tftp-server flash:/gd-sip.jar alias English_United_States/gd-sip.jar

!

control-plane

!

!

mgcp profile default

!

!

telephony-service

max-ephones 24

max-dn 48

ip source-address 172.25.140.1 port 2000

cnf-file location flash:

load 7960-7940 P00308010200

load 7942 SCCP42.9-3-1SR3-1S.loads

load 7945 SCCP45.9-3-1SR3-1S.loads

load 7962 SCCP42.9-3-1SR3-1S.loads

load 7965 SCCP45.9-3-1SR3-1S.loads

max-conferences 8 gain -6

dn-webedit

transfer-system full-consult

create cnf-files version-stamp 7960 Feb 11 2014 07:18:32

!

!

ephone-dn  1

number 1001

description Phone 1

name Phone 1

hold-alert 30 originator

!

!

ephone-dn  2

number 1002

description Phone 2

name Phone 2

hold-alert 30 originator

!

!

ephone-dn  3

number 1003

description Phone 3

name Phone 3

hold-alert 30 originator

!

!

ephone  1

device-security-mode none

mac-address 001C.58FB.6E0F

button  1:1

!

!

ephone  2

device-security-mode none

mac-address 0014.A981.7F8A

button  1:2

!

!

ephone  3

device-security-mode none

mac-address 0006.5356.A4B8

button  1:3

!

!

alias exec con conf t

alias exec sib show ip int brief

alias exec srb show run | b

alias exec sri show run int

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

line vty 0 4

privilege level 15

login local

transport input telnet ssh

transport output telnet ssh

line vty 5 15

privilege level 15

login local

transport input telnet ssh

transport output telnet ssh

!

scheduler allocate 20000 1000

ntp master 1

end

C2811#

Everyone's tags (9)
6 REPLIES
New Member

Cisco SIP Phone 9971 won't register on CME 8.6

I guess I forgot to mention that the Phone shows this error message:

VPN Error: vpn is not configured

Actually, it shows all these 4 messages in a constant Loop:

12:01:59a No Trust List instaled

12:01:59a Updating Trust list

12:02:00a VPN Error: VPN is not Configured

12:01:59a SEP189C5DB6BD09.cnf.xml (TFTP)

This is repeated for ever and the Phone never registers!

Any ideas?  Please help!

Cisco SIP Phone 9971 won't register on CME 8.6

Hi Samuel.

This post should contain a solution to your issue.

https://supportforums.cisco.com/thread/2094822

HTH

Regards

Carlo

Please rate all helpful posts

"The more you help the more you learn"

Please rate all helpful posts "The more you help the more you learn"
New Member

Hi All,Does any one was able

Hi All,

Does any one was able to figure out the issue

 

Many Thanks

Cisco Employee

Cisco SIP Phone 9971 won't register on CME 8.6

Hi Samuel,

Does the configuration file for the phone look ok? What do you see in the debug ccsip messages?

Thanks

Sree

New Member

Cisco SIP Phone 9971 won't register on CME 8.6

Thank you for your reply.

I did some debugs and the results are very strange!

This is what I got:

Feb 24 18:01:12.219: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 400 Bad Request

Via: SIP/2.0/UDP 172.35.140.12:5060;branch=z9hG4bK08011844

From: <189C5DB6BD09>;tag=189c5db6bd09000260cf3daf-289a76d1

To: <172.25.140.1>;tag=52488-160A

Date: Mon, 24 Feb 2014 18:01:12 GMT

Call-ID: 189c5db6-bd090002-7ba0f00a-5ceed8af@172.35.140.12

CSeq: 1000 REFER

Content-Length: 0

Contact: <172.35.140.1:5060>

Feb 24 18:01:12.291: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

REGISTER sip:172.25.140.1 SIP/2.0

Via: SIP/2.0/UDP 172.35.140.12:5060;branch=z9hG4bK1e9ad079

From: <1010>;tag=189c5db6bd0900032df02e9c-25d79707

To: <1010>

Call-ID: 189c5db6-bd090002-3c4be22a-043a8ab4@172.35.140.12

Max-Forwards: 70

Date: Fri, 01 Jan 1982 00:02:41 GMT

CSeq: 101 REGISTER

User-Agent: Cisco-CP9971/9.4.1

Contact: <1010>;+sip.instance="

000000-0000-0000-0000-189c5db6bd09>";+u.sip!devicename.ccm.cisco.com="SEP189C5DB

6BD09";+u.sip!model.ccm.cisco.com="493";video

Supported: replaces,join,sdp-anat,norefersub,resource-priority,extended-refer,X-

cisco-callinfo,X-cisco-serviceuri,X-cisco-escapecodes,X-cisco-service-control,X-

cisco-srtp-fallback,X-cisco-monrec,X-cisco-config,X-cisco-sis-6.0.2,X-cisco-xsi-

8.0.1

Content-Length: 0

Reason: SIP;cause=200;text="cisco-alarm:22 Name=SEP189C5DB6BD09 ActiveLoad=sip99

71.9-4-1-9.loads InactiveLoad=sip9971.9-3-2SR1-1.loads Last=reset-reset"

Expires: 3600

Feb 24 18:01:12.395: voice_reg_get_reg_expires_timer: no voice register pool found

Feb 24 18:01:12.395: VOICE_REG_POOL: Register request for (1010) from (172.35.140.12)

Feb 24 18:01:12.395: VOICE_REG_POOL: Contact matches pool 1 number list 1

Feb 24 18:01:12.395: VOICE_REG_POOL: No entry for (172.35.140.12) found in srst contact table

Feb 24 18:01:12.395: VOICE_REG_POOL: key(1010) contact(172.35.140.12:5060) add to contact table

Feb 24 18:01:12.395: VOICE_REG_POOL: No entry for (1010) found in contact table

Feb 24 18:01:12.399: VOICE_REG_POOL: key(1010) contact(172.35.140.12) added to contact table

Feb 24 18:01:12.399: VOICE_REG_POOL: key(172.35.140.12) contact(1010) add to srst contact table

Feb 24 18:01:12.399: VOICE_REG_POOL: No entry for (172.35.140.12) found in srst contact table

Feb 24 18:01:12.399: VOICE_REG_POOL: key(172.35.140.12) contact(1010) added to srst contact table

Feb 24 18:01:12.399: VOICE_REG_POOL pool->tag(1), dn->tag(1), submask(1)

But right after these errors, I get the following:

Feb 24 18:01:12.399: VOICE_REG_POOL: Creating param container for dial-peer 4000

1.VOICE_REG_POOL pool->tag(1), dn->tag(1), submask(1)

VOICE_REG_POOL pool_tag(1), dn_tag(1)

Feb 24 18:01:12.399: VOICE_REG_POOL: Created dial-peer entry of type 0

Feb 24 18:01:12.399: VOICE_REG_POOL: Registration successful for 1010, registration id is 1

Feb 24 18:01:12.411: VOICE_REG_POOL: Contact matches pool 1 number list 1

Feb 24 18:01:12.411: VOICE_REG_POOL: GW SIS: X-cisco-cme-sis-1.0.0

Feb 24 18:01:12.411: VOICE REGISTER POOL-1 has registered.

                               Name:SEP189C5DB6BD09 IP:172.35.140.12  DeviceType:Phone

Feb 24 18:01:12.411: VOICE_REG_POOL: Pool[1]: service-control (reset type: 2) message sent to sip:1010@172.35.140.12

Feb 24 18:01:12.411: voice_reg_privacy_update_to_phone: delay sending privacy update during bulk registration

Feb 24 18:01:12.415: //1/7B0070C28003/SIP/Msg/ccsipDisplayMsg:

====================

And when I do a sh voice register pool, I get the following:

C2811#sh voice register pool  1

Pool Tag 1

Config:

  Mac address is 189C.5DB6.BD09

  Type is 9971

  Number list 1 : DN 1

  Proxy Ip address is 0.0.0.0

  Current Phone load version is Cisco-CP9971/9.4.1

  DTMF Relay is enabled, rtp-nte

  Call Waiting is enabled

  DnD is disabled

  Video is enabled

  Camera is enabled

  Busy trigger per button value is 0

  call-forward b2bua busy 68600

  keep-conference is enabled

  registration expires timer max is 3600 and min is 120

  username adm password adm

  kpml signal is enabled

  Lpcor Type is none

  blf call list is enabled

  Transport type is udp

  service-control mechanism is supported

  registration Call ID is 189c5db6-bd090005-24ea26fa-655d3e3a@172.35.140.12

  Registration method: per line

  Privacy feature is not configured.

  Privacy button is disabled

  active primary line is: 1010

  contact IP address: 172.35.140.12 port 5060

  Phone SIS Version:  6.0.2

  GW SIS Version:  1.0.0

Dialpeers created:

Dial-peers for Pool 1:

dial-peer voice 40001 voip

destination-pattern 1010

session target ipv4:172.35.140.12:5060

session protocol sipv2

dtmf-relay rtp-nte

digit collect kpml

codec  g711ulaw bytes 160

no vad

  call-fwd-busy        68600

  after-hours-exempt   FALSE

Statistics:

  Active registrations  : 4

  Total SIP phones registered: 1

  Total Registration Statistics

    Registration requests  : 4

    Registration success   : 4

    Registration failed    : 0

    unRegister requests    : 0

    unRegister success     : 0

    unRegister failed      : 0

    Attempts to register

           after last unregister : 0

    Last register request time   : 18:11:43.551 UTC Mon Feb 24 2014

    Last unregister request time :

    Register success time        : 18:11:43.551 UTC Mon Feb 24 2014

    Unregister success time      :

C2811#

So apparently the Phone is actually registered!

However, the Phone screens still shows this message: Phone Not Registered.

So frankly I don't understand what's going on!

I really hope somebody can help.  Thanks!

New Member

Hi , did someone solve this

Hi , did someone solve this problem. I have the some problem , sometimes it register , sometimes don't. I have 9971 and 9951 (SIP)  in my house connected by vpn to my company. Sccp phones register correctly in CME 8.6 and CUCM 9.1 , but my 9971 in SIP  sometimes cant register to CME 8.6 in RT 2821.

I tried everything I read : with and without authenticate register , disable sccp and telephony service , create , delete everything , reboot , reset all , ...... sometimes work , sometimes don't . Can be my vpn network ?

Any idea?

I always have this errors: Apr  6 12:38:47.266: VOICE_REG_POOL: key(1F0308220018F135) added to nonce table
Apr  6 12:38:47.266: VOICE_REG_POOL: Contact doesn't match any pools
Apr  6 12:38:47.274: voice_reg_get_reg_expires_timer: no voice register pool found
Apr  6 12:38:47.274: VOICE_REG_POOL: Register request for (44208555444) from (192.168.2.69)
Apr  6 12:38:47.274: auth absent

 or

Apr  6 12:42:40.298: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
REGISTER sip:157.26.1.250 SIP/2.0
Via: SIP/2.0/UDP 192.168.2.69:5060;branch=z9hG4bK2493267d
From: <sip:44208555444@157.26.1.250>;tag=68bdaba4a060004b484167e7-01ce36b2
To: <sip:44208555444@157.26.1.250>
Call-ID: 68bdaba4-a0600033-067eb615-659961fd@192.168.2.69
Max-Forwards: 70
Date: Fri, 01 Jan 1982 00:26:46 GMT
CSeq: 110 REGISTER
User-Agent: Cisco-CP9971/9.3.2
Contact: <sip:44208555444@192.168.2.69:5060;transport=udp>;+sip.instance="<urn:uuid:00000000-0000-0000-0000-68bdaba4a060>";+u.sip!devicename.ccm.cisco.com="SEP68BDABA4A060";+u.sip!model.ccm.cisco.com="493";video
Supported: replaces,join,sdp-anat,norefersub,resource-priority,extended-refer,X-cisco-callinfo,X-cisco-serviceuri,X-cisco-escapecodes,X-cisco-service-control,X-cisco-srtp-fallback,X-cisco-monrec,X-cisco-config,X-cisco-sis-6.0.0,X-cisco-xsi-8.0.1
Content-Length: 0
Expires: 3600


Apr  6 12:42:40.302: //2252/48A738A98795/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP 192.168.2.69:5060;branch=z9hG4bK69c2f20b
From: <sip:25353333@157.26.1.250>;tag=68bdaba4a060004a5baf5a08-2126101a
To: <sip:25353333@157.26.1.250>;tag=FC81DC-13FC
Date: Thu, 06 Apr 2017 12:42:40 GMT
Call-ID: 68bdaba4-a0600032-00600537-1b303b16@192.168.2.69
Server: Cisco-SIPGateway/IOS-12.x
CSeq: 110 REGISTER
WWW-Authenticate: Digest realm="",nonce="EF02B97A00194030",algorithm=MD5,qop="auth"
Content-Length: 0

4579
Views
0
Helpful
6
Replies
CreatePlease to create content