Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco Switch > Phone > PC Daisy Chain

We have a 3500XL with IOS 12.0(5)WC17 that will not configure a daisy chain for a switch > cisco phone > PC connection.

I'm having trouble configuring our switch to run both voice VLAN traffic and our data vlan traffic through a Fast Ethernet port.

On my other switches, I use these commands:

interface FastEthernet0/18

      switchport

      switchport access vlan 4

      switchport trunk encapsulation dot1q

      switchport mode access

      switchport voice vlan 101

      no ip address

      spanning-tree portfast

Vlan 4 is our data network and Vlan 101 is voice.

When I try running those commands and then do a show running-config on the 3500XL this is what I get:

interface FastEthernet0/18

switchport access vlan 4

switchport trunk encapsulation dot1q

switchport voice vlan 101

spanning-tree portfast

The commands "no ip address" and "switchport mode access" don't seem to work.

Anybody have any ideas on how to get this to work?

Thank you for your time!

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
Green

Cisco Switch > Phone > PC Daisy Chain

Brandon,

Can you try this config for your PHONE/PC ports

!

interface FastEthernet0/18

desc *** PHONE & PC PORT ***

switchport trunk encapsulation dot1q

switchport trunk native vlan 4

switchport mode trunk

switchport voice vlan 101

switchport priority extend cos 0

spanning-tree portfast

no shut

!

Can you also verify that the vlans have been created or propogated to your switch via VTP

show vlan

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
4 REPLIES
Hall of Fame Super Gold

Cisco Switch > Phone > PC Daisy Chain

The commands "no ip address" and "switchport mode access" don't seem to work.

The commands are not "valid".

The 3500XL is a Layer 2-only switch so you can't configure IP address on an interface.  This means the command "no ip address" is not valid.

Interface FastEthernet 0/18 is already in "switchport mode access" (default) because you have one data and one voice VLAN.  The line "switchport trunk encapsulation dot1q" is not being used because the interface is an access port.

New Member

Cisco Switch > Phone > PC Daisy Chain

Thanks for the response Leolaohoo!

The current config allows for the PC to acquire a 4 address but the phone gets stuck in "Configuring IP" and never boots up properly.

Green

Cisco Switch > Phone > PC Daisy Chain

Brandon,

Can you try this config for your PHONE/PC ports

!

interface FastEthernet0/18

desc *** PHONE & PC PORT ***

switchport trunk encapsulation dot1q

switchport trunk native vlan 4

switchport mode trunk

switchport voice vlan 101

switchport priority extend cos 0

spanning-tree portfast

no shut

!

Can you also verify that the vlans have been created or propogated to your switch via VTP

show vlan

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
New Member

Cisco Switch > Phone > PC Daisy Chain

Thank you for your help Alex, this worked perfectly!

1677
Views
0
Helpful
4
Replies
CreatePlease login to create content