Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco to Nortel PRI connection

We are in the process of installing Call Manager. We have a 2851 gateway with a VWIC2-2MFT-T1/E1 card in it that is connecting to a Nortel Option 81. All external incoming and outgoing calls go over this connection. The Nortel is providing the clocking. When my Nortel guy looks at his card, he shows no errors, says everything looks great. When my Cisco guy looks at the the Cisco card, we see slip errors consistently happening.

2851-cch1-vg#sh controllers t1

T1 0/0/0 is up.

Applique type is Channelized T1

Cablelength is long 0db

No alarms detected.

alarm-trigger is not set

Soaking time: 3, Clearance time: 10

AIS State:Clear LOS State:Clear LOF State:Clear

Version info Firmware: 20071011, FPGA: 13, spm_count = 0

Framing is ESF, Line Code is B8ZS, Clock Source is Line.

CRC Threshold is 320. Reported from firmware is 320.

Data in current interval (525 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

48 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

48 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Total Data (last 2 15 minute intervals):

0 Line Code Violations, 0 Path Code Violations,

170 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

170 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

T1 0/0/1 is up.

Applique type is Channelized T1

Cablelength is long 0db

No alarms detected.

alarm-trigger is not set

Soaking time: 3, Clearance time: 10

AIS State:Clear LOS State:Clear LOF State:Clear

Version info Firmware: 20071011, FPGA: 13, spm_count = 0

Framing is ESF, Line Code is B8ZS, Clock Source is Line.

CRC Threshold is 320. Reported from firmware is 320.

Data in current interval (525 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

50 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

50 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

Total Data (last 2 15 minute intervals):

0 Line Code Violations, 0 Path Code Violations,

168 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,

168 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

2851-cch1-vg#

Now, the connection is active and calls are going across. The problem is, some faxes and some phone calls have issues and I believe they are related to the errors on the PRI. All faxes and phone calls that stay internal to the Call Manager have zero issues.

I will post the config of the router in a reply to this message since it exceeds max msg length.

Has anyone had any experience with Cisco to Nortel connections and troubleshooting these types of errors?

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Cisco to Nortel PRI connection

Hi Keith,

Actually you may have missed the pertinent part:

You will need 'network-clock-select 1 t1 0/0/0'

Try this command, 'clear counters' (exec), and see if this helps.

hth,

nick

4 REPLIES
New Member

Re: Cisco to Nortel PRI connection

Here is the pertinent part of the config on the 2851:

!

controller T1 0/0/0

framing esf

linecode b8zs

cablelength long 0db

pri-group timeslots 1-24 service mgcp

!

controller T1 0/0/1

framing esf

linecode b8zs

cablelength long 0db

pri-group timeslots 1-24 service mgcp

!

!

!

!

!

!

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

ip address 10.100.2.26 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-dms100

isdn incoming-voice voice

isdn bind-l3 ccm-manager

isdn channel-id invert extend-bit

no cdp enable

!

interface Serial0/0/1:23

no ip address

encapsulation hdlc

isdn switch-type primary-dms100

isdn incoming-voice voice

isdn bind-l3 ccm-manager

isdn channel-id invert extend-bit

no cdp enable

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.100.2.1

!

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

!

!

!

control-plane

!

!

!

voice-port 0/0/0:23

!

voice-port 0/0/1:23

!

ccm-manager redundant-host 10.100.4.20 10.100.2.20

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 10.100.3.20

!

mgcp

mgcp call-agent 10.100.3.20 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp modem passthrough voip mode nse

no mgcp timer receive-rtcp

mgcp fax t38 inhibit

mgcp bind control source-interface GigabitEthernet0/0

mgcp bind media source-interface GigabitEthernet0/0

!

mgcp profile default

!

sccp local GigabitEthernet0/0

sccp ccm 10.100.2.20 identifier 3 version 4.1

sccp ccm 10.100.4.20 identifier 2 version 4.1

sccp ccm 10.100.3.20 identifier 1 version 4.1

sccp

!

sccp ccm group 1

associate ccm 3 priority 3

associate ccm 2 priority 2

associate ccm 1 priority 1

associate profile 2 register cch-tra-1

associate profile 1 register cch-cfb-1

!

dspfarm profile 2 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

maximum sessions 2

associate application SCCP

!

dspfarm profile 1 conference

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 18

associate application SCCP

!

!

dial-peer voice 1 pots

service mgcpapp

port 0/0/0:23

Thanks.

Re: Cisco to Nortel PRI connection

Hi Keith,

Actually you may have missed the pertinent part:

You will need 'network-clock-select 1 t1 0/0/0'

Try this command, 'clear counters' (exec), and see if this helps.

hth,

nick

New Member

Re: Cisco to Nortel PRI connection

Yes, that appears to have been quite pertinent. I put that command in, cleared the counters, and monitored the controllers for 15 minutes. No new errors have appeared. In addition, I have sent approximately 20 pages of faxes between the Nortel and Cisco systems and none of them had any visible errors. Thank you!

Re: Cisco to Nortel PRI connection

Slips will do a number on faxing :)

Glad I could help.

-nick

853
Views
0
Helpful
4
Replies