Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Cisco Unity AutoAttendant not working..

Hello Guys..

 

I've been configuring an AA on a Cisco Unified CM BE6K. I created the call handlers, the greetings. I created and extension and I fowarded all calls to the voice mail. I also created a CTI route point and assign the forwarded extension to it (I don't know if this CTI RP is requiered and Im not sure on how does the Unity recognize when a calls go to the AA or when it goes to the VM... (Question 1)

When I call from the IP phones inside my network everything works fine, the AA gets the call, let me move through the options, let me dial any extension I want to, including the operator, BUT.. when I call from the PSTN (through a H323 Gateway) the AA drops the call. 

When you debug the call on the router, the H323 disconnected cause code is 65 (I think that's a codec Missmatch) but I don't know why. 

The dial peer I'm using to call to the AA is the same that I'm using to call to the extensions and it's forced to G711ulaw..  The IP phones are SPA phones so they are registered as third-party devices and they are also forced to work with G711ulaw.

Is there any suggestions on how can I troubleshoot this thing? (Question 2)

 

Thank you all... 

  • IP Telephony
2 REPLIES
New Member

Hi,The dial-peer forces codec

Hi,

The dial-peer forces codec to G711u but what about the Regions ?

Are the Gateway and UnityCx ports in the same Region ? or what is the codec relationship between the 2 Regions ?

Hi Richard, I'll try to be

Hi Richard, 

I'll try to be more explicit this time... 

 

PSTN ----------(E1)----------- GATEWAY--------(VoIP)------- CUCM-UC(BE6K) / IPPhones (BE6K)  

|------------ g711alaw--------------|        |--------------- g711ulaw---------------------------------------------------|

Let's start by the fact that I have no transconding configured on my router.

As far as I know... when I get a call from the PSTN it uses g711alaw. The router gets the call and recodec the voice stream on g711ulaw (which is the default codec used by the Communication Manager Enviroment). 

When the call goes to any of my IP Phones  (SPA Phones / Third party SIP phones) the call proceeds and everything works fine. Every phone is manually configured to register with CUCM via SIP and every phone is forced to use G711ulaw.  

I've also created an AA extension and forwarded all calls to the voice mail. The system call handler that gets the call is the Openning Greating with a new audio which I recorded from a phone.

At this point, two things could happen

     - If I call from my inside network (my IP Phones) the AA gets the call and works as expected.

     - If I get a call from the PSTN the AA drops the call and I get a busy tone and an H323 disconnected cause code = 65 (Codec Missmatch)

The ports and the Gateway are in the same region, Caracas, which is configured to use a maximun rate of 64K... so it can use g711 and  g722

The DNs are numbered from 100 to 199 and the PSTN is sending me 3 digits from 900 to 999.. So I'm using  a voice translation rule to change the first digit from 9 to 1..  I assume that this is working because all calls works fine.

 

Regardig dial-peers, here is the Gateway's config:

 

dial-peer voice 1 pots (USED TO RECIEVED CALLS FROM PSTN)

description LLAMADAS ENTRANTES (PSTN/E1 MOVISTAR)

translation-profile incoming DNIS

incoming called-number ..

no digit-strip

direct-inward-dial

port 0/3/0:1

forward-digits all

 

dial-peer voice 2 voip (USED TO RECIEVED CALLS FROM CUCM)

description LLAMADAS ENTRANTES (FROM CUCM)

incoming called-number .

dtmf-relay rtp-nte

codec g711ulaw

 

dial-peer voice 3 voip (USED TO FORWARD CALLS TO CUCM / FORCED TO USE g711ulaw)

description LLAMADAS INTERNAS (TO CUCM)

translation-profile outgoing ANI

destination-pattern [1-3]..$

session target ipv4:200.200.202.10

dtmf-relay h245-signal rtp-nte cisco-rtp

codec g711ulaw

 

I was triying to force the dial-peer 3 to use g729 to make a little test... When I did that, the AA worked when I called from the PSTN but it was not forwarding calls to internal extensions (It worked twice and no more). Also, I can't use g729 because everyphone is using g711 and by the time of that test, if the call was destinated to an internal DN, the phone droped the call.

Let me know if you need some extra info...

Hope you can help and thank you for your reply.

 

Regards, 

David.

 

 

 

207
Views
0
Helpful
2
Replies
This widget could not be displayed.