Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Cisco Unity Connection doesn't recognize DTMF buttons when pressed

When I dial the Unity Connection AutoAttendant and hear the recording (Press 1 for Sales Press 2 for Support, etc... there is no response when I press any of the DTMF buttons to reach the different departments. It just keeps playing the recording.

I created a System Call Handler for the Auto Attendant recording. under EDIT - GREETINGS - ALTERNATE , I unchecked the box to Ignore Caller Input.

Also for the first Call Handler that was created under the aforementioned Call Handler, when I Edit Caller Input for KEY #1, it is UNLOCKED and forEDIT - CALLER INPUT - when I select the 1 KEY, the Call Handler Radio Button is selected to go to the Consumer Sales System Call Handler that was created, however when I press 1 on the phone, there is no response...

                                                                                  ##### ALL CONFIGURATIONS ARE SCCP #####

Any ideas?

thanks,

Ron

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Super Bronze

Cisco Unity Connection doesn't recognize DTMF buttons when press

Please add this to your config...

dial-peer voice 100 voip

dtmf-relay rtp-nte sip-kpml

dial-peer voice 101 voip

dtmf-relay rtp-nte

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
6 REPLIES
Cisco Employee

Cisco Unity Connection doesn't recognize DTMF buttons when press

Is this an internal or external call??

HTH

java

if this helps, please rate

www.cisco.com/go/pdihelpdesk

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
New Member

Cisco Unity Connection doesn't recognize DTMF buttons when press

Jamie:

It's an inbound call from a PSTN phone. Internally, the call works fine..

Thanks,

VIP Super Bronze

Cisco Unity Connection doesn't recognize DTMF buttons when press

In that case whats type of gateway are you using sip or h323?.Can you attach your sh run?

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Cisco Unity Connection doesn't recognize DTMF buttons when press

It is a SIP gateway. Please see below...

thanks

=================================================================================

CorpHQ#sh run

Building configuration...

Current configuration : 6846 bytes

!

! No configuration change since last restart

!

version 12.4

no service pad

no service timestamps debug uptime

no service timestamps log uptime

no service password-encryption

!

hostname CorpHQ

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

clock timezone PST -8

clock summer-time PDT recurring

network-clock-participate wic 0

network-clock-select 1 T1 0/0/0

!        

dot11 syslog

ip source-route

!

!

ip cef

ip dhcp excluded-address 177.1.11.1 177.1.11.14

ip dhcp excluded-address 177.1.11.21 177.1.11.254

ip dhcp excluded-address 177.2.11.1 177.2.11.14

ip dhcp excluded-address 177.2.11.21 177.2.11.254

!

ip dhcp pool CorpHQ-Phones

   network 177.1.11.0 255.255.255.0

   option 150 ip 177.1.10.10 177.1.10.20

   default-router 177.1.11.1

   dns-server 177.1.100.110

!

ip dhcp pool Branch1-Phones

   network 177.2.11.0 255.255.255.0

   option 150 ip 177.1.10.10 177.1.10.20

   default-router 177.2.11.1

   dns-server 177.1.100.110

!

!        

no ip domain lookup

ip multicast-routing

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-ni

!

!

!

voice service voip

allow-connections h323 to h323

fax protocol cisco

sip

  bind control source-interface Loopback0

  bind media source-interface Loopback0

  no update-callerid

!

!

!        

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g711alaw

codec preference 3 g729r8

!

!

!

!

!

!

!

!

!

!

!

!

!

!

voice translation-rule 1

rule 1 // // type any subscriber plan any isdn

!

voice translation-rule 2

rule 1 // // type any national plan any isdn

!

voice translation-rule 3

rule 1 // // type any international plan any isdn

!

voice translation-rule 10

rule 1 /^[2-9].........$/ /9&/

rule 2 /^1[2-9].........$/ /9&/

rule 3 /^011/ /9&/

!

voice translation-rule 20

rule 1 // /+1/ type subscriber subscriber

rule 2 // /+1/ type national national

rule 3 // /+/ type international international

!

!

voice translation-profile GlobalizeInboundANI

translate calling 20

!

voice translation-profile MakeInternational

translate called 3

!

voice translation-profile MakeNational

translate called 2

!

voice translation-profile MakeSubscriber

translate called 1

!

voice translation-profile Prefix9_InFrom_CUCM

translate called 10

!

!

voice-card 0

dsp services dspfarm

!

!

!

!

!

archive

log config

  hidekeys

!

!

!

!

!        

controller T1 0/0/0

pri-group timeslots 1-3,24

description == Voice Circuit to PSTN

!

!

!

!

!

interface Loopback0

ip address 177.1.254.1 255.255.255.255

ip pim dense-mode

!

interface FastEthernet0/0

description == To CorpHQ-Switch

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.10

description == Server VLAN

encapsulation dot1Q 10

ip address 177.1.10.1 255.255.255.0

ip pim dense-mode

!

interface FastEthernet0/0.11

description == Voice VLAN

encapsulation dot1Q 11

ip address 177.1.11.1 255.255.255.0

ip helper-address 177.1.10.10

ip nbar protocol-discovery

ip pim dense-mode

!

interface FastEthernet0/0.12

description == Data VLAN

encapsulation dot1Q 12

ip address 177.1.12.1 255.255.255.0

!

interface FastEthernet0/0.13

description == PSTN PHONE VLAN

encapsulation dot1Q 13

ip address 177.1.13.1 255.255.255.0

!

interface FastEthernet0/1

description === To PSTN

ip address 177.1.19.254 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

!

interface Serial0/1/0

description == Frame-Relay Circuit to WAN

no ip address

encapsulation frame-relay

fair-queue 64 256 36

cdp enable

frame-relay lmi-type ansi

ip rsvp bandwidth

!

interface Serial0/1/0.1 point-to-point

description == FR To BR1

bandwidth 384

ip address 177.0.101.1 255.255.255.0

ip pim dense-mode

snmp trap link-status

frame-relay interface-dlci 101  

ip rsvp bandwidth 136

!

interface Serial0/1/0.2 point-to-point

description == FR To BR2

ip address 177.0.201.1 255.255.255.0

snmp trap link-status

frame-relay interface-dlci 102  

ip rsvp bandwidth 136

!

router ospf 1

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 0

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 177.1.19.1

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0.10

no ip http server

no ip http secure-server

!

!

!        

!

!

!

!

!

!

control-plane

!

!

!

voice-port 0/0/0:23

translation-profile incoming GlobalizeInboundANI

!

voice-port 0/3/0

!

voice-port 0/3/1

!

ccm-manager music-on-hold

!

!

sccp local Loopback0

sccp ccm 177.1.10.10 identifier 1 priority 1 version 5.0.1

sccp ccm 177.1.10.20 identifier 2 priority 2 version 5.0.1

sccp ccm 177.1.254.3 identifier 3 priority 3 version 5.0.1

sccp

!

sccp ccm group 1

bind interface Loopback0

associate ccm 2 priority 1

associate ccm 1 priority 2

associate ccm 3 priority 3

associate profile 1 register CorpHQ-729-MTP

associate profile 2 register CorpHQ-711-MTP

associate profile 3 register CorpHQ-HW-Xcode

!

dspfarm profile 3 transcode 

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

codec ilbc

maximum sessions 2

associate application SCCP

!        

dspfarm profile 1 mtp 

codec g729ar8

codec g729r8

rsvp

maximum sessions software 10

associate application SCCP

!

dspfarm profile 2 mtp 

codec g711ulaw

rsvp

maximum sessions software 10

associate application SCCP

!

!

dial-peer voice 1 pots

incoming called-number .

direct-inward-dial

!

dial-peer voice 10 pots

translation-profile outgoing MakeSubscriber

destination-pattern 911

no digit-strip

port 0/0/0:23

!

dial-peer voice 11 pots

translation-profile outgoing MakeSubscriber

destination-pattern 9[2-9]..[2-9]......$

port 0/0/0:23

!

dial-peer voice 12 pots

translation-profile outgoing MakeNational

destination-pattern 91[2-9]..[2-9]......$

port 0/0/0:23

forward-digits 11

!

dial-peer voice 13 pots

translation-profile outgoing MakeInternational

destination-pattern 9011T

port 0/0/0:23

prefix 011

!

dial-peer voice 100 voip

description == Inbound/Outbound SIP PSTN GW From/To CUCM Pub

translation-profile incoming Prefix9_InFrom_CUCM

destination-pattern ^2065011...$

voice-class codec 1

session protocol sipv2

session target ipv4:177.1.10.10

incoming called-number .

ip qos dscp cs3 signaling

!

dial-peer voice 101 voip

description == Outbound SIP PSTN GW To CUCM Sub

destination-pattern ^2065011...$

voice-class codec 1

session protocol sipv2

session target ipv4:177.1.10.20

ip qos dscp cs3 signaling

!

!

dial-peer hunt 1

sip-ua

!

!

!

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous level 0 limit 20

line aux 0

line vty 0 4

exec-timeout 0 0

privilege level 15

logging synchronous

no login

line vty 5 15

exec-timeout 0 0

privilege level 15

logging synchronous

no login

!

scheduler allocate 20000 1000

ntp source Loopback0

ntp master 2

ntp server 177.1.254.254

end

==================================================================================

VIP Super Bronze

Cisco Unity Connection doesn't recognize DTMF buttons when press

Please add this to your config...

dial-peer voice 100 voip

dtmf-relay rtp-nte sip-kpml

dial-peer voice 101 voip

dtmf-relay rtp-nte

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Cisco Unity Connection doesn't recognize DTMF buttons when press

Thanks a million. I have to research those commands.

737
Views
0
Helpful
6
Replies
CreatePlease to create content