Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Cisco unity Express installation

hello, I'm trying to install Cisco Unity Express software on the ISM-SRE-300-K9 on a 2951 router

when i issue a service-module sim 0/0 status this is what i get

service module is cisco ism 0/0

service module supports session via tty line 195

service module is failed

service module heart-reset is enabled

service module is in fail open

service moodule status is not available

no install/uninstall in progress

could you please help me out, i need to be able to install cue on this module

thanks

Cris

35 REPLIES
Hall of Fame Super Gold

Re: Cisco unity Express installation

Begin configuring the interface right, and connecting to port 2195.

New Member

Re: Cisco unity Express installation

the interface is properly configured and i can start a session properly to the cue module

and this is what i get once i start a session

SRE step 1 - SM registration...

Response - no installation needed (len: 422)

SRE Installation Not Needed
Loading disk:/bzImage ... done.
Unable to load image
Unable to boot image

Initializing memory. Please wait...
Memory initialization OK. Continue...
DDR Memory 0512 MB detected
Genuine Intel(R) processor              1.06GHz
BIOS ISM 2.6,  BIOS Build date: 10/16/2009
System now booting...

any thoughts ?

Hall of Fame Super Gold

Re: Cisco unity Express installation

Disk appears corrupted, from another terminal issue service-module x/y reset, try to interrupt boot process to get to boot rom, install again from scratch.

If that fails also, RMA the unit.

New Member

Re: Cisco unity Express installation

I was able to re install one CUE module without any problem now i need to figure the licensing stuff out

however on the second CUE module on the second router on the installation step 12 it fails

SRE step 12 - SM now boots Installer
Verifying ...
Corrupted netboot image  detected
done.
Starting Kernel.

and then it loops

is there a way to fix this ?

Cisco Employee

Re: Cisco unity Express installation

Hello Cristobal,

Regarding licensing, if you're running a CUE version that's pre CUE 7.1, and non CSL, (shown by doing "sho software version", look for "Global" version), then you can use the traditional licenses off CCO to install/upgrade licenses, see below;

http://www.cisco.com/en/US/docs/voice_ip_comm/unity_exp/rel7_0/install/upglic.html

If you're running CUE 7.1 or later (which I believe you are, since you said you're running an ISM CUE), this is a different beast.  7.1 onwards uses CSL licenses and the licenses are enforced, below is the guide for installing/upgrading CSL licenses on CUE 7.1 and later:

http://www.cisco.com/en/US/docs/voice_ip_comm/unity_exp/rel7_1/Licensing//Using_CSL.html#wp1065047

Regarding the error you're seeing, it looks as if the image is in fact corrupted.  Before submitting an RMA through TAC what I'd suggest is first try to re-install the CUE software using the "boothelper" method, see below:

http://www.cisco.com/en/US/docs/voice_ip_comm/unity_exp/rel7_1/install/boothelp.html

***Note, the one file that's not mentioned in the file list, in the above link, is the language package manifest file, seen below, this also nees to be downloaded, I think the link is partially wrong.  The .pkg extension is for the manifest file, the link has them mixed up:

cue-vm-langpack.sme.7.1.X.pkg

The .prt1 extension file is the actual voice payload file, which loads the region specific prompts etc...(below is an examle for English US):

cue-vm-en_US-langpack.sme.7.1.X.prt1

So you'd need all the files below in total for the installation:

cue-installer.sme.7.1.x

cue-vm-k9.sme.7.1.x.pkg

cue-vm-full-k9.sme.7.1.x.prt1

cue-vm-installer-k9.sme.7.1.x.prt1

cue-vm-langpack.sme.7.1.x.pkg

cue-vm-en_US-langpack.sme.7.1.(X).prt1  (this is an example for English US language, use your own country specific lanuage payload)

Here's a link to CUE 7.1 software files:

http://tinyurl.com/kja228

Good luck, -Dave

New Member

Re: Cisco unity Express installation

Hello Dave,

I have a question for you,

when I'm on boot-loader for some reason I can't ping my laptop where i have the tftp server running

however if i ping my laptop from the router itself it's fine

from the ism module i can ping the int of the ism, i can't even ping the ip address of the default gateway

this is my config


interface ISM0/0
description Cisco Unity Express
ip unnumbered GigabitEthernet0/1.11
service-module fail-open
service-module ip address 172.21.17.7 255.255.255.0
service-module ip default-gateway 172.21.17.3

this is the config of the gi0/1.11

interface GigabitEthernet0/1.11
description Voice
encapsulation dot1Q 11
ip address 172.21.17.3 255.255.255.0
ip helper-address 172.21.16.21
ip helper-address 172.21.16.22

h323-gateway voip interface
h323-gateway voip bind srcaddr 172.21.17.3
end

any thoughts ?

thank you

New Member

Re: Cisco unity Express installation

never mind i got it fixed thanks all

New Member

Re: Cisco unity Express installation

Could you tell how you fix this?

I have the same problem.

New Member

Re: Cisco unity Express installation

sure.

My problem was. that I didn't have connectivity from the module to my ftp server, and then i checked the configuration on the router and i forgot to add the default route pointing to the module

something like  ip route x.x.x.x y.y.y.y ism 0/0

once i put that in, I was able to install cue

New Member

Re: Cisco unity Express installation

No for this problem, but i have the problem with

SRE Installation Not Needed
Loading disk:/bzImage ... done.
Unable  to load image
Unable to boot image

Initializing memory. Please wait...

Memory  initialization OK. Continue...

DDR Memory 0512 MB detected

Genuine  Intel(R) processor              1.06GHz

BIOS ISM 2.6,  BIOS Build  date: 10/16/2009

System now booting

For this problem i want the result.

Thanks

New Member

Re: Cisco unity Express installation

oh ok, you need to install unity express from scratch

download unity express 8.0 from cisco

then on the isr go to global config mode

and then issue

service-module ism 0/0 install url ftp://username:password@ addr of ftp server>/

after that you should be good to go

New Member

Re: Cisco unity Express installation

I did this without success.

Router#$url ftp://io:****@10.50.0.10/cue-vm-k9.sme.8.0.2.pkg      
Delete the installed Cisco Foundation Software and proceed with new installation? [no]: y
Loading cue-vm-k9.sme.7.1.7.pkg.install.sre !
[OK - 22272/4096 bytes]

You can install upto 5 language(s) on this platform.
Please select the language(s) you want to install by entering the language number(s)
Languages can be entered as comma separated or space separated list
Example: 1,3 would select 'Italian' and 'US English'

Enter languages:
*Sep 10 06:32:40.831: %SM_INSTALL-6-INST_RBIP: ISM0/0 received msg: RBIP Registration Request3
Following languages will be installed on the system:
CUE Voicemail US English
Do you want to continue with the selected options?(y/n):y
input string: lang=no=1,CUE Voicemail US English

Router#
*Sep 10 06:32:46.607: %SM_INSTALL-6-INST_RESET: ISM0/0 is reset for software installation.
*Sep 10 06:33:06.831: %SM_INSTALL-6-INST_RBIP: ISM0/0 received msg: RBIP Registration Request
*Sep 10 06:33:06.839: %SM_INSTALL-6-INST_RBIP: ISM0/0 received msg: RBIP File Request
*Sep 10 06:33:08.711: %SM_INSTALL-6-INST_RBIP: ISM0/0 received msg: RBIP File Request
*Sep 10 06:33:33.243: %SM_INSTALL-6-INST_RBIP: ISM0/0 received msg: RBIP File Request
*Sep 10 06:33:33.711: %SM_INSTALL-6-INST_RBIP: ISM0/0 received msg: RBIP File Request
*Sep 10 06:34:04.347: %SM_INSTALL-6-INST_PROG: ISM0/0 PROGRESSING: Validating package signature ....
*Sep 10 06:34:04.599: %SM_INSTALL-6-INST_PROG: ISM0/0 PROGRESSING: Parsing package manifest files ....
*Sep 10 06:34:06.595: %SM_INSTALL-6-INST_PROG: ISM0/0 PROGRESSING: Validating package signature ....
*Sep 10 06:34:07.175: %SM_INSTALL-6-INST_PROG: ISM0/0 PROGRESSING: Parsing package manifest files ....
*Sep 10 06:34:46.563: %SM_INSTALL-6-INST_PROG: ISM0/0 PROGRESSING: Starting payload download.
*Sep 10 06:35:01.723: %SM_INSTALL-6-INST_PROG: ISM0/0 PROGRESSING: Successfully processed user input.
*Sep 10 06:35:01.755: %SM_INSTALL-6-INST_PROG: ISM0/0 PROGRESSING: Starting payload download.
*Sep 10 06:35:03.363: %SM_INSTALL-6-INST_FAIL: ISM0/0 is reset due to Error encountered while downloading payload(s) .
*Sep 10 06:35:03.363: %SM_INSTALL-6-INST_FAIL: ISM0/0 is reset due to Unable to install. Please try again.
*Sep 10 06:35:23.835: %SM_INSTALL-6-INST_RBIP: ISM0/0 received msg: RBIP Registration Request
*Sep 10 06:35:49.835: %SM_INSTALL-6-INST_RBIP: ISM0/0 received msg: RBIP Registration Request

And then stops

New Member

Re: Cisco unity Express installation

I know that this question is a few days old but I trust that other members might run into the same issue. The point of failure indicates that the language pack was not uploaded to the FTP server.

The full installation packages offer everything except for the language packs that need to be downloaded separately.

After loading the initial header files and installing the foundation software the installation continues (messages shortened for better readability:

- "Starting payload download." - This refers to the main file, i.e. 'cue-vm-full-k9.sme.8.0.2.prt1' in this case

- "Successfully processed user input." - After downloading the main file the system checks which language(s) were selected.

- "Starting payload download." - Now the selected language packs are downloaded, i.e. 'cue-vm-en_US-langpack.sme.8.0.2.prt1' in this case.

- "ISM0/0 is reset due to Error encountered while downloading payload(s) ."
- "ISM0/0 is reset due to Unable to install. Please try again."

This is the typical error message if a file is not found. At least one language pack must be installed in order to run CUE. As only one language was selected this is a critical error so that the installation fails. If you look at the log files of your FTP server you will probably notice a "505 File not found" error message as well.

Re: Cisco unity Express installation

Hey all,

I'm getting a similar problem with a CUE here, but there is a slightly difference: It's a 2821 router ( c2800nm-adventerprisek9-mz.124-25a.bin) and config for the NM-CUE module is the following:

!

interface Service-Engine1/0

ip address 192.168.254.1 255.255.255.252

service-module ip address 192.168.254.2 255.255.255.252

service-module ip default-gateway 192.168.254.1

!

ip forward-protocol nd

ip route 192.168.254.2 255.255.255.255 Service-Engine1/0

!

!

When I ask for a module status:
Router#service-module service-Engine 1/0 status
Service Module is Cisco Service-Engine1/0
Service Module supports session via TTY line 66
Service Module is failed
Service Module status is not available
Router#
The problem is I can't ping the address 192.168.254.2, therefore I can't lauch neither boot-loader nor any other kind of reinstallation.
Do you guys have any tips?

Thanks,
Karl

New Member

Re: Cisco unity Express installation

did you do a no sh on the ser 0/1 ?

is 192.168.254.X routable ?

Re: Cisco unity Express installation

Hello Cris,

I did a no shut yes. Take a look:

Router#sh int servi

Router#sh int service-Engine 1/0

Service-Engine1/0 is up, line protocol is up

  Hardware is I82559FE, address is 0013.c41a.ba90 (bia 0013.c41a.ba90)

  Internet address is 192.168.254.1/30

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 01:13:31, output 00:00:02, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 input packets with dribble condition detected

     572 packets output, 59220 bytes, 0 underruns

     0 output errors, 0 collisions, 1 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

Router#

The network 192.168.254.X/30 was created by me to establish a point-to-point network between the service module and the router. Is that a problem?
Thanks,
Karl

Hall of Fame Super Gold

Re: Cisco unity Express installation

No need to get creative with addressing for the CUE. Use the recommended tecnique of unnumbered to LAN and static /32 route.

After, you do service module connect and check what's happening.

Re: Cisco unity Express installation

Paolo,

I did it already, the unnumbered way is currently running, but I still got no answer - not able to telnet the module.

Thanks for replying!
Karl

Hall of Fame Super Gold

Re: Cisco unity Express installation

Check config under line xx -  likey something is wrong there.

Re: Cisco unity Express installation

I did not understand you point. Could you explain it again? (Line XX?)

Hall of Fame Super Gold

Re: Cisco unity Express installation

If you look at your config there is a section for asynch lines (TTY 66 in your case) and you got to have configured it right in order to access CUE console.

The same is also explained in the CUE manuals.

Re: Cisco unity Express installation

Paolo,

I'm sorry but I could not find any info about how to access using the async line. Could you help me with that too?

Thanks,
Karl

Hall of Fame Super Gold

Re: Cisco unity Express installation

Hi, I think you really have to read again my answer above, and the CUE installation manual too.

Re: Cisco unity Express installation

Maybe I did not expressed me well. I looked at some manuals I have here but I did not find the info you talked about. I understand there is a config to do in the async line, but as far as I read, my config seems to be ok (at least for this line).I thought you could have this info in hands, so you could paste it here. Anyway, thanks for replying!

Hall of Fame Super Gold

Re: Cisco unity Express installation

To diagnose problems, not only you have to post your configs, but also logs of when you try to do something, and some message is received.

Otherwise it becomes a psychic reader matter.

Re: Cisco unity Express installation

I think know it's your time to read my message above.

I pasted logs, configs e errors messages.

Can you find it?

Re: Cisco unity Express installation

I'm sending again, jsut to facilitate:

!

interface Loopback0

ip address 192.168.254.1 255.255.255.0

!

interface Service-Engine1/0

ip unnumbered Loopback0

service-module ip address 192.168.254.2 255.255.255.0

service-module ip default-gateway 192.168.254.1

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 189.125.7.13

ip route 192.168.254.2 255.255.255.255 Service-Engine1/0

!

line 66
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
!
==================================================================
Router#show int service-Engine 1/0
Service-Engine1/0 is up, line protocol is up
  Hardware is I82559FE, address is 0013.c41a.ba90 (bia 0013.c41a.ba90)
  Interface is unnumbered. Using address of Loopback0 (192.168.254.1)
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 21:07:59, output 00:00:04, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     9771 packets output, 1012637 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Router#
==============================================================
Router#service-module service-Engine 1/0 status
Service Module is Cisco Service-Engine1/0
Service Module supports session via TTY line 66
Service Module is waiting for registration message
Service Module status is not available
Router#ping 192.168.254.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.254.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Router#ping 192.168.254.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.254.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
I think it's better to see know. All the info together. The message "Service Module is waiting for registration message" is new for me. The last time I got this display, in its place I got a message as: "Service Module failed"
Any tips?
thanks,
Karl

Hall of Fame Super Gold

Re: Cisco unity Express installation

As mentioned before, you should use "ip unnumbered" with a LAN address, not loopback.

Then post a log when doing service-module session.

Re: Cisco unity Express installation

Paolo,

I attached a show running-config, so you see the whole config. The displays are here:

Router#service-module service-Engine 1/0 status

Service Module is Cisco Service-Engine1/0

Service Module supports session via TTY line 66

Service Module is failed

Service Module status is not available

Router#service-module service-Engine 1/0 session clear

[confirm]

[OK]

Router#service-module service-Engine 1/0 session

Trying 172.20.4.30, 2066 ... Open

And nothing else happens. It stays at this status "Trying..."
I also changed the config to unnumbered pointing to Gigaethernet port. Is it right? Any tips?
Thanks,
Karl

10995
Views
20
Helpful
35
Replies
CreatePlease to create content