Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CM 4.2 Design question

Hi there,

I have the CM4.2 in cluster in the main office...

Now I have a remote site with 3825 connected to a Avaya PBX through an E1

Now I'm in doubt:

- I created a H323 gateway with the 3825 IP address

- I created a MGCP for registering it's E1 interface in the CM4.2, so I can create the route patterns, for local phones..

- I configured the SRST reference for it's IP

Is this right ? Should I configure anything else to integrate the remote 3825 to CM ?

Thanks.

Andrei.

11 REPLIES
Hall of Fame Super Silver

Re: CM 4.2 Design question

Do you have Cisco IP phones at this remote site?

Any other circuits besides the E1 to Avaya?

If there are no phones, there is no need for SRST, also is there a specific reason you need to run both MGCP and H323?

Besides configuring route patterns and GWs, there is plenty of other things you would want, such as paritions, calling search spaces, media resources, etc.

HTH,

Chris

New Member

Re: CM 4.2 Design question

Hi

yes, I have ip phones there

There is no other circuit, only one E1 to Avaya.. the Avaya is connected to PSTN.. so I'll need to route the calls to it.

I already have a DevicePoll, Partitions and CSS.. and other configs to remote phones...

So, can I remove h323 ?

I'm trying to route calls to Avaya, but I had no success.. I configured an ip phone here at main office with the configurations of an ip phone of remote site.. my ip phone's CSS have a route to avaya interface (already registered via MGCP)

But I only receive a fast busy tone...

Feb 17 14:17:38.010: ISDN Se1/0:15 Q931: TX -> SETUP pd = 8 callref = 0x0008

Sending Complete

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA9839F

Exclusive, Channel 31

Calling Party Number i = 0x0081, '7713'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x80, '4236'

Plan:Unknown, Type:Unknown

Feb 17 14:17:38.034: ISDN Se1/0:15 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x8008

Cause i = 0x81D2 - Identified channel does not exist

Thanks.

Andrei.

Hall of Fame Super Silver

Re: CM 4.2 Design question

Please post your entire config, is the PRI connecting to Avaya MGCP or H323 controlled?

Notice "Cause i = 0x81D2 - Identified channel does not exist " error.

What does "sh isdn status" show?

How is your clocking configured, who is the master and who is the slave? We can tell this from the full config.

Chris

New Member

Re: CM 4.2 Design question

Sorry not to post all config.. I hope you have in this config all information you need.. If you need more, let me know.

thanks.

Andrei.

=============

show isdn status

=============

#show isdn status

Global ISDN Switchtype = primary-qsig

%Q.931 is backhauled to CCM MANAGER 0x0003 on DSL 0. Layer 3 output may not apply

ISDN Serial1/0:15 interface

dsl 0, interface ISDN Switchtype = primary-qsig

**** Slave side configuration ****

L2 Protocol = Q.921 0x0000 L3 Protocol(s) = CCM MANAGER 0x0003

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 0 CCBs = 0

The Free Channel Mask: 0xFFFF7FFF

Number of L2 Discards = 0, L2 Session ID = 3

Total Allocated ISDN CCBs = 0

=====================

running config

====================

!

card type e1 1 1

!

network-clock-participate slot 1

!

!

isdn switch-type primary-qsig

!

voice-card 0

!

voice-card 1

!

!

!

!

!

!

controller E1 1/0

pri-group timeslots 1-31 service mgcp

description

!

controller E1 1/1

description

!

!

!

!

interface Loopback10

!

interface Loopback30

!

interface Loopback34

!

interface Loopback90

!

interface Loopback101

!

interface Loopback102

!

interface Loopback103

!

interface Loopback104

!

interface Loopback105

!

interface Tunnel9100210

!

interface Tunnel9100230

!

interface Tunnel9100234

!

interface Tunnel9200290

!

interface GigabitEthernet0/0

ip address 10.91.1.22 255.255.255.0

ip access-group ACL_ENTRADA_LAN in

no ip redirects

ip nat inside

ip virtual-reassembly

no ip route-cache cef

no ip route-cache

ip tcp adjust-mss 1300

ip policy route-map ROTA

no ip mroute-cache

duplex full

speed 100

media-type rj45

service-policy input MARCA_PACOTE

!

interface GigabitEthernet0/1

!

interface Serial0/0/0

!

interface Serial0/0/1

!

interface Serial1/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-qsig

isdn overlap-receiving T302 6000

isdn incoming-voice voice

isdn bind-l3 ccm-manager

isdn bchan-number-order ascending

no cdp enable

!

!

voice-port 1/0:15

output attenuation -6

echo-cancel coverage 32

timeouts initial 20

timeouts interdigit 15

description -- ccs/Q.sig

!

ccm-manager redundant-host 10.1.9.36

ccm-manager mgcp

ccm-manager fax protocol cisco

ccm-manager config server 10.1.9.35

!

mgcp

mgcp call-agent 10.1.9.35 2427 service-type mgcp version 0.1

mgcp fax t38 ecm

!

mgcp profile default

!

!

!

!

!

!

call-manager-fallback

max-conferences 8 gain -6

transfer-system full-consult

ip source-address 10.91.1.22 port 2000

max-ephones 25

max-dn 25 dual-line

system message primary En modo local

time-format 24

date-format dd-mm-yy

!

Hall of Fame Super Silver

Re: CM 4.2 Design question

I see that you are using QSIG, is QSIG supported and configured on your Avaya? Typically it requires additional license and configuration on TDM PBXes.

Add the following commands:

mgcp bind media source-interface GigabitEthernet0/0

mgcp bind control source-interface GigabitEthernet0/0

Also, ensure things are properly configured on Avaya side.

Chris

New Member

Re: CM 4.2 Design question

Ok, I applyied those commands. Thanks.

About Qsig configuration, I think it's fine ... well, the Avaya extension is able to call me. But I agree with you, I'll try to make sure about Avaya config.

Avaya has a route 831XXXX that goes to E1 (cisco) and translate to XXXX

And I keep receiving a fast busy...

================

this is an debug from Avaya extension calling cisco extension

debug isdn q931

================

Feb 17 14:55:06.474: ISDN Se1/0:15 Q931: RX <- SETUP pd = 8 callref = 0x00CC

Bearer Capability i = 0x9090A3

Standard = CCITT

Transfer Capability = 3.1kHz Audio

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA1838F

Preferred, Channel 15

Progress Ind i = 0x8183 - Origination address is non-ISDN

Called Party Number i = 0x80

Plan:Unknown, Type:Unknown

Locking Shift to Codeset 6

Codeset 6 IE 0x28 i = 'BENITO OLVERA'

Feb 17 14:55:06.754: ISDN Se1/0:15 Q931: TX -> SETUP_ACK pd = 8 callref = 0x80CC

Channel ID i = 0xA9838F

Exclusive, Channel 15

Feb 17 14:55:07.710: ISDN Se1/0:15 Q931: RX <- INFORMATION pd = 8 callref = 0x00CC

Called Party Number i = 0x81, '4'

Plan:ISDN, Type:Unknown

Feb 17 14:55:08.406: ISDN Se1/0:15 Q931: RX <- INFORMATION pd = 8 callref = 0x00CC

Called Party Number i = 0x81, '2'

Plan:ISDN, Type:Unknown

Feb 17 14:55:08.658: ISDN Se1/0:15 Q931: RX <- INFORMATION pd = 8 callref = 0x00CC

Called Party Number i = 0x81, '7'

Plan:ISDN, Type:Unknown

Feb 17 14:55:08.906: ISDN Se1/0:15 Q931: RX <- INFORMATION pd = 8 callref = 0x00CC

Called Party Number i = 0x81, '8'

Plan:ISDN, Type:Unknown

Feb 17 14:55:09.490: ISDN Se1/0:15 Q931: TX -> CALL_PROC pd = 8 callref = 0x80CC

Feb 17 14:55:09.490: ISDN Se1/0:15 Q931: TX -> ALERTING pd = 8 callref = 0x80CC

Progress Ind i = 0x8088 - In-band info or appropriate now available

Feb 17 14:55:13.154: ISDN Se1/0:15 Q931: TX -> CONNECT pd = 8 callref = 0x80CC

Feb 17 14:55:13.190: ISDN Se1/0:15 Q931: RX <- CONNECT_ACK pd = 8 callref = 0x00CC

Feb 17 14:56:55.764: ISDN Se1/0:15 Q931: RX <- DISCONNECT pd = 8 callref = 0x00CC

Cause i = 0x8190 - Normal call clearing

Feb 17 14:56:56.588: ISDN Se1/0:15 Q931: TX -> RELEASE pd = 8 callref = 0x80CC

Feb 17 14:56:56.612: ISDN Se1/0:15 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x00CC

Anything else that I could check ?

Thanks.

Andrei.

Hall of Fame Super Silver

Re: CM 4.2 Design question

Also, make sure this is not configured as partial PRI on Avaya side, you can easily check this by changing the order on Cisco side, change:

interface Serial1/0:15

isdn bchan-number-order ascending

to

interface Serial1/0:15

isdn bchan-number-order descending

HTH,

Chris

New Member

Re: CM 4.2 Design question

Done.. what I think is strange is that is only one port becomes "up" for a second...

============================

using ascending ou descending, the same por becomes up for a sec...

1/0:15 > 31

============================

#sh voice port summary | include xcc

1/0:15 01 xcc-voice up none none none y

1/0:15 02 xcc-voice up none none none y

1/0:15 03 xcc-voice up none none none y

1/0:15 04 xcc-voice up none none none y

1/0:15 05 xcc-voice up none none none y

1/0:15 06 xcc-voice up none none none y

1/0:15 07 xcc-voice up none none none y

1/0:15 08 xcc-voice up none none none y

1/0:15 09 xcc-voice up none none none y

1/0:15 10 xcc-voice up none none none y

1/0:15 11 xcc-voice up none none none y

1/0:15 12 xcc-voice up none none none y

1/0:15 13 xcc-voice up none none none y

1/0:15 14 xcc-voice up none none none y

1/0:15 15 xcc-voice up dorm none none y

1/0:15 17 xcc-voice up none none none y

1/0:15 18 xcc-voice up none none none y

1/0:15 19 xcc-voice up none none none y

1/0:15 20 xcc-voice up none none none y

1/0:15 21 xcc-voice up none none none y

1/0:15 22 xcc-voice up none none none y

1/0:15 23 xcc-voice up none none none y

1/0:15 24 xcc-voice up none none none y

1/0:15 25 xcc-voice up none none none y

1/0:15 26 xcc-voice up none none none y

1/0:15 27 xcc-voice up none none none y

1/0:15 28 xcc-voice up none none none y

1/0:15 29 xcc-voice up none none none y

1/0:15 30 xcc-voice up none none none y

1/0:15 31 xcc-voice up up none none y

New Member

Re: CM 4.2 Design question

Hi there !

I'd like to say thanks for your help.

I left only the MGCP config... the problem was the network side.. I changed that in CM4.2 and works.

One thing .. I had to access the router to restart the controller because reseting using CM was not working...

Thanks.

Andrei.

Bronze

Re: CM 4.2 Design question

Andrei,

If the Avaya PBX and Cisco CCM are networked, the easest way is to use an H.323 trunk directly from Avaya PBX to Cisco CallManager and a H.323 Gateway from Cisco CCM to Avaya PBX. All you need is to creat location/region and the codec (G.729)and map the desired digits into a route pattern in both ends. I have just finished one with H.323 Trunk/GW and so far is working fine.

MK

New Member

Re: CM 4.2 Design question

Hi about having MGCP and H323 configured...

I have 1 E1 with PBX (QSIG) and 1 E1 with R2 (non qsiq) with pstn...

That is the reason for both protocols.

Thanks.

Andrei.

235
Views
5
Helpful
11
Replies