Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

CME 4.1 and trunk config help

Hello, I'm building CME 4.1 on a 2851 to support 50 or so people at a remote office. I used QCT to set everything up, using mostly default values. I've got the system up and running for the most part, but I'm not sure if the switch trunks are configured correctly. Below are the router and corresponding switch interface configs...

---------------------------------------

***2851 router***

interface Loopback0

ip address 10.1.10.2 255.255.255.0

!

interface GigabitEthernet0/0

description ***switchport fa1/0/47***

ip address 10.10.10.1 255.255.255.0

duplex auto

speed auto

!

interface Service-Engine0/0

ip unnumbered Loopback0

service-module ip address 10.1.10.1 255.255.255.0

service-module ip default-gateway 10.1.10.2

!

interface GigabitEthernet0/1

no ip address

no ip mroute-cache

duplex auto

speed auto

!

interface GigabitEthernet0/1.100

description ** Voice VLAN **

encapsulation dot1Q 100

service-policy output output-L3-to-L2

!

interface GigabitEthernet0/1.200

description ** Data VLAN **

encapsulation dot1Q 200 native

ip address 192.168.10.1 255.255.255.0

!

interface Serial0/0/0

no ip address

shutdown

!

ip route 10.1.10.1 255.255.255.255 Service-Engine0/0

***3750 switch***

interface FastEthernet1/0/47

description ***Gig0/0***

switchport access vlan 200

switchport trunk encapsulation dot1q

switchport trunk native vlan 100

switchport trunk allowed vlan 100

switchport mode trunk

switchport voice vlan 100

no snmp trap link-status

no mdix auto

spanning-tree portfast

!

interface FastEthernet1/0/48

description ***Gig0/1***

switchport trunk encapsulation dot1q

switchport trunk native vlan 200

switchport mode trunk

no snmp trap link-status

no mdix auto

interface Vlan100

ip address 10.10.10.2 255.255.255.0

!

interface Vlan200

ip address 192.168.10.5 255.255.255.0

!

ip default-gateway 192.168.10.1

---------------------------------------

I had to change the SM on the Gig0/0 router interface to make it a 24bit to make it work (QCT configures 10.10.10.1 255.255.255.248, but that wouldn't let phones register even if I changed to vlan100 ip to match).

Any help/advice would be greatly appreciated!

Thanks,

Jad

7 REPLIES
Hall of Fame Super Gold

Re: CME 4.1 and trunk config help

Hi,

this is wrong:

switchport trunk native vlan 100

please remove all commands on 3750, just leave the defaults and it will work fine.

Hope this helps, please rate post if it does!

New Member

Re: CME 4.1 and trunk config help

Thanks for the response --

do you really mean remove ALL commands? what about my VLAN's and switch IP's? Trunking?

...or do you mean remove all "switchport trunk native vlan 100" commands for all switchports? Please clarify.

Hall of Fame Super Gold

Re: CME 4.1 and trunk config help

Just leave "switchport mode trunk" and remove all the rest unde the relevant interface. Thats shoudl restablish connectivty to the phones. Then you can go from there.

New Member

Re: CME 4.1 and trunk config help

sorry - can you show me an example of what you're trying to say?

Hall of Fame Super Gold

Re: CME 4.1 and trunk config help

under your trunk ports:

"no switchport access vlan 200"

and repeat for all the unnecessary commands you have. The only needed one is "switchport mode trunk".

New Member

Re: CME 4.1 and trunk config help

that doesn't work - and the reason why i'm confused. If i pull those commands off, i don't get voice or data on any ports and lose all ping communications between the switch and the router.

If I add "switchport trunk native vlan 200" to int fa48, the trunk is built. Adding "switchport trunk native vlan 100" to fa47 gets voice traffic working. I can't see how it would work any other way.

Hall of Fame Super Gold

Re: CME 4.1 and trunk config help

Ok, I see. You just want one port of 3845 do voice, and other do data. Then, on router, remove subinterfaces and configure ip directly on main interfaces.

On the switch, configure "switchport mode access" and "switchport access vlan xx". Do not worry if no vlan is marked voice - that won't make any difference, and you can still configure as "voice vlan" on ports connected to telephones.

247
Views
4
Helpful
7
Replies
CreatePlease to create content