Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CME 7 using FXO ports keeps calls up after pstn call hangsup

I have a 3825 with CME 7 and 8 fxo ports.  This is a small config with 7 phones, CUE and a shared line. My IOS is 12.4(20)T

 

When a call comes in, the call is forwarded to an extension and call-forwarded noans to vm. 

If an outside caller places a call into the CME via one of the FXO ports and hangs up whether it answered or not, the CME system doesn't recognize the hang up from the PSTN.  I have read where I need to set up a voice class custom-cptone so it will recognize the disconnect tone.  I have followed several suggestions from this forum and I can't seem to make a difference.  The call on the CME side only ends when we hang up.  If the call comes in the caller hangs up before we answer, it keeps ringing the phone and then goes to vmail and leaves a silent message that is a 100 seconds long. 

My installation is in the US.

I use debug voice call inout and see the call coming in and get answered, but no debug output is displayed  when the call is disconnected from outside.

Here is some of my config.

I have tried both of these configs from suggestions.

 

voice class dualtone-detect-params 1
 freq-max-deviation 50
 

voice class custom-cptone Super-disconnect
 dualtone disconnect
  frequency 480 620
  cadence 250 250
 

currently gave this

 

voice-port 0/0/1
 supervisory dualtone-detect-params 1
 connection plar opx 6335260
 description Gary Asher
 bearer-cap Speech
 caller-id enable
 

dial-peer voice 60 pots
 description Used to have Gary's Calls go out his FXO
 destination-pattern 60.T
 incoming called-number .
 direct-inward-dial
 port 0/0/1
 

 

Any help would be greatly appreciated.

 

Thanks

Gary

 

 

 

 

 

 

 

 

1 REPLY

So your problem sounds like

So your problem sounds like it is with supervisory disconnect.  With that being said I assume you tried the configuration int he cisco documentation here.

http://www.cisco.com/c/en/us/support/docs/voice/analog-signaling-e-m-did-fxs-fxo/8120-fxo-disconnect.html

 

88
Views
0
Helpful
1
Replies