Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

CME\7960 running SIP firmware - How do i setup incoming calls? - Can anyone help please?

Hi Guys,

I have a SIP trunk setup with a 2811 running CME version 7.  I can make outbound calls ok but having issues getting the incoming calls working, i have 1 number on my SIP trunk and that is 01133501788 and i want that to ring my Cisco 7960 which is running SIP firmware not SCCP.  I have included by config for anyone who can help me, i just want the incoming call to work. 

Many Thanks.

Matthew.

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

clock timezone GMT 0

!

dot11 syslog

ip source-route

!

!

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.1.1

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool DATA_POOL

   network 10.10.10.0 255.255.255.0

   default-router 10.10.10.1

   dns-server 188.92.232.50 188.92.232.100

!

ip dhcp pool VOICE_POOL

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   dns-server 188.92.232.50 188.92.232.100

   option 150 ip 192.168.1.1

!

!

ip name-server 188.92.232.50

ip name-server 188.92.232.100

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

no supplementary-service sip moved-temporarily

no supplementary-service sip refer

sip

  bind control source-interface FastEthernet0/1.20

  bind media source-interface FastEthernet0/1.20

  registrar server

!

!

!

voice class codec 1

codec preference 2 g711ulaw

codec preference 3 g711alaw

!

!

!

!

!

!

!

!

!

!

!

!

voice register global

mode cme

source-address 192.168.1.1 port 5060

max-dn 144

max-pool 42

load 7960-7940 P0S3-8-12-00

authenticate register

tftp-path flash:

create profile sync 0008072514198272

!

voice register dn  1

number 6999

allow watch

name SIP

label SIP

!

voice register pool  1

id mac 000F.902B.40E0

type 7960

number 1 dn 1

dtmf-relay sip-notify

username cisco password cisco

codec g711ulaw

!

!

voice translation-rule 1

rule 1 /^9\(.*\)/ /\1/

!

voice translation-rule 2

rule 1 /^6...$/ /4143*002/

!

!

voice translation-profile DiscardDigit9

translate calling 2

translate called 1

!

voice translation-profile IncomingSIP

translate calling 1133501788

!

!

voice-card 0

no dspfarm

!

!

!

!

!

username matt privilege 15 secret 5 $1$DCD0$SjWqnKgDSGVzzIKRerXh11

archive

log config

  hidekeys

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 194.12.0.222 255.255.255.252

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1.10

description DATA

encapsulation dot1Q 10

ip address 10.10.10.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface FastEthernet0/1.20

description VOICE

encapsulation dot1Q 20

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 194.12.0.221

ip http server

ip http authentication local

no ip http secure-server

!

!

ip nat inside source list 1 interface FastEthernet0/0 overload

!

access-list 1 permit 192.168.1.0 0.0.0.255

access-list 1 permit 10.10.10.0 0.0.0.255

!

!

!

!

!

!

tftp-server flash:P003-8-12-00.bin

tftp-server flash:P003-8-12-00.sbn

tftp-server flash:P0S3-8-12-00.loads

tftp-server flash:P0S3-8-12-00.sb2

tftp-server flash:P003-8-12-00

tftp-server flash:P003-8-12-00.loads

tftp-server flash:P003-8-12-00.sb2

tftp-server flash:SIP000F902B40E0.cnf.xml

!

control-plane

!

!

!

!

mgcp behavior g729-variants static-pt

!

!

dial-peer cor custom

!

!

!

dial-peer voice 2 voip

description Outgoing Geographic

translation-profile outgoing DiscardDigit9

destination-pattern 0[7]........

voice-class codec 1

session protocol sipv2

session target dns:sip.cloudcalling.co.uk

dtmf-relay rtp-nte

no vad

!

dial-peer voice 1 voip

description IncomingSIP

translation-profile incoming IncomingSIP

voice-class codec 1

session protocol sipv2

session target dns:sip.cloudcalling.co.uk

incoming called-number .T

dtmf-relay sip-notify rtp-nte

no vad

!

!

sip-ua

credentials username 4143*002 password 7 password realm sip.cloudcalling.co.uk

authentication username 4143*002 password 7 password

nat symmetric role passive

nat symmetric check-media-src

calling-info sip-to-pstn number set 4143*002

no remote-party-id

retry invite 3

retry register 3

timers connect 100

registrar dns:sip.cloudcalling.co.uk expires 60

sip-server dns:sip.cloudcalling.co.uk

  host-registrar

!

!

!

gatekeeper

shutdown

!

!

telephony-service

load 7960-7940 P0S3-8-12-00

max-ephones 24

max-dn 30

ip source-address 192.168.1.1 port 2000

max-conferences 8 gain -6

web admin system name Admin secret 5 $1$Fktw$t9GQkdDdHmoYdwptO8.or.

transfer-system full-consult

create cnf-files version-stamp Jan 01 2002 00:00:00

!

!

line con 0

line aux 0

line vty 0 4

login

!

scheduler allocate 20000 1000

ntp server 85.119.80.232

end

Router#

1 ACCEPTED SOLUTION

Accepted Solutions

CME\7960 running SIP firmware - How do i setup incoming calls? -

Add these....

voice translation-rule 3

rule 1 /^01133501788$/ /6999/

rule 2 /^1133501788$/ /6999/

voice translation-profile IncomingSIP

translate called 3

--------------------------------------------------

dial-peer voice 1 voip

description IncomingSIP

translation-profile incoming IncomingSIP

voice-class codec 1

session protocol sipv2

incoming called-number .T

dtmf-relay sip-notify rtp-nte

no vad

5 REPLIES

CME\7960 running SIP firmware - How do i setup incoming calls? -

Add these....

voice translation-rule 3

rule 1 /^01133501788$/ /6999/

rule 2 /^1133501788$/ /6999/

voice translation-profile IncomingSIP

translate called 3

--------------------------------------------------

dial-peer voice 1 voip

description IncomingSIP

translation-profile incoming IncomingSIP

voice-class codec 1

session protocol sipv2

incoming called-number .T

dtmf-relay sip-notify rtp-nte

no vad

New Member

CME\7960 running SIP firmware - How do i setup incoming calls? -

You my friend are a star! worked straight away, many thanks.  Just one more thing, when i make an outgoing call, it always appears as "blocked" on my phone, my sip trunk is set to allow CME to alter outgoing CLI's how would i program the outgoing CLI to 01133501788 also?

The new working config is below with your suggestion, which works!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

clock timezone GMT 0

!

dot11 syslog

ip source-route

!

!

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.1.1

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool DATA_POOL

   network 10.10.10.0 255.255.255.0

   default-router 10.10.10.1

   dns-server 188.92.232.50 188.92.232.100

!

ip dhcp pool VOICE_POOL

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   dns-server 188.92.232.50 188.92.232.100

   option 150 ip 192.168.1.1

!

!

ip name-server 188.92.232.50

ip name-server 188.92.232.100

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

no supplementary-service sip moved-temporarily

no supplementary-service sip refer

sip

  registrar server

!

!

!

voice class codec 1

codec preference 2 g711ulaw

codec preference 3 g711alaw

!

!

!

!

!

!

!

!

!

!

!

!

voice register global

mode cme

source-address 192.168.1.1 port 5060

max-dn 144

max-pool 42

load 7960-7940 P0S3-8-12-00

authenticate register

tftp-path flash:

create profile sync 0015244443466064

!

voice register dn  1

number 6999

allow watch

name SIP

label SIP

!

voice register pool  1

id mac 000F.902B.40E0

type 7960

number 1 dn 1

dtmf-relay sip-notify

username cisco password cisco

codec g711ulaw

!

!

voice translation-rule 1

rule 1 /^6...$/ /4143*002/

!

voice translation-rule 3

rule 1 /^01133501788$/ /6999/

rule 2 /^1133501788$/ /6999/

!

!

voice translation-profile IncomingSIP

translate called 3

!

voice translation-profile Translatetrunk

translate calling 1

!

!

voice-card 0

no dspfarm

!

!

!

!

!

username matt privilege 15 secret 5 $1$DCD0$SjWqnKgDSGVzzIKRerXh11

archive

log config

  hidekeys

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 194.12.0.222 255.255.255.252

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1.10

description DATA

encapsulation dot1Q 10

ip address 10.10.10.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface FastEthernet0/1.20

description VOICE

encapsulation dot1Q 20

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 194.12.0.221

ip http server

ip http authentication local

no ip http secure-server

!

!

ip nat inside source list 1 interface FastEthernet0/0 overload

!

access-list 1 permit 192.168.1.0 0.0.0.255

access-list 1 permit 10.10.10.0 0.0.0.255

!

!

!

!

!

!

tftp-server flash:P003-8-12-00.bin

tftp-server flash:P003-8-12-00.sbn

tftp-server flash:P0S3-8-12-00.loads

tftp-server flash:P0S3-8-12-00.sb2

tftp-server flash:P003-8-12-00

tftp-server flash:P003-8-12-00.loads

tftp-server flash:P003-8-12-00.sb2

tftp-server flash:SIP000F902B40E0.cnf.xml

!

control-plane

!

!

!

!

mgcp behavior g729-variants static-pt

!

!

dial-peer cor custom

!

!

!

dial-peer voice 1 voip

description IncomingSIP

translation-profile incoming IncomingSIP

voice-class codec 1

session protocol sipv2

session target sip-server

incoming called-number .T

dtmf-relay sip-notify rtp-nte

no vad

!

dial-peer voice 2 voip

description Outgoing Geographic

translation-profile outgoing Translatetrunk

destination-pattern 0[7]........

voice-class codec 1

session protocol sipv2

session target dns:sip.cloudcalling.co.uk

dtmf-relay rtp-nte

no vad

!

!

sip-ua

credentials username 4143*002 password 7 password realm sip.cloudcalling.co.uk

authentication username 4143*002 password 7 password

nat symmetric role passive

nat symmetric check-media-src

calling-info sip-to-pstn number set 4143*002

no remote-party-id

retry invite 3

retry register 3

timers connect 100

registrar dns:sip.cloudcalling.co.uk expires 60

sip-server dns:sip.cloudcalling.co.uk

  host-registrar

!

!

!

gatekeeper

shutdown

!

!

telephony-service

load 7960-7940 P0S3-8-12-00

max-ephones 24

max-dn 30

ip source-address 192.168.1.1 port 2000

max-conferences 8 gain -6

web admin system name Admin secret 5 $1$Fktw$t9GQkdDdHmoYdwptO8.or.

transfer-system full-consult

create cnf-files version-stamp 7960 Dec 17 2013 14:35:13

!

!

line con 0

line aux 0

line vty 0 4

login

!

scheduler allocate 20000 1000

ntp server 85.119.80.232

end

Router#

CME\7960 running SIP firmware - How do i setup incoming calls? -

voice translation-rule 1

rule 1 /^6...$/ /01133501788/

New Member

CME\7960 running SIP firmware - How do i setup incoming calls? -

I already have a voice translation rule 1 in place, that strips off the local extension header and replaces it with my SIP trunk header.

6999 is my local extension, that rule replaces 6999 with 4143*002, is there another way to do this?

This is just to manipulate the caller outgoing CLI?

Re: CME\7960 running SIP firmware - How do i setup incoming call

Correct me if i am wrong , you want your caller id to be 01133501788 when making outgoing call ?

Now my question is why are you sending 4143*002 as your caller id? Is this something your ITSP asked for? You are already doing authentication through sip-ua.

Sent from Cisco Technical Support iPhone App

603
Views
0
Helpful
5
Replies